Installation et administration de SOLIDWORKS

Ce guide couvre l'installation, les licences, la mise à niveau et l'administration des produits SOLIDWORKS pour les installations individuelles et multiples.

Installations individuelles | Déploiement de plusieurs installations
Installation Installation sur un ou plusieurs ordinateurs. | Installation Création d'une image administrative déployée sur plusieurs ordinateurs clients.
Licence Activation de l'ordinateur, licences en ligne ou licences réseau. | Licence Activation de l'ordinateur, licences en ligne ou licences réseau.
Mises à niveau Mise à niveau d'ordinateurs individuels vers une nouvelle version. | Mises à niveau Mise à niveau de plusieurs ordinateurs vers une nouvelle version en mettant à niveau l'image administrative utilisée pour l'installation sur ces ordinateurs.
Administration Modification, réparation et suppression des installations, mises à niveau vers les nouvelles versions. | Administration Mise à niveau d'images administratives et de clients, et administration des licences réseau.

Le Gestionnaire d'installation SOLIDWORKS permet de configurer les paramètres des composants de produits SOLIDWORKS, y compris SOLIDWORKS, SOLIDWORKS Toolbox, PhotoView 360, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS PCB, SOLIDWORKS Visualize et SOLIDWORKS SolidNetWork License Manager.

SolidNetWork License Manager prend en charge les clients de licence multiples en distribuant les licences aux clients du réseau. Le nombre d'utilisateurs peut ainsi dépasser le nombre de licences en utilisant des licences flottantes.

Le Portail administrateur SOLIDWORKS est une ressource basée sur le Cloud et un système de gestion de services qui vous permet d'affecter et de gérer les licences en ligne. L'attribution de licences est requise uniquement pour les licences en ligne. Pour les autres types de licences, l'attribution est facultative.

Table des matières

  • Installation individuelle ou image administrative

    Faut-il installer les produits SOLIDWORKS individuellement sur chaque ordinateur ou créer une image administrative et déployer l'installation sur tous les clients en une seule commande?

  • Vérifier le système et les logiciels requis

    Avant l'installation, assurez-vous que votre système satisfait aux exigences du matériel, du système d'exploitation et des produits Microsoft. Notez que les compléments, tels que SOLIDWORKS Electrical, SOLIDWORKS Visualize et eDrawings ont des exigences supplémentaires.

  • Télécharger le média d'installation à partir du portail clients

    Tous les médias d'installation sont disponibles sur le portail clients SOLIDWORKS.

  • Définition des options pour le gestionnaire d'installation

    Ces options comprennent les réglages pour l'enregistrement et l'emplacement des fichiers, la désactivation de l'accès Internet et la langue utilisée pour les écrans du gestionnaire d'installation.


Installation individuelle ou image administrative

Faut-il installer les produits SOLIDWORKS individuellement sur chaque ordinateur ou créer une image administrative et déployer l'installation sur tous les clients en une seule commande?

Si l'installation concerne un seul ordinateur ou si vous gérez des douzaines ou des centaines d'ordinateurs, la question ne se pose pas. Si vous êtes entre les deux, laissez-vous guider par la comparaison suivante.

Installation individuelle | Image administrative
Les utilisateurs assurent eux-mêmes l'administration de SOLIDWORKS. | L'administrateur système peut personnaliser plusieurs installations avec l'Editeur d'options, en indiquant des options d'installation telles que la création d'une nouvelle installation ou la mise à niveau d'une installation existante, l'exécution de l'installation en tant qu'utilisateur administratif, l'exécution des commandes externes avant ou après l'installation ou différents groupements de produits, etc.
Les ordinateurs doivent être physiquement accessibles à la personne qui réalise l'installation. | Les ordinateurs clients peuvent être distants du moment qu'ils sont accessibles à partir du même réseau.
Vous pouvez installer des versions, service packs ou produits différents sur des ordinateurs distincts avec des paramètres différents. | Les images administratives assurent la cohérence entre les versions, les service packs, les produits et les paramètres pour les installations multiples, lorsque vous utilisez l'Editeur d'options
Les ordinateurs doivent avoir un accès au réseau ou à une messagerie électronique. Une connexion au réseau ou à une messagerie électronique est nécessaire pour activer SOLIDWORKS et télécharger des fichiers. L'accès réseau est également nécessaire lors de la collecte des licences d'un serveur de licences réseau.

Une connexion au réseau local est nécessaire pour déployer l'application; les lecteurs média ne sont pas nécessaires sur les ordinateurs clients.

Les clients peuvent être mis à jour automatiquement. Tous les clients déployés à partir de la même image administrative ont le même service pack. Pour maintenir plusieurs versions, vous pouvez créer plusieurs images administratives.

L'activation de licence peut être automatisée.

Une image administrative nécessite de l'espace disque supplémentaire sur le serveur; l'espace requis sur les clients est le même que pour les installations individuelles.

Sujet parent Installation et administration de SOLIDWORKS
Vérifier le système et les logiciels requis
Télécharger le média d'installation à partir du portail clients
Définition des options pour le gestionnaire d'installation


Vérifier le système et les logiciels requis

Avant l'installation, assurez-vous que votre système satisfait aux exigences du matériel, du système d'exploitation et des produits Microsoft. Notez que les compléments, tels que SOLIDWORKS Electrical, SOLIDWORKS Visualize et eDrawings ont des exigences supplémentaires.

Pour accéder aux conditions requises actuelles, reportez-vous à http://solidworks.com/System_Requirements.

Sujet parent Installation et administration de SOLIDWORKS
Installation individuelle ou image administrative
Télécharger le média d'installation à partir du portail clients
Définition des options pour le gestionnaire d'installation


Télécharger le média d'installation à partir du portail clients

Tous les médias d'installation sont disponibles sur le portail clients SOLIDWORKS.

Si vous ne pouvez pas accéder au portail clients, contactez votre revendeur afin d'obtenir les DVDs.

Pour télécharger le média d'installation à partir du portail clients :

  1. Connectez-vous au portail clients SOLIDWORKS en tant que client sous contrat de maintenance avec votre adresse de messagerie et votre mot de passe ou votre numéro de série SOLIDWORKS.
  2. Dans la section Download (Télécharger), cliquez sur Downloads and Updates (Téléchargements et mises à jour).
  3. Sur la page Downloads (Téléchargements), dans Select Version (Sélectionner la version), sélectionnez l'année de la version à télécharger.
  4. Dans l'onglet SOLIDWORKS, sous Produit, sélectionnez le produit et le Service Pack de votre système d'exportation. Pour une version majeure, vous pouvez télécharger :
    • Un fichier .ZIP qui inclut l'ensemble complet de fichiers.
    • Ou deux fichiers .ZIP : Média SOLIDWORKS (1 sur 2) et Média SOLIDWORKS (2 sur 2). Séparer le téléchargement en deux fichiers est pratique si votre connexion Internet est lente.
      Cette option n'est pas disponible pour les Service Packs.
  5. Pour la dernière version majeure, cliquez sur SOLIDWORKS année, par exemple SOLIDWORKS Products 2020 0.0 pour télécharger le logiciel en un fichier .ZIP.
  6. Sur la page SOLIDWORKS Download EULA (CLUF de téléchargement de SOLIDWORKS), cliquez sur Accept Agreement & Continue (Accepter le contrat et continuer).
  7. Dans la page suivante, cliquez sur Download (Télécharger).

    Le fichier SolidWorksSetup.exe se télécharge sur votre ordinateur. Le fichier est extrait vers un emplacement de dossier et démarre le Gestionnaire d'installation.

Vous pouvez également choisir la méthode de téléchargement manuelle. Cette option vous permet de télécharger l'ensemble des fichiers d'installation de manière sélective. Si vous sélectionnez cette option, suivez les instructions sur la page Web.
Sujet parent Installation et administration de SOLIDWORKS
Installation individuelle ou image administrative
Vérifier le système et les logiciels requis
Définition des options pour le gestionnaire d'installation


Définition des options pour le gestionnaire d'installation

Ces options comprennent les réglages pour l'enregistrement et l'emplacement des fichiers, la désactivation de l'accès Internet et la langue utilisée pour les écrans du gestionnaire d'installation.

Pour définir les options du gestionnaire d'installation avant d'installer le logiciel :

  1. Si le gestionnaire d'installation SOLIDWORKS n'est pas ouvert, localisez le fichier SolidWorksSetup.exe dans le répertoire où il a été téléchargé, puis décompressez-le.
  2. Dans le gestionnaire d'installation, cliquez à l'aide du bouton droit de la souris sur l'icône SOLIDWORKS de la barre de titre et sélectionnez :
    Option | Description
    Niveaux de journalisation de l'installation Définit le niveau sur Elevé, Moyen, ou Faible. Les niveaux plus élevés permettent de collecter plus de données pour le dépannage, mais peuvent ralentir l'installation. Faible (le plus rapide) est sélectionné par défaut et offre une performance et une stabilité optimales.

    Créer des journaux Windows Installer permet d'enregistrer ces journaux dans le même dossier que les autres journaux d'installation.

    Options relatives à l'image administrative | Sélectionnez Utiliser des noms de fichier courts (format 8.3) ou Utiliser des noms de dossier et de fichier complets.
    Collecter les journaux d'installation... | Spécifiez le répertoire pour enregistrer les journaux d'installation. Le gestionnaire d'installation enregistre ces fichiers dans IM_Logs.zip.
    Désactiver l'accès à Internet | Vous ne pouvez pas désactiver l'accès à Internet si vous installez avec une licence en ligne.
    Langue | Définit la langue du gestionnaire d'installation. La langue par défaut est l'anglais.
  3. Cliquez sur Fermer.
Sujet parent Installation et administration de SOLIDWORKS
Installation individuelle ou image administrative
Vérifier le système et les logiciels requis
Télécharger le média d'installation à partir du portail clients


Installations individuelles

Table des matières

  • Installation sur des ordinateurs individuels

    Il existe plusieurs méthodes pour installer SOLIDWORKS sur un ordinateur individuel.

  • Administration d'installations individuelles

    De manière générale, l'administration d'installations individuelles consiste à modifier, réparer, supprimer et mettre à niveau les installations.


Installation sur des ordinateurs individuels

Il existe plusieurs méthodes pour installer SOLIDWORKS sur un ordinateur individuel.

L'installation est réalisée par le Gestionnaire d'installation SOLIDWORKS, qui personnalise l'installation en fonction des produits achetés. Avant de commencer l'installation:

  • Préparez votre numéro de série SOLIDWORKS.
  • Vérifiez que votre connexion Internet fonctionne. La connexion est nécessaire pour la vérification des droits.

Le Gestionnaire d'installation SOLIDWORKS requiert plusieurs composants Microsoft, notamment Microsoft Windows Installer, Microsoft Visual Studio Tools for Applications, Visual Basic et .NET Framework. Si la version demandée de tous les composants Windows prérequis n'est pas installée sur votre ordinateur, le Gestionnaire d'installation SOLIDWORKS l'installe automatiquement avant d'installer les produits SOLIDWORKS. Le service Bonjour pour Windows est également un composant requis.

Méthode d'installation Résumé du processus
Téléchargement depuis le portail clients de SOLIDWORKS
  1. Accédez au portail clients de SOLIDWORKS.
  2. Connectez-vous en tant que client sous contrat de maintenance avec votre adresse de messagerie et votre mot de passe ou votre numéro de série SOLIDWORKS.
  3. Sous Self Service (Libre-service), cliquez sur Download Software and Updates (Télécharger le logiciel et les mises à jour).
  4. Sous Download Software, cliquez sur la version de SOLIDWORKS que vous souhaitez installer.
Vous devez disposer d'une connexion Internet en état de fonctionnement, avoir souscrit un contrat de maintenance et avoir accès par identifiant au Portail clients.
A l'aide d'un répertoire de téléchargement sur un serveur. Dans le répertoire de téléchargement, double-cliquez sur setup.exe.

Le répertoire de téléchargement doit être accessible depuis l'ordinateur sur lequel vous installez les produits SOLIDWORKS ; il doit aussi contenir tous les fichiers d'installation de SOLIDWORKS pour que l'installation puisse commencer. Le Gestionnaire d'installation SOLIDWORKS peut vous aider à trouver les fichiers manquants si vous avez accès à Internet et accès au répertoire de téléchargement.

A l'aide du média d'installation SOLIDWORKS.
  • Procurez-vous des DVD auprès de votre revendeur (VAR) et insérez les disques dans le lecteur de l'ordinateur.
Mettre à jour une installation SOLIDWORKS existante à l'aide de la commande Vérifier la disponibilité de mises à jour Effectuez l'une des opérations suivantes:
  • Dans SOLIDWORKS, cliquez sur Aide > Vérifier la disponibilité de mises à jour.
  • Dans Windows, cliquez sur Démarrer > Tous les programmes > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour.
Vous devez disposer d'une connexion Internet en état de fonctionnement et de privilèges d'administrateur sur l'ordinateur.

Dans le gestionnaire d'installation SOLIDWORKS, vous pouvez également choisir l'option Télécharger et partager tous les fichiers, y compris le logiciel requis. Cette option est utile si vous installez le logiciel sur quelques machines et que vous souhaitez copier le téléchargement à l'aide d'un lecteur portable ou d'un lecteur réseau. Elle est également utile pour l'installation des Service Packs, car la version complète et le Service Pack sont contenus dans une seule installation.

Une fois l'installation terminée, démarrez l'application SOLIDWORKS et activez la licence.

Pour afficher la liste des produits installés sur votre ordinateur, depuis le menu principal SOLIDWORKS, cliquez sur ? > Mes produits. Les coches dans la boîte de dialogue indiquent les produits que vous ou votre organisation possédez, en fonction de vos licences d'activation et de vos licences réseau. Si vous souhaitez en savoir plus sur les produits SOLIDWORKS, cliquez sur le lien au-dessus de chaque catégorie de produit.

Pour savoir quelles sont les licences en cours d'utilisation, sous Windows, cliquez sur Démarrer > SOLIDWORKS <version> > Outils SOLIDWORKS > SolidNetWork License Manager Client > Utilisation de la licence.

Sujet parent Installations individuelles
Administration d'installations individuelles
Conseils pour l'utilisation de SOLIDWORKS avec Microsoft Windows 8


Administration d'installations individuelles

De manière générale, l'administration d'installations individuelles consiste à modifier, réparer, supprimer et mettre à niveau les installations.

Table des matières

  • Modifier une installation

    Vous pouvez modifier une installation pour installer des produits qui n'ont pas été installés ou supprimer des produits, à condition que l'installation précédente ait été effectuée avec un ensemble complet de fichiers d'installation. Cette option n'est pas disponible si vous avez mis à niveau l'installation précédente avec un service pack.

  • Réparer une installation

    Si vous rencontrez des problèmes avec un produit SOLIDWORKS installé, vous pouvez utiliser le Gestionnaire d'installation SOLIDWORKS pour réparer l'installation.

  • Restaurer un service pack antérieur dans une installation individuelle

  • Supprimer une installation

    Vous pouvez supprimer une installation sur un ordinateur individuel ou dans un environnement client/serveur.

  • Mettre à niveau vers une nouvelle version

    Plusieurs méthodes permettent de mettre à niveau une installation individuelle vers une nouvelle version de SOLIDWORKS.

  • Règles de coexistence des produits

    Ces règles de coexistence déterminent la façon dont les nouveaux produits sont installés et les produits existants mis à niveau.

Sujet parent Installations individuelles
Installation sur des ordinateurs individuels


Modifier une installation

Vous pouvez modifier une installation pour installer des produits qui n'ont pas été installés ou supprimer des produits, à condition que l'installation précédente ait été effectuée avec un ensemble complet de fichiers d'installation. Cette option n'est pas disponible si vous avez mis à niveau l'installation précédente avec un service pack.

Si vous avez acheté un complément après avoir installé SOLIDWORKS, vous pouvez modifier l'installation pour y inclure le nouveau complément. Vous devez installer le complément sur chaque ordinateur individuel.

  1. Assurez-vous qu'aucune session SOLIDWORKS n'est en cours.
  2. Dans Windows 7 ou version ultérieure, cliquez sur Démarrer > Panneau de configuration >Programmes et fonctionnalités.
  3. Sélectionnez l'installation SOLIDWORKS que vous souhaitez modifier puis cliquez sur Modifier.
  4. Sur l'écran Bienvenue dans le Gestionnaire d'installation de SOLIDWORKS, cliquez sur Modifier l'installation individuelle (sur cet ordinateur)
  5. Sur l'écran Numéro de série, vérifiez que les numéros de série appropriés sont sélectionnés.
  6. Sur l'écran Sélection des produits, sélectionnez les produits à installer ou supprimer.
    Lorsque vous modifiez une installation:
    • Aucun produit n'est installé ou supprimé par défaut, même si vous indiquez un nouveau numéro de série. Vous devez modifier l'action d'installation sur chaque produit ou composant.
    • Pour visualiser l'action que vous projetez pour un composant particulier, cliquez sur le nom du composant (mais pas dans la case à cocher). L'installation projetée s'affiche dans le champ d'information situé sous l'entrée de produit dans la liste.
    • Vous pouvez cocher la case adjacente au composant du produit pour changer l'action d'installation de ce composant. (A titre d'exemple, si vous installez ou supprimez des composants, la sélection de la case à cocher indique que le composant doit être installé ou supprimé et la suppression de la sélection de la case à cocher indique que le composant ne doit ni être installé ni supprimé).
    • Lorsque vous modifiez une action d'installation de composant de la spécification initiale, un astérisque (*) apparaît à côté de ce composant dans la liste.
    • Si un composant dispose de sous-composants d'installation optionnels, une icône + s'affiche adjacente au composant. Pour afficher les sous-composants disponibles pour un composant, cliquez sur l'icône +.
    • Si un composant a été développé pour afficher des sous-composants optionnels, une icône - s'affiche adjacente au composant. Pour réduire la liste des sous-composants, cliquez sur l'icône -.
  7. Dans l'écran Résumé, cliquez sur Modifier maintenant.
  8. Dans l'écran L'installation est terminée, cliquez sur Terminer.
Sujet parent Administration d'installations individuelles
Réparer une installation
Restaurer un service pack antérieur dans une installation individuelle
Supprimer une installation
Mettre à niveau vers une nouvelle version
Règles de coexistence des produits


Réparer une installation

Si vous rencontrez des problèmes avec un produit SOLIDWORKS installé, vous pouvez utiliser le Gestionnaire d'installation SOLIDWORKS pour réparer l'installation.

Cependant, pour réparer une installation, votre ordinateur doit disposer de tous les fichiers source de l'installation précédente et tous les service packs qui ont été appliqués, à l'emplacement auquel ils ont été installés à l'origine.

Vous pouvez réparer une installation individuelle. Vous ne pouvez pas réparer une image administrative; vous devez la désinstaller puis la réinstaller.
  1. Dans Windows 7 ou version ultérieure, cliquez sur Démarrer > Panneau de configuration > Programmes > Programmes et fonctionnalités.
  2. Sélectionnez la version de SOLIDWORKS que vous souhaitez réparer et cliquez sur Modifier.
  3. Sur l'écran Bienvenue dans le Gestionnaire d'installation de SOLIDWORKS, cliquez sur Réparer l'installation individuelle (sur cet ordinateur).
  4. Sur l'écran Produits à réparer, sélectionnez le produit à réparer.
  5. Désactivez le reste des produits sur l'écran.
  6. Cliquez sur Réparer.
Sujet parent Administration d'installations individuelles
Sujet parent Erreurs d'installation / Installation annulée
Modifier une installation
Restaurer un service pack antérieur dans une installation individuelle
Supprimer une installation
Mettre à niveau vers une nouvelle version
Règles de coexistence des produits
Récupération d'une installation qui a échoué ou qui a été annulée
Contacter le revendeur SOLIDWORKS


Restaurer un service pack antérieur dans une installation individuelle

Pour restaurer une installation individuelle à une version du service pack de la famille de la version majeure actuelle, désinstallez la version du service pack installée actuellement sur l'ordinateur puis réinstallez la version antérieure.
Sujet parent Administration d'installations individuelles
Modifier une installation
Réparer une installation
Supprimer une installation
Mettre à niveau vers une nouvelle version
Règles de coexistence des produits


Supprimer une installation

Vous pouvez supprimer une installation sur un ordinateur individuel ou dans un environnement client/serveur.

  1. Assurez-vous qu'aucune session SOLIDWORKS n'est en cours.
  2. Si vous souhaitez transférer la licence SOLIDWORKS sur un autre ordinateur, désactivez la licence sur cet ordinateur avant de supprimer l'installation SOLIDWORKS sur cet ordinateur.
    Pour plus d'informations, voir Transférer une licence.
  3. Dans Windows 7 ou une version ultérieure, lancez le Panneau de configuration > Programmes et fonctionnalités.
  4. Sélectionnez le composant produit à supprimer.
    Dans certains cas, il se peut qu'il y ait plusieurs composants Service Pack de SOLIDWORKS pour une version majeure donnée. Pour supprimer une version majeure de SOLIDWORKS, supprimez tous les éléments Service Pack de cette version majeure.
  5. Sur l'écran Désinstallation:
    1. Sélectionnez les produits à supprimer. Par défaut, tous les composants des produits sont sélectionnés.
    2. Désélectionnez les produits que vous ne voulez pas supprimer.
    3. Choisissez une désinstallation complète ou personnalisée. Par défaut, le Gestionnaire d'installation SOLIDWORKS effectue une désinstallation standard et enlève les fichiers et dossiers du programme.
      1. Cliquez sur Modifier dans Options avancées.

        L'écran Options avancées apparaît et l'option Fichiers et dossiers programme est sélectionnée

      2. Sélectionnez une option ou plus pour une désinstallation personnalisée ou toutes les options pour une désinstallation complète.
      3. Cliquez sur Retour au résumé.
      4. Sur l'écran Résumé, développez Options avancées pour afficher la méthode de désinstallation et les entrées.
    4. Cliquez sur Supprimer des éléments.
Sujet parent Administration d'installations individuelles
Sujet parent Administration d'installations multiples
Modifier une installation
Réparer une installation
Restaurer un service pack antérieur dans une installation individuelle
Mettre à niveau vers une nouvelle version
Règles de coexistence des produits
Mettre à niveau des images administratives vers une nouvelle version
Administration des mises à jour de produits au moyen des service packs
Transférer une licence


Mettre à niveau vers une nouvelle version

Plusieurs méthodes permettent de mettre à niveau une installation individuelle vers une nouvelle version de SOLIDWORKS.

Vous pouvez mettre à niveau vers une nouvelle version quand vous:
  • Recevez un nouveau média d'installation
  • Etes notifié de mises à jour lors du démarrage de SOLIDWORKS.
  • Vérifiez manuellement la disponibilité de mises à jour.
  • Démarrez une nouvelle occurrence du Gestionnaire d'installation SOLIDWORKS.

Lorsque installez une nouvelle version majeure, vous pouvez mettre à niveau une version majeure installée précédemment ou installer la nouvelle version en parallèle. Si vous installez une version Service Pack d'une version majeure installée précédemment, cette version est mise à jour automatiquement.

Sujet parent Administration d'installations individuelles
Modifier une installation
Réparer une installation
Restaurer un service pack antérieur dans une installation individuelle
Supprimer une installation
Règles de coexistence des produits

Vérifier manuellement la disponibilité de mises à jour

Si vous disposez de privilèges d'administrateur sur l'ordinateur, vous pouvez vérifier la disponibilité de mises à jour de la version SOLIDWORKS installée au moyen d'une des méthodes suivantes.

  • Dans SOLIDWORKS, cliquez sur ? > Vérifier la disponibilité de mises à jour.
  • Sous Microsoft Windows, cliquez sur Démarrer > Tous les programmes > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour.

Mises en garde relatives aux mises à niveau

Il n'est pas toujours possible d'appliquer une mise à niveau majeure aux produits pour lesquels plusieurs versions majeures différentes sont installées ou d'appliquer une mise à niveau entre des versions majeures en une seule opération.

Dans ce cas, le Gestionnaire d'installation SOLIDWORKS simule la mise à niveau en installant d'abord la nouvelle version, puis en supprimant l'ancienne. Actuellement, seul le produit SOLIDWORKS principal prend en charge les mises à niveau majeures.

Les conséquences sont les suivantes :
  • Lors de la mise à niveau du produit SOLIDWORKS principal entre des versions majeures :
    • Votre emplacement d'installation existant ne change pas.
    • La mise à niveau peut être annulée si une erreur survient ou si vous y mettez fin.
  • Lorsque d'autres produits sont mis à niveau entre des versions majeures :
    • Chaque produit est d'abord installé en tant que nouveau produit à un nouvel emplacement, puis l'installation d'origine est supprimée.
    • Une fois commencée, la mise à niveau peut être annulée si une erreur survient ou si vous y mettez fin.


Règles de coexistence des produits

Ces règles de coexistence déterminent la façon dont les nouveaux produits sont installés et les produits existants mis à niveau.

Règle | Exemples
Plusieurs versions majeures du produit SOLIDWORKS principal sont autorisées, à l'exception des produits mentionnés ci-dessous. | SOLIDWORKS 2019 SP3.0 et SOLIDWORKS 2020 SP0.0 peuvent coexister sur le même ordinateur.
Plusieurs service packs de la même version majeure ne sont pas autorisés. | SOLIDWORKS 2020 SP0.0 et 2020 SP1.0 ne peuvent pas coexister sur le même ordinateur. Si vous installez SOLIDWORKS 2020 SP1.0 sur un ordinateur où SOLIDWORKS 2020 SP0.0 est déjà installé, le Gestionnaire d'installation SOLIDWORKS remplace SP0.0 par SP1.0.
Une seule version des produits suivants est permise sur l'ordinateur :
  • SolidNetWork License Manager
 Si SOLIDWORKS 2020 SP0.0 est installé, SolidNetWork License Manager est mis à niveau vers 2020 SP0.0, même si une version majeure antérieure de SOLIDWORKS existe sur l'ordinateur.
Une seule version du produit suivant est permise sur l'ordinateur :
  • SOLIDWORKS Electrical
 Si vous créez une nouvelle installation de SOLIDWORKS Electrical 2020 SP1.0, le Gestionnaire d'installation SOLIDWORKS supprimera automatiquement toutes les versions précédentes de SOLIDWORKS Electrical présentes sur l'ordinateur. Sauvegardez votre environnement SOLIDWORKS Electrical avant de le mettre à niveau.
Une seule version des produits suivants est permise sur l'ordinateur :
  • SOLIDWORKS PDM Client
  • SOLIDWORKS PDM Server

Si vous installez SOLIDWORKS 2020 SP0.0 ou SP1.0, vous devez également mettre à niveau vers SOLIDWORKS 2020 PDM Server et PDM Client.

Si vous installez SOLIDWORKS 2020 PDM Server, vous devez utiliser le processus d'installation de PDM Server pour installer SOLIDWORKS PDM Client. N'installez pas SOLIDWORKS PDM Client séparément avec le processus d'installation du client.

SOLIDWORKS PDM Client doit être la même version et le même service pack que SOLIDWORKS PDM Server sur le même ordinateur.

Voir la rubrique Installation d'un serveur PDM avec SLDIM pour plus d'informations.

Une seule version d'un produit inclus peut être installée pour n'importe quelle version majeure de SOLIDWORKS. Toutefois, les versions des produits inclus dans différentes versions majeures de SOLIDWORKS peuvent coexister. | Si SOLIDWORKS 2020 SP0.0 est mis à niveau vers 2020 SP1.0, SOLIDWORKS Composer 2020 SP0.0 sera automatiquement mis à niveau vers 2020 SP1.0. Cependant, SOLIDWORKS Composer 2019 SP4.0 peut coexister avec SOLIDWORKS Composer 2020 SP0.0 ou avec SOLIDWORKS Composer 2020 SP1.0.
Sujet parent Administration d'installations individuelles
Modifier une installation
Réparer une installation
Restaurer un service pack antérieur dans une installation individuelle
Supprimer une installation
Mettre à niveau vers une nouvelle version


Installations multiples

Table des matières

  • Déployer vers des clients multiples

    Vous pouvez installer SOLIDWORKS sur plusieurs clients en créant une image administrative, puis en déployant l'installation vers les clients.

  • Utilisation des images administratives

    Une image administrative permet de réaliser des installations configurables des produits SOLIDWORKS à partir d'un emplacement de réseau unique.

  • Déployer une image administrative sur des clients par courrier électronique

    Après avoir créé un répertoire d'image administrative partagé, vous pouvez le notifier aux clients par courrier électronique.

  • Déploiement avec la ligne de commande

    Vous pouvez déployer une image administrative automatiquement en utilisant une Invite ou un fichier de commandes (installation silencieuse).

  • Administration d'installations multiples

    Dans le cas des installations multiples, les tâches administratives comprennent la mise à niveau des images administratives vers de nouvelles versions, l'application de services packs et la suppression d'installations.


Déployer vers des clients multiples

Vous pouvez installer SOLIDWORKS sur plusieurs clients en créant une image administrative, puis en déployant l'installation vers les clients.

Le processus de déploiement des clients multiples est le suivant:
  1. Création d'une image administrative.
    • Créer une image administrative à partir du gestionnaire d'installation SOLIDWORKS
  2. Déploiement de l'image administrative sur les clients.
    • Déployer une image administrative sur des clients par courrier électronique
    • Installer depuis l'image administrative en utilisant la ligne de commande
  3. Implémentation de licences.
    • Administrer les licences individuelles
    • Administrer des licences avec SolidNetWork License Manager
Sujet parent Installations multiples
Utilisation des images administratives
Déployer une image administrative sur des clients par courrier électronique
Déploiement avec la ligne de commande
Administration d'installations multiples
Conseils pour l'utilisation de SOLIDWORKS avec Microsoft Windows 8


Utilisation des images administratives

Une image administrative permet de réaliser des installations configurables des produits SOLIDWORKS à partir d'un emplacement de réseau unique.

Vous pouvez installer l'image administrative à partir de n'importe quel ordinateur sur le réseau, notamment un ordinateur client.
  • L'image administrative doit se trouver dans un dossier partagé.
  • Si tous les produits sont inclus, l'image administrative peut prendre jusqu'à 7 Go d'espace disque.
  • Si vous mettez à jour le nom du partage lorsque vous mettez à niveau l'image administrative, le client est automatiquement mis à jour au prochain démarrage de l'application. Pour plus de détails, voir Mise à niveau de clients à partir d'images administratives.
  • Lors du déploiement d'une image administrative, le chemin de l'image doit comporter au maximum 58 caractères.
  • Les clients doivent avoir des privilèges d'administration sur leur ordinateur. Si un client ne dispose pas des privilèges suffisants, il peut exécuter une installation sous un autre nom d'utilisateur. Cette option est pratique lorsqu'un utilisateur individuel ne dispose pas sur son ordinateur des permissions administratives locales qui sont requises pour l'installation des produits SOLIDWORKS.

    Consultez Mise en place des installations à partir de l'Editeur d'options. Une autre méthode y est également décrite pour installer des images lorsqu'un client ne dispose pas des privilèges suffisants.

  • Si la journalisation Windows est activée ou si vous utilisez la fonctionnalité d'état dans l'Editeur d'options du Gestionnaire d'images administratives, vous devez avoir les autorisations en lecture/écriture pour ce dossier : {Répertoire de l'image administrative}\x64\Logs.

Après avoir créé une image administrative, l'Editeur d'options du Gestionnaire d'images administratives peut gérer les paramètres de l'option pour les utilisateurs et les groupes effectuant une installation à partir de cette image. Pour plus de détails, reportez-vous à Editeur d'options du Gestionnaire d'images administratives.

Table des matières

  • Créer une image administrative à partir du gestionnaire d'installation SOLIDWORKS

    Si vous installez SOLIDWORKS sur plusieurs ordinateurs, vous pouvez créer une image administrative, puis déployer l'application sur d'autres ordinateurs.

Sujet parent Installations multiples
Déployer vers des clients multiples
Déployer une image administrative sur des clients par courrier électronique
Déploiement avec la ligne de commande
Administration d'installations multiples
Mise à niveau de clients à partir d'images administratives
Editeur d'options du Gestionnaire d'images administratives


Créer une image administrative à partir du gestionnaire d'installation SOLIDWORKS

Si vous installez SOLIDWORKS sur plusieurs ordinateurs, vous pouvez créer une image administrative, puis déployer l'application sur d'autres ordinateurs.

  1. Lancez le Gestionnaire d'installation SOLIDWORKS. Voir Lancer l'installation de SOLIDWORKS.
  2. Dans l'écran Bienvenue, sélectionnez Image administrative.
    Les options de création d'images administratives s'affichent.
    Option | Description
    Créer une nouvelle image en utilisant les paramètres par défaut. | Créer l'image à l'aide des paramètres de configuration par défaut (sans se baser sur les paramètres définis pour une image administrative existante sur votre site).
    Créer une nouvelle image en utilisant les paramètres et les fichiers d'une image existante. | Créer l'image à l'aide des paramètres de configuration indiqués pour une image administrative existante sur votre site. Cliquez sur Parcourir pour indiquer le répertoire d'installation de l'image administrative existante.
  3. Suivez les instructions affichées à l'écran.

Table des matières

  • Editeur d'options du Gestionnaire d'images administratives

    L'Editeur d'options du Gestionnaire d'images administratives vous permet de personnaliser les paramètres d'installation pour les groupes d'ordinateurs et pour les ordinateurs individuels..

Sujet parent Utilisation des images administratives
Lancer l'installation de SOLIDWORKS


Editeur d'options du Gestionnaire d'images administratives

L'Editeur d'options du Gestionnaire d'images administratives vous permet de personnaliser les paramètres d'installation pour les groupes d'ordinateurs et pour les ordinateurs individuels..

Après la création de l'image administrative, le Gestionnaire d'installation SOLIDWORKS vous demande de démarrer l'Editeur d'options. Vous pouvez également démarrer l'Editeur d'options en double cliquant sur sldAdminOptionEditor.exe dans le dossier de l'image administrative.

Si vous souhaitez spécifier différentes configurations d'installation pour des groupes de machines ou des machines spécifiques, dans l'Editeur d'options, sélectionnez des machines en spécifiant l'un des éléments suivants :
  • Nom de l'ordinateur
  • Adresse IP
  • Plage d'adresses IP
Spécifiez ensuite les options d'installation de ces machines.
Toutes les boîtes de dialogue qui invitent à choisir un chemin de fichier ou de dossier incluent une option vous permettant d'attribuer un dossier sélectionné à une variable d'environnement. Par exemple, si vous sélectionnez C:\Program Files\SOLIDWORKS Corp, le chemin d'accès au fichier est mappé à %ProgramFiles%\SOLIDWORKS Corp. Les variables les plus courantes sont %ProgramFiles% et %SystemDrive%. De plus, vous ne pouvez pas convertir tous les chemins en variables d'environnement. Par exemple, il n'est pas possible de mapper Z:\SOLIDWORKS Data à une variable d'environnement.

Table des matières

  • Ajouter et supprimer des groupes et des ordinateurs

    L'Editeur d'options du Gestionnaire d'images administratives vous permet d'indiquer les différentes configurations d'installation pour les groupes d'ordinateurs et pour les ordinateurs individuels.

  • Affichage et édition des paramètres d'option

    L'Editeur d'option du Gestionnaire d'images administratives SOLIDWORKS vous permet de visualiser et de modifier les paramètres d'option pour les groupes et les ordinateurs spécifiés pour l'image.

  • Outil Administrateur des paramètres

  • Mise en place des installations à partir de l'Editeur d'options

    Vous pouvez mettre en place les installations directement depuis l'Editeur d'options en vous servant d'une méthode manuelle ou de poussée.

  • Quitter l'Editeur d'options

    Vous pouvez cliquer sur OK ou sur Fermer pour quitter l'Editeur d'options.

  • Création d'un raccourci sur le Bureau vers l'Editeur d'options

    Vous pouvez créer un raccourci sur le bureau Windows vers l'Editeur d'options pour une image administrative donnée à partir de l'application.

Sujet parent Créer une image administrative à partir du gestionnaire d'installation SOLIDWORKS


Ajouter et supprimer des groupes et des ordinateurs

L'Editeur d'options du Gestionnaire d'images administratives vous permet d'indiquer les différentes configurations d'installation pour les groupes d'ordinateurs et pour les ordinateurs individuels.

Par exemple, vous pourriez souhaiter configurer plusieurs ordinateurs afin d'utiliser un ensemble particulier de composants de produits disponibles dans l'image alors q'un autre groupe pourrait utiliser un autre ensemble de sous-composants. Bien que vous utilisiez une seule image administrative, les paramètres de groupe de l'Editeur d'options vous permettent d'installer différents sous-ensembles de produits sur différents groupes d'ordinateurs.

Pour ajouter un groupe:
  1. Cliquez à l'aide du bouton droit de la souris sur Paramètres globaux puis sur Ajouter un groupe.
  2. Entrez le nom du groupe.

Pour ajouter des ordinateurs:
  1. Cliquez à l'aide du bouton droit de la souris sur Paramètres globaux puis sur Ajouter un ordinateur.
    Si vous cliquez sur un groupe existant à l'aide du bouton droit de la souris, des ordinateurs sont ajoutés à ce groupe. Sinon, ils sont ajoutés au premier niveau.
  2. Effectuez l'une des opérations suivantes :
    • Sélectionnez Par nom d'ordinateur et saisissez un ou plusieurs noms d'ordinateurs. Plusieurs ordinateurs doivent être séparés par un saut de retour à la ligne, un espace, une tabulation, une virgule, un point, deux points ou un point-virgule. Vous pouvez copier et coller une liste d'ordinateurs à partir d'un fichier externe. Les noms d'ordinateurs ne peuvent pas inclure le nom du domaine. Par exemple, pluto.solidworks.com est invalide.
    • Sélectionnez Par adresse IP et saisissez l'adresse IP d'un ordinateur.
    • Sélectionnez Par plage d'adresses IP et saisissez l'adresse IP de début et l'adresse IP de fin de la plage.
    • Cliquez sur Ajouter plusieurs ordinateurs pour sélectionner des machines sur le réseau.

Pour déplacer un ordinateur existant vers un groupe:

Faites glisser l'ordinateur dans le groupe.

Pour déplacer un ordinateur en dehors d'un groupe:

Faires glisser l'ordinateur sur Paramètres globaux ou sur un groupe différent.

Pour supprimer un groupe ou un ordinateur:

A l'aide du bouton droit de la souris, cliquez sur le groupe ou l'ordinateur, puis cliquez sur Supprimer le groupe ou Supprimer l'ordinateur.

Si vous supprimez un groupe, tous les ordinateurs de ce groupe sont supprimés.

Pour supprimer tous les groupes et tous les ordinateurs:

Cliquez à l'aide du bouton droit de la souris sur Paramètres globaux puis cliquez sur Tout supprimer.

Sujet parent Editeur d'options du Gestionnaire d'images administratives
Affichage et édition des paramètres d'option
Outil Administrateur des paramètres
Mise en place des installations à partir de l'Editeur d'options
Quitter l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options


Affichage et édition des paramètres d'option

L'Editeur d'option du Gestionnaire d'images administratives SOLIDWORKS vous permet de visualiser et de modifier les paramètres d'option pour les groupes et les ordinateurs spécifiés pour l'image.

  • Lorsque vous lancez l'Editeur d'option pour la première fois, les paramètres d'option s'affichent en mode lecture seule. L'icône Editer n'est pas grisée.

    Lorsque vous cliquez sur Paramètres globaux, un récapitulatif des paramètres d'option d'un groupe ou d'un ordinateur s'affiche pour cet élément:

    Zone d'action | Paramètres d'option affichés
    Paramètres globaux | Tous les paramètres d'option spécifiés pour l'image administrative.
    Groupe | Change dans les paramètres de groupe relatifs aux paramètres globaux
    Machine | Change dans les paramètres de l'ordinateur relatifs au groupe
  • Pour apporter des modifications aux paramètres d'option, cliquez sur l'icône Editer. L'icône est grisée et une liste des paramètres d'option plus détaillée s'affiche.

    Lorsque vous cliquez sur Paramètres globaux, un groupe ou un ordinateur vous permettent de changer les paramètres d'option pour cet élément. Lorsque vous modifiez un paramètre d'option qui diffère des paramètres globaux ou des paramètres de groupe hérités, ce paramètre d'option est mis en surbrillance.

    Si vous recliquez sur l'icône Editer, le mode de lecture seule est restauré à l'affichage.

    Si vous apportez des modifications, l'Editeur d'option vous invite à les enregistrer ou à les ignorer lorsque vous quittez.

Table des matières

  • Indiquer des paramètres d'option pour les groupes et les ordinateurs

    Vous pouvez indiquer des paramètres d'option pour tous les ordinateurs (Paramètres globaux), groupes d'ordinateurs et ordinateurs individuels.

  • Paramètres d'options relatifs à l'image administrative

    L'Editeur d'options permet de spécifier les paramètres relatifs aux options de clients ou de groupes individuels, y compris les numéros de série, les options d'installation du client, quels composants sont installés, et l'emplacement de Toolbox.

  • Héritage des paramètres d'option globaux et de groupe

    Les paramètres d'option pour Paramètres globaux ou de groupe sont hérités par des éléments situés dessous.

  • Personnalisation des paramètres pour chaque ordinateur

    Vous pouvez également modifier des paramètres que vous avez appliqués à des ordinateurs spécifiques en cliquant avec le bouton droit sur le nom de l'ordinateur.

Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Outil Administrateur des paramètres
Mise en place des installations à partir de l'Editeur d'options
Quitter l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options


Indiquer des paramètres d'option pour les groupes et les ordinateurs

Vous pouvez indiquer des paramètres d'option pour tous les ordinateurs (Paramètres globaux), groupes d'ordinateurs et ordinateurs individuels.

  1. Dans l'Editeur d'options, cliquez sur l'objet à modifier (par exemple, Paramètres globaux, un groupe ou un ordinateur).
  2. A droite, cliquez sur l'icône Editer.
    L'icône Editer est grisée et une liste des paramètres d'option plus détaillée s'affiche.
  3. Modifiez les paramètres d'option en cliquant sur les paramètres d'option à droite de l'article sélectionné sur la gauche.
    Les modifications apportées aux paramètres d'option remplaçant les Paramètres globaux ou les paramètres de groupe sont mises en surbrillance.
  4. Cliquez sur OK ou Fermer pour sauvegarder vos modifications.
    Option | Description
    OK | L'Editeur d'options enregistre vos modifications et se ferme.
    Fermer | L'Editeur d'options demande si vous voulez enregistrer les modifications apportées et se ferme.
Sujet parent Affichage et édition des paramètres d'option
Paramètres d'options relatifs à l'image administrative
Héritage des paramètres d'option globaux et de groupe
Personnalisation des paramètres pour chaque ordinateur


Paramètres d'options relatifs à l'image administrative

L'Editeur d'options permet de spécifier les paramètres relatifs aux options de clients ou de groupes individuels, y compris les numéros de série, les options d'installation du client, quels composants sont installés, et l'emplacement de Toolbox.

Numéros de série

Saisissez les numéros de série pour installer les produits sur les ordinateurs client.
Comme il existe différentes façons d'acheter les produits SOLIDWORKS, certains numéros de série couvrent deux produits ou plus. Ainsi, un numéro de série SOLIDWORKS peut vous permettre d'installer SOLIDWORKS Simulation sans entrer de numéro de série SOLIDWORKS Simulation séparé. De plus, certains produits ne requièrent pas de numéro de série. Si vous avez des questions au sujet de vos numéros de série, contactez votre revendeur agréé.
Si vous gérez les licences à l'aide SolidNetWork :
  • Dans le premier champ du numéro de série, saisissez le numéro de série de SolidNetWork.
  • Dans le champ Port serveur SNL@serveur, saisissez le nom du serveur et le port SolidNetWork License Manager au format suivant nnnnn<nomserveur. Utilisez des points virgules pour séparer les saisies.

Pour de plus amples informations sur la licence SolidNetWork, reportez-vous à Installer et configurer la gestion des licences SolidNetWork.

Options d'installation du client

Comment souhaitez-vous effectuer les installations de clients de versions majeures? Vous pouvez indiquer comment ces installations de client gèrent une installation existante de la version majeure antérieure :
  • Mettre à niveau une version majeure existante.

    Indiquez cette option pour remplacer l'installation de la version majeure antérieure par l'installation de la nouvelle version.

  • Créer une nouvelle version majeure.

    Indiquez cette option pour conserver la version majeure antérieure et créer une installation pour la nouvelle version majeure. Pour indiquer l'emplacement de l'installation de la nouvelle version, cliquez sur Parcourir.
Souhaitez-vous désinstaller la version précédente la plus récente avant d'installer une nouvelle version majeure? Vous pouvez spécifier si vous souhaitez désinstaller la version majeure antérieure existante :
  • Non, ne pas désinstaller.

    Sélectionnez cette option pour conserver l'installation de la version majeure antérieure.

  • Oui, désinstallation personnalisée.

    Sélectionnez cette option pour supprimer les éléments suivants : Fichiers et dossiers de données créés par une installation antérieure.

Comment souhaitez-vous appliquer les paramètres SOLIDWORKS ? Vous pouvez spécifier un fichier de paramètres en démarrant le logiciel. Les installations de clients se réfèrent à un fichier de paramètres. Enregistrez le fichier de paramètres (*.sldsettings) dans un chemin d'accès UNC partagé visible de toutes les installations. Spécifiez un chemin d'accès de fichier *.sldsettings avant d'installer SOLIDWORKS. Les installations de clients détectent le chemin d'accès du fichier *.sldsettings lors de l'installation.
Sécurisez le fichier *.sldsettings en définissant des autorisations de fichiers Windows qui limitent l'accès en écriture aux utilisateurs désignés.

Pour créer ou éditer un fichier *.sldsettings, cliquez sur Lancer l'Administrateur des paramètres. L'outil Administrateur de paramètres de SOLIDWORKS vous permet de définir les options système de SOLIDWORKS à appliquer et éventuellement à verrouiller pour les utilisateurs. Vous pouvez également définir comment et quand appliquer les paramètres à des installations individuelles. Vous pouvez modifier le fichier *.sldsettings à tout moment pendant l'exécution de l'outil Administrateur de paramètres et l'écrasement du fichier existant.

Vous pouvez utiliser différents fichiers *.sldsettings pour les différents ordinateurs ou groupes.

Le chemin d'accès vers le fichier *.sldsettings se définit lors de l'installation. Une fois le déploiement effectué, vous ne devez ni renommer, ni déplacer le fichier *.sldsettings.

Vous devez disposer d'une installation existante de SOLIDWORKS 2020 [version majeure actuelle] pour pouvoir exécuter l'outil Administrateur des paramètres.
Comment souhaitez-vous activer les installations clients? Vous pouvez indiquer si l'activation des produits doit être automatique après avoir exécuté l'installation ou si l'utilisateur doit s'en charger manuellement.
  • Activation automatique lorsque chaque installation client est terminée.

    L'activation s'exécute automatiquement avec un fichier d'activation de produit SOLIDWORKS.

  • Pas d'activation automatique.

    Spécifie que l'activation de produit ne se fait pas automatiquement. L'utilisation du client effectue l'activation après l'installation.

Options d'administration

Créer un journal de diagnostic lors de chaque installation. | Une installation de clients peut créer un journal de diagnostic pour dépanner les problèmes d'installation. La création de ce journal peut ralentir l'installation du client. Le fichier journal est stocké dans Répertoire de l'image administrative}\x64\Logs\<nom_machine>\Status.xml.
Exécuter l'installation sous un autre nom d'utilisateur.

Une installation client peut être exécutée comme un autre utilisateur. Cette option est pratique lorsque les utilisateurs ne disposent pas de permissions administratives locales sur leurs ordinateurs (qui sont requises pour l'installation des produits SOLIDWORKS).

Une méthode alternative de déploiement et d'installation est disponible quand les clients n'ont pas de privilèges d'administrateur. Consultez Mise en place des installations à partir de l'Editeur d'options.
Exécuter un programme avant ou après l'installation. | Vous pouvez indiquer qu'un programme personnalisé soit exécuté avant ou après l'installation client.
Voulez-vous que les clients participent au Programme Expérience Client de SOLIDWORKS ? | Vous pouvez indiquer que les machines client participent au Programme Expérience Client de SOLIDWORKS. Des informations au sujet des performances sont envoyées à SOLIDWORKS Corporation dans le but d'améliorer le produit. Le processus est transparent et confidentiel. Pour plus de détails, visitez le site Web du Programme d'amélioration de l'expérience utilisateur.

Limitations des options Exécuter un programme avant ou après l'installation.

Ces options vous permettent d'exécuter d'autres programmes d'installation ou des scripts sur les ordinateurs clients avant ou après le déploiement de SOLIDWORKS, par exemple un script qui installe Microsoft Office.

Si vous déployez automatiquement sur des ordinateurs clients exécutant Windows 10, il existe une limitation sur l'utilisation de ces options. Un échec se produit si vous utilisez une option pour déployer un programme d'installation ou un script qui affiche une interface utilisateur, par exemple un script qui affiche des boîtes de dialogue. Lorsque le déploiement automatique de SOLIDWORKS est en cours d'exécution, il ne pourra pas installer SOLIDWORKS sur les ordinateurs cibles. Cette limitation ne survient pas avec les ordinateurs clients exécutant Windows 7.

Pour utiliser les options Exécuter un programme avant l'installation et Exécuter un programme après l'installation, sélectionnez uniquement les programmes qu'il est possible d'installer en mode silencieux.

Logiciel à installer

Vous pouvez indiquer quels composants des produits SOLIDWORKS doivent être installés.
  • Le fait de cocher la case adjacente au composant du produit inclut celui-ci à l'installation de clients.
  • Si vous ne cochez pas cette case, le composant n'est pas installé.
  • Si un composant dispose de sous-composants d'installation optionnels, une icône + est visible à côté de son nom. Pour afficher les sous-composants disponibles pour un composant, cliquez sur l'icône +.
  • Si un composant est développé de façon à afficher des sous-composants optionnels, une icône - s'affiche à côté de son nom. Pour réduire la liste des sous-composants, cliquez sur l'icône -.
La spécification des Langues limite le nombre de langues installées pour le produit SOLIDWORKS uniquement. Les installations d'autres produits ne sont pas affectées par cette spécification. Par exemple, eDrawings® installe toutes les langues.

Options Toolbox

Vous pouvez indiquer les normes à prendre en charge et l'emplacement de Toolbox par défaut pour les installations des clients.

Il y a souvent plusieurs utilisateurs accédant à Toolbox partagé, généralement via un emplacement réseau (par ex. un chemin UNC, un dossier partagé ou un lecteur réseau commun).

Si l'emplacement contient une version majeure antérieure de Toolbox, l'installation de clients met à niveau cette version de Toolbox vers la nouvelle version majeure. Les fichiers ne sont plus compatibles avec les anciennes versions majeures de SOLIDWORKS.
Si certains clients continuent d'utiliser une version plus ancienne de SOLIDWORKS, vous devez définir un emplacement différent pour le réseau Toolbox pour les clients qui effectueront la mise à niveau vers une version plus récente.

Pour de plus amples informations sur l’administration SOLIDWORKS Toolbox, voir Toolbox dans l'Aide de SOLIDWORKS.

Installation du logiciel Toolbox sans installer les données Toolbox

Si votre environnement possède un emplacement PDM ou Toolbox/Assistance pour le perçage partagé, vous pouvez définir les installations de clients de sorte qu'elles n'installent pas, ni ne mettent à niveau les données Toolbox dans cet emplacement.

Pour ce faire :
  • Vous n'avez pas encore configuré la vue locale SOLIDWORKS PDM avant d'installer le logiciel SOLIDWORKS.
  • Les fichiers de l'emplacement sont en cours d'utilisation et pourraient bloquer les installations SOLIDWORKS.
  • L'emplacement n'est pas disponible et pourrait bloquer les installations SOLIDWORKS.

Lorsque vous configurez les installations de clients pour qu'elles n'installent pas les données Toolbox, le logiciel SOLIDWORKS et les paramètres pointent vers l'emplacement Assistance pour le perçage/Toolbox, mais vous devez installer les données dans un emplacement central ultérieurement.

Pour installer le logiciel SOLIDWORKS sans inclure les données de l'Assistance pour le perçage/Toolbox :
  • Lorsque vous êtes invité à installer/mettre à niveau les fichiers Toolbox, sélectionnez Non, installer le logiciel Toolbox sans inclure les fichiers de données.

Au moins une personne, généralement l'administrateur CAD, doit installer ou mettre à niveau les données de l'Assistance pour le perçage/Toolbox dans l'emplacement central pour que le logiciel fonctionne correctement. Toute personne de l'entreprise peut réaliser cette tâche avec une seule installation manuelle du logiciel SOLIDWORKS. Si vous gérez Toolbox au sein de SOLIDWORKS PDM, suivez les étapes énoncées à la section Toolbox du Guide d'administration de SOLIDWORKS PDM pour installer ou mettre à niveau les données Toolbox.

Options de client SOLIDWORKS PDM

Vous pouvez sélectionner les options suivantes pour déployer les clients SOLIDWORKS PDM et les compléments :

  • Type de produit PDM
  • Type de client PDM
  • Fonctions

Reportez-vous à la section sur SOLIDWORKS PDM pour plus d'informations sur ces clients et compléments.

Options de SolidWorks Electrical

Vous pouvez spécifier les paramètres suivants pour les composants administratifs de SOLIDWORKS Electrical :
  • Chemin d'accès aux données
  • Nom et numéro de port de l'ordinateur serveur de collaboration
  • Nom et mot de passe de l'ordinateur SQL Server

Consultez la section sur SOLIDWORKS Electrical pour en savoir plus sur ces composants.

Sujet parent Affichage et édition des paramètres d'option
Indiquer des paramètres d'option pour les groupes et les ordinateurs
Héritage des paramètres d'option globaux et de groupe
Personnalisation des paramètres pour chaque ordinateur
Installer et configurer la gestion des licences SolidNetWork
Mise en place des installations à partir de l'Editeur d'options
SOLIDWORKS Electrical


Héritage des paramètres d'option globaux et de groupe

Les paramètres d'option pour Paramètres globaux ou de groupe sont hérités par des éléments situés dessous.

A titre d'exemple:
  • Les paramètres définis pour Paramètres globaux sont hérités par tous les groupes et ordinateurs.
  • Les paramètres définis pour un groupe sont hérités par tous les ordinateurs au sein du groupe.

Vous pouvez modifier les paramètres d'option pour un ordinateur ou un groupe pour écraser les paramètres hérités ou par défaut. Lorsque vous modifiez un paramètre hérité en changeant sa valeur par défaut ou héritée, cette option est mise en surbrillance.

Pour restaurer les paramètres d'option aux valeurs héritées d'origine, cliquez à l'aide du bouton droit de la souris sur le groupe ou l'ordinateur puis cliquez sur Restaurer les paramètres globaux (pour un groupe ou un ordinateur qui n'est pas un membre du groupe) ou sur Restaurer les paramètres du groupe (pour un ordinateur membre du groupe).
Sujet parent Affichage et édition des paramètres d'option
Indiquer des paramètres d'option pour les groupes et les ordinateurs
Paramètres d'options relatifs à l'image administrative
Personnalisation des paramètres pour chaque ordinateur


Personnalisation des paramètres pour chaque ordinateur

Vous pouvez également modifier des paramètres que vous avez appliqués à des ordinateurs spécifiques en cliquant avec le bouton droit sur le nom de l'ordinateur.

A partir du menu contextuel, vous pouvez exécuter les tâches suivantes pour chaque ordinateur :
  • Supprimer l'ordinateur de l'éditeur
  • Restaurer les paramètres globaux
  • Ajouter ou éditer des notes
  • Editer des options

L'édition d'options vous permet de modifier toutes les options pour l'ordinateur, par exemple les options d'installation client et les options administratives.

Sujet parent Affichage et édition des paramètres d'option
Indiquer des paramètres d'option pour les groupes et les ordinateurs
Paramètres d'options relatifs à l'image administrative
Héritage des paramètres d'option globaux et de groupe


Outil Administrateur des paramètres

Vous pouvez utiliser l'outil Administrateur des paramètres pour définir les options système qui sont appliquées lors du déploiement ou de la mise à niveau du logiciel SOLIDWORKS, et pour empêcher les utilisateurs de modifier ces options. Cet outil remplace l'Assistance pour copier les paramètres s'il s'agit de déployer des paramètres. Toutefois l'Assistance reste disponible pour copier des paramètres.

Il existe trois étapes pour utiliser l'outil Administrateur des paramètres :
  1. Créez une image administrative pour accéder à l'outil.
  2. Utilisez l'Administrateur des paramètres pour générer un fichier *.sldsettings contenant les options SOLIDWORKS que vous avez sélectionnées.
  3. Incluez le fichier *.sldSettings dans les installations SOLIDWORKS.

Table des matières

  • Accès à l'outil Administrateur des paramètres

    Pour accéder à l'outil Administrateur des paramètres, vous devez d'abord créer une image administrative.

  • Utilisation de l'outil Administrateur des paramètres

  • Application et verrouillage des options

  • Terminer le paramétrage des options

  • Insertion d'un fichier .sldSettings dans les installations SOLIDWORKS

Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Affichage et édition des paramètres d'option
Mise en place des installations à partir de l'Editeur d'options
Quitter l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options


Accès à l'outil Administrateur des paramètres

Pour accéder à l'outil Administrateur des paramètres, vous devez d'abord créer une image administrative.

Vous pouvez lancer l'outil Administrateur des paramètres depuis une image administrative.

Pour accéder à l'outil Administrateur des paramètres :

  1. Exécutez sldAdminOptionEditor.exe dans le dossier de l'image administrative.
  2. Dans l'Editeur d'options du Gestionnaire d'images administratives, cliquez sur Modifier les paramètres.
  3. Dans la section Options d'installation du client, procédez comme suit :
    1. Cliquez sur Utiliser un fichier de paramètres exporté de l'Administrateur des paramètres SOLIDWORKS.
    2. Cliquez sur Lancer l'Administrateur de paramètres.
Sujet parent Outil Administrateur des paramètres


Utilisation de l'outil Administrateur des paramètres

Pour utiliser l'Outil Administrateur des paramètres :

  1. Dans l'onglet Bienvenue, sélectionnez parmi les options suivantes :
    • Ensemble d'options par défaut pour démarrer avec cette version de SOLIDWORKS.
    • Importer les options SOLIDWORKS 2020 depuis cet ordinateur.
    • Rechercher un fichier sldreg existant.
    • Rechercher un fichier sldSettings existant.
    Le fichier *.sldreg est généré par l'Assistance pour copier les paramètres, et le fichier *.sldSettings est généré par l'outil Administrateur des paramètres.
  2. Cliquez sur Suivant.
Sujet parent Outil Administrateur des paramètres


Application et verrouillage des options

Dans l'onglet Options du système, deux colonnes de cases à cocher vous permettent de sélectionner les options à appliquer et les options appliquées à verrouiller pour que les utilisateurs ne puissent pas les modifier.

Lorsque les utilisateurs accèdent à la boîte de dialogue Options du système dans le logiciel SOLIDWORKS, les options verrouillées apparaissent indisponibles avec une icône de verrou [image]. Cependant, vous pouvez créer un mot de passe qui permet aux utilisateurs de déverrouiller les options. Lorsque les utilisateurs survolent une option verrouillée, une info-bulle affiche votre nom et votre e-mail, pour qu'ils puissent vous contacter et demander ce mot de passe.

Pour appliquer et verrouiller des options :

  1. Dans l'onglet Options du système, procédez comme suit :
    1. Pour appliquer une option du système, sélectionnez-la et cochez la case correspondante dans la colonne Appliquer.
    2. Pour verrouiller une option du système, sélectionnez-la et cochez les cases correspondantes à la fois dans les colonnes Appliquer et Verrouiller.
      Lorsque les utilisateurs accèdent à l'onglet Options du système, ces options s'affichent avec un verrou [image].
  2. Selon l'option, vous pouvez avoir à spécifier des paramètres supplémentaires pour l'option.
  3. Vous pouvez également empêcher les utilisateurs d'ignorer les messages en appliquant des contrôles pour les Messages/Erreurs/Avertissements.
    1. Cliquez sur Messages/Erreurs/Avertissements.
    2. Sélectionnez Appliquer et éventuellement Verrouiller pour les messages que vous souhaitez gérer.
    3. Définissez le message sur Afficher ou Ne pas afficher.

      Si vous sélectionnez Afficher, le message est supprimé d'une liste de messages ignorés par l'utilisateur et s'affiche à l'utilisateur au moment voulu. Si vous sélectionnez Ne pas afficher, le message est automatiquement ajouté à une liste de messages ignorés par l'utilisateur, et ne s'affiche pas lorsque l'utilisateur travaille sur un modèle.

      Ce tableau décrit le comportement dans le logiciel :
      Appliquer | Verrouiller | Montrer | Ne pas afficher | Comportement
      X | X | Forcer le message à s'afficher.
      X | X | Ignore le message et ajoute le message à la liste des messages ignorés.
      X | X | X | Force le message à s'afficher et désactive l'option pour Ne plus afficher dans la boîte de message.
      X | X | X | Ignore le message et les bars de l'utilisateur en l'activant Outils > Options > Messages/Erreurs/Avertissements.
  4. Dans l'onglet Options du système, cliquez sur Suivant.
Sujet parent Outil Administrateur des paramètres


Terminer le paramétrage des options

Pour terminer le paramétrage des options :

  1. Sur l'onglet Terminer, sélectionnez quand les options du système sont applicables :
    • La première fois qu'un utilisateur démarre le logiciel.
    • à chaque démarrage du logiciel.
    • et si les personnalisations s'appliquent en même temps.
  2. Vous pouvez choisir d'appliquer les options verrouillées lorsque les utilisateurs sont hors réseau, et d'autoriser l'API à remplacer les options verrouillées.
  3. Pour les options système verrouillées, vous devez fournir votre Nom et une adresse e-mail. Le logiciel SOLIDWORKS affiche ces informations dans une info-bulle lorsque les utilisateurs déplacent la souris sur une option verrouillée.
  4. Vous pouvez également autoriser les utilisateurs à remplacer les options verrouillées. Vous devez alors spécifier un Mot de passe que vous pouvez fournir aux utilisateurs.
  5. Cliquez sur Enregistrer afin de générer un fichier .sldSettings pour le déploiement.
Sujet parent Outil Administrateur des paramètres


Insertion d'un fichier .sldSettings dans les installations SOLIDWORKS

Pour inclure un fichier *.sldSettings dans votre installation :

  1. Double-cliquez sur sldAdminOptionEditor.exe dans le dossier des images administratives.
  2. Dans l'Editeur d'options du Gestionnaire d'images administratives, cliquez sur Modifier les paramètres.
  3. Dans la section Options d'installation du client, procédez comme suit :
    1. Cliquez sur Utiliser un fichier de paramètres exporté de l'Administrateur des paramètres SOLIDWORKS.
    2. Cliquez sur Editer la trajectoire et naviguez jusqu'au fichier *.sldSettings.
    Vous pouvez créer et appliquer différents fichiers *.sldSettings pour différents groupes ou ordinateurs.
  4. Déployez et installez le logiciel SOLIDWORKS.

Après le déploiement, vous pouvez répéter l'étape 2 pour modifier un fichier *.sldSettings existant à tout moment. Le logiciel SOLIDWORKS lit le fichier *.sldSettings modifié au démarrage suivant.

Sujet parent Outil Administrateur des paramètres


Mise en place des installations à partir de l'Editeur d'options

Vous pouvez mettre en place les installations directement depuis l'Editeur d'options en vous servant d'une méthode manuelle ou de poussée.

  • Utilisez la page Déployer manuellement de l'Editeur d'options pour envoyer aux utilisateurs par courrier électronique des instructions sur la façon de démarrer l'installation. Utilisez cette méthode quand les utilisateurs ont des privilèges d'administrateur pour leurs ordinateurs clients.
  • Utilisez la page Déployer automatiquement de l'Editeur d'options pour pousser automatiquement des installations sur des ordinateurs cibles. Des désinstallations personnalisées peuvent également être effectuées. Utilisez cette méthode quand des utilisateurs n'ont pas de privilèges d'administrateur pour installer des logiciels sur leurs systèmes.

Pour utiliser l'une ou l'autre méthode, vous devez remplacer le répertoire d'installation de l'image administrative par un répertoire partagé de Windows, afin que l'image soit disponible via un emplacement réseau (par exemple, \\ordinateur\répertoire_partagé ou copiez l'image entière vers un répertoire local sur chaque ordinateur, tel que C:\SOLIDWORKS Admin\SOLIDWORKS 2020 SP0).

Table des matières

  • Utilisation d'un lecteur mappé pour déployer une image administrative

    Un chemin UNC (\\machine_name\share_name ) est la méthode recommandée pour la spécification d'un emplacement sur le réseau du répertoire d'installation d'images administratives. Vous pouvez toutefois utiliser un lecteur mappé comme emplacement pour le fichier StartSWInstall.hta dans l'image administrative (par exemple, U:\StartSWInstall.hta), sous condition que les utilisateurs effectuant l'installation mappe la même lettre du lecteur au répertoire partagé d'images administratives.

  • Utilisation de StartSWInstall.exe pour déployer une image administrative

  • Déployer manuellement

    Utilisez cette méthode si les utilisateurs ont les privilèges nécessaires pour installer sur leurs systèmes.

  • Prérequis pour le déploiement automatique

    Avec le déploiement automatique, les tâches d'installation sont poussées vers les machines cibles et effectuées par le Planificateur de tâches de Microsoft sur ​​chaque système, sans nécessiter d'action des utilisateurs. Utilisez cette méthode quand des utilisateurs n'ont pas de privilèges d'administrateur pour installer des logiciels sur leurs systèmes.

  • Déploiement automatique

  • Test d'une configuration pour un déploiement Push

    L'onglet Déployer automatiquement dans l'Editeur d'options du Gestionnaire d'images administratives contient une fonction de test.

Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Affichage et édition des paramètres d'option
Outil Administrateur des paramètres
Quitter l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options


Utilisation d'un lecteur mappé pour déployer une image administrative

Un chemin UNC (\\machine_name\share_name ) est la méthode recommandée pour la spécification d'un emplacement sur le réseau du répertoire d'installation d'images administratives. Vous pouvez toutefois utiliser un lecteur mappé comme emplacement pour le fichier StartSWInstall.hta dans l'image administrative (par exemple, U:\StartSWInstall.hta), sous condition que les utilisateurs effectuant l'installation mappe la même lettre du lecteur au répertoire partagé d'images administratives.

A titre d'exemple, si vous avez mappé le lecteur U: au répertoire partagé d'images administratives, la notification électronique indique aux utilisateurs de cliquer sur un lien à file://U:\StartSWIOnstall.hta. Les utilisateurs recevant le message électronique peuvent effectuer l'installation sous condition que le lecteur U: soit mappé à l'emplacement UNC de l'image administrative (\\machine_name\share_name ).

Sujet parent Mise en place des installations à partir de l'Editeur d'options


Utilisation de StartSWInstall.exe pour déployer une image administrative

Vous pouvez installer ou désinstaller une image administrative sur les clients en exécutant la commande admin_image_install_dir\ StartSWInstall.exe. Cette méthode permet d'installer SOLIDWORKS à l'aide des options, des ordinateurs et des groupes définis dans l'Editeur d'options du Gestionnaire d'images administratives.

Vous pouvez ajouter à la commande StartSWInstall.exe les commutateurs suivants :
/install | Installe l'image administrative sur les ordinateurs clients.
/uninstall Désinstalle le logiciel des ordinateurs clients, avec deux commutateurs facultatifs :

/removedata

Disponible pour la désinstallation seulement. Supprime les fichiers de données et les dossiers de SOLIDWORKS durant la désinstallation.

/removeregistry

Disponible pour la désinstallation seulement. Supprime les entrées de Registre de SOLIDWORKS durant la désinstallation.
/showui | Affiche une fenêtre de progression pour le Gestionnaire d'installation de SOLIDWORKS. Sinon, le Gestionnaire d'installation de SOLIDWORKS est masqué pour l'utilisateur.
/now | Démarre immédiatement l'installation ou la désinstallation. La boîte de dialogue d'avertissement de 5 minutes ne s'affiche pas.

StartSWInstall.exe est préférable à l'utilisation de StartSWInstall.hta lorsque vous souhaitez que l'installation continue sans interaction avec l'utilisateur, mais ne voulez pas utiliser le déploiement automatique depuis l'Editeur d'options d'image administrative.

Sujet parent Mise en place des installations à partir de l'Editeur d'options


Déployer manuellement

Utilisez cette méthode si les utilisateurs ont les privilèges nécessaires pour installer sur leurs systèmes.

Pour déployer des installations manuellement en utilisant le courrier électronique :

  1. Dans l'Editeur d'options, cliquez sur Mettre en place.
    La disponibilité et le statut de l'installation s'affichent pour chaque ordinateur.
  2. Cliquez sur Envoyer courrier électronique.
  3. Indiquez le chemin d'accès au réseau pour le répertoire d'installation d'images administratives.
    En principe, le chemin d'accès au répertoire d'installation d'images administratives est indiqué au début comme chemin d'accès à un fichier Windows (par exemple, C:\SOLIDWORKS Admin\SOLIDWORKS 2020 SP0). La boîte de dialogue indique Il ne s'agit pas d'un chemin d'accès réseau.
    1. Cliquez sur Parcourir pour indiquer l'emplacement réseau du répertoire d'installation de cette image administrative.
    2. Naviguez jusqu'à l'ordinateur où l'image administrative est installée et sélectionnez le répertoire partagé Windows indiqué comme répertoire d'installation d'image administrative.
      Ne naviguez pas à l'intérieur du répertoire partagé de l'image administrative (par exemple, dans les sous-répertoires 64bits).
    3. Cliquez sur OK.
      La boîte de dialogue indique Il s'agit d'un chemin d'accès réseau.
    Un courrier électronique est généré pour indiquer au propriétaire de l'ordinateur comment effectuer l'installation à partir de l'image administrative à l'aide de l'emplacement réseau pour le fichier StartSWInstall.hta dans l'image administrative.
  4. Envoyez le courrier électronique aux utilisateurs responsables de l'installation de SOLIDWORKS.

Dans le message électronique, les utilisateurs peuvent double-cliquer sur le lien correspondant à l'emplacement réseau de StartSWInstall.hta afin d'installer SOLIDWORKS à partir de l'image administrative.

Dans l'Editeur d'options, Etat de l'installation indique :
En attente | L'utilisateur n'a pas encore exécuté l'installation sur cet ordinateur.
Réussi | L'utilisateur a exécuté l'installation sur cet ordinateur.
Echoué | L'utilisateur a exécuté l'installation sur cet ordinateur mais elle a échoué.

Les autres messages d'état qui peuvent s'afficher sont les suivants : Installé avec succès, Désinstallé avec succès, Installation, Désinstallation, Démarrage requis, Echec de l'installation, et Echec de la désinstallation.

Sujet parent Mise en place des installations à partir de l'Editeur d'options


Prérequis pour le déploiement automatique

Avec le déploiement automatique, les tâches d'installation sont poussées vers les machines cibles et effectuées par le Planificateur de tâches de Microsoft sur ​​chaque système, sans nécessiter d'action des utilisateurs. Utilisez cette méthode quand des utilisateurs n'ont pas de privilèges d'administrateur pour installer des logiciels sur leurs systèmes.

Lors d'une installation poussée, le Planificateur de tâches lance le Gestionnaire d'installation SOLIDWORKS pour exécuter l'administrateur à l'aide des informations d'authentification que vous avez spécifiées. Le Planificateur de tâches s'exécute sous le compte LocalSystem de l'ordinateur. Ce compte est représenté sur le réseau comme un principe de sécurité de l'ordinateur. Le principe de sécurité de l'ordinateur doit disposer d'un accès en lecture au dossier partagé qui contient l'image administrative.

Dans Active Directory, lorsque vous ajoutez un ordinateur à un groupe faisant partie d'un dossier partagé, sélectionnez Types d'objets et assurez-vous que le champ Ordinateurs est sélectionné.

De plus, l'ordinateur serveur de l'image administrative et les machines clientes cibles doivent être membres du même domaine Active Directory.

Sujet parent Mise en place des installations à partir de l'Editeur d'options


Déploiement automatique

Pour déployer automatiquement en poussant des installations vers des systèmes utilisateur :

  1. Dans l'Editeur d'options, cliquez sur l'onglet Déployer automatiquement.
    La disponibilité et le statut de l'installation s'affichent pour chaque ordinateur.
  2. Dans la colonne Déploiement, sélectionnez les ordinateurs et les groupes clients cibles.
    Sélectionnez un ou plusieurs ordinateurs ou groupes dans la colonne Déploiement avant de lancer le processus de déploiement.
  3. Sous Moment d'installation, sélectionnez Maintenant pour déployer tout de suite ou Plus tard pour planifier une date et une heure spécifiques pour le déploiement.
  4. Sous Options du client, choisissez parmi les options suivantes :
    • Installer ou mettre à niveau SOLIDWORKS 2020
    • Désinstaller SOLIDWORKS 2020
      Si vous choisissez de désinstaller, vous pouvez choisir de désinstaller les entrées de registre et les fichiers et les dossiers de données avec les fichiers et les dossiers de programme.
  5. Sélectionnez Redémarrer automatiquement l'ordinateur si vous souhaitez qu'un ou plusieurs ordinateurs cibles redémarrent, si nécessaire, pendant ou après le déploiement.
  6. Saisissez les Infos d'identification du client d'une ou de plusieurs ordinateurs cibles.
  7. Cliquez sur Mettre en place pour lancer le processus de déploiement.
Dans l'Editeur d'options, l'Etat de l'installation indique :
En attente | L'installation n'a pas encore été exécutée sur cet ordinateur.
Réussi | L'installation est terminée sur cet ordinateur.
Echoué | L'installation a échoué sur cet ordinateur.

Les autres messages d'état qui peuvent s'afficher sont les suivants : Installé avec succès, Désinstallé avec succès, Planification, Connexion, Installation, Désinstallation, Démarrage requis, Installation planifiée, Désinstallation planifiée, Echec de l'installation, Echec de la désinstallation, Echec de la connexion et Echec de la planification.

Sujet parent Mise en place des installations à partir de l'Editeur d'options


Test d'une configuration pour un déploiement Push

L'onglet Déployer automatiquement dans l'Editeur d'options du Gestionnaire d'images administratives contient une fonction de test.

Vous pouvez exécuter une installation fictive qui entraîne les systèmes utilisés pour le déploiement, par exemple :
  • Connexion à l'ordinateur cible.
  • Création d'une tâche d'installation sur cet ordinateur.
  • Fin de la tâche d'installation sur cet ordinateur.
  • Mise à jour du statut et des journaux sur l'image administrative.
  • Détection d'un programme à exécuter avant ou après l'installation.

Le test vérifie le chemin des fichiers, valide les autorisations et indique que l'installation s'est terminée avec succès. Il n'installe pas de logiciel et ne modifie pas le registre sur le système cible. Si l'un des systèmes échoue sur un ordinateur cible, le test indique quel système a échoué.

Les info-bulles fournissent des informations sur les échecs. Vous pouvez exporter les résultats vers une feuille de calcul .xml (ou .csv), ce qui est utile pour examiner plusieurs échecs ou partager les résultats avec d'autres personnes du service de support technique.

Pour tester une configuration en vue d'un déploiement Push :

  1. Avec le Gestionnaire d'installation, créez une Image administrative.
  2. Démarrez l'Editeur d'options du Gestionnaire d'images administratives :

    Vous pouvez démarrer l'option lorsque le Gestionnaire d'installation a terminé de créer l'image administrative, ou double-cliquer sur sldAdminOptionEditor.exe dans le dossier des images administratives.

  3. Dans l'onglet Configuration, ajoutez un ou plusieurs ordinateurs.
  4. Cliquez sur Déployer automatiquement :
    1. Fournissez un nom d'utilisateur et un mot de passe d'administrateur de domaine.
    2. Sélectionnez un ou plusieurs ordinateurs à tester.
    3. Cliquez sur Test.
  5. Lorsque le test de configuration s'affiche, cliquez sur Exécuter le test.
  6. Accordez quelques minutes au test pour qu'il s'exécute, ou cliquez sur Annuler le test quand vous le souhaitez.
  7. Examinez et corrigez les éventuels problèmes de configuration.
Sujet parent Mise en place des installations à partir de l'Editeur d'options


Quitter l'Editeur d'options

Vous pouvez cliquer sur OK ou sur Fermer pour quitter l'Editeur d'options.

Cliquez sur OK, Fermer ou utilisez le bouton Fermer de l'application Windows pour apporter les modifications et quitter l'Editeur d'options.
  • Cliquez sur OK pour apporter des modifications aux paramètres d'option et quittez l'Editeur d'options.
  • Cliquez sur Fermer pour quitter l’Editeur d'options.

    Si des modfications doivent être apportées, un message s'affiche vous demandant si vous voulez enregistrer ces modifications.

  • Cliquez sur le bouton Fermer (X) de l'application Windows. Si des modfications doivent être apportées, un message s'affiche vous demandant si vous voulez enregistrer ces modifications.
Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Affichage et édition des paramètres d'option
Outil Administrateur des paramètres
Mise en place des installations à partir de l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options


Création d'un raccourci sur le Bureau vers l'Editeur d'options

Vous pouvez créer un raccourci sur le bureau Windows vers l'Editeur d'options pour une image administrative donnée à partir de l'application.

  1. Démarrez l'Editeur d'options.
    A titre d'exemple, dans l'explorateur Windows, naviguez vers le répertoire d'installation d'images administratives et double-cliquez sur sldAdminOptionEditor.exe.
  2. Cliquez sur Créer un raccourci sur le Bureau vers cet Editeur d'options.
    Un raccourci vers l'Editeur d'options pour l'image administrative s'affiche sur le bureau Windows.
Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Affichage et édition des paramètres d'option
Outil Administrateur des paramètres
Mise en place des installations à partir de l'Editeur d'options
Quitter l'Editeur d'options


Déployer une image administrative sur des clients par courrier électronique

Après avoir créé un répertoire d'image administrative partagé, vous pouvez le notifier aux clients par courrier électronique.

Configurez le répertoire d'image administrative à partager sur un ordinateur accessible à d'autres ordinateurs (par exemple, par l'intermédiaire d'un chemin UNC).

Vous pouvez envoyer un courriel contenant un lien vers rép_install_image_admin\StartSWInstall.hta à tous les clients. Les clients peuvent alors cliquer sur ce lien puis sur Installer les produits SOLIDWORKS maintenant : l'installation est alors immédiatement lancée depuis l'image administrative.

Si vous mettez à niveau une image administrative vers une nouvelle version de SOLIDWORKS, vous pouvez configurer votre emplacement d'image administrative et partager les propriétés : tous les clients installés auparavant à l'aide de cette image sont alors automatiquement mis à niveau. Pour plus de détails, voir Mise à niveau de clients à partir d'images administratives.
Sujet parent Installations multiples
Déployer vers des clients multiples
Utilisation des images administratives
Déploiement avec la ligne de commande
Administration d'installations multiples
Mise à niveau de clients à partir d'images administratives


Déploiement avec la ligne de commande

Vous pouvez déployer une image administrative automatiquement en utilisant une Invite ou un fichier de commandes (installation silencieuse).

Pour déployer une image administrative à l'aide de la ligne de commande pour des clients SOLIDWORKS PDM, voir le Guide d'installation de SOLIDWORKS PDM.

Table des matières

  • Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative

    Après avoir créé l'image administrative et avant de notifier les clients, vous devez installer les composants Microsoft Windows qui ne peuvent pas être installés par les images administratives créées en utilisant la ligne de commande ou Microsoft Active Directory.

  • Installer depuis l'image administrative en utilisant la ligne de commande

    Vous pouvez déployer des installations à partir d'une image administrative en utilisant la ligne de commande.

  • Propriétés de la ligne de commande

    Les propriétés de la ligne de commande décrites ici comprennent les propriétés de fonctions, les propriétés globales, les propriétés spécifiques aux produits et les conventions d'emplacements de Windows.

  • Déployer une image administrative en utilisant Microsoft Active Directory

    Le déploiement avec Microsoft Active Directory est pris en charge dans le cadre du déploiement du produit SOLIDWORKS principal sur les clients.

  • Installer les composants Windows prérequis à l'aide de Microsoft Active Directory

    Suivez ce processus pour préparer une image administrative existante qui installera SOLIDWORKS sur des ordinateurs clients à l'aide de Microsoft Windows Active Directory.

Sujet parent Installations multiples
Déployer vers des clients multiples
Utilisation des images administratives
Déployer une image administrative sur des clients par courrier électronique
Administration d'installations multiples


Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative

Après avoir créé l'image administrative et avant de notifier les clients, vous devez installer les composants Microsoft Windows qui ne peuvent pas être installés par les images administratives créées en utilisant la ligne de commande ou Microsoft Active Directory.

L'installation manuelle de ces composants Windows n'est nécessaire que si vous installez à partir d'une image administrative à l'aide de la ligne de commande ou via Microsoft Active Directory. Si vous utilisez le Gestionnaire d'installation SOLIDWORKS pour créer et installer l'image administrative, ces composants Windows sont installés automatiquement.
Voici un résumé des fichiers requis par SOLIDWORKS dans les composants Windows :
Windows Performance Toolkit : |
Visual C++ 2008, 2010, 2012, 2013 et 2015 Redistributable Package | Contient les composants d'exécution pour Microsoft Visual C++. Les versions 2008, 2010, 2012, 2013 et 2015 doivent être installées.
Visual Basic for Applications 7.1 | Fournit la prise en charge des macros Visual Basic.
Visual Studio Tools for Application 2005 | Contient un ensemble d'outils de prise en charge des applications Visual Studio 2005. Depuis SOLIDWORKS 2013, l'installation de Microsoft Visual Studio Tools for Applications (VSTA) est facultative. VSTA 2005 dépend de l'installation de Microsoft .NET Framework 3.5 sur votre ordinateur. Pour Windows 7 et versions ultérieures, .NET Framework est un composant du système d'exploitation. Si vous devez installer .NET Framework 3.5, il est disponible sur votre support Windows et sur Internet. Si vous ne localisez pas votre support Windows, que vous ne disposez pas de connexion à Internet ou que vous n'êtes pas autorisé à installer Microsoft .NET Framework 3.5 sur votre ordinateur, contactez l'administrateur de votre ordinateur pour obtenir de l'aide.
Visual Studio Tools for Application 2015 | Facultatif. Contient un ensemble d'outils de prise en charge des applications Visual Studio 2015.
Visual Studio Remote Debugger | Fournit un environnement de débogage pour les systèmes d'exploitation 64 bits.
.NET Framework 4.6.2 | Contient le Common Language Runtime (CLR) et les composants du .NET Framework nécessaires à l'exécution des applications .NET Framework 4.6.2.
Service Bonjour pour Windows | Fournit la possibilité de découvrir des services sur un réseau local.
Visual C++ Redistributable Package et .NET Framework 4.6.2 sont requis pour tous les produits SOLIDWORKS, pas seulement pour le produit SOLIDWORKS principal.

Ces composants doivent être inclus dans des sous-répertoires du répertoire de l'image administrative.

Le tableau suivant identifie les fichiers requis pour chaque système d'exploitation pris en charge.
Système d'exploitation : Windows Server 2016 64 bits et Windows Server 2019 64 bits
Système d'exploitation : Windows Server 2012 R2 64 bits
L'installation sur Windows Server 2012 R2, 2016 et 2019 est prise en charge pour SOLIDWORKS PDM Server et SOLIDWORKS SolidNetWork License Manager.
Windows Performance Toolkit : | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2012 Redistributable Package : | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2013 Redistributable Package : | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2015 Redistributable Package : | vc_redist_x86.exe vc_redist_x64.exe Les deux doivent être installés.
Visual Studio Tools for Applications 2005 : (facultatif) | vsta_aide.msi
Si VSTA 2005 est installé, .NET 3.5 Framework (dotnetfx35.exe) est nécessaire. .NET Framework 3.5 est un composant du système d'exploitation Windows 7.
Visual Studio Tools for Applications 2015 (facultatif) : | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Plus un package de langue facultatif.
.NET Framework 4.6.2 : | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Service Bonjour pour Windows : | bonjour64.msi
L'installation sur Windows Server 2012 R2 est prise en charge pour SOLIDWORKS PDM Server et SOLIDWORKS SolidNetWork License Manager.
Windows Performance Toolkit : | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2012 Redistributable Package : | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2013 Redistributable Package : | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2015 Redistributable Package : | vc_redist_x86.exe vc_redist_x64.exe Les deux doivent être installés.
Visual Studio Tools for Applications 2005 : (facultatif) | vsta_aide.msi
Si VSTA 2005 est installé, .NET 3.5 Framework (dotnetfx35.exe) est nécessaire. .NET Framework 3.5 est un composant du système d'exploitation Windows 7.
Visual Studio Tools for Applications 2015 (facultatif) : | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Plus un package de langue facultatif.
.NET Framework 4.6.2 : | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Service Bonjour pour Windows : | bonjour64.msi
Système d'exploitation : Windows 7 64 bits
Windows Performance Toolkit : | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2012 Redistributable Package : | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2013 Redistributable Package : | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2015 Redistributable Package : | vc_redist_x86.exe vc_redist_x64.exe Les deux doivent être installés.
Visual Studio Tools for Applications: (facultatif) | vsta_aide.msi
Si VSTA 2005 est installé, .NET 3.5 Framework (dotnetfx35.exe) est nécessaire. .NET Framework 3.5 est un composant du système d'exploitation Windows 7.
Visual Studio Tools for Applications 2015 : (facultatif | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Plus un package de langue facultatif.
.NET Framework 4.6.2 : | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Service Bonjour pour Windows : | bonjour64.msi
Système d'exploitation : Windows 10 64 bits
Windows Performance Toolkit : | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2012 Redistributable Package : | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2013 Redistributable Package : | vcredist_x86.exe vcredist_x64.exe Les deux doivent être installés.
Visual C++ 2015 Redistributable Package : | vc_redist_x86.exe vc_redist_x64.exe Les deux doivent être installés.
Visual Studio Tools for Applications 2005 : (facultatif) | vsta_aide.msi
Si VSTA 2005 est installé, .NET 3.5 Framework (dotnetfx35.exe) est nécessaire. .NET Framework 3.5 est un composant du système d'exploitation Windows 7.
Visual Studio Tools for Applications 2015 : (facultatif) | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Plus un package de langue facultatif.
.NET Framework 4.6.2 : | .NET 4.6.2 fait partie du système d'exploitation, qui satisfait à cette condition.
Service Bonjour pour Windows : | bonjour64.msi

Table des matières

  • Installer les composants Windows prérequis depuis la ligne de commande sur des systèmes d'exploitation 64 bits

    Suivez ce processus pour installer les prérequis Windows pour une installation d'image administrative utilisant la ligne de commande sur des versions 64 bits de Windows.

Sujet parent Déploiement avec la ligne de commande
Installer depuis l'image administrative en utilisant la ligne de commande
Propriétés de la ligne de commande
Déployer une image administrative en utilisant Microsoft Active Directory
Installer les composants Windows prérequis à l'aide de Microsoft Active Directory


Installer les composants Windows prérequis depuis la ligne de commande sur des systèmes d'exploitation 64 bits

Suivez ce processus pour installer les prérequis Windows pour une installation d'image administrative utilisant la ligne de commande sur des versions 64 bits de Windows.

Pour installer plusieurs composants en un seule opération, créez un fichier de commandes contenant les commandes fournies dans les procédures suivantes et utilisez-le pour forcer les composants sur les ordinateurs clients.

  1. Assurez-vous que l'ordinateur cible dispose d'au moins 620 Mo d'espace libre et un répertoire TEMP valide.
  2. Installez Visual C++ VERSION Redistributable Package.
    Installez le package pour VERSION = 2008, 2010, 2012, 2013 et 2015.
    répertoire_image_administrative\Microsoft_C++_VERSION_Redistributable_(x64)\vcredist_x64.exe /Q

    répertoire_image_administrative\Microsoft_C++_VERSION_Redistributable\vcredist_x86.exe /Q

    Les versions 32 et 64 bits de ce package doivent toutes deux être installées.

    Par exemple, pour installer Visual C++ 2008 Redistributable Package, utilisez :

    • répertoire_image_administrative\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q
    • répertoire_image_administrative\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q
  3. Installez Microsoft .NET Framework 4.6.2 :
    répertoire_image_administrative\.Net_Framework_4.6.2\NDP462-KB3151800-x86-x64-AllOS-ENU.exe
  4. Installez Visual Studio Tools for Applications 2015 :
    répertoire_image_administrative\Microsoft_VSTA\vsta_setup.exe
  5. Installez Visual Studio Remote Debugger:
    répertoire_image_administrative\VSRemoteDebugger\install.exe /Q
  6. Installez Visual Basic 7.1:
    répertoire_image_administrative\Microsoft_VBA\vba71.msi et répertoire_image_administrative\Microsoft_VBA\vba71_1033.msi sont nécessaires pour toutes les langues.
    Seule la version 64 bits de ce package doit être installée.

    De plus, installer le package suivant pour la langue souhaitée :

    vba71_1028.msi | Chinois
    vba71_1031.msi | Allemand
    vba71_1036.msi | Français
    vba71_1040.msi | Italien
    vba71_1041.msi | Japonais
    vba71_1042.msi | Coréen
    vba71_1046.msi | Portugais brésilien
    vba71_2052.msi | Chinois simplifié
    vba71_3082.msi | Espagnol
    L'anglais, le tchèque, le polonais le russe et le turc ne nécessitent pas de packages de langue supplémentaires.
    Depuis le Service Pack 2.0 de SOLIDWORKS 2013, vous devez installer un prérequis supplémentaire : Msiexec.exe /p vba71-kb27832-x64.msp
  7. Installez le service Bonjour pour Windows:
    répertoire_image_administrative\Bonjour\Bonjour64.msi
Sujet parent Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative


Installer depuis l'image administrative en utilisant la ligne de commande

Vous pouvez déployer des installations à partir d'une image administrative en utilisant la ligne de commande.

Pour effectuer une installation silencieuse:

  1. Ouvrez la fenêtre de l'Invite de commandes (dans Windows, cliquez sur Démarrer > Exécuter).
  2. Saisissez la commande msiexec.exe avec les commutateurs /i et /qb et définissez les propriétés des options qui ne sont pas les valeurs par défaut comme illustré ci-dessous.

    msiexec /i "64-bit_admin_image_path\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\votre_dossier /qb

Les propriétés de la ligne de commande de composants d'installation individuelle incluent:
  • Propriétés des fonctions de la ligne de commande
  • Propriétés générales de la ligne de commande
  • eDrawings Propriétés de la ligne de commande
  • Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation

Utilisez les exemples suivants comme modèles pour une installation silencieuse.

Client SOLIDWORKS

  • Produit principal SOLIDWORKS (anglais)
  • Complément de la boîte à outils
  • Participation au programme expérience client
  • Français

SOLIDWORKS:

msiexec /i "chemin_image_admin_64-bits\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\votre_dossier" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks, SolidWorksToolbox /qb

Le composant d'installation de la langue française de SOLIDWORKS doit être installé séparément :

msiexec /i "64-bit_admin_image_path\SOLIDWORKS French\french.msi" /qb

Lorsque vous indiquez les commandes d'installation du composant de la langue SOLIDWORKS, ne spécifiez pas d'arguments de ligne de commande.

Client eDrawings

  • Journal des performances
  • Toutes les fonctions

msiexec /i "chemin_image_admin\eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\votre_dossier" LOGPERFORMANCE=1 SNLSERVER=serveur_SNL_eDrawings TRANSFORMS=1040.mst ADDLOCAL=All /qb

SOLIDWORKS Electrical

En raison de la complexité technique inhérente à l'installation de SOLIDWORKS Electrical avec Microsoft SQL Server, les exemples de ligne de commande pour SOLIDWORKS Electrical sont exclus de la documentation.

SOLIDWORKS PCB

msiexec /i “admin_image_path\SOLIDWORKS PCB.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS PCB” /qb

SOLIDWORKS Visualize et Visualize Boost

Pour SOLIDWORKS Visualize :

msiexec. /i “admin_image_path\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

Pour SOLIDWORKS Visualize Boost :

msiexec /i “admin_image_path\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

Sujet parent Déploiement avec la ligne de commande
Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative
Propriétés de la ligne de commande
Déployer une image administrative en utilisant Microsoft Active Directory
Installer les composants Windows prérequis à l'aide de Microsoft Active Directory


Propriétés de la ligne de commande

Les propriétés de la ligne de commande décrites ici comprennent les propriétés de fonctions, les propriétés globales, les propriétés spécifiques aux produits et les conventions d'emplacements de Windows.

Table des matières

  • Propriétés des fonctions de la ligne de commande

    L'installation de SOLIDWORKS prend en charge ces propriétés ADDLOCAL pour le déploiement avec la ligne de commande.

  • Propriétés générales de la ligne de commande

    Chaque propriété est définie pour une installation administrative et individuelle, sauf indication contraire. Les numéros de série peuvent être définis à la fois pour l'installation administrative et pour l'installation individuelle en utilisant les propriétés générales.

  • eDrawings Propriétés de la ligne de commande

    Ces propriétés de ligne de commande sont spécifiques à eDrawings ®.

  • Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player

    Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Composer et à SOLIDWORKS Composer Player.

  • Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation

    Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Flow Simulation.

  • Propriétés de la ligne de commande de SOLIDWORKS Simulation

    Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Inspection.

  • Propriétés de la ligne de commande de SOLIDWORKS Visualize

    Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Visualize.

  • Emplacements des fichiers MSI pour les images administratives

    Pour créer des images administratives à partir de la ligne de commande, les fichiers des composants de produit .msi sont stockés à ces emplacements sur le média SOLIDWORKS.

Sujet parent Déploiement avec la ligne de commande
Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative
Installer depuis l'image administrative en utilisant la ligne de commande
Déployer une image administrative en utilisant Microsoft Active Directory
Installer les composants Windows prérequis à l'aide de Microsoft Active Directory


Propriétés des fonctions de la ligne de commande

L'installation de SOLIDWORKS prend en charge ces propriétés ADDLOCAL pour le déploiement avec la ligne de commande.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • VSTA
Lors de la spécification des propriétés pour l'installation avec la ligne de commande:
  • SOLIDWORKS ne prend pas en charge l'installation de produits avec l'option ADDSOURCE.
  • Les noms des propriétés doivent respecter la casse, ne peuvent pas contenir d'espace ou de tiret et doivent être séparés par une virgule.

    Pour que l'application s'installe correctement, il faut spécifier casse mixte SOLIDWORKS dans les propriétés ADDLOCAL.

Sujet parent Propriétés de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés générales de la ligne de commande

Chaque propriété est définie pour une installation administrative et individuelle, sauf indication contraire. Les numéros de série peuvent être définis à la fois pour l'installation administrative et pour l'installation individuelle en utilisant les propriétés générales.

Propriété | Description
ENABLEPERFORMANCE Indique si l'application doit automatiquement transmettre des données de performance à SOLIDWORKS Corporation.

1

Envoyer des données sur les performances.

0

Ne pas envoyer de données sur les performances.
INSTALLDIR Dossier d'installation de SOLIDWORKS.

Installations individuelles uniquement.
MBDSERIALNUMBER | Numéro de série du produit SOLIDWORKS MBD (Model Based Definition).
MOTIONSERIALNUMBER | Numéro de série du produit SOLIDWORKS Motion.
OFFICEOPTION Spécifiez le produit à installer :
0 | Client SOLIDWORKS
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
REINSTALL Indiquez ALL pour mettre à jour toutes les fonctions installées.
Spécifiez cette propriété uniquement lors d'une mise à jour vers un nouveau Service Pack d'une version majeure existante (par exemple, mise à jour d'une installation SOLIDWORKS 2020 SP01 existante vers SOLIDWORKS 2020 SP02).
REINSTALLMODE Options de réinstallation de Microsoft Installer.

Par exemple, lors de la mise à jour d'une installation d'une version de Service pack à une autre dans la même version majeure, vous devez indiquer REINSTALLMODE=vomus.

Pour plus d'informations sur les paramètres de REINSTALLMODE, voir la documentation de Windows Installer à l'adresse www.microsoft.com.

Spécifiez cette propriété uniquement lors d'une mise à jour vers un nouveau Service Pack d'une version majeure existante (par exemple, mise à jour d'une installation SOLIDWORKS 2020 SP01 existante vers SOLIDWORKS 2020 SP02). Ne spécifiez pas cette propriété lors de la première installation d'une nouvelle version majeure de SOLIDWORKS.
SERVERLIST Liste de serveurs SolidNetWork.
La liste de serveurs SolidNetWork est une liste délimitée de chaînes, chacune d'entre elles fait référence à un numéro de port sur un serveur au format :
  • Trièdre (délimité par des virgules) =xxxxx@nom_serveur1,yyyyy@nom_serveur2,zzzzz@nom_serveur3
  • Non trièdre (délimité par des points-virgules) = xxxxx@nom_serveur1;yyyyynom_serveur2;zzzzz@nom_serveur3
X et Y représentent un seul chiffre. Ne mettez pas de séparateur après le dernier serveur de la liste.

Installations individuelles uniquement.
SIMULATIONSERIALNUMBER | Numéro de série du produit SOLIDWORKS Motion.
SOLIDWORKSSERIALNUMBER | Numéro de série du produit SOLIDWORKS, y compris tous les compléments.
SWMIGRATE Version de SOLIDWORKS à mettre à niveau telle qu'elle apparaîtrait dans la boîte de dialogue Choix de l'installation SOLIDWORKS. Par exemple :

SWMIGRATE= "SOLIDWORKS 2020 Edition x64 SP01"

Indiquez cette propriété uniquement lors de l'installation d'une nouvelle version majeure alors que la version majeure antérieure est toujours installée. N'indiquez pas cette propriété lors de la mise à niveau d'une version de Service Pack à une autre dans la même version majeure.
TOOLBOXFOLDER Dossier d'installation des fichiers SOLIDWORKS Toolbox.

Installations individuelles uniquement.

Par exemple : TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

Si votre environnement possède un emplacement PDM ou Toolbox/Assistance pour le perçage partagé, vous pouvez définir une installation de clients de sorte qu'elle n'installe pas, ni ne mette à niveau les données Toolbox dans cet emplacement avec la propriété NOTTOOLBOXSETUP. Spécifiez les paramètres suivants :

0 | Installer les fichiers Toolbox.
1 | Ne pas installer les fichiers Toolbox.
TRANSFORMS Contient des informations spécifiques à la langue en format :
TRANSFORMS numéro.mst
  • Chinois (1028)
  • Chinois simplifié (2052)
  • Tchèque (1029)
  • Anglais (1033)
  • Français (1036)
  • Allemand (1031)
  • Italien (1040)
  • Japonais (1041)
  • Coréen (1042)
  • Polonais (1045)
  • Portugais (Brésil) (1046)
  • Russe (1049)
  • Espagnol (1034)
  • Turc (1055)
UPGRADESWINSTALL
Indiquez s'il faut ou non mettre à niveau une version existante de SOLIDWORKS vers la version actuelle.
0 | Nouvelle installation, ne pas mettre à jour.
1 | Mettre à jour

Installations individuelles uniquement.

Indiquez cette propriété uniquement lors de l'installation d'une nouvelle version majeure alors que la version majeure antérieure est toujours installée. Ne spécifiez pas cette propriété en cas de mise à niveau d'un Service Pack vers un autre faisant partie de la même version majeure.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


eDrawings Propriétés de la ligne de commande

Ces propriétés de ligne de commande sont spécifiques à eDrawings ®.

Propriété | Description
ADDLOCAL Spécifie quelle portion de l'application eDrawings doit être installée.
All est l'option recommandée.
Syntaxe de la ligne de commande | Fonction
Tout | Installe tous les composants. L'application eDrawings vérifie que les applications de publication pour SOLIDWORKS et AutoCAD sont installées pour valider l'installation.
CALS | Visionner des fichiers CAL dans l'eDrawings Viewer
Inventor | Créer des fichiers eDrawings à partir de l'application Autodesk Inventor.
eDrawingsViewer | Visionner des fichiers eDrawings et autres.
ProE | Visionner des fichiers ProE à l'aide d'eDrawings Viewer
DXFDWGTranslator | Visionner des fichiers DXF/DWG dans l'eDrawings Viewer.
Raccourcis | Installer un raccourci sur le bureau.
XML3D | Visionner des fichiers 3D XML dans l'eDrawings Viewer.
INSTALLDIR | Spécifie le dossier d'installation pour eDrawings
LOGPERFORMANCE Spécifie si l'application doit automatiquement envoyer un e-mail de performance à SOLIDWORKS Corporation.
1 | Envoyer des données sur la performance
0 | Sinon
SNLSERVER Entrez le port@nomserveur pour votre serveur de licences SolidNetWork. Utilisez des points-virgules pour séparer plusieurs combinaisons de port@nomserveur .

Le nom du serveur de port pour SNLSERVER est uniquement requis pour la configuration du serveur SNL de SOLIDWORKS. list_of_port@server_strings est une liste de chaînes de texte délimitées par des points-virgules, chacune d'entre elles faisant référence à un numéro de port sur un serveur avec le format :

xxxxx@nom_serveur1; yyyyy@nom_serveur2;

où x et y représentent un seul chiffre. Ne mettez pas de point-virgule après le dernier serveur de la liste.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player

Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Composer et à SOLIDWORKS Composer Player.

Pour SOLIDWORKS Composer :

Propriété | Description
ACTIVSERIALNUMBER | Numéro de série de SOLIDWORKS Composer.
ACTIVSERIALNUMBERPLAYERPRO | C'est facultatif Numéro de série de SOLIDWORKS Composer Player Pro.
ADDLOCAL Si vous installez l'application complète, vous n'avez pas besoin de spécifier les éléments suivants.
Requis :
  • Licence
  • Eula
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
Optionnel :
  • Sync3Dvia
INSTALLDIR | Spécifie le dossier d'installation du logiciel SOLIDWORKS Composer.

Pour SOLIDWORKS Composer Player :

Propriété | Description
ACTIVSERIALNUMBERPLAYERPRO | C'est facultatif Numéro de série de SOLIDWORKS Composer Player Pro.
INSTALLDIR | Spécifie le dossier d'installation du logiciel SOLIDWORKSComposer Player.
Sur les ordinateurs où SOLIDWORKS n'est pas installé, vous devez utiliser SOLIDWORKS Translator pour importer des fichiers SOLIDWORKS dans SOLIDWORKS Composer. Pour déployer SOLIDWORKS Translator, vous devez utiliser le Gestionnaire d'installation SOLIDWORKS. Vous ne pouvez pas utiliser la ligne de commande.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation

Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Flow Simulation.

Propriété | Description
ACTIVSERIALNUMBER Numéro de série de SOLIDWORKS Flow Simulation autonome.

(Installations individuelles et installations de clients réalisées à partir d'une image administrative)
CWUPGRADEINSTALL Met à niveau une version existante d'une application SOLIDWORKS Flow Simulation spécifique.
1 | Mise à jour
2 | Nouvelle installation; nouveau répertoire

(Installations individuelles et installations de clients réalisées à partir d'une image administrative)
INSTALLDIR Spécifie l'installation d'une application SOLIDWORKS Flow Simulation spécifique.

(Installations individuelles uniquement)
SERVERLIST | Liste de chaînes de texte délimitées par des pointsvirgules, chacune d'entre elles faisant référence à un numéro de port sur un serveur: xxxxx@nom_serveur1; yyyyy@nom_serveur2;& où x et y représentent un seul chiffre. Ne mettez pas de point-virgule après le dernier serveur de la liste.
SOLIDWORKSPATH Indique le dossier dans lequel est installé le logiciel SOLIDWORKS.

(Installations individuelles et installations de clients réalisées à partir d'une image administrative)
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés de la ligne de commande de SOLIDWORKS Simulation

Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Inspection.

Propriété | Description
ACTIVSERIALNUMBER | Numéro de série de SOLIDWORKS Inspection. (Installations individuelles et installations de clients réalisées à partir d'une image administrative)
INSTALLDIR | Spécifie l'installation pour le logiciel d'application SOLIDWORKS Inspection. (Installations individuelles uniquement)
SERVERLIST | Liste de chaînes de texte délimitées par des pointsvirgules, chacune d'entre elles faisant référence à un numéro de port sur un serveur: xxxxx@nom_serveur1; yyyyy@nom_serveur2;& où x et y représentent un seul chiffre. Ne mettez pas de point-virgule après le dernier serveur de la liste.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés de la ligne de commande de SOLIDWORKS Visualize

Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Visualize.

Propriété | Description
ACTIVSERIALNUMBER | Numéro de série SOLIDWORKS Visualize. (Installations individuelles et installations de clients réalisées à partir d'une image administrative)
INSTALLDIR | Spécifie l'installation pour le logiciel d'application SOLIDWORKS Visualize. (Installations individuelles uniquement)
SERVERLIST | Liste de chaînes de texte délimitées par des pointsvirgules, chacune d'entre elles faisant référence à un numéro de port sur un serveur: xxxxx@nom_serveur1; yyyyy@nom_serveur2;& où x et y représentent un seul chiffre. Ne mettez pas de point-virgule après le dernier serveur de la liste.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Emplacements des fichiers MSI pour les images administratives


Emplacements des fichiers MSI pour les images administratives

Pour créer des images administratives à partir de la ligne de commande, les fichiers des composants de produit .msi sont stockés à ces emplacements sur le média SOLIDWORKS.

SOLIDWORKS (produit principal, anglais)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (composants pour des langues autres que l'anglais)

Chinois Traditionnel | swwi\lang\chinese\chinese.msi
Chinois simplifié | swwi\lang\chinese-simplified\chinese-simplified.msi
Tchèque | swwi\lang\czech\czech.msi
Français | swwi\lang\french\french.msi
Allemand | swwi\lang\german\german.msi
Italien | swwi\lang\italian\italian.msi
Japonais | swwi\lang\japanese\japanese.msi
Coréen | swwi\lang\korean\korean.msi
Polonais | swwi\lang\polish\polish.msi
Portugais (brésilien) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
Russe | swwi\lang\russian\russian.msi
Espagnol | swwi\lang\spanish\spanish.msi
Turc | swwi\lang\turkish\turkish.msi

DocManager API

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

eDrawings Shaders

eDrawingsShaders\eDrawings.msi

Simulation d'écoulement

Flow Simulation\SOLIDWORKS Flow Simulation.msi

PhotoView 360 Network Render

pvnetworkrender\pvnetrender.msi

Gestionnaire de licences SolidNetWork

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

Assistant Activation de SOLIDWORKS

swactwizard\Activation Wizard.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Composer

composer\SOLIDWORKS Composer.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS PCB

PCB\SOLIDWORKS PCB.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional fournit une API, mais elle n'est disponible que pour le client et n'est pas disponible dans un fichier .msi. Pour plus d'informations, voir le Guide API dans le répertoire install\API du client SOLIDWORKS PDM.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize


Déployer une image administrative en utilisant Microsoft Active Directory

Le déploiement avec Microsoft Active Directory est pris en charge dans le cadre du déploiement du produit SOLIDWORKS principal sur les clients.

Microsoft Active Directory est un service d'annuaire pour la gestion des clients et des serveurs dans les environnements réseau. Il simplifie les tâches de gestion, de migration et de déploiement.

Contactez votre revendeur pour obtenir des informations sur l'installation de SOLIDWORKS via Microsoft Active Directory.

Sujet parent Déploiement avec la ligne de commande
Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative
Installer depuis l'image administrative en utilisant la ligne de commande
Propriétés de la ligne de commande
Installer les composants Windows prérequis à l'aide de Microsoft Active Directory


Installer les composants Windows prérequis à l'aide de Microsoft Active Directory

Suivez ce processus pour préparer une image administrative existante qui installera SOLIDWORKS sur des ordinateurs clients à l'aide de Microsoft Windows Active Directory.

  1. Extrayez les fichiers du programme d'installation Visual C++ Redistributable Package et installez-les.
    1. Visual C++ 2008
      1. répertoire_image_administrative\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x: {répertoire cible}
      2. répertoire_image_administrative\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x: {répertoire cible}
      3. Créez une stratégie pour installer les modules redistribuables Microsoft C++ 2008.
    2. Visual C++ 2010
      1. répertoire_image_administrative\Microsoft_C++_2010_Redistributable\vcredist_x86.exe /x:{répertoire cible}
      2. répertoire_image_administrative\Microsoft_C++_2010_Redistributable\vcredist_x64.exe /x:{répertoire cible}
      3. Créez une stratégie pour installer les modules redistribuables Microsoft C++ 2010.
    3. Visual C++ 2012
      1. Installez répertoire_image_administrative\Microsoft_C++_2012_Redistributable\vcredist_x86.exe sur un ordinateur de test.
      2. Copiez ces dossiers vers un emplacement réseau (répertoire cible) :
        1. C:\ProgramData\PackageCache\{BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030
        2. C:\ProgramData\PackageCache\{B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030
    4. Visual C++ 2013
      1. administrative_image_directory\Microsoft_C++_2013_Redistributable\vcredist_x86.exe /x: {répertoire cible}
      2. administrative_image_directory\Microsoft_C++_2013_Redistributable_(64)\vcredist_x64.exe /x: {répertoire cible}
      3. Créez une stratégie pour installer les modules redistribuables Microsoft C++ 2013.
    5. Visual C++ 2015
      1. administrative_image_directory\Microsoft_C++_2015_Redistributable\vcredist_x86.exe /x: {répertoire cible}
      2. administrative_image_directory\Microsoft_C++_2015_Redistributable_(64)\vcredist_x64.exe /x: {répertoire cible}
      3. Créez une stratégie pour installer les modules redistribuables Microsoft C++ 2015.

      1. Créez une stratégie pour installer les fichiers suivants :
        Le chemin d'accès au fichier ne peut pas contenir d'espaces.

        Répertoire cible\ {BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030\packages\

        vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi

        Répertoire cible\ {B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030\packages\

        vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi

      2. Installez répertoire_image_administrative\Microsoft_ C++_2012_Redistributable_(64)\vcredist_x64.exe sur un ordinateur de test.
      3. Copiez ces dossiers vers un emplacement réseau (répertoire cible) :
        1. C:\ProgramData\PackageCache\{CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030
        2. C:\ProgramData\PackageCache\{37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030
      4. Créez une stratégie pour installer les fichiers suivants :
        Le chemin d'accès au fichier ne peut pas contenir d'espaces.

        Répertoire cible\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Répertoire cible\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Répertoire cible\ {37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030\packages\

        vcRuntimeAdditionalamd64\vc_runtimeAdditionalx64.msi

  2. Installez Microsoft .NET Framework 4.6.2.
    SOLIDWORKS recommande que vous installiez .NET Framework 4.6.2 à l'aide de Windows Updates Services (WSUS) ou d'un service similaire.
  3. Installez Visual Studio Remote Debugger (versions 64 bits uniquement quand .NET Framework 3.5 est installé sur l'ordinateur), en créant cette stratégie :
    {répertoire_Microsoft_remote_debugger}\rdbgexp.MSI
    Aucun fichier de transformation n'est nécessaire pour cette installation.
  4. Effectuez les actions suivantes :
    1. Mettez à jour Visual Basic 7.1 for applications avec le Service Pack vba71-kb2783832-x64.
    2. Après avoir créé l'image administrative, exécutez cette commande :
      Msiexec /a {Image administrative de SOLIDWORKS}/Microsoft_vba/vba71.msi /p {Image administrative de SOLIDWORKS}/Microsoft_vba_ kb2783832/vba71-kb2783832-x64.msp
    3. Installez Visual Basic 7.1, en créant cette stratégie:
      {répertoire de VBA }\vba71.MSI
      Aucun fichier de transformation n'est nécessaire pour cette installation.
  5. Installez le pack de langue de Visual basic 7.1 en créant cette stratégie:
    {répertoire de VBA }\vba71_nnnn.MSI
    Où nnnn définit la langue requise:
    • 1028 = chinois
    • 1031 = allemand
    • 1033 = anglais
    • 1036 = français
    • 1040 = italien
    • 1041 = japonais
    • 1042 = coréen
    • 1046 = portugais
    • 2052 = chinois - Chine
    • 3082 = espagnol
  6. Installez le service Bonjour en créant cette stratégie:
    {répertoire de Bonjour}\Bonjour.MSI
    Aucun fichier de transformation n'est nécessaire pour cette installation.
Sujet parent Déploiement avec la ligne de commande
Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative
Installer depuis l'image administrative en utilisant la ligne de commande
Propriétés de la ligne de commande
Déployer une image administrative en utilisant Microsoft Active Directory


Administration d'installations multiples

Dans le cas des installations multiples, les tâches administratives comprennent la mise à niveau des images administratives vers de nouvelles versions, l'application de services packs et la suppression d'installations.

Table des matières

  • Mettre à niveau des images administratives vers une nouvelle version

    Pour mettre à jour des clients installés à partir d'une image administrative, commencez par mettre à jour cette dernière puis configurez les clients pour qu'ils référencent la nouvelle copie de l'image.

  • Administration des mises à jour de produits au moyen des service packs

    Les mises à jour de produits au moyen des service packs visent à améliorer la fiabilité du système, la compatibilité des programmes, la sécurité, etc.

  • Supprimer une installation

    Vous pouvez supprimer une installation sur un ordinateur individuel ou dans un environnement client/serveur.

Sujet parent Installations multiples
Déployer vers des clients multiples
Utilisation des images administratives
Déployer une image administrative sur des clients par courrier électronique
Déploiement avec la ligne de commande


Mettre à niveau des images administratives vers une nouvelle version

Pour mettre à jour des clients installés à partir d'une image administrative, commencez par mettre à jour cette dernière puis configurez les clients pour qu'ils référencent la nouvelle copie de l'image.

Exécutez le Gestionnaire d'installation SOLIDWORKS à partir d'Internet afin que les bons fichiers soient référencés. Le Gestionnaire d'installation SOLIDWORKS sera automatiquement redirigé vers le lien suivant ou vous pouvez lancer la mise à jour directement depuis le site Web de téléchargements de SOLIDWORKS (http://www.solidworks.com/sw/support/downloads.htm).

Une fois l'image administrative mise à jour (ce qui a pour effet de créer une nouvelle copie de l'image), vous pouvez mettre à jour les clients en les faisant référencer la nouvelle copie de l'image administrative.

Si les clients référençaient la version précédente de l'image administrative en utilisant un lecteur mappé ou un répertoire partagé, vous pouvez redéfinir le lecteur mappé ou le répertoire partagé en utilisant l'emplacement de la copie à jour de l'image.

Table des matières

  • Télécharger des fichiers d'installation mis à jour pour les images administratives

    Le Gestionnaire d'installation SOLIDWORKS peut détecter quand vous avez besoin de fichiers d'installation mis à jour lors de la mise à niveau d'une image administrative.

  • Mise à niveau d’une image administrative

    Pour mettre à niveau une image administrative, le Gestionnaire d'installation SOLIDWORKS crée un nouveau répertoire d'image. Vous dirigez ensuite les clients vers ce nouveau répertoire d'image administrative pour mettre à niveau vers cette version du produit.

  • Mise à niveau de clients à partir d'images administratives

    Le Gestionnaire d'installation SOLIDWORKS peut automatiquement mettre à jour des ordinateurs clients installés à partir d'une image administrative.

Sujet parent Administration d'installations multiples
Administration des mises à jour de produits au moyen des service packs
Supprimer une installation


Télécharger des fichiers d'installation mis à jour pour les images administratives

Le Gestionnaire d'installation SOLIDWORKS peut détecter quand vous avez besoin de fichiers d'installation mis à jour lors de la mise à niveau d'une image administrative.

  1. Démarrez le Gestionnaire d'installation SOLIDWORKS en insérant le DVD.
  2. Dans l'écran Bienvenue, sélectionnez Image administrative.
  3. Sur l'écran Numéro de série, entrez le numéro de série de SOLIDWORKS.
    Le Gestionnaire d'installation SOLIDWORKS recherche les produits pour lesquels vous avez une licence et les service packs disponibles sur le site Web de SOLIDWORKS.
  4. Sur l'écran Version plus récente disponible, sélectionnez Oui, télécharger et installer la nouvelle version: Version.
    Le Gestionnaire d'installation SOLIDWORKS lance une nouvelle session pour installer la version la plus récente.
  5. Dans le cas d'un problème du répertoire de téléchargement, l'écran Options de téléchargement peut apparaître; acceptez le répertoire par défaut pour les nouveaux fichiers d'installation ou entrez un nouveau nom de répertoire.
    Si vous voyez un message indiquant que le répertoire n'existe pas, cliquez sur Oui pour le créer.
  6. Sur l'écran Téléchargement terminé, cliquez sur Fermer pour fermer le programme d'installation en cours et démarrer celui de la nouvelle version.
Sujet parent Mettre à niveau des images administratives vers une nouvelle version
Mise à niveau d’une image administrative
Mise à niveau de clients à partir d'images administratives


Mise à niveau d’une image administrative

Pour mettre à niveau une image administrative, le Gestionnaire d'installation SOLIDWORKS crée un nouveau répertoire d'image. Vous dirigez ensuite les clients vers ce nouveau répertoire d'image administrative pour mettre à niveau vers cette version du produit.

Ce processus suppose que vous avez téléchargé les fichiers d'installation mis à jour pour l'image administrative. Pour plus de détails, reportez-vous à Télécharger des fichiers d'installation mis à jour pour les images administratives.

  1. Lancez le Gestionnaire d'installation SOLIDWORKS. Pour plus de détails, voir Lancer l'installation de SOLIDWORKS.
  2. Dans l'écran Bienvenue, sélectionnez Image administrative.
    Les options de création d'images administratives s'affichent.
    Option | Description
    Créer une nouvelle image en utilisant les paramètres par défaut. | Créer l'image à l'aide des paramètres de configuration par défaut (à savoir, non basés sur les paramètres définis sur une image administrative existante à votre site).
    Créer une nouvelle image en utilisant les paramètres et les fichiers d'une image existante. | Créer l'image à l'aide des paramètres de configuration indiqués pour une image administrative existante sur votre site. Cliquez sur Parcourir pour indiquer le répertoire d'installation de l'image administrative existante.
  3. Sur l'écran Numéro de série cochez le numéro de série.
  4. Dans l'écran Résumé (Prêt à créer l'image), vérifiez que les options d'image administrative sont correctes.
    Pour des détails sur les options d'images administratives individuelles et d'installation, cliquez sur MODIFIER pour aller à la page d'options puis cliquez sur ?.
  5. Pour créer la nouvelle version de l'image administrative, cliquez sur Créer maintenant.

Vous pouvez maintenant mettre à niveau les clients vers cette nouvelle version de l'image administrative. Pour plus de détails, voir Mise à niveau de clients à partir d'images administratives.

Sujet parent Mettre à niveau des images administratives vers une nouvelle version
Télécharger des fichiers d'installation mis à jour pour les images administratives
Mise à niveau de clients à partir d'images administratives
Lancer l'installation de SOLIDWORKS


Mise à niveau de clients à partir d'images administratives

Le Gestionnaire d'installation SOLIDWORKS peut automatiquement mettre à jour des ordinateurs clients installés à partir d'une image administrative.

En général, les images administratives sont organisées par dossiers sur un serveur. Pour ce faire, l'image administrative doit être située dans un dossier partagé.

Après la mise à niveau de l'image administrative, l'installation d'origine sera dans un dossier et l'installation mise à niveau sera dans un autre. Afin d'utiliser l'installation mise à niveau, supprimez l'option de partage du dossier de l'image administrative d'origine, puis ajoutez-la à celui de l'image administrative mise à niveau.

Au démarrage de SOLIDWORKS sur un ordinateur client installé à partir de l'image administrative d'origine, la nouvelle version est reconnue et le client est mis à niveau.
Lorsque SOLIDWORKS déclenche une mise à jour, d'autres produits installés à partir d'une image administrative se mettent à jour automatiquement.
Sujet parent Mettre à niveau des images administratives vers une nouvelle version
Télécharger des fichiers d'installation mis à jour pour les images administratives
Mise à niveau d’une image administrative

Supprimer l'option de partage du dossier de l'image administrative d'origine

Lorsque vous mettez à niveau une image administrative accessible depuis un dossier partagé, vous devez annuler l'option du partage du dossier d'origine.

  1. Parcourez jusqu'au dossier où se trouvent les fichiers de l'image administrative d'origine.
  2. Cliquez à l'aide du bouton droit de la souris sur le dossier et sélectionnez Propriétés.
  3. Sélectionnez Ne pas partager ce dossier dans l'onglet Partage et cliquez sur OK.

Ajoutez maintenant l'option de partage au dossier d'image administrative mise à niveau comme décrit dans Ajouter l'option de partage à un dossier d'image administrative mise à niveau.

Ajouter l'option de partage à un dossier d'image administrative mise à niveau

Après avoir créé un dossier d'image administrative mise à niveau et désactivé le partage pour le dossier d'image administrative d'origine, vous devez ajouter l'option de partage au nouveau dossier pour réactiver l'image administrative.

  1. Parcourez jusqu'au dossier où se trouvent les fichiers de l'image administrative mise à niveau.
  2. Cliquez à l'aide du bouton droit de la souris sur le dossier et sélectionnez Propriétés.
  3. Dans l'onglet Partage, spécifiez les propriétés de partage appropriées dans votre cas et modifiez le nom du partage au profit de celui utilisé par le dossier de l'image administrative d'origine.
Les ordinateurs installés depuis l'emplacement de partage de l'image administrative d'origine sont automatiquement mis à niveau vers la nouvelle version au démarrage de SOLIDWORKS.


Administration des mises à jour de produits au moyen des service packs

Les mises à jour de produits au moyen des service packs visent à améliorer la fiabilité du système, la compatibilité des programmes, la sécurité, etc.

Vous pouvez les acquérir de deux façons :
  • En utilisant le Gestionnaire d'installation SOLIDWORKS pour rechercher, télécharger et installer des mises à jour.

    Vous pouvez lancer le Gestionnaire d'installation SOLIDWORKS manuellement ou bien planifier une vérification périodique des mises à jour disponibles.

  • En téléchargeant les service packs manuellement depuis le site Web du support SOLIDWORKS.

    Les service packs sont des correctifs appliqués à une version existante du logiciel. Par exemple, SOLIDWORKS 2020 SP1.0 est un service pack de la version SOLIDWORKS 2020 SP0.0. Vous installez ces service packs à l'aide du Gestionnaire d'installation de SOLIDWORKS 2020 ; vous ne pouvez pas les installer avec le Gestionnaire d'installation SOLIDWORKS de la version SOLIDWORKS 2019.

    Pour des instructions sur le téléchargement et l'installation de service packs, consultez la documentation relative à l'installation de la version SOLIDWORKS que vous mettez à jour.

Table des matières

  • Restaurer des service packs antérieurs dans une image administrative

    Vous pouvez faire revenir une image administrative à un service pack antérieur. Si vous avez installé le logiciel SOLIDWORKS à partir de disques, vous avez besoin des disques d'origine pour installer un service pack. Une copie de l'image administrative antérieure doit être disponible.

  • Appliquer des service packs aux clients déployés avec Microsoft Active Directory

    Si vous avez installé le logiciel SOLIDWORKS avec Microsoft Active Directory, vous pouvez aussi appliquer des service packs aux clients avec celui-ci.

Sujet parent Administration d'installations multiples
Mettre à niveau des images administratives vers une nouvelle version
Supprimer une installation


Restaurer des service packs antérieurs dans une image administrative

Vous pouvez faire revenir une image administrative à un service pack antérieur. Si vous avez installé le logiciel SOLIDWORKS à partir de disques, vous avez besoin des disques d'origine pour installer un service pack. Une copie de l'image administrative antérieure doit être disponible.

Il n'est pas possible de restaurer un service pack antérieur pour les images administratives qui ont été mises à niveau. Les images administratives créées avec une méthode différente de celle du Gestionnaire d'installation SOLIDWORKS ne peuvent pas être restaurées à une version antérieure. Les clients installés à partir de ces images administratives doivent être désinstallés puis réinstallés en utilisant une image administrative créée depuis la version précédente.
  1. Supprimez le dossier contenant l'image administrative actuelle. Pour ce faire, ouvrez l'Invite de commandes et entrez:
    rmdir /s/q chemin_d'accès_à_l'image_administrative_actuelle
  2. Déplacez la copie de sauvegarde de l'image administrative vers l'emplacement où vous avez supprimé l'image administrative actuelle. Pour ce faire, ouvrez l'Invite de commandes et entrez:
    move chemin_d'accès_à_l'image_administrative_de_sauvegarde chemin_d'accès_à_l'image_administrative_actuelle
    Après avoir restauré une image administrative, les ordinateurs clients sont automatiquement restaurés à la prochaine exécution du logiciel SOLIDWORKS.
Sujet parent Administration des mises à jour de produits au moyen des service packs
Appliquer des service packs aux clients déployés avec Microsoft Active Directory


Appliquer des service packs aux clients déployés avec Microsoft Active Directory

Si vous avez installé le logiciel SOLIDWORKS avec Microsoft Active Directory, vous pouvez aussi appliquer des service packs aux clients avec celui-ci.

  1. Copiez l'image administrative vers un nouveau dossier en utilisant la ligne de commande suivante:
    xcopy chemin_d'accès_à_l'image_administrative_actuelle chemin_d'accès_à_l'image_administrative_de_sauvegarde /s/i/v
  2. Mettez à niveau l'image administrative à l'aide du Gestionnaire d'installation de SOLIDWORKS.
  3. Créez un nouveau fichier de transformation pour spécifier la mise à niveau d'une installation du logiciel SOLIDWORKS :
    1. Ouvrez la fenêtre Invite de commandes.
    2. Dans le dossier contenant l'image administrative, faites glisser SWCreateMST.exe dans l'Invite de commandes.
      Le format de la commande est le suivant:

      chemin_d'accès_de_l'image_administrative\SWCreateMST.exe chemin_d'accès_au_fichier_MSI_d'une_image_administrative liste_des_propriétés

      La ligne de commande doit inclure tous les paramètres utilisés pour créer le fichier de transformation d'origine, plus les propriétés générales UPGRADESWINSTALL et SWMIGRATE.

      Par exemple, si la commande d'origine était:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\votre_dossier" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@votre_serveur

      la commande de mise à jour doit être:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\le_dossier_de_votre_choix" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@votre_serveur UPGRADESWINSTALL=1 SWMIGRATE="SOLIDWORKS version service_pack"

      Le fichier de transformation, SOLIDWORKS.mst, est créé dans le dossier contenant l'image administrative.

  4. Dans Active Directory, éditez la stratégie Published Apps du ou des groupe(s) pour déployer le logiciel SOLIDWORKS.
  5. Dans la boîte de dialogue Stratégie de groupe, développez Configuration ordinateur et Paramètres logiciel.
  6. A l'aide du bouton droit de la souris, cliquez sur Installation de logiciel et sélectionnez Nouveau > Package.
  7. Recherchez l'image administrative et cliquez sur Ouvrir.
  8. Dans la boîte de dialogue Déploiement du logiciel, sélectionnez Publication ou attribution avancée, puis cliquez sur OK.
  9. Dans la boîte de dialogue Propriétés de SOLIDWORKS, sur l'onglet Modifications :
    1. Cliquez sur Ajouter.
    2. Parcourez jusqu'au fichier .mst.
    3. Cliquez sur Ouvrir.
  10. Cliquez sur OK.
Sujet parent Administration des mises à jour de produits au moyen des service packs
Restaurer des service packs antérieurs dans une image administrative


SOLIDWORKS PDM et SOLIDWORKS Manage

SOLIDWORKS PDM est un produit de gestion de documents basé sur l'architecture client/serveur précédemment appelée SOLIDWORKS Enterprise PDM. SOLIDWORKS PDM est disponible dans deux types :
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM utilise une base de données Microsoft SQL Server pour gérer les coffres-forts de fichiers.

Ce tableau répertorie les systèmes de base de données, les composants de serveur et les options de client disponibles pour chaque type de produit.
 | PDM Standard | PDM Professional
Conçu pour | Réseaux de bureau petits et moyens, avec généralement moins de 20 utilisateurs simultanés. | Grand réseaux de bureau, avec un grand nombre d'utilisateurs simultanés
Limites | Moins de 1 socket ou 4 cœurs, 1 Go de RAM et une base de données de 10 Go | Limites de SQL Standard : Moins de 4 sockets ou 16 cœurs, 128 Mo de RAM et une base de données de 524 Po
Système de gestion de base de données | Microsoft SQL Server Express 2014 (inclus et installé avec SOLIDWORKS) | Microsoft SQL Server 2014 (inclus séparément avec SOLIDWORKS) ou instances déjà installées de Microsoft SQL Server 2014, 2012 ou 2008 R2
Requiert SolidNetWork License Manager ? | Oui | Oui
Inclut un serveur d'archives et un serveur de base de données ? | Oui | Oui
Inclut le serveur Web SOLIDWORKS PDM et le serveur Web2 ? | Non | Oui
Types de clients | Natif | Natif, basé sur navigateur
Compléments client pour CAD Editor | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Microsoft Office Integration, Autodesk Inventor, AutoCAD
Compléments client pour Contributor | DraftSight | DraftSight, Intégration avec Microsoft Office
Compléments client pour Viewer |  | Intégration de Microsoft Office

SOLIDWORKS Manage Professional offre des outils avancés de gestion des données à SOLIDWORKS PDM Professional. Il permet un contrôle avancé des versions ainsi qu'une gestion des projets, des processus et des éléments. Des tableaux de bord et des rapports interactifs vous aident à suivre les éléments, les activités et la progression des projets.

L'architecture de SOLIDWORKS Manage Professional est similaire à celle de SOLIDWORKS PDM Professional. Il utilise une architecture client/serveur et une base de données Microsoft SQL Server afin de gérer les données de projet et d'élément. Il existe trois services pour les fonctions de base de données, de serveur de fichiers et de serveur Web, qui prennent en charge les clients lourds et les clients de navigateur Web. Ces trois services peuvent être hébergés sur le même serveur ou sur des serveurs différents. Les utilisateurs qui disposent d'une licence SOLIDWORKS Manage Professional Editor peuvent utiliser un complément SOLIDWORKS Manage pour accéder aux données de Manage directement à partir de SOLIDWORKS.

Vous pouvez utiliser le gestionnaire d'installation SOLIDWORKS pour installer le serveur et le client SOLIDWORKS Manage Professional.

Pour obtenir des instructions sur l'installation de SOLIDWORKS Manage Professional, consultez le Guide d'installation de SOLIDWORKS PDM / SOLIDWORKS Manage.

Table des matières

  • Liste des composants serveur de PDM

  • Clarification des différences entre les clients PDM

    Avant d'installer le logiciel client, vous devez déterminer les clients nécessaires en fonction de votre environnement PDM.

  • Avant l'installation de PDM Server

    Retenez les exigences suivantes avant d'installer les composants serveur de PDM :

  • Installation d'un serveur PDM avec SLDIM

    Lorsque vous installez le serveur PDM pour PDM Standard, vous pouvez installer le serveur d'archives, le serveur de base de données et le client PDM CAD Editor sur le même ordinateur. Vous n'avez pas besoin d'exécuter l'installation du client séparément.

  • Installation d'un client PDM avec SLDIM


Liste des composants serveur de PDM

Ce tableau résume les composants serveur de SOLIDWORKS PDM Server.

Serveur | Function | Installation
Microsoft SQL Server Express pour PDM Standard | Gère les données dans les coffres-forts de données SOLIDWORKS PDM. | Peut être installé avec PDM Standard, ou utiliser une version sous licence et installée précédemment.
Microsoft SQL Server pour PDM Professional | Gère les données dans les coffres-forts de données SOLIDWORKS PDM. | Livré séparément avec PDM Professional. Vous pouvez également utiliser une version sous licence et installée antérieurement.
Gestionnaire de licences SolidNetWork | Gère les licences SOLIDWORKS PDM. | Doit être installé pour permettre la création de nouveaux coffres-forts. Peut être installé avec les composants du serveur SOLIDWORKS PDM lors de l'utilisation de SLDIM.
Serveur d'archives | Gère les transferts de fichiers entre les clients et les archives du coffre-fort de fichiers et gère les utilisateurs et leurs informations d'identification. | C'est nécessaire Installer avec PDM Standard ou Professional.
Serveur de base de données | Interroge les bases de données PDM pour vérifier la présence de mises à jour, gère les règles d'importation et d'exportation de données, gère le système de messagerie, et planifie la réplication et le stockage en mémoire froide. | C'est nécessaire Installer avec PDM Standard ou Professional.
Serveur Web et Serveur Web2 | Permet d'accéder aux coffres-forts de fichiers sur Internet à partir de clients utilisant un navigateur. | C'est facultatif Installer avec PDM Professional uniquement.
Web API Server | Les utilisateurs d'EXALEAD OnePart peuvent faire appel à un serveur Web API pour indexer et récupérer des données SOLIDWORKS PDM. | Facultatif. Installer avec PDM Professional uniquement.

Les serveurs d'archives sont exécutés en tant que services sur le compte système des ordinateurs où ils sont installés. Un serveur d'archives peut héberger plusieurs coffres-forts de fichiers sur le même ordinateur.

Dans une installation autonome, il est possible d'installer sur le même ordinateur le serveur d'archives, le serveur de base de données, le serveur de licences et le serveur Web API, ainsi que la base de données SQL Server ou SQL Express.

Dans un environnement distribué, les composants serveur peuvent résider sur des ordinateurs différents. Vous pouvez aussi configurer plusieurs serveurs d'archives sur différents ordinateurs pour héberger les copies répliquées de la même archive de coffre-fort de fichiers. Pour plus de détails, voir Guide de réplication de SOLIDWORKS PDM Professional.

Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


Clarification des différences entre les clients PDM

Avant d'installer le logiciel client, vous devez déterminer les clients nécessaires en fonction de votre environnement PDM.

Ce tableau résume les clients pour SOLIDWORKS PDM standard :
Type de client Standard | Description
CAD Editor | Compatible avec les fichiers SOLIDWORKS, DWG/DXF, Microsoft Word et Microsoft Excel. Tous les formats de fichiers pris en charge par le plug-in Office se comportent de la même manière dans SOLIDWORKS PDM Standard, à l'exception d'Aperçu.
Contributeur | Compatible avec les fichiers SOLIDWORKS, DWG/DXF, Microsoft Word et Microsoft Excel.
Visionneuse | Donne l'accès en lecture seule aux coffres-forts de fichiers. L'utilisateur peut effectuer la transition des fichiers via un flux de travail, mais il ne peut ni ajouter ni modifier (extraire, archiver, mettre à jour des valeurs) les fichiers.
Ce tableau résume les clients pour SOLIDWORKS PDM Professional :
Type de client Professional | Description
CAD Editor & Web | Prend en charge le fonctionnement avec tous les types de fichiers, y compris la gestion améliorée et la prévisualisation de formats CAO tels que SOLIDWORKS. Des compléments de CAO permettent aux utilisateurs d'accéder à SOLIDWORKS PDM Professional à partir de l'application de CAO. Les utilisateurs à distance peuvent rechercher dans les coffres-forts et effectuer des fonctions de base sur l'Internet à l'aide de clients Web et Web2.
Contributor & Web | Prend en charge le fonctionnement avec tous les types de fichiers, y compris des fichiers CAO. Cependant, les compléments CAO ne sont pas pris en charge par ce type de clients. Les utilisateurs à distance peuvent rechercher dans les coffres-forts et effectuer des fonctions de base sur l'Internet à l'aide de clients Web et Web2.
Visionneuse | Donne l'accès en lecture seule aux coffres-forts de fichiers. L'utilisateur peut effectuer la transition des fichiers via un flux de travail, mais ne peut ni ajouter, ni modifier des fichiers (extraire, archiver, mettre à jour des valeurs), ni utiliser des compléments CAO.
Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


Avant l'installation de PDM Server

Retenez les exigences suivantes avant d'installer les composants serveur de PDM :

  • Obtenez des droits administratifs complets sur les ordinateurs où vous allez installer les serveurs et les clients.
  • Assurez-vous que le serveur de bases de données a accès au serveur d'archives par le port TCP 3030 et au serveur SQL par le port TCP 1433.
  • Si vous allez utiliser une base de données SQL Server Express ou SQL Server existante, procurez-vous le nom de la base de données SQL Server, ainsi que l'ID de compte et le mot de passe d'un administrateur SQL Server ou du propriétaire de la base de données avec l'accès en lecture/écriture à la base de données. Vous ne pouvez pas utiliser l'utilisateur tew.
  • Si un client PDM est déjà installé sur le système, désinstallez-le. Si vous voulez le serveur PDM et le client PDM sur le même système, vous devez installer les deux à partir de la page Produits serveur dans le Gestionnaire d'installation de SOLIDWORKS.
Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


Installation d'un serveur PDM avec SLDIM

Lorsque vous installez le serveur PDM pour PDM Standard, vous pouvez installer le serveur d'archives, le serveur de base de données et le client PDM CAD Editor sur le même ordinateur. Vous n'avez pas besoin d'exécuter l'installation du client séparément.

Lors de l'installation du serveur PDM pour PDM Professional, vous pouvez inclure ces composants, ainsi que les serveur Web, Web2 et Web API.

Pour installer un serveur PDM et ses composants :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Produits serveur et cochez les options suivantes :
    • Installer les composants SOLIDWORKS PDM Server sur cet ordinateur.
    • Installer SolidNetWork License Manager sur cet ordinateur.

      Si SolidNetwork License Manager est installé, cette option ne s'affiche pas.

  3. Si la page Options de SolidNetwork License Manager s'affiche, saisissez un numéro de série et spécifiez un emplacement pour le répertoire, puis cliquez sur Suivant.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, pour SOLIDWORKS PDM Server, cliquez sur Modifier.
  6. Sur la page Options de SOLIDWORKS PDM Server :
    1. Pour Sélectionner un produit Serveur, cliquez sur SOLIDWORKS PDM Standard ou Professional.
    2. Pour Emplacement d'installation, cliquez sur Parcourir afin de spécifier un chemin de fichier.
    3. Dans Sélectionner les fonctions :
      1. Cliquez sur Serveur d'archives, Serveur de base de données et Client pour installer ces composants sur le même ordinateur. Si vous êtes dans un environnement distribué, vous pouvez installer le serveur d'archives et le serveur de base de données en exécutant le Gestionnaire d'installation sur un autre ordinateur.
        Si un client PDM est déjà installé sur l'ordinateur, vous devez annuler l'installation et désinstaller le client. Vous pouvez ensuite exécuter SLDIM pour installer le serveur PDM en même temps que le client.
      2. Si vous installez PDM Professional, vous pouvez également cliquer sur Serveur Web, Serveur Web2 et Web API Server.
        Si vous installez le serveur Web API, vous pouvez spécifier une valeur comprise entre 0 et 65535 dans le champ Numéro de port HTTP. La valeur par défaut est 65453.
    4. Dans SQL Server, vous pouvez installer une nouvelle instance des outils de base de données qui sont fournis avec PDM Server (SQL Server Express pour PDM Standard), ou vous pouvez spécifier le nom de la base de données, le nom d'utilisateur et le mot de passe d'une instance existante.
      Une version complète de SQL Server est livrée séparément avec PDM Professional.
    5. Cliquez sur Retour au résumé.
  7. Sur la page Résumé, acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.

    Lorsque l'installation de SOLIDWORKS Installation Manager est terminée, l'outil Configuration du serveur d'archives démarre. Suivez les instructions de l'assistant pour configurer le serveur d'archives.

Pour installer, configurer et dépanner le serveur d'archives, le serveur de base de données, les serveurs Web et Web2, ainsi que les bases de données SQL Server, consultez les rubriques associées dans le Guide d'installation de SOLIDWORKS PDM 2020.

Table des matières

  • Modification d'une installation SOLIDWORKS PDM Server

Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


Modification d'une installation SOLIDWORKS PDM Server

Pour modifier une installation de SOLIDWORKS PDM Server et ses composants, utilisez Programmes et fonctionnalités à partir du Panneau de configuration de Windows. Vous ne pouvez pas modifier l'installation avec le Gestionnaire d'installation de SOLIDWORKS (SLDIM), même s'il s'agit de l'outil que vous avez utilisé pour installer SOLIDWORKS PDM Server.

Sujet parent Installation d'un serveur PDM avec SLDIM


Installation d'un client PDM avec SLDIM

La version principale de SOLIDWORKS PDM Client doit correspondre à la version majeure de SOLIDWORKS PDM Server. Lorsque vous installez ou mettez à jour SOLIDWORKS PDM Client, assurez-vous que les versions correspondent.

Pour installer un client PDM :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Individuelle.
  3. Sur la page Numéro de série, cliquez sur Suivant.
    Les clients SOLIDWORKS PDM n'ont pas besoin d'un numéro de série séparé.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, sous Produits, cliquez sur Modifier.
  6. Sur la page Sélection de produit, cliquez sur Sélectionnez différents packages ou produits.
  7. Dans la boîte de dialogue Sélectionnez le package à afficher, sélectionnez une édition de SOLIDWORKS. Puis cliquer OK.
  8. Sur la page Sélection de produit, sélectionnez Client SOLIDWORKS PDM. Sélectionnez ensuite eDrawings pour activer la fonctionnalité d'aperçu de PDM. Si vous utilisez PDM SOLIDWORKS Professional, vous pouvez également sélectionner Explorateur d'articles.
  9. Sur la page Résumé, développez Options SOLIDWORKS PDM et cliquez sur Modifier.
  10. Sur la page Options de client SOLIDWORKS PDM, sélectionnez les éléments suivants, puis cliquez sur Retour au résumé:
    • Type de produit PDM
    • Type de client PDM
    • Compléments
  11. Sur la page Résumé, acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.
Les administrateurs peuvent également utiliser l'Editeur d'options du Gestionnaire d'images administratives pour créer et déployer des images des clients PDM. Pour plus de détails, voir Utilisation des images administratives dans le Guide d'installation et d'administration de SOLIDWORKS.
Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


SOLIDWORKS Electrical

SOLIDWORKS Electrical simplifie la conception des systèmes électriques grâce à des outils de conception intelligents, à une base de données de pièces complète et à l'intégration en temps réel entre schémas 2D et modèles 3D.

Les principaux composants de SOLIDWORKS Electrical sont :
  • SOLIDWORKS Electrical Schematic - Outils pour la création dynamique de schémas électriques 2D.
  • SOLIDWORKS Electrical 3D - Outils pour l'intégration de schémas 2D à des modèles 3D, ce qui vous permet de modéliser des systèmes électriques en 3D, y compris les câbles et les fils.
  • Data - Base de données de pièces, symboles, bibliothèques et catalogues pouvant être partagés par des utilisateurs.
  • Collaborative Server - Utilitaire pour la gestion de l'ouverture et de la mise à jour de schémas électriques.
  • Une instance de la base de données Microsoft SQL Server.

SOLIDWORKS Electrical nécessite une base de données Microsoft SQL Server. Il peut utiliser une base de données existante, ou une nouvelle instance, durant l'installation.

Il est possible d'installer tous les composants SOLIDWORKS Electrical sur le même ordinateur. Cette installation est généralement considérée comme une installation autonome. Toutes les données de programme, comme les mises en plan de projet et les rapports, sont enregistrés sur un système unique. L'installation de SOLIDWORKS Electrical nécessite au préalable des droits administratifs complets pour accéder au système.

Il est également possible d'installer les composants de SOLIDWORKS Electrical en tant qu'application client/serveur. Cette installation est nécessaire lorsque les données doivent être enregistrées sur un serveur réseau, ou lorsqu'il existe une base de données SQL Server sur un serveur réseau contenant toutes les bases de données SOLIDWORKS Electrical. Dans ces cas, les droits administratifs complets sont nécessaires sur le serveur et les systèmes clients. En outre, les systèmes clients doivent avoir accès aux réseaux sur le serveur et disposer d'autorisations de lecture/écriture pour créer des projets, des bibliothèques et des symboles.

Seule une version de SOLIDWORKS Electrical peut être installée par ordinateur. Si vous créez une nouvelle installation de SOLIDWORKS et que vous sélectionnez SOLIDWORKS Electrical comme l'un des produits à installer, l'ancienne version de SOLIDWORKS Electrical sera supprimée.

Effectuez toujours une sauvegarde de l'environnement SOLIDWORKS Electrical existant avant d'installer une nouvelle version. Dans SOLIDWORKS Electrical Schematic, sélectionnez Fichier Archiver l'environnement. Dans SOLIDWORKS Electrical 3D, sélectionnez SOLIDWORKS Electrical > Outils > Archiver l'environnement.

Table des matières

  • Gestion des données dans SOLIDWORKS Electrical

  • Conditions requises pour l'installation de SOLIDWORKS Electrical


Gestion des données dans SOLIDWORKS Electrical

De nombreux programmes utilisent une base de données unique qui contient toutes les données du programme. Tel n'est pas le cas de SOLIDWORKS Electrical. Chaque projet de SOLIDWORKS Electrical est affecté d'un numéro d'identification unique, et à chaque projet est associée une base de données identifiable par son numéro d'identification unique. Par exemple, dans le Project Manager SOLIDWORKS Electrical, un projet avec l'identificateur n° 112 sera associée à une base de données nommée « tew_project_data_112 ».

La raison de l'utilisation d'une base de données unique pour chaque projet est que ceci réduit de manière significative le temps de traitement. En outre, en cas de défaillance critique d'une base de données, un seul projet est affecté, et l'intégrité de la majorité des informations de programme est maintenue.

Toutefois, certaines entreprises possèdent des règles limitant la création de nouvelles bases de données. Pour exécuter SOLIDWORKS Electrical, il ne peut exister de restriction à la création de nouvelles bases de données par les utilisateurs. Consultez l'administrateur système ou de base de données pour vous assurer qu'aucun paramètre de configuration n'empêche les utilisateurs de créer de nouvelles bases de données.
Sujet parent SOLIDWORKS Electrical
Conditions requises pour l'installation de SOLIDWORKS Electrical


Conditions requises pour l'installation de SOLIDWORKS Electrical

Pour accéder aux conditions requises actuelles, reportez-vous à http://solidworks.com/System_Requirements.

Table des matières

  • Options Individuel et Serveur

    Vous pouvez installer SOLIDWORKS Electrical en mode individuel ou en mode serveur.

  • Spécifier l'emplacement des données

  • Configurer le serveur de collaboration

  • Configurer Microsoft SQL Server

Sujet parent SOLIDWORKS Electrical
Gestion des données dans SOLIDWORKS Electrical


Options Individuel et Serveur

Vous pouvez installer SOLIDWORKS Electrical en mode individuel ou en mode serveur.

Il est important de noter que SOLIDWORKS Electrical doit se connecter à une instance de SQL Server, soit-elle existante ou nouvelle.

En mode individuel, vous pouvez installer les composants suivants :
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Serveur de collaboration
  • Données
  • Une nouvelle instance de la base de données SQL Server
En mode serveur, vous pouvez installer les composants suivants :
  • Une nouvelle instance de la base de données SQL Server
  • Serveur de collaboration
  • Données

Vous pouvez combiner des composants des modes individuel et serveur pour créer un environnement client/serveur. Par exemple, vous pouvez installer SOLIDWORKS Electrical Schematic et SOLIDWORKS Electrical 3D sur des systèmes clients, et installer tous les composants serveur sur un système serveur.

Sujet parent Conditions requises pour l'installation de SOLIDWORKS Electrical
Spécifier l'emplacement des données
Configurer le serveur de collaboration
Configurer Microsoft SQL Server


Spécifier l'emplacement des données

Pour l'emplacement des données, sélectionnez un répertoire pour l'enregistrement des données de programme comme les pièces, les modèles et les symboles 2D et 3D. Cet emplacement devrait être un répertoire dédié. Il ne peut pas s'agir d'un répertoire racine ou du répertoire utilisé pour enregistrer les données de SOLIDWORKS.

Le répertoire par défaut est C:\ProgramData\SOLIDWORKS Electrical. Un dossier nommé Update est ajouté à ce répertoire pour enregistrer toutes les données de programme disponibles.

Lors du premier lancement de SOLIDWORKS Electrical, l'assistant Mise à jour des données s'affiche. Dans cet assistant, vous pouvez sélectionner les données à ajouter dans l'application et la base de données SQL Server.
Sujet parent Conditions requises pour l'installation de SOLIDWORKS Electrical
Options Individuel et Serveur
Configurer le serveur de collaboration
Configurer Microsoft SQL Server


Configurer le serveur de collaboration

Pour exécuter SOLIDWORKS Electrical, vous devez installer le serveur de collaboration sur le système qui héberge la base de données Microsoft SQL Server.

Le serveur de collaboration doit être exécuté en permanence, et avoir une communication constante, ininterrompue et bidirectionnelle avec les clients au travers des pare-feu et des antivirus.

Pour installer le serveur de collaboration en mode individuel ou serveur, vous devez spécifier les paramètres suivants :
  • Le nom de l'ordinateur, par exemple LOCALHOST
  • L'adresse IP de l'ordinateur, par exemple 127.0.0.1
  • Le numéro de port, par exemple 26666

Pour fournir la communication bidirectionnelle ininterrompue, assurez-vous que le port numéro 26666 est disponible sur le système sur lequel le serveur de collaboration est installé. Si le port 26666 n'est pas accessible, collaborez avec l'administrateur système pour trouver un autre port accessible par SOLIDWORKS Electrical.

Sujet parent Conditions requises pour l'installation de SOLIDWORKS Electrical
Options Individuel et Serveur
Spécifier l'emplacement des données
Configurer Microsoft SQL Server


Configurer Microsoft SQL Server

Vous devez vous assurer qu'une instance de la base de données SQL Server est disponible pour n'importe quel type d'installation SOLIDWORKS Electrical. Vous pouvez utiliser une base de données SQL Server existante si elle est déjà installée sur le système, ou installer une nouvelle instance dans le cadre de l'installation de SOLIDWORKS Electrical.

Lorsque vous installez une nouvelle instance de SQL Server, l'installation de SOLIDWORKS fournit une version gratuite de Microsoft SQL Server Express. Cette version est limitée à 1 processeur, 1 Go de mémoire et 10 Go de données. Les limitations de mémoire et processeur sont suffisantes pour prendre en charge 5 utilisateurs simultanés.

Si vous installez SQL Server Express Edition, veillez à ce que le logiciel et le matériel de serveur répondent aux exigences répertoriées http://solidworks.com/System_Requirements.

S'il existe 6 utilisateurs simultanés ou plus sur le même serveur, il vous faut acheter et installer une version complète de SQL Server, et utiliser le flux de travail décrit pour l'installation de SolidWorks Electrical avec une instance existante de SQL Server.

Pour des informations sur SQL Server Express Edition, consultez la documentation de Microsoft SQL Server.

Sujet parent Conditions requises pour l'installation de SOLIDWORKS Electrical
Options Individuel et Serveur
Spécifier l'emplacement des données
Configurer le serveur de collaboration

Nouvelles instance de SQL Server

Si vous installez une nouvelle instance de SQL Server, vous devez posséder des droits administratifs complets sur le serveur, ainsi que tous les systèmes clients. Vous devez également veiller à ce que les clients aient les droits de lecture/écriture pour la base de données, afin qu'ils puissent créer et modifier les projets, les bibliothèques, les symboles et les autres données de projet.

Lorsque vous installez une nouvelle instance de SQL Server, sélectionnez un nom différent du nom par défaut.

Instances existantes de SQL Server

Pour installer de nouvelles bases de données SOLIDWORKS Electrical ou vous connecter à une installation de SOLIDWORKS Electrical sur une instance existante de SQL Server, vous devez être muni d'un compte utilisateur possédant des droits administratifs complets sur la base de données SQL Server.

Pour que SOLIDWORKS Electrical fonctionne correctement, vous devez activer SQL Server pour une authentification en mode mixte. L'authentification en mode mixte permet l'utilisation d'informations d'identification de Windows ainsi que SQL Server.

Pour vous connecter à une base de données SQL Server existante, vous pouvez utiliser l'authentification Windows ou SQL Server. Entrez un nom d'utilisateur et un mot de passe pour un compte de connexion Windows ou SQL Server possédant les droits complets d'administrateur de SQL Server.

Vous ne pouvez pas utiliser l'utilisateur tew pour vous connecter à SQL Server pour l'installation. Contactez votre administrateur de SQL Server ou l'administrateur système pour obtenir un compte de connexion avec les informations d'identification correctes pour SQL Server.

Post-installation de SQL Server

Une fois SOLIDWORKS Electrical installé, l'instance de SQL Server crée dans SOLIDWORKS Electrical les bases de données suivantes :
  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION
  • TEW_SQLEXPRESS


SOLIDWORKS PCB

SOLIDWORKS® PCB (autrefois PCBWorks) est un outil de conception de PCB (carte de circuit imprimé) qui est intégré au logiciel de conception 3D SOLIDWORKS. Il est installé par le Gestionnaire d'installation SOLIDWORKS dans le cadre de l'installation Individuelle.

Un ingénieur électricien utilisant SOLIDWORKS PCB peut apporter des modifications à une carte de circuit imprimé et transférer ces modifications vers un référentiel partagé. Un ingénieur en mécanique utilisant le logiciel SOLIDWORKS peut extraire la carte de circuit imprimé modifiée du référentiel, analyser les modifications, apporter des modifications supplémentaires, et retransférer la conception vers le référentiel où l'ingénieur électricien pourra de nouveau y accéder.

Pour permettre cette collaboration, vous devez installer SOLIDWORKS PCB Services, qui gère le référentiel sur un serveur partagé. Il est installé par le Gestionnaire d'installation SOLIDWORKS dans le cadre de l'installation Serveur et ne nécessite aucune licence distincte. Il inclut Microsoft Internet Information Services et une base de données qui stocke les données utilisées pour synchroniser le travail des concepteurs électriciens et mécaniques.

Dans les environnements réseau, SOLIDWORKS PCB Services est généralement installé sur un serveur de partage qui n'exécute pas le logiciel SOLIDWORKS. Il peut également être installé avec d'autres composants SOLIDWORKS PCB sur un seul ordinateur. SOLIDWORKS PCB Services, qui doit être exécuté en permanence, doit avoir une communication bidirectionnelle ininterrompue à travers les pare-feu et les antivirus avec les clients exécutant SOLIDWORKS PCB et le logiciel SOLIDWORKS, et avec tous les clients exécutant Altium Designer qui doivent être intégrés au logiciel SOLIDWORKS.
Il est recommandé d'installer SOLIDWORKS PCB Services avant d'installer SOLIDWORKS PCB.

En outre, un autre composant nommé « complément SOLIDWORKS PCB » doit être activé sur les ordinateurs exécutant le logiciel SOLIDWORKS. Vous pouvez activer le complément à partir du menu Outils > Compléments.

Les ingénieurs électriciens ayant une licence Altium Designer peuvent également échanger des conceptions avec des utilisateurs du logiciel de conception 3D SOLIDWORKS par le biais du référentiel. Pour effectuer cet échange, les utilisateurs doivent installer SOLIDWORKS PCB Connector. Ce logiciel est installé à partir du client Altium Designer.

Table des matières

  • Prérequis

  • Installation de PCB Services avec SLDIM

  • Installation de PCB avec SLDIM

  • Modification de la connexion Admin par défaut

  • Installation de SOLIDWORKS PCB Viewer

    Vous pouvez télécharger et installer SOLIDWORKS® PCB Viewer avec le Gestionnaire d'installation, ce qui facilite son installation en même temps que SOLIDWORKS ou d'autres produits SOLIDWORKS. Ce PCB Viewer gratuit est disponible sans licence.

  • Installation du connecteur PCB pour Altium Designer

  • Post-installation

  • Mise à niveau de PCB Services

  • Désinstallation de PCB Services


Prérequis

Avant l'installation, assurez-vous de disposer des prérequis suivants :
  • un numéro de série SOLIDWORKS PCB.
  • un numéro de série SOLIDWORKS PCB Connector pour tout client Altium Designer à intégrer avec le logiciel SOLIDWORKS.

Pour accéder aux conditions système requises actuelles, reportez-vous à http://solidworks.com/System_Requirements.

Sujet parent SOLIDWORKS PCB


Installation de PCB Services avec SLDIM

Pour installer SOLIDWORKS PCB Services :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Produits Serveur.
  3. Sélectionnez ensuite Installer SOLIDWORKS PCB Services sur cet ordinateur et cliquez sur Suivant.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, acceptez les paramètres par défaut pour SOLIDWORKS PCB Services ou cliquez sur Changer pour spécifier les paramètres suivants :
    • Emplacement d'installation
    • Dossier de base de données
    • Dossier du fichier de révisions
    • Numéro de port

    PCB Services inclut Microsoft Internet Information Services et une base de données qui stocke les données utilisées pour synchroniser le travail des concepteurs électriciens et mécaniques.

    Le numéro de port par défaut est 9780.

  6. Acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.
Sujet parent SOLIDWORKS PCB


Installation de PCB avec SLDIM

Pour installer SOLIDWORKS PCB :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Individuelle.
  3. Procédez comme suit :
    1. Développez Conception électrique.
    2. Sélectionnez SOLIDWORKS PCB et saisissez le numéro de série.
    3. Cliquez sur Suivant.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.
Sujet parent SOLIDWORKS PCB


Modification de la connexion Admin par défaut

SOLIDWORKS PCB Services fournit un compte administrateur par défaut avec les informations d'identification suivantes :
  • admin pour le nom d'utilisateur
  • admin pour le mot de passe
Pour plus de sécurité, il est fortement recommandé de modifier les informations d'identification de connexion de ce compte.

Pour modifier la connexion Admin par défaut :

  1. Ouvrez un navigateur Web et, dans la barre d'adresses, saisissez le nom de la machine et le numéro de port sous la forme : http://nom du serveur:numéro de port.

    Le numéro de port par défaut est 9780.

  2. Sur la page Se connecter à SOLIDWORKS PCB Services, saisissez admin comme nom d'utilisateur et admin comme mot de passe, et cliquez sur Connexion.
  3. Dans le menu SOLIDWORKS PCB Services, cliquez sur Utilisateurs et cliquez sur l'onglet Utilisateurs.
  4. Cliquez sur le lien associé au compte administrateur ou cliquez sur l'icône Editer l'utilisateur [image].
  5. Modifiez les informations utilisateur, le nom d'utilisateur et le mot de passe.
  6. Cliquez sur Enregistrer.
Sujet parent SOLIDWORKS PCB


Installation de SOLIDWORKS PCB Viewer

Vous pouvez télécharger et installer SOLIDWORKS® PCB Viewer avec le Gestionnaire d'installation, ce qui facilite son installation en même temps que SOLIDWORKS ou d'autres produits SOLIDWORKS. Ce PCB Viewer gratuit est disponible sans licence.

Vous pouvez utiliser la visionneuse pour accéder à tous les fichiers de conception de votre équipe créés dans Altium Designer, les rechercher et les imprimer.

Vous pouvez également ajouter SOLIDWORKS PCB Viewer à vos déploiements d'image administrative.

Vous ne pouvez pas installer SOLIDWORKS PCB Viewer sur le même ordinateur que SOLIDWORKS PCB.
Sujet parent SOLIDWORKS PCB


Installation du connecteur PCB pour Altium Designer

Altium Designer est un outil de conception de carte de circuit imprimé. Les utilisateurs disposant d'une licence et d'une version installée de Altium Designer peuvent l'intégrer au logiciel SOLIDWORKS en installant SOLIDWORKS PCB Connector.

Pour installer SOLIDWORKS PCB Connector sur un ordinateur exécutant Altium Designer:

  1. Connectez-vous à votre compte Altium si vous n'êtes pas connecté automatiquement.
  2. Lancez Altium Designer, ouvrez l'onglet DXP, puis cliquez sur les Extensions et mises à jour.
  3. Sur la page Extensions et mises à jour, cliquez sur l'onglet Acheté.
  4. Faites défiler jusqu'à la section Extensions du logiciel. Puis, sur SOLIDWORKS PCB Connector, cliquez sur la flèche vers le bas dans le coin supérieur droit du carreau pour télécharger et commencer l'installation.

  5. Dans la boîte de dialogue Confirmer, cliquez sur Oui pour poursuivre l'installation.
    Vous devez effectuer les étapes 6 et 7 dans l'ordre spécifié pour éviter les problèmes d'activation et d'installation.
  6. Sur la page Immatriculation de PCB Connector, entrez le numéro de série de SOLIDWORKS PCB Connector et cliquez sur Enregistrer.
  7. Dans la boîte de dialogue Confirmer affichée par l'app Altium Designer, cliquez sur Oui pour redémarrer le système et terminer l'installation, ou sur Non pour terminer l'installation ultérieurement.

Pour désactiver une licence SOLIDWORKS PCB Connector, dans le menu Aide, cliquez sur SOLIDWORKS PCB Connector Licensing > Désactiver des licences.

Sujet parent SOLIDWORKS PCB


Post-installation

Après l'installation de SOLIDWORKS PCB et de ses composants, vous pouvez ajouter des comptes utilisateur à SOLIDWORKS PCB Services, de sorte que les utilisateurs puissent accéder aux cartes à partir du référentiel.

Les tâches supplémentaires comprennent la connexion au référentiel du complément SOLIDWORKS PCB et la désinstallation du logiciel.

Table des matières

  • Ajout d'un utilisateur à PCB Services

  • Connexion à un référentiel PCB

Sujet parent SOLIDWORKS PCB


Ajout d'un utilisateur à PCB Services

Pour ajouter un utilisateur sur le site Web SOLIDWORKS PCB Services :

  1. Ouvrez un navigateur Web et dans la barre d'adresse, saisissez le nom du serveur et le numéro de port affecté à SOLIDWORKS PCB Services. Par exemple, sous la forme : Http://nom du serveur:Numéro de port.
  2. Sur la page Se connecter à SOLIDWORKS PCB Services, saisissez votre nom d'utilisateur et mot de passe d'administrateur, puis cliquez sur Se connecter.
  3. Dans le menu SOLIDWORKS PCB Services, cliquez sur Utilisateurs et cliquez sur l'onglet Utilisateurs.
  4. Cliquez sur le bouton Ajouter un utilisateur et saisissez les informations suivantes :
    • Prénom
    • Nom
    • Nom d'utilisateur
    • Mot de passe
    • Adresse de messagerie
    • Numéro de téléphone

    Aussi, vous devez sélectionner un rôle d'utilisateur et cocher la case Elément mécano-soudé pour associer l'utilisateur à un groupe.

  5. Cliquez sur Enregistrer.
Vous pouvez modifier les informations utilisateur dans l'onglet Utilisateur.
Sujet parent Post-installation


Connexion à un référentiel PCB

Dans SOLIDWORKS, lorsque vous sélectionnez une nouvelle carte ou tirez une carte existante du volet des tâches de complément PCB, vous devez vous connecter à SOLIDWORKS PCB Services pour pouvoir accéder au référentiel.

Connexion au référentiel SOLIDWORKS PCB :

  1. A partir du volet des tâches SOLIDWORKS, cliquez sur le bouton Complément SOLIDWORKS PCB [image].
  2. Cliquez sur Nouvel assemblage de carte ou Tirer la carte du coffre-fort.
  3. Connectez-vous à SOLIDWORKS PCB Services :
    1. Spécifiez le nom du serveur et le numéro de port affecté à SOLIDWORKS PCB Services. Par exemple, tapez dans le formulaire : http://nom du serveur:numéro de port.
    2. Tapez vos Nom d'utilisateur et Mot de passe, puis cliquez sur OK.
Sujet parent Post-installation


Mise à niveau de PCB Services

Lorsque vous mettez à niveau SOLIDWORKS PCB Services vers la version 2020, le gestionnaire d'installation SOLIDWORKS met à niveau la base de données Firebird et effectue automatiquement la migration de vos données. Avant de procéder à la mise à niveau, vous devriez faire une sauvegarde de la base de données.

Pour mettre à niveau SOLIDWORKS PCB Services :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Produits Serveur.
  3. Sélectionnez Mettre à niveau SOLIDWORKS PCB Services sur cet ordinateur et cliquez sur Suivant.

    Le message suivant s'affiche : SOLIDWORKS PCB Services requiert une mise à niveau de votre base de données Firebird. Si vous continuez, votre logiciel et votre base de données Firebird seront mis à niveau.

  4. Cliquez sur Suivant.
  5. Sur la page Résumé, acceptez les paramètres par défaut ou cliquez sur Modifier pour spécifier d'autres paramètres.
  6. Acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.
Sujet parent SOLIDWORKS PCB


Désinstallation de PCB Services

Pour désinstaller SOLIDWORKS PCB Services :

  1. Cliquez sur Démarrer > Tous les programmes > SOLIDWORKS version > SOLIDWORKS PCB Services > Désinstaller SOLIDWORKS PCB Services.
  2. Lorsque vous êtes invité à supprimer SOLIDWORKS PCB Services et ses composants, cliquez sur Oui.
  3. Lorsque vous êtes invité à supprimer toutes les données SOLIDWORKS PCB Services, cliquez sur Non.
    Vous devez cliquer sur Non pour empêcher que tous les données et les fichiers de révision soient supprimés définitivement.
Sujet parent SOLIDWORKS PCB


SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize (dont le nom précédent était Bunkspeed) fournit une suite d'outils logiciels autonomes qui combinent des techniques avancées de rendu avec des flux de travail et des fonctionnalités axés sur la conception visuelle, afin que vous puissiez créer des images hautement réalistes de modèles CAO 3D.

Les produits SOLIDWORKS Visualize sont disponibles dans deux packages :
  • Standard
  • Professional

Pour une liste des fonctions actuelles dans chaque version du logiciel SOLIDWORKS Visualize, accédez à solidworks.com et recherchez SOLIDWORKS Visualize Datasheet.

Une licence gratuite de SOLIDWORKS Visualize Standard est offerte avec chaque licence de SOLIDWORKS 2020 Professional et Premium sous abonnement actif. Pour activer la licence gratuite, vous avez besoin d'un numéro de série supplémentaire, que vous trouverez en vous connectant au Portail clients SOLIDWORKS et en cliquant sur Mes produits. Vous ne pouvez plus utiliser le numéro de série de votre licence SOLIDWORKS Professional ou Premium pour activer votre licence complémentaire de SOLIDWORKS Visualize Standard.

SOLIDWORKS Visualize prend également en charge les types de licence SolidNetWork Licensing (SNL) comme les licences flottantes, ainsi que l'activation hors ligne.

A l'aide du Gestionnaire d'installation SOLIDWORKS (SLDIM), vous installez SOLIDWORKS Visualize dans le cadre de l'installation individuelle. Vous pouvez l'installer comme une application autonome, ce qui représente un avantage si vous voulez utiliser des ordinateurs distincts pour la modélisation et le rendu. Il ne consomme aucune licence SOLIDWORKS.

SOLIDWORKS Visualize Boost est un service qui vous permet de distribuer le rendu depuis un ordinateur exécutant SOLIDWORKS Visualize Professional vers un ou plusieurs ordinateurs sur un réseau. Vous pouvez effectuer d'autres tâches sur votre ordinateur pendant l'exécution du rendu et les images finales rendues sont disponibles plus tôt. Les images administratives peuvent être rendues sur un seul ordinateur, ou sur un groupe de plusieurs ordinateurs exécutant Visualize Boost.

Une licence gratuite de SOLIDWORKS Visualize Boost est offerte avec chaque licence de SOLIDWORKS Visualize Professional 2020 sous abonnement actif.
Visualize Boost est un complément conçu exclusivement pour Visualize Professional. Visualize Boost n'est pas compatible avec Visualize Standard.

Vous devez installer Visualize Boost sur un autre ordinateur que celui qui exécute SOLIDWORKS Visualize Professional. Vous pouvez également installer Visualize Boost dans le cadre de l'installation Individuelle dans le gestionnaire d'installation SOLIDWORKS (SLDIM).

Table des matières

  • Prérequis et configuration requise

  • Installation de SOLIDWORKS Visualize avec SLDIM

  • Installation de Visualize Boost avec SLDIM


Prérequis et configuration requise

Avant d'installer SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost, vous devez disposer des prérequis suivants pour chaque ordinateur :
  • un numéro de série SOLIDWORKS Visualize
  • un numéro de série SOLIDWORKS Visualize Boost
Chaque ordinateur exécutant SOLIDWORKS Visualize ou SOLIDWORKS Visualize Boost doit remplir les conditions suivantes :
  • Windows® 7 et Windows® 10 (64 bits)
  • Processeur à deux cœurs ; quatre cœurs recommandés
  • 8 Go de RAM ; 16 Go recommandés
  • 2 Go d'espace disque disponible ; 5 Go recommandés
  • 2 Go ou plus de RAM carte graphique ; 4 Go recommandés
  • Carte graphique NVIDIA® : NVIDIA Quadro®/NVIDIA GeForce®/Tesla™ avec au moins une puce NVIDIA Kepler™ ; configuration double GPU avec au moins des cartes NVIDIA Maxwell™ pour une expérience optimale
  • NVIDIA version de pilote 385.41 (ou version ultérieure) recommandé
  • Pilote NVIDIA prenant en charge CUDA® 9.0 ou version ultérieure requis
  • Connexion HDR Light Studio : HDR Light Studio v5.3.3 ou version ultérieure, sauf v5.4
  • 4 Go ou plus de mémoire vidéo requis pour la fonction Denoiser
Si des cartes graphiques autres que NVIDIA sont installées, SOLIDWORKS Visualize utilise par défaut le processeur central, et non ces cartes, pour l'accélération par GPU. Par ailleurs, les cartes NVIDIA reposant sur l'architecture Fermi™ ne prennent plus en charge l'accélération par GPU.
Sujet parent SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost


Installation de SOLIDWORKS Visualize avec SLDIM

Pour installer SOLIDWORKS Visualize :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Individuelle.
  3. Procédez comme suit :
    1. Sur la page Numéro de série, développez Visualization.
    2. Sélectionnez SOLIDWORKS Visualize et saisissez le numéro de série.
    3. Cliquez sur Suivant.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.

Cliquez deux fois sur l'icône de raccourci SOLIDWORKS Visualize sur le bureau pour démarrer l'application ou à partir du menu Démarrer de Windows, cliquez sur Tous les programmes > SOLIDWORKS version > SOLIDWORKS Visualize version.

Table des matières

  • Tâches de post-installation

Sujet parent SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost


Tâches de post-installation

Après l'installation, certaines tâches doivent être réalisées pour configurer SOLIDWORKS Visualize.

Table des matières

  • Création du dossier de contenu

  • Sélection d'un mode de rendu

  • Accès à l'aide, aux tutoriels, aux informations système et aux licences

Sujet parent Installation de SOLIDWORKS Visualize avec SLDIM


Création du dossier de contenu

Lorsque vous exécutez le logiciel pour la première fois, SOLIDWORKS Visualize vous demande un emplacement où créer un dossier de contenu.

Le dossier de contenu contient les sous-dossiers suivants, dans lesquels vous pouvez stocker les actifs de vos projets :
Sous-dossiers | Stockages
Caméras | Caméras et caméras par défaut que vous avez enregistrées
Environnements | Images High Dynamic Range (HDR)
Palettes | Fichiers de palette exportés
Images | Rendus et clichés
Apparences | Matériaux dans votre Bibliothèque d'apparences Les contenus se mettent à jour lorsque vous ajoutez une apparence à la bibliothèque.
Modèles | Fichiers de modèle Par défaut, SOLIDWORKS Visualize recherche d'abord dans ce dossier lorsque vous utilisez Fichier > Importer un modèle.
Fonds | Images 2D standard à utiliser dans les images de fond
Projets | Fichiers de projet natifs au format .SVP
Textures | Textures 2D à utiliser dans les apparences
Sujet parent Tâches de post-installation


Sélection d'un mode de rendu

Divers systèmes peuvent produire des résultats différents avec chaque mode de rendu. Essayez chaque mode de rendu avant de définir celui qui vous convient le mieux.

Pour sélectionner un mode de rendu :

  1. Cliquez sur Outils > Options > Fenêtre 3D.
  2. Sous Périphérique de rendu, décochez Automatique.
  3. Sélectionnez un mode de rendu :
    • CPU, si votre processeur est beaucoup plus puissant que votre carte graphique.
    • GPU, si vous possédez une carte graphique puissante comme une nVidia CUDA avec plus d'1 Go de VRAM.
    • Hybride, si vous possédez un système équilibré avec une bonne carte nVidia et un processeur comparable.

Pour plus d'informations, voir Pour commencer.

Sujet parent Tâches de post-installation


Accès à l'aide, aux tutoriels, aux informations système et aux licences

Le menu Aide offre de la documentation et des options pour mettre à jour le logiciel et dépanner votre système.

Aide de Visualize | Ouvre l'aide en ligne de SOLIDWORKS Visualize.
Tutoriels de Visualize | Ouvre MySolidWorks et vous permet d'accéder aux tutoriels de SOLIDWORKS Visualize.
Notes de version | Affiche les notes de version en ligne pour la version actuelle.
Nouveautés | Affiche les nouvelles fonctionnalités des produits SOLIDWORKS.
Raccourcis | Répertorie les touches de raccourci.
Informations système | Effectue une vérification du système du logiciel SOLIDWORKS Visualize avec votre matériel de PC, et suggère des mises à niveau, si nécessaire.
Activer la licence | (licences fixes) Utilise l'assistant d'activation de produit SOLIDWORKS pour activer votre produit.
Désactiver la licence | (licences fixes) Utilise l'assistant d'activation de produit SOLIDWORKS pour désactiver votre produit.
Gestionnaire de licences SolidNetWork | Utilise l'assistant d'activation de produit SOLIDWORKS pour désactiver votre produit.
A propos de Visualize | Affiche le numéro de version et les informations de licence de votre copie de SOLIDWORKS Visualize.
Sujet parent Tâches de post-installation


Installation de Visualize Boost avec SLDIM

Vous installez Visualize Boost à l'aide du Gestionnaire d'installation SOLIDWORKS. Il requiert un numéro de série distinct.

Le but de Visualize Boost étant de décharger le rendu, vous devriez installer Visualize Boost sur des ordinateurs différents de ceux exécutant SOLIDWORKS Visualize Professional. La performance de rendu ne peut pas être optimisée par l'installation de Visualize Boost sur les ordinateurs équipés de plusieurs noyaux d'unité centrale et unités de traitement graphique (GPU).

Pour installer SOLIDWORKS Visualize Boost :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Individuelle.
  3. Procédez comme suit :
    1. Sur la page Numéro de série, développez Visualization.
    2. Sélectionnez SOLIDWORKS Visualize Boost et saisissez le numéro de série.
    3. Cliquez sur Suivant.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.

Cliquez deux fois sur l'icône de raccourci SOLIDWORKS Visualize Boost sur le bureau pour ouvrir l'interface.

Table des matières

  • Activation de la licence Visualize Boost

    Vous devez activer et configurer SOLIDWORKS Visualize Boost via une interface Web pour pouvoir utiliser le produit pour le rendu. Les navigateurs Chrome, Firefox et Internet Explorer sont pris en charge.

  • Configuration de Visualize Boost

Sujet parent SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost


Activation de la licence Visualize Boost

Vous devez activer et configurer SOLIDWORKS Visualize Boost via une interface Web pour pouvoir utiliser le produit pour le rendu. Les navigateurs Chrome, Firefox et Internet Explorer sont pris en charge.

Une fois que vous avez activé et configuré Visualize Boost, il se lance automatiquement au démarrage du système et s'exécute en arrière-plan. Aucune action supplémentaire n'est requise.

Pour activer la licence SOLIDWORKS Visualize Boost :

  1. Effectuez l'une des opérations suivantes :
    1. A partir de votre bureau, cliquez deux fois sur l'icône de raccourci Visualize Boost.
    2. Ouvrez un navigateur et saisissez l'URL : http://localhost:8993/config.html.
  2. Saisissez votre adresse e-mail et cliquez sur Activer la licence.
Sujet parent Installation de Visualize Boost avec SLDIM


Configuration de Visualize Boost

Pour la plupart des réseaux, les paramètres par défaut sont suffisants pour configurer un ordinateur pour Visualize Boost. Toutefois, si votre environnement réseau nécessite d'autres paramètres, procédez comme suit pour configurer manuellement un ordinateur.

Pour configurer un ordinateur afin de l'intégrer dans un groupe de rendu dans Visualize Boost :

  1. Effectuez l'une des opérations suivantes :
    1. Si votre système exécute SOLIDWORKS Visualize Boost, double-cliquez sur l'icône de raccourci Visualize Boost sur votre bureau ou ouvrez un navigateur et saisissez l'URL : http://localhost:8993/config.html.
    2. Si vous êtes sur un autre système, ouvrez un navigateur et saisissez l'URL : http://<Adresse IP>:8993/config.html ou http://<Nom DNS>:8993/config.html.
  2. Sélectionnez votre Langue dans la liste déroulante dans le coin supérieur droit de l'écran.
  3. Cliquez sur l'onglet Installation pour configurer le nœud Visualize Boost.
  4. Dans le champ Nom du groupe, spécifiez un nom d'ordinateur, comme Rendu super-rapide, Groupe de présentation ou Ordinateurs du 4e étage.

    Le nom du groupe s'affiche dans SOLIDWORKS Visualize Professional comme profil de groupe. Pour effectuer le rendu d'une image, les utilisateurs exécutant SOLIDWORKS Visualize Professional sélectionnent un profil de groupe dans la liste des groupes Boost disponibles.

    Il est recommandé d'indiquer le nom du groupe sur l'ordinateur Visualize Boost, plutôt que localement sur l'ordinateur Visualize Professional, ainsi tous les utilisateurs Visualize ont accès aux mêmes noms de groupe dans leur liste de profils Visualize Boost.
  5. Saisissez le Port d'accès du client au groupe.
    Il s'agit du port que les ordinateurs exécutant SOLIDWORKS Visualize utilisent pour se connecter au groupe Boost. Le port d'accès du client au groupe par défaut est 8998.
  6. Dans la zone Mode réseau, sélectionnez une option en fonction de votre environnement réseau :
    • Sélectionnez Aucun réseau pour que cet ordinateur n'appartienne à aucun autre groupe. Ce mode est utile pour dépanner les problèmes avec Visualize Boost.
    • Sélectionnez Mode multidiffusion UDP si votre réseau prend en charge la multidiffusion UDP. Visualize Boost effectue une recherche sur le réseau et forme un groupe avec tous les ordinateurs clients utilisant le mode de multidiffusion UDP sur le même port. Ce mode est recommandé si votre réseau le prend en charge.
    • Sélectionnez Mode TCP avec recherche (par défaut) si vous ne pouvez pas utiliser le mode de multidiffusion UDP. Visualize Boost effectue une recherche sur le réseau et forme un groupe avec tous les ordinateurs clients utilisant le mode TCP avec recherche sur le même port.
    • Sélectionnez Mode TCP si vous avez besoin de créer une liste explicite des ordinateurs dans le groupe, car les autres modes ne parviennent pas à trouver les ordinateurs que vous voulez inclure. Ce mode nécessite une configuration supplémentaire et n'est pas recommandé si le mode de multidiffusion UDP ou le mode TCP avec recherche est disponible.
  7. Si vous sélectionnez Mode multidiffusion UDP ou Mode TCP avec recherche, saisissez l'Adresse de recherche de groupe.
    Ce paramètre doit être une adresse IP et un port supérieur à 1024. Le port par défaut varie selon les modes réseau :
    • 8994 pour la multidiffusion UDP
    • 8995 pour le mode TCP avec recherche
    • 8996 pour TCP

    Ces ports sont utilisés pour que les ordinateurs Visualize Boost se connectent entre eux. Tous les ordinateurs configurés avec la même Adresse de recherche de groupe et qui se trouvent sur le même réseau local forment un groupe.

  8. Si vous sélectionnez Mode TCP :
    • Saisissez un Port d'accès au groupe. Il s'agit du port que les nœuds Visualize Boost du groupe utilisent pour communiquer entre eux. Le port par défaut pour le mode TCP est 8996.
    • Si cet ordinateur est le « nœud de tête » du groupe (l'ordinateur qui coordonne le travail d'un groupe), utilisez le champ Liste des adresses du groupe pour répertorier la liste des adresses IP des autres nœuds du groupe. Chaque adresse IP (comme 192.168.0.100:8996) doit inclure le Port d'accès au groupe configuré pour tous les nœuds du groupe. Laissez le champ vide si cet ordinateur n'est pas le nœud de tête du groupe.
  9. Cliquez sur Enregistrer la configuration. Visualize Boost enregistre la nouvelle configuration, puis arrête et redémarre le service.
  10. Cliquez sur l'onglet Etat. Si l'état est Prêt, l'écran affiche les ordinateurs connectés dans le groupe et les Sessions (tâches) affectées au groupe.
Sujet parent Installation de Visualize Boost avec SLDIM


Portail administrateur SOLIDWORKS et licence en ligne

Le Portail administrateur SOLIDWORKS est une ressource basée sur le Cloud et un système de gestion de services qui vous permet d'affecter et de gérer les licences en ligne.

Le Portail administrateur vous permet de surveiller facilement les licences en ligne SOLIDWORKS, inviter des membres sur un compte, d'affecter des produits et services aux membres et de créer de nouveaux administrateurs. Vous pouvez également supprimer des utilisateurs des licences, même lorsque les utilisateurs se trouvent à distance.

En tant qu'utilisateur SOLIDWORKS, la licence en ligne vous donne la possibilité d'utiliser une licence SOLIDWORKS sur tous vos appareils, n'importe où, sans avoir à activer et désactiver manuellement des licences sur chaque machine. Vous devez disposer d'un accès Internet pour vous connecter et utiliser les licences en ligne, mais après vous être connecté, vous pouvez sélectionner le mode hors ligne et travailler alors que l'appareil n'est pas connecté à un réseau.

Table des matières

  • Accès au Portail administrateur

    Vous devez posséder un ID SOLIDWORKS et un compte invité, standard ou professionnel MySolidWorks pour accéder au Portail administrateur.

  • Tâches Administrateur

    Les administrateurs sont généralement responsables de la gestion des comptes utilisateur et des licences en ligne.

  • Utilisation des produits SOLIDWORKS avec la licence en ligne

  • Accès au tableau de bord CAD Admin

    Si vous disposez d'un contrat d'abonnement SOLIDWORKS, vous pouvez accéder à Tableau de bord SOLIDWORKS CAD Admin depuis le Portail administrateur sans vous reconnecter.


Accès au Portail administrateur

Vous devez posséder un ID SOLIDWORKS et un compte invité, standard ou professionnel MySolidWorks pour accéder au Portail administrateur.

Cependant, tout client commercial possédant un ID SOLIDWORKS valide, quel que soit le statut de l'abonnement, peut se connecter à MySolidWorks.com et accéder au Portail administrateur s'il est éligible.

Pour accéder au Portail administrateur :

  1. Inscrivez-vous sur MySolidWorks.com.
  2. Sous votre nom de profil, développez la liste et cliquez sur Portail Administrateur.
Sujet parent Portail administrateur SOLIDWORKS et licence en ligne
Tâches Administrateur
Utilisation des produits SOLIDWORKS avec la licence en ligne
Accès au tableau de bord CAD Admin


Tâches Administrateur

Les administrateurs sont généralement responsables de la gestion des comptes utilisateur et des licences en ligne.

Par défaut, le logiciel SOLIDWORKS est configuré pour utiliser l'activation machine. Les étapes de base pour activer la licence en ligne avec le Portail administrateur sont :
  1. Si le logiciel SOLIDWORKS est déjà installé sur une machine, désactivez manuellement la licence.
  2. Définissez un type d'activation de produit entre l'activation machine et la licence en ligne.
  3. Affectez ensuite des produits et services aux membres (utilisateurs).

Table des matières

  • Création du premier compte Administrateur

    Si vous êtes la première personne à accéder à un compte sur le Portail administrateur, vous pouvez vous nommer comme premier administrateur, à condition que :

  • Gestion des produits et services

  • Gestion des membres et des licences

  • Configuration des produits pour utiliser une licence en ligne

    Par défaut, le logiciel SOLIDWORKS est configuré pour utiliser l'activation machine. Si le logiciel SOLIDWORKS est installé sur une machine, vous devez désactiver manuellement la licence, puis modifier le type d'activation pour utiliser la licence en ligne.

  • Nomination d'un utilisateur comme Administrateur

    Si un compte possède des administrateurs, le Portail administrateur affiche les informations de contact des administrateurs. Vous pouvez les contacter et demander à être administrateur du compte.

  • Inscription de mes produits dans le Portail clients SOLIDWORKS

    Une fois qu'un administrateur a été désigné pour votre société, aucun utilisateur ne peut inscrire un produit de cette société dans le Portail clients SOLIDWORKS.

Sujet parent Portail administrateur SOLIDWORKS et licence en ligne
Accès au Portail administrateur
Utilisation des produits SOLIDWORKS avec la licence en ligne
Accès au tableau de bord CAD Admin


Création du premier compte Administrateur

Si vous êtes la première personne à accéder à un compte sur le Portail administrateur, vous pouvez vous nommer comme premier administrateur, à condition que :

  • Le compte soit votre compte principal.
  • Le compte possède des ressources.
  • Un produit soit enregistré pour le compte.

Si vous n'êtes pas associé au compte, ou si le compte ne possède pas de ressources, contactez le SOLIDWORKS Customer Center.

Pour vous affecter comme premier administrateur d'un compte :

  1. Connectez-vous à MySolidWorks.com et sous votre nom de profil, développez la liste et sélectionnez Portail administrateur.

    La page d'accueil vous informe qu'il n'existe actuellement aucun administrateur.

  2. Lisez et acceptez les termes, conditions et responsabilités liés à la gestion des affectations de licence produit SOLIDWORKS.
  3. Cliquez sur Me nommer administrateur.
Sujet parent Tâches Administrateur
Gestion des produits et services
Gestion des membres et des licences
Configuration des produits pour utiliser une licence en ligne
Nomination d'un utilisateur comme Administrateur
Inscription de mes produits dans le Portail clients SOLIDWORKS


Gestion des produits et services

Le portail administrateur inclut un onglet Produits et un onglet Services. Utilisez l'onglet Produits pour affecter et activer des produits. Utilisez l'onglet Services pour affecter des services comme des cours d'e-learning et MySolidWorks Pro aux membres.

A la différence des produits, vous ne pouvez pas transférer des services. Dès lors que vous avez affecté un service à un membre, vous ne pouvez pas le supprimer pour ce membre.

La gestion des produits est facultative pour les produits avec activation de l'ordinateur, y compris les produits avec licence réseau.

Vous pouvez choisir de nommer vos membres et de leur affecter des produits afin d'acquérir les avantages suivants :
  • Vos membres peuvent utiliser la fonction de connexion dans le Gestionnaire d'installation afin d'installer les numéros de série qui leur sont affectés.
  • L'affectation de produits sur abonnement à vos membres permettra à ces derniers d'accéder au contenu sur abonnement en ligne.

Vous n'avez cependant pas besoin de nommer vos membres et de leur affecter des produits dans le cas de produit avec activation de l'ordinateur. L'accès aux produits avec activation de l'ordinateur est bloqué par un serveur de licence ou des événements d'activation, quelle que soit l'affectation sur le portail administrateur. Dans les organisations plus importantes, vous ne gérerez probablement pas tous les membres et leurs produits.

La gestion des produits est requise pour les licences en ligne. De la même façon, les services doivent être affectés aux membres nommés.

Sujet parent Tâches Administrateur
Création du premier compte Administrateur
Gestion des membres et des licences
Configuration des produits pour utiliser une licence en ligne
Nomination d'un utilisateur comme Administrateur
Inscription de mes produits dans le Portail clients SOLIDWORKS


Gestion des membres et des licences

Table des matières

  • Invitation de nouveaux membres sur un compte

    Les administrateurs peuvent inviter de nouveaux membres à rejoindre un compte.

  • Suppression de membres des comptes

    Avant de supprimer un membre, les administrateurs doivent d'abord supprimer tous les produits affectés au compte du membre.

  • Affectation de produits aux membres

    Les administrateurs ne peuvent affecter un membre qu'à un seul produit par type de produit. Par exemple, un seul produit CAD et un seul produit Simulation peuvent être affectés à un membre.

  • Affectation de membres à des produits

  • Affectation de services aux membres

  • Suppression de licences pour les membres

    Vous pouvez supprimer des produits pour un membre.

  • Recherche de membres et vérification des droits d'utilisateur et des produits affectés

    Le Portail administrateur offre plusieurs méthodes pour trouver un utilisateur et pour surveiller les droits d'utilisateur et les produits affectés.

  • Recherche de produits et vérification des utilisateurs qui y sont affectés

    Le Portail administrateur offre plusieurs méthodes pour trouver des produits et pour surveiller les utilisateurs affectés à ces produits affectés.

  • Retrait de produits de membres externes

    Les membres externes sont des personnes extérieures à votre organisation et qui ont enregistré un de vos produits. Le portail administrateur vous permet de les identifier et de les retirer de votre produit.

  • Utilisation du menu Engrenage pour les requêtes

    Le menu Engrenage contient des commandes pour créer et affiner des requêtes.

Sujet parent Tâches Administrateur
Création du premier compte Administrateur
Gestion des produits et services
Configuration des produits pour utiliser une licence en ligne
Nomination d'un utilisateur comme Administrateur
Inscription de mes produits dans le Portail clients SOLIDWORKS


Invitation de nouveaux membres sur un compte

Les administrateurs peuvent inviter de nouveaux membres à rejoindre un compte.

Pour inviter de nouveaux membres :

  1. Cliquez sur l'onglet Membres.
  2. Cliquez sur Inviter le membre.
  3. Saisissez les Adresses e-mail des membres à inviter.
    Vous pouvez inviter plusieurs utilisateurs avec un seul e-mail en saisissant leurs adresses dans le champ prévu à cet effet, séparées par des points-virgules (;).
  4. Sélectionnez Membre ou Administrateur pour le niveau de Droits d'utilisateur.
  5. Modifiez le texte de l'invitation si nécessaire et cliquez sur Envoyer des invitations.
Sujet parent Gestion des membres et des licences
Suppression de membres des comptes
Affectation de produits aux membres
Affectation de membres à des produits
Affectation de services aux membres
Suppression de licences pour les membres
Recherche de membres et vérification des droits d'utilisateur et des produits affectés
Recherche de produits et vérification des utilisateurs qui y sont affectés
Retrait de produits de membres externes
Utilisation du menu Engrenage pour les requêtes


Suppression de membres des comptes

Avant de supprimer un membre, les administrateurs doivent d'abord supprimer tous les produits affectés au compte du membre.

Pour supprimer un membre d'un compte :

  1. Cliquez sur l'onglet Membres.
  2. Sélectionnez un nom en cliquant sur une ligne dans la liste Membres.

    Utilisez les commandes de navigation en bas pour avancer ou revenir en arrière dans l'ensemble des enregistrements. Vous pouvez également utiliser le volet Trouver des membres pour rechercher un membre.

  3. Dans la page Détails du membre, supprimez tous les produits de la liste Produits affectés en cliquant sur Supprimer un produit.
  4. Sous Détails du membre, cliquez sur Supprimer un membre et cliquez sur OK pour confirmer.
Sujet parent Gestion des membres et des licences
Invitation de nouveaux membres sur un compte
Affectation de produits aux membres
Affectation de membres à des produits
Affectation de services aux membres
Suppression de licences pour les membres
Recherche de membres et vérification des droits d'utilisateur et des produits affectés
Recherche de produits et vérification des utilisateurs qui y sont affectés
Retrait de produits de membres externes
Utilisation du menu Engrenage pour les requêtes


Affectation de produits aux membres

Les administrateurs ne peuvent affecter un membre qu'à un seul produit par type de produit. Par exemple, un seul produit CAD et un seul produit Simulation peuvent être affectés à un membre.

Vous ne pouvez pas affecter des produits aux membres en attente.

Pour affecter un produit à un membre :

  1. Cliquez sur l'onglet Membres.
  2. Sélectionnez un nom en cliquant sur une ligne dans la liste Membres.

    Utilisez les commandes de navigation en bas de la liste pour avancer ou revenir en arrière dans l'ensemble des enregistrements. Vous pouvez également utiliser le volet Trouver des membres pour rechercher un membre.

    La page Détails du membre répertorie les Produits affectés et les Produits disponibles qui ne sont pas affectés.

  3. Sélectionnez un produit sous Produits disponibles.

    Vous pouvez affecter un seul produit à la fois à un membre. Le premier élément de la liste est sélectionné par défaut. Si le produit que vous voulez affecter n'est pas le premier de la liste, décochez cet élément et sélectionnez l'élément approprié.

    Vous pouvez appliquer plusieurs facteurs de filtre pour afficher uniquement les produits :
    • Avec un abonnement actuel ou expiré
    • Qui sont ou non affectés
    • Qui sont ou non activés, ou activés pour la licence en ligne
    • Qui appartiennent à un ou plusieurs types de produits
    Vous pouvez également appliquer un filtre de nom de produit ou de numéro de série.

    Si vous sélectionnez un nom de produit, la page Détails du produit s'affiche. Dans le navigateur, appuyez sur Précédent pour revenir à la page Détails du membre.

  4. Cliquez sur Affecter un produit.

    La Portail administrateur ajoute le produit à la liste Produits affectés du membre.

    Vous pouvez également affecter des membres à des produits à partir de la page Détails du produit.
Sujet parent Gestion des membres et des licences
Invitation de nouveaux membres sur un compte
Suppression de membres des comptes
Affectation de membres à des produits
Affectation de services aux membres
Suppression de licences pour les membres
Recherche de membres et vérification des droits d'utilisateur et des produits affectés
Recherche de produits et vérification des utilisateurs qui y sont affectés
Retrait de produits de membres externes
Utilisation du menu Engrenage pour les requêtes


Affectation de membres à des produits

Pour affecter un membre à un produit :

  1. Cliquez sur l'onglet Produits.

    La page Détails du produit répertorie les membres disponibles qui ne sont pas affectés au produit.

  2. Sélectionnez un produit sous Produits disponibles.
  3. Pour rechercher un membre, vous pouvez filtrer les membres disponibles à partir du prénom, du nom, de l'adresse e-mail et du type de produit.
  4. Cliquez sur Affecter un membre.

Vous pouvez également affecter des produits à des membres depuis la section Produits affectés de l'onglet Membres.

Sujet parent Gestion des membres et des licences
Invitation de nouveaux membres sur un compte
Suppression de membres des comptes
Affectation de produits aux membres
Affectation de services aux membres
Suppression de licences pour les membres
Recherche de membres et vérification des droits d'utilisateur et des produits affectés
Recherche de produits et vérification des utilisateurs qui y sont affectés
Retrait de produits de membres externes
Utilisation du menu Engrenage pour les requêtes


Affectation de services aux membres

Les administrateurs peuvent affecter des services aux membres. Exemples de services : MySolidWorks Professional et les cours d'e-learning. A la différence des produits, vous ne pouvez pas transférer des services. Après avoir affecté un service à un membre, vous ne pouvez pas le supprimer pour ce membre.

Pour affecter des services aux membres :

  1. Cliquez sur l'onglet Membres.
  2. Recherchez un membre dans le volet Trouver des membres ou cliquez sur un nom d'utilisateur dans la liste.
  3. Dans la page du membre, sous Détails du membre, cliquez sur Services.

    L'onglet Services répertorie les services associés au membre et les Services disponibles qui ne sont pas affectés.

  4. Sélectionnez un service sous Services disponibles.

    Vous pouvez affecter un seul service à la fois à un membre. Le premier élément de la liste est sélectionné par défaut. Si le service que vous voulez affecter n'est pas le premier de la liste, désactivez cet élément et sélectionnez l'élément approprié.

    Vous pouvez appliquer plusieurs facteurs de filtre pour afficher uniquement les services :
    • Avec un abonnement en cours ou expiré.
    • Qui sont ou non affectés.
    Vous pouvez également appliquer un filtre de nom de service ou de numéro de série.

    Si vous sélectionnez un nom de service, la page Détails du service s'affiche. Dans le navigateur, cliquez sur Précédent pour revenir à la page Détails du membre.

  5. Cliquez sur Affecter un service.

La Portail administrateur ajoute le produit à la liste Services du membre.

Sujet parent Gestion des membres et des licences
Invitation de nouveaux membres sur un compte
Suppression de membres des comptes
Affectation de produits aux membres
Affectation de membres à des produits
Suppression de licences pour les membres
Recherche de membres et vérification des droits d'utilisateur et des produits affectés
Recherche de produits et vérification des utilisateurs qui y sont affectés
Retrait de produits de membres externes
Utilisation du menu Engrenage pour les requêtes


Suppression de licences pour les membres

Vous pouvez supprimer des produits pour un membre.

Pour retirer un produit à un membre :

  1. Cliquez sur l'onglet Membres.
  2. Recherchez un membre dans le volet Trouver des membres ou cliquez sur le nom dans la liste.

    Dans la page Membre, les Produits affectés répertorient tous les produits associés au membre et les Produits disponibles répertorient les produits qui ne sont pas affectés.

  3. Sélectionnez le produit sous Produits affectés et cliquez sur Supprimer un produit.
  4. Cliquez sur OK pour confirmer.

    La Portail administrateur ajoute le produit à la liste Produits disponibles du membre.

Si un membre utilise des produits en mode hors ligne, vous ne pouvez pas récupérer et réaffecter ses licences tant que le membre active le Mode Hors ligne ou que la période hors ligne de 30 jours n'a pas expiré.
Sujet parent Gestion des membres et des licences
Invitation de nouveaux membres sur un compte
Suppression de membres des comptes
Affectation de produits aux membres
Affectation de membres à des produits
Affectation de services aux membres
Recherche de membres et vérification des droits d'utilisateur et des produits affectés
Recherche de produits et vérification des utilisateurs qui y sont affectés
Retrait de produits de membres externes
Utilisation du menu Engrenage pour les requêtes


Recherche de membres et vérification des droits d'utilisateur et des produits affectés

Le Portail administrateur offre plusieurs méthodes pour trouver un utilisateur et pour surveiller les droits d'utilisateur et les produits affectés.

Pour rechercher un membre, et pour vérifier les droits d'utilisateur et les produits affectés :

  1. Cliquez sur l'onglet Membres.
  2. Dans le volet Trouver des membres, vous pouvez filtrer en fonction des droits d'utilisateur et des produits affectés :
    • Sélectionnez Administrateur, Membre ou En attente pour restreindre la recherche aux utilisateurs avec ce statut.
    • Sélectionnez un ou plusieurs types de produit pour restreindre la recherche aux utilisateurs affectés aux produits sélectionnés.
  3. Pour vérifier les droits et les produits attribués à un utilisateur spécifique, sélectionnez un nom sous Membres.

    Vous pouvez afficher le niveau de droits d'un utilisateur spécifique dans Détails du membre. La même page répertorie les produits affectés associés à l'utilisateur et les produits disponibles qui peuvent être affectés.

Sujet parent Gestion des membres et des licences
Invitation de nouveaux membres sur un compte
Suppression de membres des comptes
Affectation de produits aux membres
Affectation de membres à des produits
Affectation de services aux membres
Suppression de licences pour les membres
Recherche de produits et vérification des utilisateurs qui y sont affectés
Retrait de produits de membres externes
Utilisation du menu Engrenage pour les requêtes


Recherche de produits et vérification des utilisateurs qui y sont affectés

Le Portail administrateur offre plusieurs méthodes pour trouver des produits et pour surveiller les utilisateurs affectés à ces produits affectés.

Pour rechercher un produit :

  1. Cliquez sur l'onglet Produits.
  2. Dans le volet trouver des produits, saisissez le nom du produit.
  3. Vous pouvez filtrer en fonction de plusieurs facteurs pour afficher uniquement les produits :
    • Avec un abonnement actuel ou expiré
    • Qui sont ou non affectés
    • Qui sont ou non activés pour la licence en ligne
    • Qui appartiennent à un ou plusieurs types de produit
    Vous pouvez également filtrer selon un numéro de série.
  4. Cliquez sur Rechercher.
  5. Pour vérifier les utilisateurs affectés à un produit, sélectionnez un nom de produit sous Produits.
    La page Détails du produit répertorie tous les membres qui sont affectés à ce produit.
Sujet parent Gestion des membres et des licences
Invitation de nouveaux membres sur un compte
Suppression de membres des comptes
Affectation de produits aux membres
Affectation de membres à des produits
Affectation de services aux membres
Suppression de licences pour les membres
Recherche de membres et vérification des droits d'utilisateur et des produits affectés
Retrait de produits de membres externes
Utilisation du menu Engrenage pour les requêtes


Retrait de produits de membres externes

Les membres externes sont des personnes extérieures à votre organisation et qui ont enregistré un de vos produits. Le portail administrateur vous permet de les identifier et de les retirer de votre produit.

Pour retirer des produits à des membres externes :

  1. Cliquez sur l'onglet Produits.
  2. Dans le volet Trouver des produits, saisissez le nom du produit ou les critères de recherche.
  3. Cliquez sur Rechercher.
  4. Sélectionnez le nom du produit.
    La page Détails du produit répertorie tous les membres qui sont affectés à ce produit.
  5. Dans la liste des Membres externes affectés, sélectionnez le membre externe et cliquez sur Supprimer un membre.
Sujet parent Gestion des membres et des licences
Invitation de nouveaux membres sur un compte
Suppression de membres des comptes
Affectation de produits aux membres
Affectation de membres à des produits
Affectation de services aux membres
Suppression de licences pour les membres
Recherche de membres et vérification des droits d'utilisateur et des produits affectés
Recherche de produits et vérification des utilisateurs qui y sont affectés
Utilisation du menu Engrenage pour les requêtes


Utilisation du menu Engrenage pour les requêtes

Le menu Engrenage contient des commandes pour créer et affiner des requêtes.

Commande | Raccourci clavier | Description
Nouvelle requête | Alt + Q | Crée une requête en saisissant du texte dans un ou plusieurs champs sur la page Membres, comme Prénom, Nom, Droits d'utilisateur, E-mail et Produits affectés, et sur les pages Produits, comme Nom du produit, Type de produit, Numéro de série, Activé, Affecté et Expiration.
Exécuter une requête | Alt + Entrée | Exécute la requête.
Affiner la requête | Alt + G | Modifie et ajoute du texte dans les champs de requête.
Colonnes affichées | Ctrl + Maj + K | Sélectionne les colonnes à afficher sur les pages de membres et de produits.
Exporter |  | Exporte les résultats de la requête. Vous pouvez exporter toutes les lignes ou uniquement la ligne actuelle de la colonne, et exporter toutes les colonnes ou seulement les colonnes visibles. Vous pouvez exporter les résultats sous forme de fichier texte délimité par des tabulations, fichier texte délimité par des virgules, fichier HTML ou fichier texte avec un délimiteur que vous spécifiez.
Tri avancé |  | Trie les résultats de la requête selon trois colonnes au maximum.
Sujet parent Gestion des membres et des licences
Invitation de nouveaux membres sur un compte
Suppression de membres des comptes
Affectation de produits aux membres
Affectation de membres à des produits
Affectation de services aux membres
Suppression de licences pour les membres
Recherche de membres et vérification des droits d'utilisateur et des produits affectés
Recherche de produits et vérification des utilisateurs qui y sont affectés
Retrait de produits de membres externes


Configuration des produits pour utiliser une licence en ligne

Par défaut, le logiciel SOLIDWORKS est configuré pour utiliser l'activation machine. Si le logiciel SOLIDWORKS est installé sur une machine, vous devez désactiver manuellement la licence, puis modifier le type d'activation pour utiliser la licence en ligne.

Sujet parent Tâches Administrateur
Création du premier compte Administrateur
Gestion des produits et services
Gestion des membres et des licences
Nomination d'un utilisateur comme Administrateur
Inscription de mes produits dans le Portail clients SOLIDWORKS

Désactivation des licences installées dans SOLIDWORKS

Avant d'utiliser une licence en ligne, vous devez vérifier qu'un produit identique n'est pas installé sur la machine. S'il est installé, vous devez désactiver la licence du produit installé avant de configurer la licence en ligne avec le Portail administrateur.

Pour désactiver une licence :

  • Dans le logiciel SOLIDWORKS, cliquez sur Aide > Licences > Désactiver et suivez les instructions qui s'affichent.
Vous pouvez posséder une combinaison de licences en ligne et de licences SolidNetWork sur la même machine. Par exemple, la même machine peut exécuter SOLIDWORKS Premium 2020 avec une licence en ligne et SOLIDWORKS Simulation Premium 2020 avec une licence SolidNetWork.

Modification du type d'activation pour la licence en ligne

Pour pouvoir utiliser la licence en ligne avec un produit, vous devez modifier son type d'activation de l'activation machine à la licence en ligne.

Vous pouvez modifier le type d'activation d'une licence avant ou après son affectation à un membre. Vous ne pouvez pas modifier le type d'activation d'une licence si celle-ci est activée ou si le produit est affecté à plusieurs membres. Si une licence est activée via l'activation machine, elle ne peut pas être désactivée à distance ; un utilisateur sur la machine doit désactiver cette licence.

Pour remplacer le type d'activation par la licence en ligne :

  1. Si le produit est affecté à un membre :
    1. Cliquez sur l'onglet Membres et sélectionnez un membre dans la liste.
    2. Sous Produits affectés, cliquez sur le produit que vous devez modifier.
    3. Dans Détails du produit, sous Type d'activation, cliquez sur Remplacer par la licence en ligne.
    4. Cliquez sur Modifier pour confirmer ou Annuler.
  2. Si le produit n'est pas affecté à un membre :
    1. Cliquez sur l'onglet produits et sélectionnez un produit dans la liste.

      Vous pouvez utiliser le volet Trouver des produits pour demander le produit.

  3. Dans Détails du produit, sous Type d'activation, cliquez sur Remplacer par la licence en ligne.
  4. Cliquez sur Modifier pour confirmer ou Annuler.
  5. Affectez un produit à un membre.
Lorsque vous affectez une licence en ligne, ce produit peut être utilisé par ce membre uniquement. Cependant, l'affectation d'un produit avec une activation machine à un membre n'est effectuée qu'à des fins de suivi. Toute personne installée sur la machine désignée peut utiliser le produit. Dans ce cas, vous devrez peut-être vérifier que la personne utilisant la machine est le membre qui est supposé disposer de cette licence.


Nomination d'un utilisateur comme Administrateur

Si un compte possède des administrateurs, le Portail administrateur affiche les informations de contact des administrateurs. Vous pouvez les contacter et demander à être administrateur du compte.

Si vous êtes administrateur, vous pouvez nommer d'autres utilisateurs du compte comme administrateurs.

Pour nommer un utilisateur comme administrateur :

  1. Cliquez sur l'onglet Membres.
  2. Dans la liste de noms, sélectionnez un utilisateur.

    Si vous avez des difficultés à trouver un utilisateur, vous pouvez interroger le Portail administrateur en saisissant des critères de recherche dans le volet Trouver des membres.

  3. Dans la page Détails du membre, sous Droits d'utilisateur, cliquez sur Changer en administrateur.
  4. Cliquez ensuite sur Modifier pour confirmer ou Annuler.
  5. Un e-mail invitant l'utilisateur à devenir administrateur s'affiche. Cliquez sur Envoyer.

Les droits d'utilisateur s'affichent En attente une fois l'invitation envoyée. Une fois l'invitation acceptée, les droits d'utilisateur passent à Admin.

Vous pouvez rétrograder un administrateur en utilisateur en sélectionnant Changer en Membre.
Sujet parent Tâches Administrateur
Création du premier compte Administrateur
Gestion des produits et services
Gestion des membres et des licences
Configuration des produits pour utiliser une licence en ligne
Inscription de mes produits dans le Portail clients SOLIDWORKS


Inscription de mes produits dans le Portail clients SOLIDWORKS

Une fois qu'un administrateur a été désigné pour votre société, aucun utilisateur ne peut inscrire un produit de cette société dans le Portail clients SOLIDWORKS.

L'inscription est refusée à l'utilisateur, et un e-mail est envoyé aux administrateurs nommés de la société avec les coordonnées du demandeur et le numéro de série demandé. En tant qu'administrateur, vous pouvez décider d'affecter ou non les produits au demandeur pour leur compte.
L'affectation d'un produit et l'inscription d'un produit donnent le même statut.

Si le demandeur est déjà membre de votre compte, vous pouvez affecter le produit demandé ou un produit équivalent pour leur compte.

Si le demandeur n'est pas encore membre du compte, l'administrateur peut inviter le demandeur en tant que membre et terminer l'affectation par la suite.

Sujet parent Tâches Administrateur
Création du premier compte Administrateur
Gestion des produits et services
Gestion des membres et des licences
Configuration des produits pour utiliser une licence en ligne
Nomination d'un utilisateur comme Administrateur


Utilisation des produits SOLIDWORKS avec la licence en ligne

La licence en ligne SOLIDWORKS vous donne la possibilité d'utiliser une licence sur tous vos appareils, n'importe où, sans avoir à activer et désactiver manuellement des licences sur chaque machine.

Par exemple, vous pouvez travailler sur une machine au bureau pendant la journée, puis rentrer chez vous et vous connecter au même produit depuis votre ordinateur personnel. Vous n'avez pas besoin d'une deuxième licence pour le produit. Vous n'avez pas besoin de désactiver manuellement une licence sur l'ordinateur du bureau, puis l'activer à nouveau sur votre ordinateur personnel.

Vous devez accéder à Internet pour vous connecter et utiliser les licences en ligne. Après vous être connecté, vous pouvez sélectionner le mode hors ligne et travailler alors que la machine n'est pas connectée à un réseau.

En outre, vous pouvez synchroniser les options SOLIDWORKS sur plusieurs machines et accéder aux sites Web SOLIDWORKS comme MySolidWorks.com et le Portail client SOLIDWORKS sans vous reconnecter.

Table des matières

  • Connexion à un produit SOLIDWORKS avec une licence en ligne

    Après avoir installé un produit SOLIDWORKS avec une licence en ligne, vous pouvez vous connecter sur n'importe quelle machine. Vous n'avez pas besoin de réinstaller le produit pour l'utiliser sur une autre machine.

  • Utilisation d'un produit SOLIDWORKS en mode hors ligne

    Lorsque vous utilisez un produit SOLIDWORKS avec une licence en ligne, vous pouvez spécifier le mode hors ligne lorsque vous n'avez pas de connexion Internet.

  • Changement de machines lorsque les licences en ligne sont utilisées

    La licence en ligne vous donne la possibilité d'utiliser une licence sur toutes vos machines. Cependant, la licence peut être utilisée sur une machine à la fois uniquement.

  • Synchronisation des paramètres et des options sur plusieurs ordinateurs

    Si vous utilisez le logiciel SOLIDWORKS sur plusieurs ordinateurs, vous pouvez mettre à jour vos paramètres et les synchroniser sur l'ensemble de vos ordinateurs qui exécutent SOLIDWORKS 2018 et versions ultérieures.

  • Notification du produit SOLIDWORKS pour utiliser les licences en ligne

Sujet parent Portail administrateur SOLIDWORKS et licence en ligne
Accès au Portail administrateur
Tâches Administrateur
Accès au tableau de bord CAD Admin


Connexion à un produit SOLIDWORKS avec une licence en ligne

Après avoir installé un produit SOLIDWORKS avec une licence en ligne, vous pouvez vous connecter sur n'importe quelle machine. Vous n'avez pas besoin de réinstaller le produit pour l'utiliser sur une autre machine.

Pour se connecter à un produit SOLIDWORKS avec une licence en ligne :

  1. Cliquez sur SOLIDWORKS [image] sur votre bureau.
  2. Saisissez votre ID SOLIDWORKS et votre mot de passe, puis cliquez sur Connecter.
    L'ID SOLIDWORKS peut être votre adresse électronique.

Le produit SOLIDWORKS démarre si vous saisissez un ID SOLIDWORKS et un mot de passe valide, et si une licence valide pour ce produit vous a été affectée par votre administrateur SOLIDWORKS.

Vous pouvez fermer et redémarrer le produit SOLIDWORKS sur la même machine sans avoir à saisir à nouveau les identifiants, jusqu'à ce vous vous déconnectiez.

Sujet parent Utilisation des produits SOLIDWORKS avec la licence en ligne
Utilisation d'un produit SOLIDWORKS en mode hors ligne
Changement de machines lorsque les licences en ligne sont utilisées
Synchronisation des paramètres et des options sur plusieurs ordinateurs
Notification du produit SOLIDWORKS pour utiliser les licences en ligne


Utilisation d'un produit SOLIDWORKS en mode hors ligne

Lorsque vous utilisez un produit SOLIDWORKS avec une licence en ligne, vous pouvez spécifier le mode hors ligne lorsque vous n'avez pas de connexion Internet.

Pour travailler en mode hors ligne :

  • Dans la barre de titre SOLIDWORKS, cliquez à l'aide du bouton droit sur Connecter [image] et cliquez sur Mettre la licence hors ligne.

Vous pouvez utiliser le produit SOLIDWORKS pendant 30 jours sans vous reconnecter à un site Web SOLIDWORKS. Après 30 jours, vous devez à nouveau cliquer sur Mettre la licence hors ligne pour continuer à travailler en mode hors ligne.

Lorsque vous utilisez une licence en ligne en mode hors ligne sur une machine, vous ne pouvez pas utiliser cette licence sur les autres machines.
Sujet parent Utilisation des produits SOLIDWORKS avec la licence en ligne
Connexion à un produit SOLIDWORKS avec une licence en ligne
Changement de machines lorsque les licences en ligne sont utilisées
Synchronisation des paramètres et des options sur plusieurs ordinateurs
Notification du produit SOLIDWORKS pour utiliser les licences en ligne


Changement de machines lorsque les licences en ligne sont utilisées

La licence en ligne vous donne la possibilité d'utiliser une licence sur toutes vos machines. Cependant, la licence peut être utilisée sur une machine à la fois uniquement.

Vous exécutez le logiciel SOLIDWORKS sur votre machine principale sans vous déconnecter. Lorsque vous essayez de vous connecter sur une deuxième machine (par exemple, un ordinateur chez vous), le logiciel propose de récupérer votre licence de la machine principale.

Pour démarrer le logiciel SOLIDWORKS sur une deuxième machine :

  1. Lorsque vous vous connectez à la deuxième machine, le logiciel SOLIDWORKS vous informe qu'un produit avec licence en ligne est utilisé sur une autre machine. Cliquez sur Oui pour continuer.

    Le produit SOLIDWORKS s'exécute sur la deuxième machine.

  2. Lorsque vous revenez sur la machine principale, vous êtes invité à enregistrer votre travail avant que le logiciel SOLIDWORKS ne se ferme. Cliquez sur OK pour enregistrer les modifications apportées à votre modèle.
Sujet parent Utilisation des produits SOLIDWORKS avec la licence en ligne
Connexion à un produit SOLIDWORKS avec une licence en ligne
Utilisation d'un produit SOLIDWORKS en mode hors ligne
Synchronisation des paramètres et des options sur plusieurs ordinateurs
Notification du produit SOLIDWORKS pour utiliser les licences en ligne


Synchronisation des paramètres et des options sur plusieurs ordinateurs

Si vous utilisez le logiciel SOLIDWORKS sur plusieurs ordinateurs, vous pouvez mettre à jour vos paramètres et les synchroniser sur l'ensemble de vos ordinateurs qui exécutent SOLIDWORKS 2018 et versions ultérieures.

La synchronisation des paramètres est un service qui peut être bloqué par certaines configurations de réseau. Pour accéder au service de stockage cloud, assurez-vous que les serveurs proxy ou pare-feu autorisent les communications vers *.solidworks.com.

Pour synchroniser les paramètres et les options sur plusieurs ordinateurs :

  1. Connectez-vous au logiciel SOLIDWORKS.
  2. Dans Outils > Options, cliquez sur Synchroniser les paramètres.
  3. Choisissez une méthode manuelle ou automatique :
    • Synchroniser maintenant.

      Charger les paramètres. Permet d'envoyer vos paramètres de la machine actuelle vers le service de stockage cloud. Mettez à jour vos paramètres dans le cloud à tout moment en les chargeant à nouveau.

      Télécharger les paramètres. Permet de télécharger et d'appliquer vos paramètres depuis le service de stockage cloud sur votre machine actuelle.

    • Synchronisation automatique.

      Permet de synchroniser automatiquement les machines actuelles avec le service de stockage cloud. Les paramètres et les personnalisations sélectionnés sont automatiquement chargés vers les services de stockage cloud lorsqu'ils sont mis à jour, puis ils sont téléchargés et appliqués lors du démarrage ou de la connexion.

    Les paramètres de synchronisation peuvent varier d'un ordinateur à l'autre. Par exemple, vous pouvez spécifier un ordinateur pour synchroniser automatiquement les options système et les emplacements de fichiers, mais pas les personnalisations. Sur une autre machine, vous pouvez spécifier de télécharger et charger manuellement tous les types de paramètres.

    Avec le processus de synchronisation, vous ne pouvez pas passer outre les paramètres d'administrateur qui sont appliqués ou verrouillés.
  4. Cliquez sur OK.
Sujet parent Utilisation des produits SOLIDWORKS avec la licence en ligne
Connexion à un produit SOLIDWORKS avec une licence en ligne
Utilisation d'un produit SOLIDWORKS en mode hors ligne
Changement de machines lorsque les licences en ligne sont utilisées
Notification du produit SOLIDWORKS pour utiliser les licences en ligne


Notification du produit SOLIDWORKS pour utiliser les licences en ligne

Il existe deux façons de notifier le produit SOLIDWORKS que vous basculez sur une licence en ligne :
  • Lorsque vous vous connectez à un produit SOLIDWORKS, un message vous informe que le numéro de série que vous avez saisi est réinitialisé pour une licence en ligne. Redémarrez le produit et connectez-vous.
  • Votre administrateur peut indiquer au produit d'utiliser la licence en ligne au lieu d'un numéro de série via l'Editeur d'options du Gestionnaire d'images administratives. Chaque produit installé de cette manière vous invite à vous connecter lorsque vous exécutez le logiciel.
Sujet parent Utilisation des produits SOLIDWORKS avec la licence en ligne
Connexion à un produit SOLIDWORKS avec une licence en ligne
Utilisation d'un produit SOLIDWORKS en mode hors ligne
Changement de machines lorsque les licences en ligne sont utilisées
Synchronisation des paramètres et des options sur plusieurs ordinateurs


Accès au tableau de bord CAD Admin

Si vous disposez d'un contrat d'abonnement SOLIDWORKS, vous pouvez accéder à Tableau de bord SOLIDWORKS CAD Admin depuis le Portail administrateur sans vous reconnecter.

Sur le tableau de bord CAD Admin, vous pouvez effectuer des tâches comme surveiller les performances, surveiller les statistiques de session et afficher les détails des machines de votre réseau qui exécutent le logiciel SOLIDWORKS.

Pour plus d'informations, voir l'Aide dans le tableau de bord CAD Admin.

Sujet parent Portail administrateur SOLIDWORKS et licence en ligne
Accès au Portail administrateur
Tâches Administrateur
Utilisation des produits SOLIDWORKS avec la licence en ligne


Administration des licences

Après l'installation, vous pouvez activer les licences SOLIDWORKS de différentes manières : en activant les ordinateurs individuels (activation d'ordinateur), en installant et en activant des licences réseau flottantes sur un serveur (Gestion des licences SolidNetWork) ou en vous connectant à vos applications SOLIDWORKS (gestion des licences en ligne).

En général, l'activation de licence est utilisée pour les installations sur des ordinateurs individuels; vous pouvez cependant installer le logiciel individuellement, puis contrôler les licences avec SolidNetWork License Manager. A l'inverse, même si les sites plus grands utilisent généralement des licences réseau flottantes, vous pouvez déployer des installations à partir d'une image administrative, puis activer les numéros de série à partir d'ordinateurs individuels.

Table des matières

  • Administrer les licences individuelles

    Vous pouvez définir une licence individuelle pour utiliser l'activation de l'ordinateur ou la licence en ligne. Cette section traite de l'activation de l'ordinateur. Pour en savoir plus sur la licence en ligne, rendez-vous sur le Portail administrateur.

  • Administrer des licences avec SolidNetWork License Manager

    SolidNetWork License Manager prend en charge les clients de licence multiples en distribuant les licences aux clients du réseau. Le nombre d'utilisateurs peut ainsi dépasser le nombre de licences en utilisant des licences flottantes.


Administrer les licences individuelles

Vous pouvez définir une licence individuelle pour utiliser l'activation de l'ordinateur ou la licence en ligne. Cette section traite de l'activation de l'ordinateur. Pour en savoir plus sur la licence en ligne, rendez-vous sur le Portail administrateur.

En règle générale, l'administration des licences individuelles consiste à activer et désactiver des licences directement depuis le logiciel SOLIDWORKS.

L'activation est une procédure d'enregistrement et de validation des licences SOLIDWORKS autonomes (autres que la licence SolidNetWork). En général, si votre licence de produit n'est pas activée, SOLIDWORKS tente de l'activer lorsque vous démarrez le produit.

Vous pouvez désactiver les licences individuelles en cliquant sur Aide > Licences > Désactiver dans le logiciel SOLIDWORKS.

Sujet parent Administration des licences
Administrer des licences avec SolidNetWork License Manager

Activer une licence

Avant de pouvoir exécuter les produits SOLIDWORKS sur un ordinateur individuel, vous devez activer la licence pour cet ordinateur.

Pour procéder à l'activation, vous devez avoir accès à Internet ou à la messagerie électronique. Après l'activation, vous n'avez pas besoin d'être en ligne pour utiliser les produits. Si vous n'avez pas accès à la messagerie électronique sur l'ordinateur sur lequel vous utilisez ce produit, vous pouvez enregistrer le fichier d'activation et l'envoyer à partir d'un autre ordinateur.

Cette procédure:
  • Active toutes les licences de la gamme de produits SOLIDWORKS.
  • Vous permet de transférer les droits de licence d'un ordinateur à l'autre.
  • Peut être réalisée immédiatement (action recommandée) ou dans les 30 jours suivant l'installation.
  • Permet de se passer de dongles. Cependant, si vous exécutez des versions précédentes des produits SOLIDWORKS qui n'ont pas recours à l'activation, vous devez utiliser un dongle.

Pour les administrateurs système qui ont plusieurs numéros de série à gérer, il est possible d'utiliser l'Editeur d'options du Gestionnaire d'images administratives. Pour plus de détails, reportez-vous à Editeur d'options du Gestionnaire d'images administratives.

Pour activer une licence:

  1. Démarrez le logiciel SOLIDWORKS.
  2. Démarrez l'Activation de produit SOLIDWORKS à l'aide d'une des méthodes suivantes :
    • Si vous n'avez pas encore activé la licence pour cet ordinateur, la fenêtre Activation de produit SOLIDWORKS s'affiche automatiquement quand vous démarrez le logiciel SOLIDWORKS.
    • Si la fenêtre Activation de produit SOLIDWORKS ne s'affiche pas automatiquement, lancez l'activation en cliquant sur Aide > Licences > Activer.
  3. Cliquez dans la liste Produit pour spécifier le produit dont vous souhaitez activer la licence.
  4. Spécifiez l'activation automatique par Internet ou l'activation manuelle par la messagerie électronique.
  5. Fournissez les informations de contact par courrier électronique.
  6. Cliquez sur Suivant.
    • Par Internet: L'activation a lieu automatiquement.
    • Courriel : Cliquez sur Enregistrer pour créer un fichier de requête, puis envoyez le fichier à activation@solidworks.com. Lorsque vous recevez l'e-mail contenant le fichier de réponse, extrayez ce dernier de l'e-mail et cliquez sur Ouvrir pour le charger.
      Si nécessaire, quittez la procédure d'activation et exécutez-la de nouveau pour ouvrir le fichier de réponse.
  7. Cliquez sur Terminer.
Editeur d'options du Gestionnaire d'images administratives

Transférer une licence

Pour transférer votre licence sur un nouvel ordinateur ou sur un ordinateur mis à niveau, désactivez-la d'abord sur le serveur de clés de licence de Dassault Systèmes SolidWorks Corporation, puis réactivez-la sur l'autre ordinateur.

Si vous ne pouvez pas désactiver la licence de Dassault Systèmes SolidWorks Corporation (en raison d'une défaillance du disque dur, par exemple), la réactivation peut tout de même avoir lieu dans la plupart des cas. Si ce n'est pas le cas, contactez votre revendeur pour qu'il vous assiste.

Pour retransférer une licence vers le serveur :

  1. Dans le logiciel SOLIDWORKS, cliquez sur Aide > Licences > Désactiver et suivez les instructions qui s'affichent.
  2. Pour réactiver la licence, allez sur le nouvel ordinateur ou l'ordinateur mis à niveau et activez la licence en suivant la procédure d'activation initiale. Pour plus de détails, reportez-vous à Activer une licence.


Administrer des licences avec SolidNetWork License Manager

SolidNetWork License Manager prend en charge les clients de licence multiples en distribuant les licences aux clients du réseau. Le nombre d'utilisateurs peut ainsi dépasser le nombre de licences en utilisant des licences flottantes.

Cette image illustre une installation de licence SolidNetWork typique:

Cette image montre:
  • Le logiciel SolidNetWork License Manager est installé et activé uniquement sur l'ordinateur du gestionnaire de licences.
  • Aucun logiciel additionnel spécifique à SolidNetWork n'est installé sur les ordinateurs clients de la licence.

    Si vous spécifiez un numéro de série pour la licence SolidNetWork lors de l'installation, le Gestionnaire de licences SOLIDWORKS identifie cet ordinateur comme étant un client de licence SolidNetWork. Le Gestionnaire d'installation SOLIDWORKS demande le nom de l'ordinateur sur lequel réside SolidNetWork License Manager, ainsi que le numéro de port sur lequel connecter le client au gestionnaire de licences.

  • Le Gestionnaire de licences et tous les clients de licence doivent pouvoir être connectés au protocole TCP/IP (Transmission Control Protocol/Internet Protocol).

Table des matières

  • Activer une licence SolidNetWork

    Avant que les clients puissent exécuter les produits SOLIDWORKS sur leurs ordinateurs individuels, vous devez activer une licence SolidNetWork sur l'ordinateur de SolidNetwork License Manager.

  • Transférer une licence SolidNetWork

    Pour transférer une licence SolidNetWork sur un nouvel ordinateur ou sur un ordinateur mis à niveau, désactivez-la d'abord sur le serveur de clés de licence de Dassault Systèmes SOLIDWORKS Corporation, puis réactivez-la sur l'autre ordinateur.

  • Installer et configurer la gestion des licences SolidNetWork

    La configuration de la gestion des licences SolidNetWork consiste à installer SolidNetwork License Manager sur l'ordinateur du gestionnaire de licences puis à installer SOLIDWORKS sur des ordinateurs clients en utilisant le numéro de série de la licence SolidNetWork.

  • Administration des licences SolidNetWork.

    Au nombre des tâches se trouvent le démarrage, la mise à niveau et la désinstallation du gestionnaire de licences, ainsi que l'emprunt et le retour des licences.

Sujet parent Administration des licences
Administrer les licences individuelles


Activer une licence SolidNetWork

Avant que les clients puissent exécuter les produits SOLIDWORKS sur leurs ordinateurs individuels, vous devez activer une licence SolidNetWork sur l'ordinateur de SolidNetwork License Manager.

Pour procéder à l'activation, vous devez avoir accès à Internet ou à la messagerie électronique. Après l'activation, vous n'avez pas besoin d'être en ligne pour utiliser les produits. Si vous n'avez pas accès à la messagerie électronique sur l'ordinateur sur lequel vous utilisez ce produit, vous pouvez enregistrer le fichier d'activation et l'envoyer à partir d'un autre ordinateur.

Cette procédure:
  • Active les licences SOLIDWORKS qui se trouvent sur SolidNetwork License Manager pour les produits SOLIDWORKS.
  • Vous permet de transférer les droits de licence SolidNetWork d'un ordinateur SolidNetwork License Manager à l'autre.
  • Vous permet d'installer et d'activer les droits de licence SolidNetWork sur un ordinateur SolidNetwork License Manager.
  • Cette opération doit être effectuée pour que vous puissiez utiliser les licences SolidNetWork.
  • Permet de se passer de dongles. Si vous activez une licence SolidNetWork pour cette version de SOLIDWORKS, les licences SolidNetWork des versions précédentes de SOLIDWORKS sont activées. (Il n'est plus nécessaire de garder le dongle.)

Pour activer une licence SolidNetWork:

  1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Si vous n'avez pas encore activé la licence SolidNetWork, le programme vous demande si vous souhaitez l'activer maintenant. Cliquez sur Oui pour activer.
  3. Sous Comment voulez-vous procéder à l'activation?, sélectionnez Automatiquement sur Internet (recommandé).
  4. Sous Coordonnées, spécifiez une adresse électronique à laquelle vous contacter.
La boîte de dialogue L’activation/réactivation a réussi affiche les produits qui ont été activés.
Sujet parent Administrer des licences avec SolidNetWork License Manager
Transférer une licence SolidNetWork
Installer et configurer la gestion des licences SolidNetWork
Administration des licences SolidNetWork.


Transférer une licence SolidNetWork

Pour transférer une licence SolidNetWork sur un nouvel ordinateur ou sur un ordinateur mis à niveau, désactivez-la d'abord sur le serveur de clés de licence de Dassault Systèmes SOLIDWORKS Corporation, puis réactivez-la sur l'autre ordinateur.

Si vous êtes dans l'impossibilité de désactiver la licence de Dassault Systèmes SOLIDWORKS Corporation (en raison d'une défaillance du disque dur, par exemple), la réactivation peut tout de même avoir lieu dans la plupart des cas. Si ce n'est pas le cas, contactez votre revendeur pour qu'il vous assiste.

Pour transférer de nouveau une licence SolidNetWork sur le serveur :

  1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Sous Informations sur la licence, cliquez sur Modifier. L'assistant Activation de produit SOLIDWORKS démarre.
  3. Sous Que souhaitez-vous faire ?, sélectionnez Désactiver une licence du logiciel, puis cliquez sur Suivant.
  4. Sous Comment voulez-vous procéder à la désactivation ?, sélectionnez Automatiquement sur Internet (recommandé).
  5. Sous Coordonnées, spécifiez une adresse électronique à laquelle vous contacter.
  6. Cliquez sur Suivant. La désactivation de la licence produit se termine.
Sujet parent Administrer des licences avec SolidNetWork License Manager
Activer une licence SolidNetWork
Installer et configurer la gestion des licences SolidNetWork
Administration des licences SolidNetWork.


Installer et configurer la gestion des licences SolidNetWork

La configuration de la gestion des licences SolidNetWork consiste à installer SolidNetwork License Manager sur l'ordinateur du gestionnaire de licences puis à installer SOLIDWORKS sur des ordinateurs clients en utilisant le numéro de série de la licence SolidNetWork.

Table des matières

  • Installer et activer un Gestionnaire de licences

    SolidNetWork License Manager prend en charge plusieurs clients de licences. Il distribue les licences aux clients sur le réseau.

  • Installer un client de licence

    Quand vous installez SOLIDWORKS sur des ordinateurs clients de licence SolidNetWork, le numéro de série identifie cet ordinateur en tant que client de licence SolidNetWork.

  • Installer les logiciels SolidNetwork License Manager avant d'installer les clients de licence

    Vous devez installer et configurer SolidNetWork License Manager sur un ordinateur au moins avant d'installer des ordinateurs client de licence SolidNetWork.

  • Gestion de l'accès aux versions de SOLIDWORKS

    Vous pouvez empêcher les utilisateurs d'utiliser des versions spécifiques de SOLIDWORKS dans un environnement SolidNetWork. Cette fonctionnalité vous permet de gérer les versions de SOLIDWORKS utilisées par différent(e)s personnes, projets et unités commerciales.

  • Installation des gestionnaires de licences triade

    Les gestionnaires de licences triade utilisent trois ordinateurs pour une stabilité accrue. Si l'ordinateur qui gère le fichier de licence n'est pas disponible, un des deux autres ordinateurs prend le relais.

  • Utiliser les licences SolidNetWork avec des pare-feux

    Si votre ordinateur utilise un pare-feu, vous devez configurer les ports de façon à ce qu'ils prennent en charge la gestion des licences SolidNetWork.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Activer une licence SolidNetWork
Transférer une licence SolidNetWork
Administration des licences SolidNetWork.


Installer et activer un Gestionnaire de licences

SolidNetWork License Manager prend en charge plusieurs clients de licences. Il distribue les licences aux clients sur le réseau.

Si vous mettez à niveau une version antérieure de SolidNetwork License Manager qui utilisait un dongle matériel pour l'activation de licence, enlevez le dongle avant d'installer la nouvelle version de SolidNetwork License Manager.

  1. Démarrez le Gestionnaire d'installation SOLIDWORKS (comme décrit sous Lancer l'installation de SOLIDWORKS).
    1. Pour le type d'installation, sélectionnez l'une des options suivantes:
      • Produits Serveur
      • Installer SolidNetwork License Manager (licences distribuées) sur cet ordinateur.
    2. Sur la page Options de SolidNetwork License Manager, indiquez le numéro de licence SolidNetWork ainsi que l'emplacement d'installation de SolidNetwork License Manager.
    3. Sur la page Résumé, cliquez sur Installer maintenant pour terminer le processus du Gestionnaire d'installation SOLIDWORKS.
  2. Pour activer la licence SolidNetWork:
    1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Lorsque vous êtes invité à activer, cliquez sur Oui.
    3. Sur l'écran Informations du Serveur de licences SolidNetWork :
      • Si votre société utilise un pare-feu, sélectionnez Un pare-feu est utilisé sur ce serveur.

        Pour obtenir de plus amples informations, voir Utiliser les licences SolidNetWork avec des pare-feux.

      • Utilisez la valeur par défaut dans les champs Numéro de port (et Numéro de port du démon si vous avez un pare-feu), ou spécifiez les numéros de port utilisés par votre société.
        Le numéro de port est un numéro TCP/IP compris entre 1024 et 60000 utilisé exclusivement par ce processus. Le réglage par défaut, 25734, est normalement adéquat et il est improbable qu'il soit le même que tout autre processus de serveur FLEXnet en cours sur l'ordinateur du serveur de licences.
    4. Sur l'écran Activer votre produit SOLIDWORKS :
      • Sélectionnez la procédure par Internet ou par courrier électronique.
      • Fournissez les informations de contact par courrier électronique.
      • Cliquez sur Suivant pour continuer.
        • Par Internet: L'activation a lieu automatiquement.
        • Courriel : Appuyez sur Enregistrer pour créer un fichier de requête, puis envoyez ce fichier à activation@solidworks.com. Quand vous recevez le courriel contenant le fichier de réponse, extrayez ce dernier du courriel puis cliquez sur Ouvrir pour le charger.
          Si nécessaire, quittez et exécutez de nouveau la procédure d'activation pour ouvrir le fichier de réponse.
  3. Cliquez sur Terminer.
Sujet parent Installer et configurer la gestion des licences SolidNetWork
Installer un client de licence
Installer les logiciels SolidNetwork License Manager avant d'installer les clients de licence
Gestion de l'accès aux versions de SOLIDWORKS
Installation des gestionnaires de licences triade
Utiliser les licences SolidNetWork avec des pare-feux
Lancer l'installation de SOLIDWORKS


Installer un client de licence

Quand vous installez SOLIDWORKS sur des ordinateurs clients de licence SolidNetWork, le numéro de série identifie cet ordinateur en tant que client de licence SolidNetWork.

  1. Démarrez le Gestionnaire d'installation SOLIDWORKS (comme décrit sous Lancer l'installation de SOLIDWORKS).
  2. Sur l'écran Bienvenue, cliquez sur Individuelle (sur cet ordinateur) si SOLIDWORKS est installé pour la première fois sur cet ordinateur pour cette version majeure.
    Si vous mettez à niveau depuis une version existante et passez des licences individuelles à la gestion des licences SolidNetWork, cliquez sur Modifier l'installation individuelle (sur cet ordinateur). Pour obtenir des informations détaillées, voir Mise à niveau de la gestion des licences individuelles vers la gestion des licences SolidNetWork.
  3. Lorsque le programme vous demande un numéro de série, entrez le numéro de série de la licence SolidNetWork.
  4. Dans la boîte de dialogue Ajouter un serveur, saisissez l'adresse de SolidNetWork License Manager comme suit :

    port@NomOrdinateur

    Le numéro de port doit être le même que celui utilisé pour l'ordinateur du Gestionnaire de licences. Le réglage par défaut est 25734 (comme décrit dans Installation et activation d’un Gestionnaire de licences).

    Le Gestionnaire d'installation SOLIDWORKS essayera de confirmer que SolidNetwork License Manager est accessible. Si vous n'avez pas encore installé un gestionnaire de licences, cette confirmation échouera, mais vous pouvez cependant continuer l'installation du client de licence.
  5. Terminez l'installation de SOLIDWORKS en suivant les instructions du Gestionnaire d'installation SOLIDWORKS.
Sujet parent Installer et configurer la gestion des licences SolidNetWork
Installer et activer un Gestionnaire de licences
Installer les logiciels SolidNetwork License Manager avant d'installer les clients de licence
Gestion de l'accès aux versions de SOLIDWORKS
Installation des gestionnaires de licences triade
Utiliser les licences SolidNetWork avec des pare-feux
Lancer l'installation de SOLIDWORKS
Mettre à niveau de la gestion des licences individuelles vers la gestion SolidNetWork


Installer les logiciels SolidNetwork License Manager avant d'installer les clients de licence

Vous devez installer et configurer SolidNetWork License Manager sur un ordinateur au moins avant d'installer des ordinateurs client de licence SolidNetWork.

Lorsque vous installez en utilisant un numéro de série de licence SolidNetWork, le Gestionnaire d'installation SOLIDWORKS vous demande d'entrer le nom de l'ordinateur sur lequel réside SolidNetwork License Manager et le numéro de port puis tente de valider ces informations.

Si vous n'avez pas encore installé SolidNetwork License Manager sur l'ordinateur que vous avez spécifié, cette validation ne peut pas réussir. Cependant, l'échec de la validation n'indique pas dans ce cas si vous avez fourni les informations de gestionnaire de licences correctes. Si le gestionnaire de licences est installé, l'échec de la validation indique que vous avez donné des informations de gestionnaire de licences incorrectes.

Sujet parent Installer et configurer la gestion des licences SolidNetWork
Installer et activer un Gestionnaire de licences
Installer un client de licence
Gestion de l'accès aux versions de SOLIDWORKS
Installation des gestionnaires de licences triade
Utiliser les licences SolidNetWork avec des pare-feux


Gestion de l'accès aux versions de SOLIDWORKS

Vous pouvez empêcher les utilisateurs d'utiliser des versions spécifiques de SOLIDWORKS dans un environnement SolidNetWork. Cette fonctionnalité vous permet de gérer les versions de SOLIDWORKS utilisées par différent(e)s personnes, projets et unités commerciales.

Pour gérer l'accès aux versions de SOLIDWORKS à l'aide d'un fichier d'options FLEXnet :

  1. Dans le répertoire d'installation de SolidNetWork License Manager, créez un fichier texte :
    Dossier_installation_SolidNetWork_License_Manager\Licenses\sw_d.opt
  2. Pour gérer l'accès à une version spécifique de SOLIDWORKS dans le fichier de licence, ajoutez la syntaxe suivante en face de SOLIDWORKS :
    :SWVERSION=xx Où xx est la version du produit SOLIDWORKS que vous souhaitez gérer
  3. Pour gérer plusieurs versions de SOLIDWORKS, ajoutez une ligne pour chaque version que vous désirez gérer.

    Les options FlexNet ne sont pas toutes prises en charge. Les options prises en charge pour les filtres de version sont les suivantes :

    INCLUDE | Autoriser uniquement l'utilisateur ou le groupe à démarrer la version spécifique. Tous les autres utilisateurs ne sont pas autorisés à démarrer cette version.
    INCLUDE_BORROW | Autoriser uniquement l'utilisateur ou le groupe à emprunter la version spécifique. Tous les autres utilisateurs ne sont pas autorisés à emprunter cette version.
    EXCLUDE | Empêcher l'utilisateur ou le groupe indiqué de démarrer la version spécifique de SOLIDWORKS. EXCLUDE supplante INCLUDE.
    EXCLUDE_BORROW | Empêcher l'utilisateur ou le groupe indiqué d'emprunter la version spécifique de SOLIDWORKS. EXCLUDE supplante INCLUDE.
    Exemples :
    1 | SWVERSION=27.0 fait référence à SOLIDWORKS 2020
    SWVERSION=26.0 fait référence à SOLIDWORKS 2019
    2 | INCLUDE solidworks:SWVERSION=27.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=27.0 USER jane
    Ces lignes dans le fichier d'options autorisent uniquement jane à exécuter SOLIDWORKS 2020. Tous les autres utilisateurs ne peuvent ni exécuter ni emprunter SOLIDWORKS 2020, mais peuvent exécuter et emprunter d'autres versions de SOLIDWORKS. jane peut également exécuter et emprunter d'autres versions de SOLIDWORKS.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=27.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=26.0 GROUP chicago
    EXCLUDE solidworks USER don
    Ces lignes définissent un groupe d'utilisateurs nommé Chicago et leur interdisent l'accès à la fois à SOLIDWORKS 2020 et à SOLIDWORKS 2019, mais ils peuvent exécuter n'importe quelle autre version de SOLIDWORKS. L'utilisateur don ne peut exécuter aucune version de SOLIDWORKS.
    4 | EXCLUDE swinspection_std:SWVERSION=27.0 HOST machine1
    Cette ligne interdit à quiconque sur la machine1 de lancer SOLIDWORKS Inspection 2020

    Pour des informations supplémentaires sur FLEXnet, voir le License Administration Guide (Guide d'administration des licences) de FLEXnet Publisher dans le répertoire d'installation de SolidNetwork License Manager (\Docs\flexuser\licensingenduserguide.pdf).

Sujet parent Installer et configurer la gestion des licences SolidNetWork
Installer et activer un Gestionnaire de licences
Installer un client de licence
Installer les logiciels SolidNetwork License Manager avant d'installer les clients de licence
Installation des gestionnaires de licences triade
Utiliser les licences SolidNetWork avec des pare-feux


Installation des gestionnaires de licences triade

Les gestionnaires de licences triade utilisent trois ordinateurs pour une stabilité accrue. Si l'ordinateur qui gère le fichier de licence n'est pas disponible, un des deux autres ordinateurs prend le relais.

Les composants suivants sont nécessaire pour utiliser des gestionnaires de licence triade:
  • Installez les gestionnaires de licences triade uniquement sur des ordinateurs stables qui ne sont pas fréquemment arrêtés.
  • Les trois ordinateurs gestionnaires de licences doivent être sur le même sous-réseau. Ne configurez jamais des gestionnaires de licences triade avec des communications ou des liaisons d'accès à distance lentes.
  • L'administrateur système doit détecter lorsqu'un gestionnaire de licences est hors service et le redémarrer le plus vite possible.
    Si seuls deux gestionnaires de licences fonctionnent, la situation est pire qu'avec un gestionnaire de licences unique, parce qu'il y a alors deux points d'échec.

Table des matières

  • Installer le Gestionnaire de licences triade initial

    Ce processus montre comment installer SolidNetWork License Manager sur le premier ordinateur de la triade.

  • Installer le gestionnaire de licences triade sur les ordinateurs suivants

    Suivez ces instructions pour installer le logiciel SolidNetWork License Manager sur le deuxième et le troisième ordinateur de la triade. Cette procédure est presque identique à l'installation du logiciel sur l'ordinateur initial, à l'exception des étapes 2(f) et 2(i).

Sujet parent Installer et configurer la gestion des licences SolidNetWork
Installer et activer un Gestionnaire de licences
Installer un client de licence
Installer les logiciels SolidNetwork License Manager avant d'installer les clients de licence
Gestion de l'accès aux versions de SOLIDWORKS
Utiliser les licences SolidNetWork avec des pare-feux


Installer le Gestionnaire de licences triade initial

Ce processus montre comment installer SolidNetWork License Manager sur le premier ordinateur de la triade.

  1. Sur le premier ordinateur du gestionnaire de licences triade, installez SolidNetWork License Manager à l'aide du Gestionnaire d'installation SOLIDWORKS.
    1. Démarrez le Gestionnaire d'installation SOLIDWORKS (comme décrit sous Lancer l'installation de SOLIDWORKS).
    2. Pour le type d'installation, sélectionnez l'une des options suivantes:
      • Produits Serveur
      • Installer SolidNetWork License Manager (licences distribuées) sur cet ordinateur.
    3. Sur la page Options de SolidNetWork License Manager, indiquez le numéro de licence SolidNetWork ainsi que l'emplacement d'installation de SolidNetWork License Manager.
    4. Sur la page Résumé, cliquez sur Installer maintenant pour terminer le processus du Gestionnaire d'installation SOLIDWORKS.
  2. A l'aide de SolidNetWork License Manager, configurez l'ordinateur du gestionnaire de licences triade initial:
    1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Cliquez sur Non.
      L'onglet Administration du serveur de SolidNetWork License Manager de SOLIDWORKS apparaît.
    3. Sous Options avancées, cliquez sur Options.
      La boîte de dialogue Options avancées apparaît.
    4. Sous Mode de licence du serveur SolidNetWork, cliquez sur Fichier de licence, puis sur OK.
      La boîte de dialogue Options avancées se ferme.
    5. Sous Informations sur la licence, cliquez sur Modifier.
      La boîte de dialogue Assistance du fichier de licence SolidNetWork apparaît.
    6. Sous Type de serveur, sélectionnez Triade et cliquez sur Suivant.
    7. Dans le volet Informations sur le serveur, vérifiez que le nom de l'ordinateur et le numéro de port de l'ordinateur gestionnaire de licences triade initial sont corrects et cliquez sur Suivant.

      Vérifiez que l'adresse de carte d'interface réseau (NIC) correspond aux informations contenues dans le fichier de licence SOLIDWORKS et que les numéros de port de l'ordinateur du gestionnaire de licences triade sont corrects. L'adresse NIC est également connue sous le nom d'adresse MAC (contrôle d'accès au support). Cliquez ensuite sur Suivant.

      Pour rechercher les adresses NIC, ouvrez une fenêtre d'invite de commandes et saisissez :

      ipconfig /all

      De plus, si votre ordinateur utilise un pare-feu, il se peut que vous ayez à ajouter des spécifications sur cet écran. Pour obtenir des informations, voir Utiliser les licences SolidNetWork avec des pare-feux.

    8. Sur l'écran Informations sur le serveur triade partenaire, saisissez le nom de l'ordinateur et l'identificateur hôte pour les deux autres ordinateurs gestionnaires de licences triade.
      Ceci garantit qu'en cas d'indisponibilité d'un gestionnaire de licences, les ordinateurs client peuvent obtenir une licence des deux autres serveurs.
    9. Dans l'écran Licences, cliquez sur Lire pour rechercher et ouvrir le fichier de licence SolidNetWork.
      Les licences apparaissent dans l'assistant Fichier de licence SolidNetWork. Pour cet ordinateur, vous pouvez utiliser un fichier de licence que vous avez reçu d'un revendeur ou du Customer Center.
    10. Cliquez sur Terminer.
    11. Cliquez sur OK pour quitter l'Assistance du fichier de licence SolidNetWork puis sur Terminer pour quitter le SolidNetWork License Manager.
Sujet parent Installation des gestionnaires de licences triade
Installer le gestionnaire de licences triade sur les ordinateurs suivants
Lancer l'installation de SOLIDWORKS
Utiliser les licences SolidNetWork avec des pare-feux


Installer le gestionnaire de licences triade sur les ordinateurs suivants

Suivez ces instructions pour installer le logiciel SolidNetWork License Manager sur le deuxième et le troisième ordinateur de la triade. Cette procédure est presque identique à l'installation du logiciel sur l'ordinateur initial, à l'exception des étapes 2(f) et 2(i).

On suppose que vous avez déjà installé au moins un gestionnaire de licences triade sur un autre ordinateur.

  1. Sur l'ordinateur du gestionnaire de licences triade, installez SolidNetWork License Manager à l'aide du Gestionnaire d'installation SOLIDWORKS :
    1. Démarrez le Gestionnaire d'installation SOLIDWORKS (comme décrit dans Lancer l'installation de SOLIDWORKS).
    2. Pour le type d'installation, sélectionnez l'une des options suivantes:
      • Produits Serveur
      • Installer SolidNetWork License Manager (licences distribuées) sur cet ordinateur.
    3. Sur la page Options de SolidNetWork License Manager, indiquez le numéro de licence SolidNetWork ainsi que l'emplacement d'installation de SolidNetWork License Manager.
    4. Sur la page Résumé, cliquez sur Installer maintenant pour terminer le processus du Gestionnaire d'installation SOLIDWORKS.
  2. A l'aide de SolidNetWork License Manager, configurez l'ordinateur du gestionnaire de licences triade:
    1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
      Puisque c'est la première fois que vous exécutez SolidNetWork License Manager sur cet ordinateur, le programme vous demande si vous souhaitez l'activer maintenant.
    2. Cliquez sur Non.
      L'onglet Administration du serveur de SOLIDWORKS SolidNetwork License Manager apparaît.
    3. Sous Options avancées, cliquez sur Options.
      La boîte de dialogue Options avancées apparaît.
    4. Sous Mode de licence du serveur SolidNetWork, cliquez sur Fichier de licence, puis sur OK.
      La boîte de dialogue Options avancées se ferme.
    5. Sous Informations sur la licence, cliquez sur Modifier.
      La boîte de dialogue Assistance du fichier de licence SolidNetWork apparaît.
    6. Sous Type de serveur, sélectionnez Triade et Synchroniser les informations serveur/licence puis cliquez sur Suivant.
    7. Dans le volet Informations sur le serveur, vérifiez que le nom de l'ordinateur et le numéro de port pour cet ordinateur gestionnaire de licences triade sont corrects et cliquez sur Suivant.

      Vérifiez que l'adresse de carte d'interface réseau (NIC) correspond aux informations contenues dans le fichier de licence SOLIDWORKS et que les numéros de port de l'ordinateur du gestionnaire de licences triade sont corrects. L'adresse NIC est également connue sous le nom d'adresse MAC (contrôle d'accès au support). Cliquez ensuite sur Suivant.

      Pour rechercher les adresses NIC, ouvrez une fenêtre d'invite de commandes et saisissez :

      ipconfig /all

      De plus, si votre ordinateur utilise un pare-feu, il se peut que vous ayez à ajouter des spécifications sur cet écran. Pour plus d'informations, voir Utiliser les licences SolidNetWork avec des pare-feux.

    8. Sur l'écran Informations sur le serveur triade partenaire, saisissez le nom de l'ordinateur et l'identificateur hôte.
      Ceci garantit qu'en cas d'indisponibilité d'un gestionnaire de licences, les ordinateurs client peuvent obtenir une licence des deux autres serveurs.
    9. Dans l'écran Licences, cliquez sur Lire pour rechercher et ouvrir le fichier de licence SolidNetWork.
      Les licences apparaissent dans l'assistant Fichier de licence SolidNetWork.
    Ce fichier de licences est généré par le premier ordinateur gestionnaire de licences triade que vous avez configuré. Généralement, le fichier de licence se trouve sous \licenses\sw_d.lic. Par exemple : C:\Program Files\SOLIDWORKS Corp\SolidNetWork License Manager\licenses\sw_d.lic.
    1. Cliquez sur Terminer.
      Une boîte de dialogue Assistance du fichier de licence SolidNetWork apparaît.
    2. Cliquez sur OK pour quitter l'Assistance du fichier de licence SolidNetWork puis sur Terminer pour quitter SOLIDWORKS SolidNetwork License Manager.

Répétez ce processus pour le troisième ordinateur gestionnaire de licences triade.

Sujet parent Installation des gestionnaires de licences triade
Installer le Gestionnaire de licences triade initial


Utiliser les licences SolidNetWork avec des pare-feux

Si votre ordinateur utilise un pare-feu, vous devez configurer les ports de façon à ce qu'ils prennent en charge la gestion des licences SolidNetWork.

Vous devez ajouter deux ports de licences SolidNetWork dans le logiciel pare-feu (par exemple, SNL-in-port et SNL-out-port) dans la liste d'exceptions du pare-feu. Pour obtenir des détails sur la configuration de ces ports, consultez votre administrateur système.

Si vous utilisez le Pare-feu Windows sur un système d'exploitation Windows pris en charge, vous devez modifier des ports sur l'ordinateur de SolidNetwork License Manager et modifier le fichier de licence SolidNetWork pour distribuer les licences aux ordinateurs clients de licence.

Table des matières

  • Modifier les ports de l'ordinateur du Gestionnaire de licences pour le Pare-feu Windows

    Si vous utilisez le Pare-feu Windows, vous devez modifier les paramètres des ports de pare-feu sur l'ordinateur de SolidNetwork License Manager.

  • Modifier les paramètres SolidNetWork License Manager pour le Pare-feu Windows

    Si vous utilisez le pare-feu Windows, vous devez modifier le fichier de licence SolidNetWork afin d'utiliser les ports du pare-feu pour distribuer les licences aux ordinateurs client de la licence.

Sujet parent Installer et configurer la gestion des licences SolidNetWork
Installer et activer un Gestionnaire de licences
Installer un client de licence
Installer les logiciels SolidNetwork License Manager avant d'installer les clients de licence
Gestion de l'accès aux versions de SOLIDWORKS
Installation des gestionnaires de licences triade


Modifier les ports de l'ordinateur du Gestionnaire de licences pour le Pare-feu Windows

Si vous utilisez le Pare-feu Windows, vous devez modifier les paramètres des ports de pare-feu sur l'ordinateur de SolidNetwork License Manager.

  1. Dans Windows, ouvrez le Panneau de configuration et double-cliquez sur Centre de sécurité.
  2. Cliquez sur Pare-feu Windows.
  3. Dans l'onglet Exceptions, cliquez sur Ajouter un port.
  4. Saisissez un Nom, (par exemple, SNL-in-port) et un Numéro de port (par exemple 25734), puis cliquez sur OK.
  5. Pour le deuxième port, cliquez sur Ajouter un port de nouveau dans l'onglet Exceptions, spécifiez le nom et le numéro de l'autre port (par exemple SNL-out-port et 25735), puis cliquez sur OK. Prenez note du numéro du port qui vous servira de référence par la suite lorsque vous modifierez le fichier de licence SolidNetWork.
  6. Fermez le Centre de sécurité Windows et le Panneau de configuration.
Sujet parent Utiliser les licences SolidNetWork avec des pare-feux
Modifier les paramètres SolidNetWork License Manager pour le Pare-feu Windows


Modifier les paramètres SolidNetWork License Manager pour le Pare-feu Windows

Si vous utilisez le pare-feu Windows, vous devez modifier le fichier de licence SolidNetWork afin d'utiliser les ports du pare-feu pour distribuer les licences aux ordinateurs client de la licence.

  1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Dans l'onglet Administration du serveur, sous Serveur de licences, cliquez sur Arrêter. (Cliquez sur Oui lorsque vous êtes invité à confirmer et sur OK pour compléter l'arrêt du serveur de licences.)
  3. Sous Informations sur la licence, cliquez sur Modifier.
  4. Sous Type de serveur, sélectionnez la configuration de serveur pour votre réseau (Unique ou Triade) puis cliquez sur Suivant.
  5. Sous Informations sur le serveur:
    1. Sélectionnez Un pare-feu est utilisé sur ce serveur.
    2. Le numéro de port et le numéro de port du démon doivent contenir les numéros de port spécifiés pour le pare-feu Windows (pour des détails, voir Modifier les ports de l'ordinateur du Gestionnaire de licences pour le Pare-feu Windows).
    3. Sélectionnez Fichier d'options et cliquez sur Parcourir pour localiser le fichier. Cliquez sur Editer pour modifier ses paramètres.
      Le fichier d'options permet à l'administrateur de licences de contrôler les différents paramètres de fonctionnement des licences FLEXnet.

      Il est recommandé de placer le fichier d'options dans le répertoire d'installation de SolidNetWork License Manager (SolidNetwork_License_Manager_install_dir\Licenses \sw_d.opt). Ce fichier doit se situer dans le même répertoire que le fichier sw_d.lic.

      Pour obtenir des informations supplémentaires sur le fichier d'options, voir le License Administration Guide (Guide d'administration des licences) de FLEXnet Publisher dans le répertoire d'installation de SolidNetWork License Manager (\Docs\flexuser\licensingenduserguide.pdf).

    4. Cliquez sur Suivant, puis sur Terminer.
  6. Dans l'onglet Administration du serveur, sous Serveur de licences, cliquez sur Démarrer.
  7. Cliquez sur OK pour fermer SolidNetWork License Manager.
Sujet parent Utiliser les licences SolidNetWork avec des pare-feux
Modifier les ports de l'ordinateur du Gestionnaire de licences pour le Pare-feu Windows


Administration des licences SolidNetWork.

Au nombre des tâches se trouvent le démarrage, la mise à niveau et la désinstallation du gestionnaire de licences, ainsi que l'emprunt et le retour des licences.

Avant de démarrer ou de mettre à niveau le Gestionnaire de licences, vous devez retourner toutes les licences empruntées.

Table des matières

  • Démarrer SolidNetWork License Manager

    Vous pouvez démarrer SolidNetWork License Manager depuis le menu Démarrer de Windows.

  • Mettre à niveau SolidNetwork License Manager

    Dans le cas des versions principales de SOLIDWORKS, la mise à niveau du gestionnaire de licences consiste à désinstaller l'ancien gestionnaire de licences, à en installer un nouveau et à réactiver la licence SolidNetWork.

  • Suppression des fichiers de licence SolidNetWork

    Supprimez les anciens fichiers de licence SolidNetWork et ceux qui ont expiré avant de procéder à une mise à niveau vers les nouveaux.

  • Emprunter et rendre des licences SolidNetWork

    Vous pouvez emprunter une licence SolidNetWork pour utiliser le logiciel à distance. Puisque la licence est retirée du groupe de licences disponibles, une licence empruntée doit être rendue pour être de nouveau disponible.

  • Surveillance du temps d'inactivité d'une licence

    SOLIDWORKS a la possibilité d'enregistrer le temps d'inactivité avec SolidNetWork License Manager de façon à ce que les licences qui n'ont pas été utilisées pendant un certain temps soient remises à disposition.

  • Installer des licences temporaires

    La licence temporaire « ANY » peut être utilisée temporairement lorsque la licence SolidNetWork d'origine n'est pas disponible.

  • Mettre à niveau de la gestion des licences individuelles vers la gestion SolidNetWork

    Vous pouvez mettre un ordinateur à niveau de la gestion des licences individuelles SOLIDWORKS vers la gestion SolidNetWork en spécifiant le numéro de série de la licence SolidNetWork dans le Gestionnaire d'installation SOLIDWORKS.

  • Utiliser les licences SolidNetWork avec des compléments

    Vous pouvez utiliser SolidNetWork License Manager pour distribuer les licences des compléments SOLIDWORKS.

  • Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork

    Les utilisateurs de licences SolidNetWork peuvent choisir les licences SOLIDWORKS® Simulation de leur groupe de licences à utiliser lorsqu'ils ajoutent SOLIDWORKS Simulation. Ils peuvent également réaliser une mise à niveau de la licence SOLIDWORKS Simulation sans décharger le complément, au cas où ils auraient besoin d'un type de licence plus élevée pour des études plus avancées.

  • Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative

    Vous pouvez configurer un ordinateur de réseau pour servir à la fois de gestionnaire de licences distribuant les licences SolidNetWork et d'emplacement de l'image administrative à partir de laquelle les utilisateurs peuvent installer le logiciel SOLIDWORKS.

  • Gestion des licences FLEXnet Publisher

    La gestion des licences SolidNetWork est basée sur FLEXnet Publisher®.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Activer une licence SolidNetWork
Transférer une licence SolidNetWork
Installer et configurer la gestion des licences SolidNetWork


Démarrer SolidNetWork License Manager

Vous pouvez démarrer SolidNetWork License Manager depuis le menu Démarrer de Windows.

Sous Windows, exécutez cette commande: Démarrer > Tous les programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager.
Sujet parent Administration des licences SolidNetWork.


Mettre à niveau SolidNetwork License Manager

Dans le cas des versions principales de SOLIDWORKS, la mise à niveau du gestionnaire de licences consiste à désinstaller l'ancien gestionnaire de licences, à en installer un nouveau et à réactiver la licence SolidNetWork.

Le gestionnaire de licences pour une version plus récente peut distribuer des licences aux ordinateurs clients continuant d'utiliser la version antérieure.

  1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Sur l'onglet Utilisation de la licence, vérifiez qu'aucun ordinateur client du réseau n'exécute SOLIDWORKS.
  3. Désinstaller le Gestionnaire de licences SolidNetWork. Pour plus de détails, voir Désinstaller SolidNetwork License Manager.
  4. Installer le nouveau gestionnaire de licences et réactiver la licence SolidNetWork sur l'ordinateur du gestionnaire de licences. Pour plus de détails, voir Installer et activer un Gestionnaire de licences.

Si vous mettez à niveau SolidNetwork License Manager sur un ordinateur exécutant aussi l'application SOLIDWORKS, mettez à niveau les Gestionnaires de licences SolidNetWork et les clients avant d'installer tout nouveau service pack de l'application SOLIDWORKS sur cet ordinateur.

Si vous mettez à niveau le gestionnaire de licences sur un ordinateur hébergeant des images administratives, mettez à niveau le gestionnaire de licences avant les images administratives. Pour plus de détails, voir Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative.

Table des matières

  • Désinstaller SolidNetwork License Manager

    Lorsque vous mettez à niveau SolidNetwork License Manager, vous devez désinstaller l'anciene version avant d'installer la nouvelle.

Sujet parent Administration des licences SolidNetWork.


Désinstaller SolidNetwork License Manager

Lorsque vous mettez à niveau SolidNetwork License Manager, vous devez désinstaller l'anciene version avant d'installer la nouvelle.

  1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Vérifiez qu'aucun ordinateur client du réseau n'exécute SOLIDWORKS.
    L'onglet Utilisation de la licence indique les clients exécutant SOLIDWORKS.
  3. Si vous souhaitez transférer la licence SolidNetWork sur un autre ordinateur, désactivez-la sur cet ordinateur avant de supprimer SolidNetwork License Manager.
    Pour des informations sur le transfert de licences SolidNetWork, voir Transférer une licence SolidNetWork.
  4. Dans l'onglet Administration du serveur, sous Serveur de licences, cliquez sur Arrêter.
  5. Cliquez sur OK pour quitter le gestionnaire de licences.
  6. Dans Windows, ouvrez Panneau de configuration > Ajout/Suppression de programmes.
  7. Sélectionnez SOLIDWORKS SolidNetWork License Manager, cliquez sur Supprimer et confirmez la suppression.
  8. Dans l'Explorateur Windows, supprimez le dossier SOLIDWORKS SolidNetwork License Manager.
    (En général, vous trouverez ce dossier sous Program Files dans le répertoire d'installation de SOLIDWORKS.)

Vous êtes maintenant prêt à installer une nouvelle version du gestionnaire de licences. Pour plus de détails, voir Installer et activer un Gestionnaire de licences.

Si l'ordinateur de SolidNetwork License Manager est équipé d'un dongle matériel, enlevez-le avant d'installer la nouvelle version de SolidNetwork License Manager.
Sujet parent Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Installer et activer un Gestionnaire de licences


Suppression des fichiers de licence SolidNetWork

Supprimez les anciens fichiers de licence SolidNetWork et ceux qui ont expiré avant de procéder à une mise à niveau vers les nouveaux.

  1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Dans l'onglet Administration du serveur, sous Fichier de licence, cliquez sur Modifier, puis sur Suivant jusqu'à ce que vous arriviez à l'écran Licences.
  3. Dans l'écran Licences, sélectionnez le fichier SolidNetWork ancien ou expiré, puis cliquez sur Supprimer.
  4. Cliquez sur Terminer puis sur OK.
Sujet parent Administration des licences SolidNetWork.


Emprunter et rendre des licences SolidNetWork

Vous pouvez emprunter une licence SolidNetWork pour utiliser le logiciel à distance. Puisque la licence est retirée du groupe de licences disponibles, une licence empruntée doit être rendue pour être de nouveau disponible.

Les licences empruntées ne sont valides que pour l'utilisateur actuel et la machine sur laquelle elles ont été empruntées. Elles ne peuvent pas être transférées.

La licence peut être empruntée pendant une période définie (jusqu'à 30 jours ou comme défini par l'administrateur système) et elle est supprimée du groupe de licences disponibles.

L'emprunt et le retour de licences ne fonctionnent pas si la licence SOLIDWORKS est en cours d'utilisation.

Les administrateurs système peuvent personnaliser les options d'emprunt pour:
  • Définir des utilisateurs ou des groupes autorisés à emprunter des licences.
  • Définir le nombre de licences ne pouvant pas être empruntées.

Pour des détails, voir rép_install_Gestionnaire_licences\Docs\flexuser\licensingenduserguide.pdf.

Table des matières

  • Emprunter des licences SolidNetWork

  • Rendre une licence SolidNetWork empruntée

    Puisqu'une licence SolidNetWork empruntée est retirée du groupe de licences disponibles, cette licence empruntée doit être rendue pour pouvoir devenir de nouveau disponible.

Sujet parent Administration des licences SolidNetWork.


Emprunter des licences SolidNetWork

Démarrez toujours SolidNetWork License Manager depuis le menu Démarrer. Vous devez être connecté à SolidNetWork License Manager pour emprunter la licence.

Ces étapes peuvent varier selon la configuration de votre système. Consultez la documentation de Microsoft Windows pour des instructions et des options supplémentaires.
  1. Démarrez SolidNetWork License Manager sur l'ordinateur client (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Dans l'onglet Emprunt de licence:
    1. Sélectionnez une date dans le champ Emprunter jusqu'au.
    2. Sélectionnez les produits à emprunter, puis cliquez sur Emprunter et sur Oui pour confirmer.
    3. Cliquez sur Actualiser. La colonne Date d'expiration indique la date à laquelle les licences doivent être rendues.
  3. Cliquez sur OK.
Sujet parent Emprunter et rendre des licences SolidNetWork
Rendre une licence SolidNetWork empruntée


Rendre une licence SolidNetWork empruntée

Puisqu'une licence SolidNetWork empruntée est retirée du groupe de licences disponibles, cette licence empruntée doit être rendue pour pouvoir devenir de nouveau disponible.

  1. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Dans l'onglet Emprunt de licence:
    1. Sélectionnez les produits à rendre, puis cliquez sur Rendre et sur Oui pour confirmer.
    2. Cliquez sur Actualiser. La colonne Date d'expiration devient vide, ce qui indique que les licences ont été rendues.
  3. Cliquez sur OK.
Il n'est pas nécessaire de rendre des licences après la date d'expiration. A minuit le jour de la date d'expiration, la licence est replacée dans la réserve dans SolidNetWork License Manager et les applications ne peuvent plus être exécutées sur le système à distance.
Sujet parent Emprunter et rendre des licences SolidNetWork
Emprunter des licences SolidNetWork


Surveillance du temps d'inactivité d'une licence

SOLIDWORKS a la possibilité d'enregistrer le temps d'inactivité avec SolidNetWork License Manager de façon à ce que les licences qui n'ont pas été utilisées pendant un certain temps soient remises à disposition.

  1. Dans le répertoire d'installation de SolidNetWork License Manager, créez un fichier texte :
    Dossier_installation_Gestionnaire_licences_SolidNetWork\Licenses\sw_d.opt
  2. Ajoutez la ligne suivante au fichier:
    TIMEOUTALL secondes

    où secondes est un nombre supérieur ou égal à 900 (15 minutes), temps minimum autorisé.

Sujet parent Administration des licences SolidNetWork.


Installer des licences temporaires

La licence temporaire « ANY » peut être utilisée temporairement lorsque la licence SolidNetWork d'origine n'est pas disponible.

En installant le fichier de licence "ANY", vous acceptez de mettre en place le fichier de licence traditionnel lorsque vous recevez une licence SolidNetWork délivrée par Dassault Systèmes SOLIDWORKS Corporation. Vous devez respecter les restrictions relatives à la licence à tout moment.

Pour installer une licence "ANY":

  1. Si vous êtes un utilisateur existant de SolidNetWork, désinstallez SolidNetwork License Manager et supprimez le dossier d'installation. Pour plus de détails, voir Désinstaller SolidNetwork License Manager.
  2. Démarrez le Gestionnaire d'installation SOLIDWORKS (comme décrit dans Lancer l'installation de SOLIDWORKS).
    1. Pour le type d'installation, sélectionnez l'une des options suivantes:
      • Produits Serveur
      • Installer SolidNetwork License Manager (licences distribuées) sur cet ordinateur.
    2. Sur la page Options de SolidNetwork License Manager, indiquez le numéro de licence SolidNetWork ainsi que l'emplacement d'installation de SolidNetwork License Manager.
    3. Sur la page Résumé, cliquez sur Installer maintenant pour terminer le processus du Gestionnaire d'installation SOLIDWORKS.
  3. Démarrez SolidNetWork License Manager (Démarrer > Programmes > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager).
  4. Si le programme vous demande d'activer, cliquez sur Non.
    L'onglet Administration du serveur de SOLIDWORKS SolidNetwork License Manager apparaît.
  5. Sous Options avancées, cliquez sur Options.
    La boîte de dialogue Options avancées apparaît.
  6. Sous Mode de licence du serveur SolidNetWork, cliquez sur Fichier de licence, puis sur OK.
    La boîte de dialogue Options avancées se ferme.
  7. Sous Informations sur la licence, cliquez sur Modifier.
    La boîte de dialogue Assistance du fichier de licence SolidNetWork apparaît.
  8. Sous Type de serveur, sélectionnez Unique et cliquez sur Suivant.
  9. Quand vous recevez le message suivant:
    N'a pas pu lire le numéro d'identification du dongle. Cliquez sur Annuler.
    L'identification "ANY" apparaît automatiquement.
    Si votre ordinateur utilise un pare-feu, il se peut que vous ayez à spécifier d'autres informations sur cet écran. Pour plus d'informations, voir Utiliser les licences SolidNetWork avec des pare-feux.
  10. Poursuivez l'installation.
Sujet parent Administration des licences SolidNetWork.


Mettre à niveau de la gestion des licences individuelles vers la gestion SolidNetWork

Vous pouvez mettre un ordinateur à niveau de la gestion des licences individuelles SOLIDWORKS vers la gestion SolidNetWork en spécifiant le numéro de série de la licence SolidNetWork dans le Gestionnaire d'installation SOLIDWORKS.

Si SOLIDWORKS n'est pas installé sur un ordinateur, vous pouvez spécifier la gestion des licences SolidNetWork en entrant le numéro de série SolidNetWork lorsque vous faites l'installation avec le Gestionnaire d'installation SOLIDWORKS.

Si SOLIDWORKS est déjà installé sur un ordinateur et que vous passez de la gestion des licences individuelles à la gestion des licences SolidNetWork, vous pouvez modifier l'installation pour l'ordinateur client et spécifier le numéro de série de la licence SolidNetWork à la place du numéro de série individuel lorsque vous exécutez le Gestionnaire d'installation SOLIDWORKS. Pour plus de détails, voir Modifier une installation.
Si vous avez installé SOLIDWORKS à partir d'une image administrative, l'option Modifier n'est pas disponible. Vous devez modifiez l'image administrative à l'aide de l'Editeur d'options du Gestionnaire d'images administratives, désinstaller le client et réexécuter l'installation.
Sujet parent Administration des licences SolidNetWork.
Modifier une installation


Utiliser les licences SolidNetWork avec des compléments

Vous pouvez utiliser SolidNetWork License Manager pour distribuer les licences des compléments SOLIDWORKS.

  • Il n'est pas nécessaire d'avoir le même nombre de licences pour le logiciel SOLIDWORKS et pour les compléments.
  • Pour obtenir une licence pour un complément, vous devez d'abord obtenir une licence pour SOLIDWORKS.
  • Pour emprunter une licence pour un complément, vous devez emprunter la licence du logiciel SOLIDWORKS et la licence du produit SOLIDWORKS qui inclut le complément. Une licence SOLIDWORKS Standard sera empruntée par défaut, mais pour activer un complément, vous devez emprunter une licence SOLIDWORKS Professional ou une licence SOLIDWORKS Premium.
  • Pour libérer la licence d'un complément:
    • Dans SOLIDWORKS, cliquez sur Outils > Compléments et désactivez le complément.
    • Quittez SOLIDWORKS.
Sujet parent Administration des licences SolidNetWork.


Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork

Les utilisateurs de licences SolidNetWork peuvent choisir les licences SOLIDWORKS® Simulation de leur groupe de licences à utiliser lorsqu'ils ajoutent SOLIDWORKS Simulation. Ils peuvent également réaliser une mise à niveau de la licence SOLIDWORKS Simulation sans décharger le complément, au cas où ils auraient besoin d'un type de licence plus élevée pour des études plus avancées.

  1. Pour utiliser une licence SOLIDWORKS Simulation spécifique :
    1. Dans SOLIDWORKS, cliquez sur Outils > Compléments et, dans la boîte de dialogue Complément, sélectionnez SOLIDWORKS Simulation.
    2. Dans SOLIDWORKS Simulation (CommandManager), cliquez sur la flèche Bas [image] pour afficher une liste des licences sur votre serveur pouvant prendre en charge Simulation.

    3. Sélectionnez la licence SOLIDWORKS Simulation appropriée.
  2. Pour vérifier ou modifier votre licence SOLIDWORKS Simulation actuelle, cliquez sur la flèche Bas [image] dans SOLIDWORKS Simulation (CommandManager).

    La licence en cours d'utilisation porte une coche. Si des types de licences plus avancées sont disponibles, vous pouvez faire une mise à niveau.
    Vous ne pouvez pas rétrograder une licence SOLIDWORKS Simulation. Désactivez le complément SOLIDWORKS Simulation et ajoutez à nouveau la licence à un niveau inférieur.
  3. Facultatif : Pour désactiver le complément, cliquez sur SOLIDWORKS Simulation (CommandManager) ou supprimez-le dans Outils > Compléments.
Les cas suivants utilisent toujours l'ordre des licences :
  • Lors du lancement de SOLIDWORKS Simulation.
  • Si SOLIDWORKS Simulation est ajouté dans Outils > Compléments.
  • Si vous cliquez sur SOLIDWORKS Simulation sans préciser de licence dans la liste déroulante.
Sujet parent Administration des licences SolidNetWork.


Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative

Vous pouvez configurer un ordinateur de réseau pour servir à la fois de gestionnaire de licences distribuant les licences SolidNetWork et d'emplacement de l'image administrative à partir de laquelle les utilisateurs peuvent installer le logiciel SOLIDWORKS.

Les ordinateurs clients peuvent se procurer des licences auprès du gestionnaire de licences puis installer SOLIDWORKS depuis le même ordinateur.

Cette configuration nécessite l'installation du gestionnaire de licences et de l'image administrative sur le même ordinateur. Commencez par installer le gestionnaire de licences puis créez et déployez l'image administrative.
Pour plus de détails, voir:
  • Installer et activer un Gestionnaire de licences
  • Déployer vers des clients multiples
Sujet parent Administration des licences SolidNetWork.


Gestion des licences FLEXnet Publisher

La gestion des licences SolidNetWork est basée sur FLEXnet Publisher®.

Pour obtenir des informations supplémentaires sur la gestion des licences FLEXnet Publisher, voir le License Administration Guide (Guide d'administration des licences) de FLEXnet Publisher dans le répertoire d'installation SolidNetwork License Manager (\Docs\flexuser\licensingenduserguide.pdf).

Pour obtenir les informations les plus récentes sur la gestion des licences FLEXnet Publisher, contactez Acresso Software®.

Sujet parent Administration des licences SolidNetWork.


Dépannage

Reportez-vous à ces rubriques pour vous aider à résoudre les problèmes d'installation.

Table des matières

  • Utilisation de la licence de réseau

  • Fichiers journaux du Gestionnaire d'installation SOLIDWORKS

    Les fichiers journaux du Gestionnaire d'installation SOLIDWORKS sont disponibles pour vous aider à résoudre les problèmes d'installation.

  • Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS

    Le Gestionnaire d'installation SOLIDWORKS télécharge les fichiers d'installation dont il a besoin vers le dossier que vous spécifiez. Cette rubrique fournit des réponses aux questions fréquemment posées concernant le dossier de téléchargement.

  • Dépannage des licences SolidNetWork

    Si l'installation du logiciel SolidNetWork License Manager échoue, consultez les explications possibles suivantes.

  • Dépannage relatif aux mises à niveau

    Si vous rencontrez des problèmes lorsque vous mettez à niveau vers une nouvelle version SOLIDWORKS, consultez les explications possibles suivantes.

  • Validation de votre carte graphique lors de l'installation ou de la mise à niveau

    Lorsque vous terminez l'installation ou la mise à niveau de SOLIDWORKS sur votre ordinateur, vous devriez exécuter SOLIDWORKS Rx pour vous assurer que votre ordinateur utilise une carte graphique et un pilote de carte graphique pris en charge.


Utilisation de la licence de réseau

Cette boîte de dialogue s'ouvre lorsque le serveur n'a plus assez de licences pour un produit.

Cliquez sur la flèche dans la case Produit pour afficher tous les choix de produits. Le choix inclut SOLIDWORKS et tous les compléments que vous pouvez acheter.

Nombre total de licences est le nombre total de licences que vous avez acheté.

Licences disponibles est le nombre de licences qui ne sont pas utilisées actuellement.

La case Licences utilisées par vous donnent des informations sur chaque personne utilisant une licence actuellement.

Sujet parent Dépannage
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Dépannage relatif aux mises à niveau
Validation de votre carte graphique lors de l'installation ou de la mise à niveau


Fichiers journaux du Gestionnaire d'installation SOLIDWORKS

Les fichiers journaux du Gestionnaire d'installation SOLIDWORKS sont disponibles pour vous aider à résoudre les problèmes d'installation.

Ces fichiers journaux se trouvent avec les autres fichiers journaux de l'application SOLIDWORKS.
  • Pour Windows 7 ou version ultérieure :

    C:\Users\nom_utilisateur\AppData\Roaming\SOLIDWORKS\Installation Logs\version_installée

Pour afficher les répertoires des fichiers journaux, vous devrez peut-être définir les Options des dossiers Windows sur Afficher les fichiers et dossiers cachés.

Si les données d'application sont situées sur une lecteur autre que C:, modifiez le chemin d'accès du répertoire en conséquence.

Ce répertoire contient le fichier SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, qui est un journal général de la progression du Gestionnaire d'installation SOLIDWORKS.

Le sous-répertoire Other Logs (Autres journaux) renferme des informations de journal d'installation plus détaillées.

Sujet parent Dépannage
Utilisation de la licence de réseau
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Dépannage relatif aux mises à niveau
Validation de votre carte graphique lors de l'installation ou de la mise à niveau


Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS

Le Gestionnaire d'installation SOLIDWORKS télécharge les fichiers d'installation dont il a besoin vers le dossier que vous spécifiez. Cette rubrique fournit des réponses aux questions fréquemment posées concernant le dossier de téléchargement.

Question Réponse
Comment installer les fichiers dans ce dossier?

Exécutez setup.exe. Vous devrez peut-être télécharger certains fichiers si vous choisissez d'installer des éléments qui n'ont pas été téléchargés antérieurement.

N'installez les fichiers pas en utilisant msiexec (voir ci-dessous).
Puis-je installer des fichiers MSI manuellement à partir de ce dossier en utilisant msiexec ou une autre application?

Non. Le Gestionnaire d'installation ne télécharge pas certains fichiers requis lors de l'exécution de msiexec.
Puis-je sélectionner le même dossier de téléchargement pour chaque version que j'installe?

Les dossiers de téléchargement sont spécifiques à la version. A partir de SOLIDWORKS 2010, le Gestionnaire d'installation de SOLIDWORKS crée automatiquement un sous-dossier spécifique à la version dans le dossier spécifié.

J'ai téléchargé certains produits manuellement sur le site Web de Dassault Systèmes SOLIDWORKS Corporation. Est-ce que le Gestionnaire d'installation peut les installer?
A partir de SW2009, les fichiers téléchargés manuellement peuvent être utilisés par le Gestionnaire d'installation SOLIDWORKS. Cependant, il est préférable d'exécuter le Gestionnaire d'installation SOLIDWORKS, et de sélectionner l'option de téléchargement des fichiers. Le Gestionnaire d'installation SOLIDWORKS indique les fichiers dont vous avez besoin selon ce que vous installez, et vous fournit des liens pour télécharger chaque fichier. Cette option peut être utilisée lorsque la page de téléchargement intégrée ne fonctionne pas (probablement à cause de restrictions de téléchargement imposées par le serveur proxy).
Si Microsoft Internet Explorer vous demande si vous souhaitez enregistrer ou exécuter les fichiers pendant un téléchargement ou une installation, spécifiez toujours d'enregistrer.
Est-ce que les fichiers téléchargés peuvent être partagés avec d'autres utilisateurs?

Oui. Le téléchargement doit alors se faire sur un partage réseau. Chaque client peut ensuite exécuter le Gestionnaire d'installation SOLIDWORKS à partir du partage pour procéder à l'installation.

Aucun téléchargement supplémentaire n'est requis, à moins qu'un utilisateur ne choisisse d'installer des produits qui n'ont pas été sélectionnés au cours du téléchargement initial ou qu'un ordinateur utilisant ce téléchargement pour faire l'installation n'ait un configuration requise différente de celle de l'ordinateur sur lequel vous avez téléchargé les fichiers.

Si vous téléchargez pour le compte d'autres utilisateurs, mais que vous n'installez pas, sélectionnez l'option Télécharger uniquement lorsque vous installez. Cette option vous permet de sélectionner des produits indépendamment de ce qui est installé sur votre système. Cependant, elle ne peut pas être utilisée pour télécharger des correctifs ou pour créer des images administratives.
Comment savoir quand une nouvelle version des produits SOLIDWORKS est disponible?
Vous serez informé de la disponibilité d'une nouvelle version dans les cas suivants:
  • Si vous exécutez la fonction Vérifier la disponibilité de mises à jour ( Démarrer > Tous les programmes > Gestionnaire d'installation de SOLIDWORKS > Vérifier la disponibilité de mises à jour)
  • Si vous avez activé Téléchargement en arrière-plan de SOLIDWORKS.
  • Si vous sélectionnez une version installée de SOLIDWORKS dans Windows et Ajout/Suppression de programmes cliquez sur Modifier
  • Si vous exécutez une version antérieure du Gestionnaire d'installation (sldIM.exe) à partir d'un dossier de téléchargement
Dans ces cas, vous pouvez choisir de télécharger la version plus récente. Le Gestionnaire d'installation SOLIDWORKS téléchargera et exécutera la nouvelle version de lui-même, sans aucun fichier d'installation. Après l'exécution de la nouvelle version du Gestionnaire d'installation SOLIDWORKS, vous pouvez sélectionner un ensemble d'actions d'installation. Le Gestionnaire d'installation SOLIDWORKS déterminera alors quels fichiers d'installation sont requis (et n'ont pas encore été téléchargés) et vous proposera de les télécharger.
Pourquoi le Gestionnaire d'installation SOLIDWORKS ne me laisse-t-il pas sélectionner un autre service pack de produit à installer ?

Les versions du Gestionnaire d'installation SOLIDWORKS n'installent qu'une version spécifique des produits SOLIDWORKS. Si vous voulez installer un autre service pack, vous devez exécuter la version correspondante du Gestionnaire d'installation SOLIDWORKS. Pour trouver la dernière version disponible, voir la rubrique précédente.
Pourquoi le Gestionnaire d'installation SOLIDWORKS ne parvient-il pas à télécharger des fichiers ?

Si des restrictions de serveur proxy empêchent les applications de télécharger des fichiers, le Gestionnaire d'installation SOLIDWORKS ne peut pas télécharger les fichiers automatiquement.

Vous pouvez télécharger les fichiers manuellement, puis les installer à l'aide du Gestionnaire d'installation SOLIDWORKS. Sélectionnez l'option dans le Gestionnaire d'installation SOLIDWORKS pour télécharger des fichiers individuels (par exemple, Téléchargement manuel sur la page Options de téléchargement). Selon votre sélection de produits et votre configuration minimale requise, une page Web apparaît dans une fenêtre séparée contenant des liens pour télécharger tous les fichiers requis manuellement. Ces liens sont identiques à ceux fournis par le Portail clients de SOLIDWORKS, mais vous n'avez pas besoin de chercher les fichiers.
Tous mes produits SOLIDWORKS ne sont pas mis à jour vers le Service Pack le plus récent. Pourquoi la fonction Vérifier la disponibilité m'indique-t-elle que je dispose de la version la plus récente ?

La fonction Vérifier la disponibilité de mises à jour ne vous indique que si vous avez installé (ou que vous exécutez) la dernière version du Gestionnaire d'installation SOLIDWORKS.

Si vous voulez mettre à jour tous les produits à la dernière version installée, dans Ajout/Suppression de programmes, sélectionnez la dernière version de SOLIDWORKS installée puis cliquez sur Modifier.

Puis-je copier un DVD vers un dossier de téléchargement?

Oui, mais les installations risquent d'échouer à moins de copier l'intégralité du contenu de chaque DVD pour cette plate-forme. Le Gestionnaire d'installation SOLIDWORKS recherche les fichiers swdata*.id pour déterminer la version. Si ces fichiers ne sont pas présents, il ne pourra pas reconnaître les fichiers d'installation copiés et vous demandera de les télécharger.
Sujet parent Dépannage
Utilisation de la licence de réseau
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Dépannage relatif aux mises à niveau
Validation de votre carte graphique lors de l'installation ou de la mise à niveau
Conseils pour l'utilisation de SOLIDWORKS avec Microsoft Windows 8


Dépannage des licences SolidNetWork

Si l'installation du logiciel SolidNetWork License Manager échoue, consultez les explications possibles suivantes.

Sujet parent Dépannage
Utilisation de la licence de réseau
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage relatif aux mises à niveau
Validation de votre carte graphique lors de l'installation ou de la mise à niveau

Accéder aux fichiers journaux des licences SolidNetWork

En cas d'erreur avec la licence, la réponse apparaît souvent dans le fichier dossier_installation_Gestionnaire_SNL\lmgrd.log.

Impossible d'obtenir une licence pour SOLIDWORKS. Impossible d'établir la connexion au serveur de licence.

De manière générale, ce problème est créé par les paramètres de port.

  • Les paramètres de port ne correspondent pas entre SolidNetwork License Manager et le client de la licence.
  • Des paramètres de port supplémentaires n'ont peut-être pas été spécifiés pour des versions multiples de SolidNetWork License Manager.
  • Vérifiez que l'ordinateur client peut résoudre et router vers le serveur, compte tenu du nom du serveur. Vérifiez également que le serveur peut résoudre et router vers le client, compte tenu du nom du client.
Pour plus de détails sur les paramètres de port pour les logiciels SolidNetwork License Manager et les clients, voir Utiliser les licences SolidNetWork avec des pare-feu.
Utiliser les licences SolidNetWork avec des pare-feux


Dépannage relatif aux mises à niveau

Si vous rencontrez des problèmes lorsque vous mettez à niveau vers une nouvelle version SOLIDWORKS, consultez les explications possibles suivantes.

Sujet parent Dépannage
Utilisation de la licence de réseau
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Validation de votre carte graphique lors de l'installation ou de la mise à niveau

Mettre à niveau à partir d'une source qui a été déplacée

Lorsque SOLIDWORKS est installé, le Gestionnaire d'installation SOLIDWORKS se souvient de l'emplacement des sources d'installation (disque média, image du disque sur un réseau, etc.). Les sources doivent être disponibles au même endroit lors d'une mise à jour.

Si ce n'est pas le cas ou bien si la source a été supprimée ou si le média source change, le Gestionnaire d'installation SOLIDWORKS produit un message d'erreur. Vous pouvez néanmoins continuer la mise à niveau en naviguant vers un autre emplacement à condition qu'il contienne la même structure de fichiers et de dossiers.


Validation de votre carte graphique lors de l'installation ou de la mise à niveau

Lorsque vous terminez l'installation ou la mise à niveau de SOLIDWORKS sur votre ordinateur, vous devriez exécuter SOLIDWORKS Rx pour vous assurer que votre ordinateur utilise une carte graphique et un pilote de carte graphique pris en charge.

Pour valider une carte graphique et un pilote :

  1. Lorsque le gestionnaire d'installation termine l'installation et affiche la page Terminer, sous Vérifier votre système, cliquez sur Exécuter le diagnostic du système.

    SOLIDWORKS Rx démarre et exécute le diagnostic.

  2. SOLIDWORKS Rx confirme si la carte graphique et le pilote de carte graphique sont pris en charge. Si la carte graphique est prise en charge, mais pas le pilote, un message d'état peut fournir un lien vers un pilote pris en charge.

Tous les dix démarrages de SOLIDWORKS, un message Vérifier votre système s'affiche et recommande une nouvelle exécution du diagnostic du système. Pour supprimer ces notifications, cliquez à l'aide du bouton droit de la souris sur SOLIDWORKS Resource Monitor [image] dans la zone de notification Windows, puis cliquez sur Ignorer les notifications graphiques.

Vous pouvez valider une carte graphique et un pilote n'importe quand en cliquant à l'aide du bouton droit de la souris sur SOLIDWORKS Resource Monitor dans la zone de notification Windows. Le menu contextuel vous permet également d'effectuer les opérations suivantes :
  • Afficher l'aide de SOLIDWORKS Resource Monitor
  • Exécuter le diagnostic du système
  • Ignorer les notifications de maintenance
  • Mettre à jour les pilotes de la carte graphique
Sujet parent Dépannage
Utilisation de la licence de réseau
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Dépannage relatif aux mises à niveau


Aide pour l'application Gestionnaire d'installation SOLIDWORKS

Le Gestionnaire d'installation SOLIDWORKS est une application autonome qui installe et met à jour vos produits SOLIDWORKS.

Le Gestionnaire d'installation SOLIDWORKS est l'outil principal pour le téléchargement, l'installation, la modification, la mise à jour, la réparation et la suppression du logiciel SOLIDWORKS.

Vous pouvez exécuter le Gestionnaire d'installation SOLIDWORKS :
  • A partir d'un DVD SOLIDWORKS, d'un dossier source partagé ou d'un dossier de téléchargement (lorsque vous installez une nouvelle version)
  • A partir du Panneau de configuration, à la page Ajout/Suppression de programmes (lorsque vous modifiez ou supprimez une version existante)
  • Par l'intermédiaire d'une vérification de mises à jour planifiée ou manuelle (lorsque vous recherchez, téléchargez et installez de nouvelles versions)

Les versions de SOLIDWORKS sont dotées du Gestionnaire d'installation SOLIDWORKS spécifique à la version de SOLIDWORKS en question.

Table des matières

  • Téléchargement en arrière-plan de SOLIDWORKS

    L'option de téléchargement en arrière-plan de SOLIDWORKS effectue des téléchargements automatiques des fichiers (par exemple, lorsqu'une nouvelle version de Service Pack est localisée) via des traitements en arrière-plan, vous permettant ainsi de continuer de travailler pendant le téléchargement. Une fois le téléchargement terminé, vous pouvez choisir d'installer maintenant, remettre le téléchargement à plus tard ou le supprimer.

  • Résultats de la vérification de la disponibilité de mises à jour

    La fonction Vérifier la disponibilité de mises à jour recherche les versions plus récentes de SOLIDWORKS.

  • Emplacement de l'image administrative

    Indiquez l'emplacement de l'installation de l'image administrative.

  • Options de téléchargement

    Spécifiez les détails de la fin de l'opération de téléchargement tels que l'emplacement des fichiers téléchargés, comment télécharger les fichiers et s'il faut installer ceux-ci.

  • Options de téléchargement pour les fichiers du Gestionnaire d'installation SOLIDWORKS

    Vous avez choisi de télécharger une version ultérieure du Gestionnaire d'installation SOLIDWORKS. Utilisez cet écran pour spécifier où et comment elle est téléchargée.

  • Télécharger les fichiers d'installation du produit

    Spécifiez où et comment télécharger les fichiers manquants pour le produit spécifié.

  • Progression du téléchargement

    Le Gestionnaire d'installation SOLIDWORKS télécharge, vérifie et extrait tous les fichiers en parallèle pendant ce processus.

  • Download Results

    Indique si le téléchargement s'est bien terminé, a échoué pendant l'opération ou a été annulé.

  • Erreurs d'installation / Installation annulée

    L'installation a rencontré une erreur ou a été annulée.

  • L'installation est terminée

    Le Gestionnaire d'installation SOLIDWORKS a terminé son traitement.

  • Emplacement d'installation

  • Options de mise à niveau

    Une ou plusieurs versions majeures antérieures de SOLIDWORKS sont installées sur cet ordinateur. Vous pouvez créer une nouvelle installation, qui coexistera avec la version antérieure, ou faire une mise à niveau, ce qui supprimera la version antérieure.

  • Progression de l'installation

    Cette écran montre la progression de l'installation.

  • Type d'installation

    Vous pouvez spécifier l'opération d'installation que vous souhaitez exécuter. Par exemple, créer une nouvelle installation, modifier ou réparer une installation existante, créer une image administrative, installer des produits Serveur administratif ou télécharger des fichiers de façon à pouvoir les partager et les installer sur d'autres ordinateurs.

  • Installer et gérer plusieurs ordinateurs

    Le Gestionnaire d'installation SOLIDWORKS propose les outils suivants pour l'installation et la gestion de SOLIDWORKS sur plusieurs ordinateurs.

  • Téléchargement manuel

    Vous avez choisi de télécharger les fichiers manuellement (ou vous avez peut-être choisi de télécharger manuellement la dernière fois que vous avez exécuté le Gestionnaire d'installation SOLIDWORKS).

  • Version plus récente disponible

    Le Gestionnaire d'installation a détecté une version plus récente des produits SOLIDWORKS. Vous pouvez choisir d'installer la version contenue dans le DVD d'installation d'origine ou de télécharger et d'installer la nouvelle version.

  • Aucune nouvelle version disponible

    Aucune version plus récente ne peut être téléchargée. Continuer à installer la version indiquée.

  • Processus détectés

    Le Gestionnaire d'installation SOLIDWORKS a détecté sur cet ordinateur des processus qui pourraient empêcher la réussite de l'installation.

  • Sélection des produits

    Vous pouvez spécifier les produits à installer, modifier, télécharger ou supprimer.

  • Produits à télécharger

    Sélectionnez les produits SOLIDWORKS à télécharger à l'emplacement spécifié.

  • Produits à réparer

    Lorsque vous spécifiez Réparer cette installation, cet écran affiche les produits SOLIDWORKS, avec les numéros de version, qui peuvent être réparés par cette version du Gestionnaire d'installation SOLIDWORKS.

  • Numéros de série

    Les numéros de série, qui se trouvent sur la boîte du produit, associent votre ordinateur aux produits SOLIDWORKS que vous avez achetés.

  • Installation du serveur

    Les produits Serveur que vous tentez d'installer sont listés, ainsi que les résultats des installations.

  • SolidNetWork License Manager

    Indiquez les options d'installation du serveur de SolidNetwork License Manager.

  • Résumé

    Le Gestionnaire d'installation SOLIDWORKS a toutes les informations nécessaires pour terminer l'opération d'installation.

  • Avertissements de la vérification du système

    L'option de vérification du système a signalé des problèmes qui pourraient avoir un impact sur la façon dont vous continuez l'installation. Dans la plupart des cas, vous devriez pouvoir continuer l'exécution du Gestionnaire d'installation SOLIDWORKS.

  • Options de l'Assistance pour le perçage/Toolbox

    Si SOLIDWORKS Toolbox est installé, SOLIDWORKS comprend une bibliothèque de types de perçages standard et de composants.

  • Désinstaller des produits

    Lorsque vous sélectionnez Supprimer ou Désinstaller des programmes dans le Panneau de configuration, cet écran affiche les produits SOLIDWORKS (avec les numéros de version), qui peuvent être désinstallés par cette version du Gestionnaire d'installation SOLIDWORKS. Choisissez une désinstallation standard, personnalisée ou complète.

Conseils pour l'utilisation de SOLIDWORKS avec Microsoft Windows 8


Téléchargement en arrière-plan de SOLIDWORKS

L'option de téléchargement en arrière-plan de SOLIDWORKS effectue des téléchargements automatiques des fichiers (par exemple, lorsqu'une nouvelle version de Service Pack est localisée) via des traitements en arrière-plan, vous permettant ainsi de continuer de travailler pendant le téléchargement. Une fois le téléchargement terminé, vous pouvez choisir d'installer maintenant, remettre le téléchargement à plus tard ou le supprimer.

L'option de téléchargement en arrière-plan est activée par défaut lorsque vous installez SOLIDWORKS.

Lorsque le Gestionnaire d'installation est exécuté, que ce soit pour une installation ou pour un téléchargement, le processus de téléchargement en arrière-plan est interrompu. A titre d'exemple, il interrompt tous les téléchargements en cours, il interdit le lancement d'autres téléchargements et ne permet pas de changer la spécification du fichier de téléchargement.

Vous pouvez désactiver le téléchargement en arrière-plan durant l'installation. Sur la page Résumé, sous Options de téléchargement, désactivez l'option Utiliser le téléchargement en arrière-plan pour les service packs à venir.

Lorsque cette option est activée, l'icône s'affiche dans la barre d'état système de Windows de la barre d'outils:

Cliquez sur cette icône pour activer les fonctions suivantes :
  • Aide sur le téléchargement en arrière-plan
  • Suspendre le téléchargement
  • Reprendre le téléchargement
  • Annuler le téléchargement
  • Options d'installation
  • Modifier l'emplacement du téléchargement
  • Vérifier la disponibilité de mises à jour
  • Rechercher automatiquement des mises à jour
  • Télécharger automatiquement des mises à jour
  • Désactiver le téléchargement en arrière-plan

Aide sur le téléchargement en arrière-plan

Ouvrez cette rubrique d'aide pour le téléchargement en arrière-plan dans le Guide d'installation de SOLIDWORKS.

Suspendre/reprendre le téléchargement

Si un téléchargement s'effectue en arrière-plan, cliquez sur Suspendre le téléchargement pour interrompre l'opération, sachant que vous pouvez continuer le téléchargement plus tard en cliquant sur Reprendre le téléchargement.

Annuler le téléchargement

Si un téléchargement est en cours, interrompez-le et supprimez tous les fichiers téléchargés par l'option Téléchargement en arrière-plan.
Vous ne pouvez pas reprendre un téléchargement annulé.

Options d'installation

Lorsque le téléchargement est terminé, vous pouvez choisir parmi les options suivantes :
  • Installer maintenant : Installez les fichiers téléchargés.
  • Me le rappeler ultérieurement : N'installez pas les fichiers téléchargés, mais créez un message pour vous rappeler de reprendre l'opération plus tard.
  • Supprimer ce téléchargement : N'installez pas les fichiers téléchargés et supprimez-les. (Cette option est pratique lorsque vous avez finalement décidé de ne pas installer les fichiers téléchargés).

Modifier l'emplacement du téléchargement

Changez l'emplacement du téléchargement des fichiers en arrière-plan.

Cette option n'est pas disponible lorsqu'un téléchargement est soit en cours soit suspendu.

Vérifier la disponibilité de mises à jour

Exécutez la fonction Vérifier la disponibilité de mises à jour du Gestionnaire d'installation SOLIDWORKS.

Recherche automatique des mises à jour

Exécutez régulièrement la fonction Vérifier la disponibilité de mises à jour, vous avertissant des mises à jour disponibles au téléchargement.

Téléchargement automatique des mises à jour

Exécutez régulièrement la fonction Vérifier la disponibilité de mises à jour, téléchargeant les mises à jour à mesure de leur disponibilité.

Désactivation et réactivation du téléchargement en arrière-plan SOLIDWORKS

Vous pouvez désactiver le téléchargement en arrière-plan en cliquant sur l'icône et en sélectionnant l'option Désactiver le téléchargement en arrière-plan.

Pour réactiver le téléchargement en arrière-plan, cliquez sur Démarrer > Tous les programmes > Gestionnaire d'installation SOLIDWORKS > Téléchargement en arrière-plan SOLIDWORKS.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Résultats de la vérification de la disponibilité de mises à jour

La fonction Vérifier la disponibilité de mises à jour recherche les versions plus récentes de SOLIDWORKS.

Si vous disposez de privilèges d'administrateur sur l'ordinateur, vous pouvez exécuter la commandeVérifier la disponibilité de mises à jour manuellement :
  • Sous Windows, cliquez sur Démarrer > Programmes > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour
  • Dans SOLIDWORKS, cliquez sur ? > Vérifier la disponibilité de mises à jour.
L'option Vérifier la disponibilité de mises à jour n'est pas disponible pour les clients installés depuis des images administratives.

Version plus récente disponible

Le Gestionnaire d'installation SOLIDWORKS a détecté une version plus récente des produits SOLIDWORKS. Vous pouvez mettre à jour en sélectionnant le Gestionnaire d'installation SOLIDWORKS pour cette version.

La version plus récente peut télécharger les fichiers d'installation en fonction des produits que vous spécifiez dans l'installation. Vous pouvez partager les fichiers téléchargés avec d'autres utilisateurs qui effectuent des installations par l'intermédiaire du Gestionnaire d'installation SOLIDWORKS.

Ces téléchargements sont uniquement destinés au Gestionnaire d'installation SOLIDWORKS.
Les options suivantes sont disponibles:
  • Si plusieurs versions sont disponibles, vous pouvez en sélectionner une dans la liste.
  • Pour des détails sur cette version, cliquez sur Voir ce que comprend cette mise à niveau.
Cliquez sur Suivant pour extraire et exécuter la version sélectionnée du Gestionnaire d'installation SOLIDWORKS.

Aucun nouveau téléchargement disponible/Impossible de vérifier la disponibilité de nouvelles versions

Le gestionnaire d'installation SOLIDWORKS n'a pas trouvé de version plus récente des produits SOLIDWORKS, soit parce que vous installez la dernière version disponible, soit parce qu'il n'a pas pu se connecter au site SOLIDWORKS pour vérifier.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Emplacement de l'image administrative

Indiquez l'emplacement de l'installation de l'image administrative.

Quand vous créez une image administrative, les options suivantes s'appliquent:
Emplacement de la nouvelle image | C'est l'emplacement du répertoire dans lequel le Gestionnaire d'installation SOLIDWORKS créera la nouvelle image. | Cet emplacement ne peut pas contenir une image administrative existante. L'image administrative doit se trouver dans un dossier pouvant être partagé pour le déploiement client.
Estimation de l'espace requis pour la création de l'image | Il s'agit de l'espace supplémentaire requis pour l'image administrative. | Vérifiez que le disque sur lequel vous installez a suffisamment d'espace libre pour prendre en charge les composants de l'image requis.
Créer une image à partir de | C'est l'emplacement du répertoire depuis lequel vous installez les produits SOLIDWORKS. Cette option s'affiche uniquement si l'option Installer uniquement est spécifiée. Pour plus de détails, voir Options de téléchargement.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Options de téléchargement

Spécifiez les détails de la fin de l'opération de téléchargement tels que l'emplacement des fichiers téléchargés, comment télécharger les fichiers et s'il faut installer ceux-ci.

Le Gestionnaire d'installation SOLIDWORKS permet la distribution électronique du logiciel (DEL). Si vous n'installez pas à partir d'un DVD SOLIDWORKS, vous êtes invité à spécifier la source des produits SOLIDWORKS que vous installez.

Pour obtenir des réponses à vos questions sur le dossier de téléchargement, voir Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS.

Que voulez-vous faire ?

Sélectionnez l'une des options suivantes :

Télécharger et installer/Télécharger et créer une image

Une fois le téléchargement terminé, le Gestionnaire d'installation SOLIDWORKS exécute une installation en utilisant les fichiers téléchargés.

Télécharger uniquement. Vous pouvez télécharger une fois puis partager les fichiers téléchargés avec plusieurs ordinateurs.

Le Gestionnaire d'installation SOLIDWORKS n'exécute pas d'installation après son téléchargement.

De manière générale, vous spécifiez cette option si vous téléchargez les fichiers pour configurer un ensemble de fichiers d'installation à partager entre plusieurs ordinateurs.

Si vous spécifiez cette option, il vous est alors demandé de choisir entre deux ensembles de fichiers à télécharger :
  • Fichiers pour CET ordinateur : Le téléchargement comprendra uniquement les fichiers manquants dans l'ensemble de fichiers d'installation qui se trouve actuellement sur l'ordinateur.
    Ce téléchargement devrait être plus petit car il contient :
    • Seulement les fichiers que vous avez sélectionnés dans la page Sélection des produits.
    • Seulement les fichiers prérequis nécessaires à l'ordinateur mais pas encore installés.

    Cependant, si vous essayez d'utiliser cet ensemble de fichiers téléchargés sur un autre ordinateur pour exécuter une installation, certains fichiers pourraient manquer (parce que l'ensemble de fichiers d'installation de l'autre ordinateur pourrait être différent de celui-ci). Vous pouvez utiliser ces fichiers de téléchargement pour réaliser une installation sur un autre ordinateur, mais lors de l'exécution de l'installation, il se peut que vous deviez télécharger d'autres fichiers pour compléter l'ensemble de fichiers d'installation sur cet ordinateur.

  • Fichiers à partager avec N'IMPORTE QUEL ordinateur : Le téléchargement contiendra l'ensemble complet de fichiers d'installation pouvant servir à installer cette version sur tout ordinateur.

    Ce téléchargement sera plus volumineux car il contient l'ensemble complet des fichiers que vous pouvez utiliser pour installer cette version d'un produit sur n'importe quel ordinateur.

    Si vous avez spécifié un ensemble limité de produits à télécharger, cette option ignore cette sélection et télécharge tous les produits contenus dans la version du produit.

    Le téléchargement contiendra tous les produits requis pour créer une image administrative, et pas seulement les fichiers requis pour une installation individuelle.

Installation uniquement/Création d'une image uniquement. J'ai déjà tous les fichiers d'installation nécessaires.

Le Gestionnaire d'installation SOLIDWORKS ne télécharge aucun fichier mais utilise les fichiers qui se trouvent dans le répertoire sélectionné.

Cliquez sur Parcourir pour accéder à un autre emplacement. Par exemple, vous pouvez naviguer jusqu'à un DVD d'installation ou un dossier de téléchargement, à condition que cet emplacement contienne tous les fichiers requis.

Si un message d'erreur vous informe que le dossier est incomplet et que vous vous attendiez à ce que tous les fichiers d'installation soient présents à cet emplacement, les explications possibles sont les suivantes :
  • Vous avez choisi d'installer un composant qui n'a pas encore été téléchargé ou a été sélectionné par défaut.
  • Les fichiers ont été téléchargés sur un autre ordinateur avec une configuration minimale différente.
  • Vous aviez précédemment effectué une installation client et vous créez à présent une image administrative qui requiert un plus grand nombre de fichiers.

Vous pouvez soit naviguer jusqu'à un dossier contenant tous les fichiers (par exemple, un DVD), soit sélectionner une des options de téléchargement.

Où souhaitez-vous télécharger les fichiers nécessaires ?

Il s'agit de l'emplacement du dossier de téléchargement.

Dans certains cas, il se peut que cette option soit visible, mais désactivée. Par exemple, si vous avez spécifié Installation uniquement, le Gestionnaire d'installation SOLIDWORKS installera tous les fichiers téléchargés contenus dans le répertoire spécifié pour cette option, plutôt que d'utiliser un dossier de téléchargement distinct.

Que vous téléchargiez ces fichiers ou que vous y accédiez depuis votre propre emplacement, tous les fichiers doivent être téléchargés dans le même dossier de téléchargement.

Taille estimée du téléchargement

L'espace disque requis estimé pour le téléchargement dépend de la liste complète des composants choisis, qu'il s'agisse d'un nouveau téléchargement ou que vous repreniez un téléchargement interrompu.

Ainsi, si vous reprenez un téléchargement antérieur, le Gestionnaire d'installation SOLIDWORKS ne télécharge que les fichiers qui ne l'ont pas encore été. La durée de téléchargement peut alors être inférieure à la durée estimée.

Si le téléchargement d'un fichier a été complété dans le téléchargement précédent, sa taille n'est pas comprise dans cette estimation. Par conséquent, l'estimation peut être plus importante que la taille réelle du téléchargement.

Quelle méthode de téléchargement souhaitez-vous utiliser ?

Il existe deux options :

Téléchargement manuel

Dans certains cas, un serveur proxy peut empêcher les chargements automatiques depuis le Gestionnaire d'installation SOLIDWORKS.

En sélectionnant cette option, vous pouvez télécharger manuellement tous les fichiers par l'intermédiaire d'une page Web puis continuer l'exécution du Gestionnaire d'installation SOLIDWORKS pour terminer les opérations d'installation. Cette page Web est personnalisée par le gestionnaire d'installation pour télécharger uniquement les fichiers nécessaires pour terminer l'installation SOLIDWORKS.

Accélérer les téléchargements en utilisant plus de bande passante du réseau

Le programme de téléchargement utilise un algorithme qui augmente la vitesse de téléchargement en accroissant la bande passante du réseau utilisée pendant le téléchargement.

Dans certains cas, ceci peut affecter la performance du réseau. Si vous rencontrez des problèmes lors du téléchargement, il se peut que cette option ne soit pas prise en charge par le serveur proxy. Essayez de la désactiver et recommencez le téléchargement. Pour plus de détails, consultez votre administrateur réseau.

Cette option s'applique seulement aux téléchargements automatiques. Elle n'a aucun impact sur les téléchargements manuels.

Utilisation de Téléchargement en arrière-plan de SOLIDWORKS

Vous pouvez utiliser l'option Téléchargement en arrière-plan SOLIDWORKS pour exécuter le téléchargement ou pour télécharger les futures versions de SOLIDWORKS Service Pack dès qu'elles sont disponibles.

L'option Téléchargement en arrière-plan de SOLIDWORKS peut détecter et télécharger automatiquement de nouvelles mises à jour de Service Pack en arrière-plan et vous avertir lorsque le téléchargement est terminé et que les fichiers sont prêts pour l'installation. Pour plus de détails, voir Téléchargement en arrière-plan de SOLIDWORKS.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Options de téléchargement pour les fichiers du Gestionnaire d'installation SOLIDWORKS

Vous avez choisi de télécharger une version ultérieure du Gestionnaire d'installation SOLIDWORKS. Utilisez cet écran pour spécifier où et comment elle est téléchargée.

Pour obtenir des réponses à vos questions sur le dossier de téléchargement, voir Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS.

Cet écran apparaît uniquement si le dossier de téléchargement par défaut présente un problème (par exemple, s'il n'y a pas d'accès en écriture ou d'accès au réseau). De manière générale, il vous suffit d'indiquer un répertoire de téléchargement de rechange pour continuer.

Répertoire de téléchargement

Parcourez jusqu'à la destination des fichiers du Gestionnaire d'installation SOLIDWORKS.

La taille du téléchargement et l'espace requis sont affichés. L'espace requis tient compte de l'espace supplémentaire nécessaire au dézippage de certains téléchargements et est supérieur à la taille réelle du téléchargement.

Activer l'accélération du téléchargement

Si vous choisissez cette option, le programme de téléchargement utilise un algorithme pour augmenter la vitesse de téléchargement.

L'accélération du téléchargement augmente l'utilisation de la bande passante et peut affecter la performance du réseau. Consultez votre administrateur réseau avant d'activer cette option.

Si l'accélération du téléchargement n'est pas prise en charge par le serveur proxy, cette option est automatiquement désactivée.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Télécharger les fichiers d'installation du produit

Spécifiez où et comment télécharger les fichiers manquants pour le produit spécifié.

Le Gestionnaire d'installation SOLIDWORKS télécharge, vérifie et extrait tous les fichiers en parallèle pendant le processus de téléchargement.

Si vous quittez cet écran, le reste de l'installation est annulé.

Pour savoir quelles sont les conséquences d'une annulation et pour des instructions sur la façon de terminer des installations interrompues, consultez Erreurs d'installation.

Répertoire de téléchargement

Parcourez jusqu'à la destination des fichiers téléchargés.

La taille du téléchargement et l'espace requis sont affichés. L'espace requis tient compte de l'espace supplémentaire nécessaire au dézippage de certains téléchargements et est supérieur à la taille réelle du téléchargement.

Pour obtenir des réponses à vos questions sur le dossier de téléchargement, voir Dossier de téléchargement du Gestionnaire d'installation de SOLIDWORKS.

Options de téléchargement

Accélérer les téléchargements en utilisant plus de bande passante du réseau

Le programme de téléchargement utilise un algorithme qui augmente la vitesse de téléchargement en accroissant la bande passante du réseau utilisée pendant le téléchargement.

Dans certains cas, ceci peut affecter la performance du réseau. Si vous rencontrez des problèmes lors du téléchargement, il se peut que cette option ne soit pas prise en charge par le serveur proxy. Essayez de la désactiver et recommencez le téléchargement. Pour plus de détails, consultez votre administrateur réseau.
L'accélération du téléchargement augmente l'utilisation de la bande passante et peut affecter la performance du réseau. Consultez votre administrateur réseau avant d'activer cette option.

Si l'accélération du téléchargement n'est pas prise en charge par le serveur proxy, cette option est peut-être désactivée automatiquement.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Erreurs d'installation / Installation annulée
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS


Progression du téléchargement

Le Gestionnaire d'installation SOLIDWORKS télécharge, vérifie et extrait tous les fichiers en parallèle pendant ce processus.

Pour annuler le téléchargement une fois qu'il a commencé, cliquez sur Annuler.

Si vous annulez le téléchargement ou si celui-ci échoue, l'écran Téléchargement annulé ou Problème de téléchargement indique les téléchargements incomplets et vous permet de les reprendre ou de fermer l'application.

Pour obtenir des réponses à vos questions sur le dossier de téléchargement, voir Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Download Results

Indique si le téléchargement s'est bien terminé, a échoué pendant l'opération ou a été annulé.

Problème de téléchargement/Téléchargement annulé

Si vous voyez le message Problème de téléchargement, le Gestionnaire d'installation SOLIDWORKS a rencontré des problèmes qui ont empêché le succès du téléchargement.

Si vous voyez Téléchargement annulé, vous avez annulé le téléchargement avant qu'il ne soit terminé.

Pour continuer:

Réessayer/Reprendre les téléchargements automatiques | Pour reprendre le chargement automatique à partir du point où vous l'avez annulé, sélectionnez cette option et cliquez sur Réessayer ou Reprendre le téléchargement.
Télécharger les fichiers individuellement dans un navigateur Web | Dans certains cas, un serveur proxy peut empêcher les chargements automatiques depuis le Gestionnaire d'installation SOLIDWORKS. | En sélectionnant cette option, vous pouvez télécharger manuellement tous les fichiers par l'intermédiaire d'une page Web puis continuer l'exécution du Gestionnaire d'installation SOLIDWORKS pour terminer les opérations d'installation. Cette page Web est personnalisée par le gestionnaire d'installation pour télécharger uniquement les fichiers nécessaires pour terminer l'installation SOLIDWORKS.

Téléchargement terminé

L'écran Téléchargement terminé s'affiche quand le téléchargement est terminé si vous avez spécifié l'option Télécharger uniquement.

Cliquez sur Terminer pour quitter le Gestionnaire d'installation SOLIDWORKS.

N'essayez d'installer aucun de ces produits manuellement. Servez-vous toujours du Gestionnaire d'installation SOLIDWORKS pour installer les fichiers téléchargés.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Erreurs d'installation / Installation annulée

L'installation a rencontré une erreur ou a été annulée.

Si une erreur ou une annulation se produit:
  • Les produits qui ont été installés avant l'erreur ou l'annulation demeurent sur l'ordinateur.
  • Le produit en cours d'installation au moment de l'annulation est supprimé, si possible, de sorte qu'il n'y ait pas d'installations partielles.
  • Les produits restants ne sont pas installés ou désinstallés. Une liste est affichée sous Pas encore de tentative.

    Pour reprendre l'installation ou la désinstallation de ces produits, cliquez sur le lien fourni.

Le Gestionnaire d'installation SOLIDWORKS installe d'abord les composants nécessaires qui manquent, tel que .NET Framework.

Table des matières

  • Récupération d'une installation qui a échoué ou qui a été annulée

    Si une erreur ou une annulation survient pendant l'installation, vous pouvez récupérer à partir de ce point en réexécutant l'installation.

  • Réparer une installation

    Si vous rencontrez des problèmes avec un produit SOLIDWORKS installé, vous pouvez utiliser le Gestionnaire d'installation SOLIDWORKS pour réparer l'installation.

  • Contacter le revendeur SOLIDWORKS

    Si vous n'avez pas réussi à modifier ou à réparer l'installation, contactez votre revendeur SOLIDWORKS local avec les informations réunies sur cet écran. Il pourrait aussi vous être demandé de fournir un fichier zip contenant les fichiers journaux du Gestionnaire d'installation SOLIDWORKS.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Récupération d'une installation qui a échoué ou qui a été annulée

Si une erreur ou une annulation survient pendant l'installation, vous pouvez récupérer à partir de ce point en réexécutant l'installation.

  1. Enregistrez le message d'erreur et le code produit pour l'installation qui a échoué, comme indiqué sur l'écran Erreurs d'installation ou Installation annulée.
    Si le logiciel vous demande un fichier source et que vous n'êtes pas en train de modifier une installation SOLIDWORKS existante, il se peut que l'installation ou l'ordinateur soit corrompu. Contactez votre revendeur SOLIDWORKS.
  2. Redémarrez l'ordinateur.
  3. Pour vous assurer qu'aucun produit SOLIDWORKS n'est en cours d'exécution, appuyez sur Ctrl+Alt+Suppr. pour ouvrir le Gestionnaire des tâches de Windows.
  4. Dans l'onglet Processus, si un ou plusieurs des processus suivants apparaît sous Nom de l'image, sélectionnez-les et cliquez sur Terminer le processus.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Si l'application est déjà installée et que vous étiez en train de la modifier ou de la supprimer, essayez de réparer l'installation. Pour plus de détails, cliquez sur Réparer une installation.
  6. Dans Windows 7 ou version ultérieure, cliquez sur Démarrer > Panneau de configuration > Programmes et fonctionnalités.
  7. Sélectionnez la version de SOLIDWORKS qui a échoué.
    S'il n'y a pas d'entrée pour la version de SOLIDWORKS que vous vouliez installer, recommencez le processus d'installation.
  8. Effectuez l'une des actions suivantes:
    • Pour réessayer, cliquez sur Modifier et sélectionnez tous les produits qui n'ont pas été installés ou ont été ignorés pendant l'installation.

    • Pour ignorer l'installation qui a échoué, cliquez sur Modifier et sélectionnez tous les produits qui ont été ignorés pendant l'installation. Désactivez le produit dont l'installation a échoué.

    • Pour abandonner l'installation, cliquez sur Supprimer et sélectionnez les produits qui ont été installés.
    Ceci ne restaure pas la version antérieure des produits que vous mettez à niveau.
Sujet parent Erreurs d'installation / Installation annulée
Réparer une installation
Contacter le revendeur SOLIDWORKS


Contacter le revendeur SOLIDWORKS

Si vous n'avez pas réussi à modifier ou à réparer l'installation, contactez votre revendeur SOLIDWORKS local avec les informations réunies sur cet écran. Il pourrait aussi vous être demandé de fournir un fichier zip contenant les fichiers journaux du Gestionnaire d'installation SOLIDWORKS.

  1. Localisez les fichiers journaux:
    • Pour Windows 7 ou version ultérieure :

      C:\Users\nomu_tilisateur\AppData\Roaming\SOLIDWORKS\Installation Logs\version_installée\

    Si le dossier est introuvable, il se pourrait qu'il soit caché. Dans l'Explorateur Windows, cliquez sur Outils > Options des dossiers. Dans l'onglet Affichage, sous Paramètres avancés, sélectionnez Afficher les fichiers et dossiers cachés sous Fichiers et dossiers cachés.
  2. Zippez la totalité du contenu de ce dossier, y compris les sous-dossiers.
Sujet parent Erreurs d'installation / Installation annulée
Récupération d'une installation qui a échoué ou qui a été annulée
Réparer une installation


L'installation est terminée

Le Gestionnaire d'installation SOLIDWORKS a terminé son traitement.

Une ou plusieurs des options suivantes peuvent être affichées.

Nouveautés

Dans le cas d'installations individuelles, un document décrivant les nouvelles fonctionnalités dans SOLIDWORKS et ses compléments apparaît à la fin de l'installation.

Dans le cas d'installations d'images administratives, le document apparaît sur les ordinateurs individuels une fois leur installation terminée.

Enquête

Dites-nous ce que vous pensez du processus d'installation en répondant à quelques questions.

Participer au Programme d'amélioration de l'expérience utilisateur de SOLIDWORKS

Des informations au sujet des performances sont envoyées à SOLIDWORKS Corporation dans le but d'améliorer le produit. Le processus est transparent et confidentiel. Sélectionnez l'une des options suivantes :
  • Oui, je souhaite participer
  • Non, merci
  • Me le rappeler ultérieurement
Pour plus d'informations, voir le site Web du Programme d'amélioration de l'expérience utilisateur.

La création de l'image administrative est terminée

Lorsque vous terminez la création de l'image administrative, vous pouvez cliquer sur Personnaliser une image et exécuter l'Editeur d'options d'image administrative pour personnaliser l'image.

Cliquez sur Montrez-moi comment installer cette image sur un client. pour afficher des instructions sur l'utilisation de l'Editeur d'options.

Pour plus de détails sur la configuration d'une image administrative à l'aide de l'Editeur d'options, voir Editeur d'options du Gestionnaire d'images administratives.

Cliquez sur Personnaliser une image pour lancer l'Editeur d'options d'image administrative pour personnaliser les paramètres d'option de cette image administrative.
Vous pouvez le faire en cliquant sur sldAdminOptionEditor.exe dans le répertoire d'installation des images administratives.

Table des matières

  • Vérifier la disponibilité de mises à jour de SOLIDWORKS

    Si vous disposez de droits d'administrateur sur l'ordinateur, le Gestionnaire d'installation SOLIDWORKS vous permet de vérifier la disponibilité de mises à jour soit la densité et les dimensions du modèle, soit en configurant des vérifications automatiques régulières.

  • Programme d'amélioration de l'expérience utilisateur de SOLIDWORKS

    Lorsque vous installez SOLIDWORKS, vous pouvez indiquer que les informations sur la performance soient envoyées à SOLIDWORKS Corporation pour améliorer le produit.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Editeur d'options du Gestionnaire d'images administratives


Vérifier la disponibilité de mises à jour de SOLIDWORKS

Si vous disposez de droits d'administrateur sur l'ordinateur, le Gestionnaire d'installation SOLIDWORKS vous permet de vérifier la disponibilité de mises à jour soit la densité et les dimensions du modèle, soit en configurant des vérifications automatiques régulières.

  1. Démarrez le Gestionnaire d'installation SOLIDWORKS en effectuant l'une des actions suivantes :

    • Dans SOLIDWORKS, cliquez sur ? > Vérifier la disponibilité de mises à jour.

    • Sous Windows, cliquez sur Démarrer > Programmes > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour.

    Le Gestionnaire d'installation SOLIDWORKS vous informe s'il y a des mises à jour disponibles.
  2. Si c'est le cas, choisissez si vous voulez les télécharger et les installer.
  3. Pour activer les vérifications automatiques, lorsque le Gestionnaire d'installation SOLIDWORKS a terminé son traitement, sélectionnez Vérifier la disponibilité de mises à jour tous les __ jours et spécifiez la fréquence.
Sujet parent L'installation est terminée
Programme d'amélioration de l'expérience utilisateur de SOLIDWORKS


Programme d'amélioration de l'expérience utilisateur de SOLIDWORKS

Lorsque vous installez SOLIDWORKS, vous pouvez indiquer que les informations sur la performance soient envoyées à SOLIDWORKS Corporation pour améliorer le produit.

SOLIDWORKS utilise ces informations pour déterminer les tendances relatives à l'utilisation et à la qualité des produits. Notre but est de fournir des produits de la plus haute qualité et les journaux de performance nous aident à atteindre ce but.

Le processus est transparent. Toutes les informations contenues dans les fichiers journaux sont traitées de façon confidentielle. Elles ne sont utilisées à aucune autre fin et personne ne vous contactera.

Pour en savoir plus, visitez le site Web du Programme d'amélioration de l'expérience utilisateur.

Sujet parent L'installation est terminée
Vérifier la disponibilité de mises à jour de SOLIDWORKS


Emplacement d'installation

Les options suivantes s'appliquent aux installations, à l'exception de la création d'images administratives :
Installer les produits sélectionnés dans | C'est l'emplacement du répertoire dans lequel vous installez SOLIDWORKS. Si vous mettez à niveau ou modifiez une installation, tous les fichiers doivent être installés vers l'emplacement existant pour cette installation. Dans ce cas, il ne vous est pas possible de changer l'emplacement de l'installation SOLIDWORKS existante.
Estimation de l'espace requis pour l'installation | Il s'agit de l'espace supplémentaire requis pour les produits à installer ou modifier. | Vérifiez que le disque sur lequel vous effectuez l'installation a suffisamment d'espace libre pour prendre en charge les composants requis.
Installer à partir de | C'est l'emplacement du répertoire depuis lequel vous installez SOLIDWORKS. Cette option s'affiche uniquement si l'option Installer uniquement est spécifiée. Pour plus de détails, voir Options de téléchargement.
Consultez votre administrateur système avant de changer un des emplacements d'installation de SOLIDWORKS.

Emplacements de l'image administrative

Quand vous créez une image administrative, les options suivantes s'appliquent :
Emplacement de la nouvelle image | C'est l'emplacement du répertoire dans lequel le Gestionnaire d'installation SOLIDWORKS créera la nouvelle image. | Cet emplacement ne peut pas contenir une image administrative existante.
Estimation de l'espace requis pour la création de l'image | Il s'agit de l'espace supplémentaire requis pour l'image administrative. | Vérifiez que le disque sur lequel vous effectuez l'installation a suffisamment d'espace libre pour prendre en charge les composants de l'image requis.
Créer une image à partir de | C'est l'emplacement du répertoire depuis lequel vous installez les produits SOLIDWORKS. Cette option s'affiche uniquement si l'option Installer uniquement est spécifiée. Pour plus de détails, voir Options de téléchargement.
Emplacement de l'image existante | Quand vous mettez à niveau une image administrative, le Gestionnaire d'installation SOLIDWORKS crée une nouvelle image sur la base des paramètres de cette image existante. L'image existante n'est pas modifiée. C'est l'emplacement de l'image d'origine que vous avez spécifié dans l'écran Bienvenue qui est affiché.

Eviter d'utiliser des chemins de répertoire spécifiques à une version

Si vous spécifiez un numéro de version dans un emplacement du répertoire d'installation (par exemple, C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2019\) et que vous mettez ensuite à niveau vers SOLIDWORKS 2020, vous aurez un répertoire d'installation de SOLIDWORKS 2020 appelé SOLIDWORKS 2019.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Options de téléchargement


Options de mise à niveau

Une ou plusieurs versions majeures antérieures de SOLIDWORKS sont installées sur cet ordinateur. Vous pouvez créer une nouvelle installation, qui coexistera avec la version antérieure, ou faire une mise à niveau, ce qui supprimera la version antérieure.

Créez une nouvelle installation de version SOLIDWORKS.

Si vous choisissez de créer une nouvelle installation, vous pouvez sélectionner les produits SOLIDWORKS à installer.

Pour chacun des produits sélectionnés, une nouvelle installation de la version majeure est créée. Les versions majeures antérieures restent sur l'ordinateur, sauf SOLIDWORKS Electrical et SOLIDWORKS PDM Client.

Si vous désélectionnez un produit, sa nouvelle version n'est pas installée.

La création d'une nouvelle installation peut être utile si vous souhaitez accéder à la version antérieure de SOLIDWORKS même après l'installation de la version plus récente. Par exemple, si vous partagez des fichiers avec d'autres utilisateurs qui utilisent toujours la version plus ancienne, vous pouvez éviter les incompatibilités de versions pour les fichiers enregistrés dans la version plus récente.

Mettre à niveau SOLIDWORKS version_majeure_précédente vers SOLIDWORKS 2020 version_majeure_actuelle

Si vous choisissez la mise à niveau, vous pouvez sélectionner les produits SOLIDWORKS à mettre à niveau. Pour chacun des produits sélectionnés, une nouvelle installation est créée et les anciennes versions sont supprimées.

Si vous désélectionnez un produit, sa nouvelle version n'est pas installée et la version antérieure est conservée sur l'ordinateur.

Eléments à prendre en compte concernant SOLIDWORKS Electrical et SOLIDWORKS PDM Client

Vous ne pouvez installer qu'une seule version de SOLIDWORKS Electrical sur une machine. Si vous créez une nouvelle installation de SOLIDWORKS et que vous sélectionnez SOLIDWORKS Electrical comme l'un des produits à installer, l'ancienne version de SOLIDWORKS Electrical est supprimée.

Effectuez une sauvegarde de l'environnement SOLIDWORKS Electrical existant avant d'installer une nouvelle version. Dans SOLIDWORKS Electrical Schematic, sélectionnez Fichier Archiver l'environnement. Dans SOLIDWORKS Electrical 3D, sélectionnez SOLIDWORKS Electrical > Outils > Archiver l'environnement.

La version majeure de SOLIDWORKS PDM Client doit correspondre à la version majeure de SOLIDWORKS PDM Server. Si vous ne souhaitez pas mettre à niveau SOLIDWORKS PDM Server, ne sélectionnez pas SOLIDWORKS PDM Client pour la mise à jour.

Pour supprimer un produit sous Windows, utilisez Ajout/Suppression de programmes. Pour plus de détails, voir Supprimer une installation.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Supprimer une installation


Progression de l'installation

Cette écran montre la progression de l'installation.

Pour annuler l'installation une fois qu'elle a commencé, cliquez sur Annuler.

Pour savoir quelles sont les conséquences d'une annulation et pour des instructions sur la façon de terminer des installations interrompues, consultez Erreurs d'installation.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Type d'installation

Vous pouvez spécifier l'opération d'installation que vous souhaitez exécuter. Par exemple, créer une nouvelle installation, modifier ou réparer une installation existante, créer une image administrative, installer des produits Serveur administratif ou télécharger des fichiers de façon à pouvoir les partager et les installer sur d'autres ordinateurs.

Si la version la plus récente du logiciel SOLIDWORKS est déjà installée sur votre ordinateur, les options de modification ou de réparation vous seront proposées.

Individuel

Installez les produits SOLIDWORKS sur cet ordinateur.

Cette option apparaît uniquement si cette version n'est pas installée sur cet ordinateur.

Modifier l'installation individuelle

Modifiez l'installation SOLIDWORKS individuelle existante sur cet ordinateur.

Cette option apparaît uniquement si cette version est installée sur cet ordinateur.
Les modifications comprennent:
  • Ajout ou suppression de composants de SOLIDWORKS
  • Passez à une suite SOLIDWORKS différente (par exemple, SOLIDWORKS Professional, SOLIDWORKS Premium, etc.)
  • Changez le paramètre de numéro de série SOLIDWORKS
    Si vous avez déjà indiqué un numéro de série au cours d'une installation précédente, le Gestionnaire d'installation SOLIDWORKS peut ne pas afficher une invite de nouveau. Pour modifier le numéro de série, vous devez sélectionner cette option.

Réparer l'installation individuelle

Réparez l'installation SOLIDWORKS existante sur cet ordinateur.

Cette option apparaît uniquement si cette version est installée sur cet ordinateur.
Réparer vérifie que tous les fichiers sont présents et correctement enregistrés et corrige les problèmes rencontrés. Les données que vous avez créées ne sont pas affectées.
  • Pour réparer un produit, assurez-vous qu'il est sélectionné.
  • Désactivez les cases à cocher des produits que vous ne voulez pas réparer.
Vous pouvez réparer une installation individuelle. Vous ne pouvez pas réparer l'installation d'une image administrative; vous devez réinstaller en utilisant l'image administrative.

Image administrative

Créez ou mettez à jour une image administrative à déployer sur plusieurs ordinateurs.

Pour des détails sur l'installation de SOLIDWORKS sur plusieurs clients en utilisant l'image administrative, voir Utilisation des images administratives.

Lorsque vous créez ou mettez à jour des images administratives:
  • Vous pouvez utiliser les paramètres d'installation d'une image existante pour configurer une nouvelle image ou une image mise à jour, ou vous pouvez utiliser les paramètres d'installation SOLIDWORKS par défaut.
  • Si vous mettez à jour une image existante:
    • Le Gestionnaire d'installation SOLIDWORKS crée une nouvelle copie de l'image, même si vous mettez à jour. L'image d'origine n'est pas modifiée.
    • Vous pouvez créer l'image mise à jour en utilisant les fichiers de l'image existante que vous mettez à jour. Il en résulte un téléchargement moins volumineux.
    Si vous ne spécifiez pas une image pour laquelle un nouveau Service Pack est disponible pour mettre à jour l'image précédente, vous ne pouvez pas profiter du chargement de taille résulte.

Produits Serveur

Les produits Serveur SOLIDWORKS comprennent SOLIDWORKS Electrical, SOLIDWORKS PDM et SolidNetWork License Manager.

Pour SOLIDWORKS Electrical et SOLIDWORKS PDM, vous pouvez choisir d'installer les outils de client et serveur sur le même ordinateur ou sur des ordinateurs différents.

Pour plus de détails sur l'installation de ces serveurs, consultez les rubriques correspondantes dans l'aide.

Télécharger et partager tous les fichiers

Téléchargez les fichiers d'installation pour les produits SOLIDWORKS sélectionnés sans les installer.

Cette option ne s'affiche pas lorsque vous effectuez l'installation à partir de DVD.
Le contenu des fichiers téléchargés est le même que celui des fichiers disponibles sur les DVD d'installation de SOLIDWORKS. La sélection de cette option télécharge la totalité des fichiers d'installation, quels que soient les fichiers déjà installés sur votre ordinateur. Vous pouvez ensuite copier les fichiers vers un périphérique portable ou un répertoire de réseau et les utiliser pour installer le logiciel SOLIDWORKS sur d'autres ordinateurs. Vous pouvez également utiliser cette méthode pour configurer un serveur à partir duquel les utilisateurs peuvent effectuer les installations.
Cette méthode diffère de la création d'une image administrative.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Utilisation des images administratives
SOLIDWORKS PDM
Administrer des licences avec SolidNetWork License Manager
SOLIDWORKS Electrical


Installer et gérer plusieurs ordinateurs

Le Gestionnaire d'installation SOLIDWORKS propose les outils suivants pour l'installation et la gestion de SOLIDWORKS sur plusieurs ordinateurs.

Images administratives de SOLIDWORKS

Si vous installez SOLIDWORKS sur plusieurs ordinateurs, vous pouvez créer une image administrative, puis déployer l'application sur d'autres ordinateurs.

SOLIDWORKS PDM

SOLIDWORKS PDM est un produit de gestion de documents basé sur la même architecture client/serveur que SOLIDWORKS Enterprise PDM. Il est disponible en deux versions : Standard et Professional. SOLIDWORKS PDM utilise une base de données Microsoft SQL Server pour gérer les coffres-forts de fichiers.

SolidNetWork License Manager

Avec SolidNetwork License Manager, le nombre d'utilisateurs peut dépasser le nombre de licences en faisant "flotter" l'utilisation des licences. Lorsqu'une licence client n'est pas utilisée, elle est disponible pour un autre utilisateur SOLIDWORKS.

Vous pouvez également utiliser SolidNetWork License Manager pour distribuer les licences pour les compléments SOLIDWORKS (par exemple, FeatureWorks).

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Téléchargement manuel

Vous avez choisi de télécharger les fichiers manuellement (ou vous avez peut-être choisi de télécharger manuellement la dernière fois que vous avez exécuté le Gestionnaire d'installation SOLIDWORKS).

Cliquez sur le lien pour ouvrir une page Web générée automatiquement qui contient une liste complète des fichiers dont vous avez besoin pour terminer le téléchargement.

Vous devez télécharger dans le dossier spécifié dans la page Résumé. L'installation ne pourra commencer que lorsque tous les fichiers seront téléchargés dans ce dossier.

Après avoir terminé les téléchargements manuels, cliquez sur Suivant pour continuer.

Si vous souhaitez télécharger automatiquement, vous pouvez changer l'option en retournant à la page Résumé et en changeant les réglages Options de téléchargement.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Version plus récente disponible

Le Gestionnaire d'installation a détecté une version plus récente des produits SOLIDWORKS. Vous pouvez choisir d'installer la version contenue dans le DVD d'installation d'origine ou de télécharger et d'installer la nouvelle version.

Si vous installez à partir d'un téléchargement

Sélectionnez l'une des options suivantes :
  • Continuer l'installation de la version.

    Sélectionnez cette option pour poursuivre l'installation de la version contenue dans le téléchargement initial.

  • Télécharger et installer une nouvelle version : version.

    Sélectionnez cette option pour télécharger et installer la nouvelle version. Si plusieurs nouvelles versions sont disponibles, vous pouvez sélectionner la version à télécharger et à installer.

Si vous installez à partir d'un DVD

Sous Voulez-vous utiliser la version plus récente ?, choisissez l'une des options suivantes :
  • Non, continuer l'installation de version à partir de ce DVD. Vous pouvez ensuite procéder à la mise à jour.

    Sélectionnez cette option pour continuer l'installation avec le Gestionnaire d'installation en cours.

    Une fois l'installation terminée, vous pouvez rechercher et installer des mises à jour avec le Gestionnaire d'installation. Pour vérifier la disponibilité de mises à jour, exécutez Démarrer > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour.
    Vérifier la disponibilité de mises à jour est disponible uniquement si vous disposez de privilèges d'administration sur l'ordinateur.

    L'avantage de cette méthode est que le téléchargement est moins volumineux. Les inconvénients sont qu'il s'agit d'un processus en deux étapes et que les fichiers téléchargés sont spécifiques à la version (et ne peuvent pas être partagés par d'autres utilisateurs utilisant des versions différentes).

  • Oui, installer avec ce DVD, puis télécharger et effectuer la mise à jour en utilisant version.

    Sélectionnez cette option pour télécharger et exécuter une version ultérieure du Gestionnaire d'installation afin d'installer les produits SOLIDWORKS pour cette version.

    Si un nouveau Service Pack peu volumineux est disponible pour mettre à jour la version DVD, le Gestionnaire d'installation installe la version d'origine depuis le DVD, puis applique la mise à jour du Service Pack. Il en résulte un téléchargement moins volumineux.

    Vous pouvez parvenir au même résultat en sectionnant l'option permettant de continuer l'installation depuis le DVD et en appliquant la mise à jour plus tard.

    L'avantage de cette option est qu'il s'agit d'un processus en une seule étape.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Aucune nouvelle version disponible

Aucune version plus récente ne peut être téléchargée. Continuer à installer la version indiquée.

Pour poursuivre l'installation, cliquez sur Suivant.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Processus détectés

Le Gestionnaire d'installation SOLIDWORKS a détecté sur cet ordinateur des processus qui pourraient empêcher la réussite de l'installation.

  • Pour continuer l'installation, effectuez une des opérations suivantes:
    • Fermez ces processus (par exemple en utilisant le Gestionnaire de tâches de Microsoft Windows) puis appuyez sur Réessayer.
    • Cliquez sur Ignorer pour continuer sans fermer les processus.
  • Pour arrêter l'installation, appuyez sur la touche Annuler.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Sélection des produits

Vous pouvez spécifier les produits à installer, modifier, télécharger ou supprimer.

Dans la liste des produits :
  • La liste des produits est la liste complète des produits disponibles dans la suite spécifiée au-dessus de la liste des produits.
  • Pour visualiser l'action que vous projetez pour un composant particulier, cliquez sur le nom du composant (mais pas dans la case à cocher). L'installation projetée s'affiche dans le champ d'information situé sous l'entrée de produit dans la liste.
  • Vous pouvez cocher la case adjacente au composant du produit pour changer l'action d'installation de ce composant. (A titre d'exemple, si vous installez ou supprimez des composants, la sélection de la case à cocher indique que le composant doit être installé ou supprimé et la suppression de la sélection de la case à cocher indique que le composant ne doit ni être installé ni supprimé).
  • Si vous effectuez une modification d'installation, un astérisque (*) apparaît à gauche des composants quand vous modifiez la sélection de produits.
  • Si un composant dispose de sous-composants d'installation optionnels, une icône + est visible à côté de son nom. Pour afficher les sous-composants disponibles pour un composant, cliquez sur l'icône +.
  • Si un composant est développé de façon à afficher des sous-composants optionnels, une icône - s'affiche à côté de son nom. Pour réduire la liste des sous-composants, cliquez sur l'icône -.

Si vous appliquez un Service Pack, vous ne pouvez pas sélectionner les fonctionnalités de SOLIDWORKS (FeatureWorks, par exemple) apparaissant sous SOLIDWORKS. La raison en est que vous ne pouvez pas ajouter ou supprimer de composant avec ce type de mise à niveau.

Les actions réalisées par le Gestionnaire d'installation SOLIDWORKS sont régies par un ensemble de règles de coexistence des produits Pour plus de détails, voir Règles de coexistence des produits.

Le Gestionnaire d'installation SOLIDWORKS sélectionne ces composants de produits par défaut :
  • Si vous effectuez une mise à niveau ou une mise à niveau d'un Service Pack, le Gestionnaire d'installation SOLIDWORKS sélectionne les produits installés couramment.
  • Dans le cas contraire, le Gestionnaire d'installation SOLIDWORKS sélectionne tous les produits auxquels vous avez droit.
Pour réduire la durée de l'installation et du téléchargement, ainsi que l'espace disque requis, développez les composants de produits et désactivez la case à cocher pour les composants dont vous n'avez pas besoin.

Si le Gestionnaire d'installation SOLIDWORKS n'a pas pu vérifier les produits auxquels vous avez droit, vous pouvez cliquer sur Sélectionnez différents packages ou produits pour changer la suite de produits (par exemple, SOLIDWORKS Professional ou SOLIDWORKS Premium) à installer ou à modifier. Le Gestionnaire d'installation SOLIDWORKS liste tous les produits SOLIDWORKS sur votre média d'installation qui sont compatibles avec la suite sélectionnée. Vous pouvez sélectionner tous les produits que vous avez achetés ou que vous avez le droit d'évaluer.

Recherche SOLIDWORKS

La fonction Recherche SOLIDWORKS est un puissant outil de recherche sur le texte complet de documents SOLIDWORKS et de 3D ContentCentral. La recherche affiche un aperçu, ainsi que l'emplacement et le nom du fichier.

Après l'installation, la Recherche SOLIDWORKS indexe les documents SOLIDWORKS pour permettre des recherches plus rapides. Seuls les fichiers SOLIDWORKS sont indexés par défaut.

Si ce n'est pas déjà fait, Windows Desktop Search est automatiquement installé sur votre ordinateur en même temps que la Recherche SOLIDWORKS.

Langues prises en charge

Développez le produit SOLIDWORKS et le composant Langues pour voir quelles langues vous pouvez installer.

La spécification des Langues limite le nombre de langues installées pour le produit SOLIDWORKS uniquement. Les installations d'autres produits ne sont pas affectées par cette spécification. A titre d'exemple, toutes les langues sont installées pour eDrawings® et SOLIDWORKS PDM.

Espace requis

Le Gestionnaire d'installation SOLIDWORKS indique la taille totale de l'installation ou la taille totale du téléchargement au bas de la page.

  • Si vous avez sélectionné l'option Télécharger uniquement, taille du téléchargement s'affiche. La taille du téléchargement est l'espace total requis pour tous les fichiers téléchargés (sans compter l'espace additionnel requis pour dézipper les fichiers une fois le téléchargement terminé). Le chiffre indiqué est une estimation.
    Tous les fichiers nécessaires à l'installation sont inclus dans la taille totale du téléchargement. Si certains fichiers ont déjà été téléchargés dans le dossier de téléchargement actuel, ils ne seront pas à nouveau téléchargés. C'est pourquoi la taille de téléchargement réelle peut être inférieure à la taille totale indiquée. Il se peut aussi que vous n'ayez pas besoin de télécharger de fichiers.
  • Sinon, Taille de l'installation s'affiche. La taille de l'installation correspond à la différence d'utilisation de l'espace disque une fois l'installation terminée. En raison de la compression des fichiers, les chiffres indiqués ne sont que des estimations.

    Si vous procédez à une mise à niveau ou que vous supprimez une installation existante, la taille de l'installation peut être nulle.

    Le chiffre indiqué n'inclut pas l'espace requis pour télécharger ou extraire des fichiers si cela est requis pour l'installation.

    Si des téléchargements sont requis et que vous les téléchargez sur le même lecteur, il se peut que l'espace requis soit significativement supérieur à la taille de l'installation.

    Afin de réduire la durée de téléchargement ou d'installation pour les futures modifications, ne supprimez pas les fichiers téléchargés après l'installation. Les mises à jour ou correctifs suivants nécessitent généralement d'avoir accès à la totalité des derniers fichiers d'installation.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Règles de coexistence des produits


Produits à télécharger

Sélectionnez les produits SOLIDWORKS à télécharger à l'emplacement spécifié.

Les produits disponibles pour téléchargement sont déterminés par le numéro de série fourni:

  • L'action à réaliser s'affiche à droite de chaque composant.
  • Si un composant dispose de sous-composants d'installation optionnels, une icône + s'affiche adjacente au composant. Pour afficher les sous-composants disponibles pour un composant, cliquez sur l'icône +.
  • Si un composant a été développé pour afficher des sous-composants optionnels, une icône - s'affiche adjacente au composant. Pour réduire la liste des sous-composants, cliquez sur l'icône -.
  • Cochez la case à gauche de chaque composant pour sélectionner la façon dont il est géré par le Gestionnaire d'installation SOLIDWORKS.
Le Gestionnaire d'installation SOLIDWORKS télécharge tous les produits auxquels vous avez droit, à moins que vous n'en décidiez autrement. Pour réduire la durée de téléchargement et l'espace disque requis, développez la liste des produits et sélectionnez les composants dont vous n'avez pas besoin.

Si le Gestionnaire d'installation SOLIDWORKS n'a pas pu vérifier les produits auxquels vous avez droit, vous pouvez sélectionner la suite SOLIDWORKS à télécharger. Le Gestionnaire d'installation SOLIDWORKS liste tous les produits SOLIDWORKS qui sont compatibles avec la suite sélectionnée.

Si le Gestionnaire d'installation SOLIDWORKS n'a pas pu vérifier les produits auxquels vous avez droit, vous pouvez cliquer sur Sélectionnez différents packages ou produits pour changer la suite de produits (par exemple, SOLIDWORKS Professional ou SOLIDWORKS Premium) à installer ou à modifier. Le Gestionnaire d'installation SOLIDWORKS liste tous les produits SOLIDWORKS sur votre média d'installation qui sont compatibles avec la suite sélectionnée. Vous pouvez sélectionner tous les produits que vous avez achetés ou que vous avez le droit d'évaluer.

Langues prises en charge

La spécification des Langues limite le nombre de langues installées pour le produit SOLIDWORKS uniquement. Les installations d'autres produits ne sont pas affectées par cette spécification. A titre d'exemple, toutes les langues sont installées pour eDrawings® et SOLIDWORKS Explorer.

Espace requis

L'espace requis pour le téléchargement est indiqué en fonction des produits sélectionnés. La taille du téléchargement est l'espace total requis pour tous les fichiers téléchargés (sans compter l'espace additionnel requis pour dézipper les fichiers une fois le téléchargement terminé). Le chiffre indiqué est une estimation.

Afin de réduire la durée de téléchargement ou d'installation pour les futurs mises à jour ou correctifs, ne supprimez pas les fichiers téléchargés après l'installation. Les mises à jour ou correctifs suivants nécessitent généralement d'avoir accès à la totalité des derniers fichiers d'installation.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Produits à réparer

Lorsque vous spécifiez Réparer cette installation, cet écran affiche les produits SOLIDWORKS, avec les numéros de version, qui peuvent être réparés par cette version du Gestionnaire d'installation SOLIDWORKS.

Réparer vérifie que tous les fichiers sont présents et correctement enregistrés et corrige les problèmes rencontrés. Les données que vous avez créées ne sont pas affectées.
  • Pour réparer un produit, assurez-vous qu'il est sélectionné.
  • Désactivez les cases à cocher des produits que vous ne voulez pas réparer.

Cliquez sur Réparer pour commencer la réparation des produits sélectionnés.

Vous pouvez réparer une installation individuelle. Vous ne pouvez pas réparer l'installation d'une image administrative; vous devez la réinstaller.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Numéros de série

Les numéros de série, qui se trouvent sur la boîte du produit, associent votre ordinateur aux produits SOLIDWORKS que vous avez achetés.

Si des produits SOLIDWORKS sont déjà installés sur votre ordinateur, leur numéro de série s'affiche par défaut :
  • Saisissez votre numéro de série SOLIDWORKS s'il n'est pas déjà affiché.
  • Si vous disposez de numéros de série correspondant à des produits qui ne sont pas inclus dans votre licence SOLIDWORKS, saisissez-les dans les champs appropriés.
  • Si votre administrateur SOLIDWORKS vous a affecté des produits dans le Portail administrateur SOLIDWORKS, utilisez la fonction de Connexion en haut de la page pour renseigner automatiquement les numéros de série qui vous sont affectés.

Si vous avez une connexion Internet, les numéros de série que vous fournissez sont utilisés pour déterminer les produits auxquels vous avez droit à mesure que l'installation se poursuit.

Comme il existe différentes façons d'acheter les produits SOLIDWORKS, certains numéros de série couvrent deux produits ou plus. Ainsi, un numéro de série SOLIDWORKS peut vous permettre d'installer SOLIDWORKS Simulation sans entrer de numéro de série SOLIDWORKS Simulation séparé. De plus, certains produits ne requièrent pas de numéro de série. Si vous avez des questions au sujet de vos numéros de série, contactez votre revendeur agréé.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Installation du serveur

Les produits Serveur que vous tentez d'installer sont listés, ainsi que les résultats des installations.

Etat de l'installation du serveur

Les installations des produits Serveur sont effectuées par une application d'installation externe. Si vous n'êtes pas dans cette application actuellement, vous devez y passer pour terminer l'installation.

Cliquez sur Annuler pour arrêter les installations de produits Serveur.

Installation du serveur terminée

L'application d'installation externe a terminé ses opérations.

Cliquez sur Terminer ou Suivant.
  • Si vous installez d'autres produits administratifs (par exemple une image administrative SOLIDWORKS), cette installation se poursuit.
  • Si les installations de produits Serveur étaient les seules effectuées, le Gestionnaire d'installation SOLIDWORKS se ferme.

Installation de serveur annulée ou échouée

Si une installation de produit Serveur a échoué ou a été annulée après avoir commencé, les serveurs non installés sont listés.

Cliquez sur Fermer ou Suivant.
  • Si vous avez spécifié d'autres installations de produits administratifs, le Gestionnaire d'installation SOLIDWORKS reprendra ses opérations.
  • Si les installations de produits Serveur étaient les seules effectuées, le Gestionnaire d'installation SOLIDWORKS se ferme.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


SolidNetWork License Manager

Indiquez les options d'installation du serveur de SolidNetwork License Manager.

Numéros de série

Indiquez les numéros de série de licence SolidNetWork. Vous pouvez indiquer plusieurs numéros de série en les séparant par des virgules.
Les numéros de série de SolidNetWork diffèrent de ceux de SOLIDWORKS.

Emplacement d'installation

Indiquez l'emplacement d'installation de SolidNetwork License Manager.

Si vous actualisez SolidNetwork License Manager, vous devez l'installer à l'emplacement de l'installation actuelle.

Pour plus d'informations

Pour de plus amples informations sur l'installation, la configuration et l'utilisation de SolidNetWork License Manager, voir Administrer des licences avec SolidNetWork License Manager.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Administrer des licences avec SolidNetWork License Manager


Résumé

Le Gestionnaire d'installation SOLIDWORKS a toutes les informations nécessaires pour terminer l'opération d'installation.

Pour continuer: | Cliquez sur le bouton Action maintenant pour lancer l'opération d'installation (par exemple, Installer maintenant, Créer maintenant, Télécharger maintenant, Modifier maintenant).
Pour changer les réglages de votre installation: | Cliquez sur MODIFIER [image] pour la section que vous souhaitez modifier (par exemple, Produits, Emplacement d'installation, Options Toolbox).
Pour annuler: | Cliquez sur Annuler pour quitter le Gestionnaire d'installation SOLIDWORKS sans modifier les composants de l'installation.
Pour retourner à une page précédente: | Cliquez sur Précédent pour retourner à une page précédente du Gestionnaire d'installation SOLIDWORKS.
Pour des informations sur un ensemble donné d'options d'installation, (par exemple, Produits, Emplacement d'installation, Options Toolbox, etc.) :
  1. Cliquez sur MODIFIER [image] en regard de la section sur laquelle vous voulez des informations.
  2. Dans la page de détails qui s'affiche, cliquez sur Aide pour obtenir des informations sur ces paramètres d'options d'installation.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Avertissements de la vérification du système

L'option de vérification du système a signalé des problèmes qui pourraient avoir un impact sur la façon dont vous continuez l'installation. Dans la plupart des cas, vous devriez pouvoir continuer l'exécution du Gestionnaire d'installation SOLIDWORKS.

Les avertissements qui peuvent survenir à ce niveau sont listés ci-dessous avec des suggestions sur la manière de procéder.

Problèmes de validation du numéro de série

Le Gestionnaire d'installation n'a pas pu vérifier la disponibilité de nouvelles versions car il n'a pas pu valider votre numéro de série. Si vous êtes connecté et que vous avez entré un numéro de série valide, il s'agit peut-être d'un problème temporaire sur notre serveur. Réessayez ultérieurement.

Validation du numéro de série: Le Gestionnaire d'installation n'a pas pu valider votre numéro de série afin de déterminer quels produits vous pouvez installer. Vous pourrez néanmoins choisir les produits à installer, mais vous ne pourrez pas télécharger de fichiers d'installation. Vous devrez fournir l'ensemble des fichiers source téléchargés ou un DVD à partir desquels réaliser l'installation.

Résolution:
  • Vérifiez la connexion Internet. La vérification du numéro de série requiert une connexion Internet valide.
  • Vérifiez que le numéro de série que vous avez saisi, est valide pour les produits que vous essayez d'installer.
  • Certaines installations requièrent un contrat de maintenance valide lors du lancement commercial de la version. Pour de plus amples informations, contactez votre revendeur SOLIDWORKS.
  • Dans la plupart des cas, vous pouvez poursuivre l'installation, sous condition que vous installiez à partir d'un DVD ou d'un ensemble de fichiers téléchargés précédemment.

Version plus récente disponible

Version plus récente disponible

Nouvelles versions disponibles

Une version plus récente de ce produit peut être téléchargée.

Résolution: Lorsque vous exécutez une vérification de disponibilité de mises à jour, il peut vous être demandé d'installer une version ultérieure disponible au téléchargement auprès de SOLIDWORKS. Vous pouvez poursuivre cette opération à l'aide de la version que vous avez indiquée initialement ou vous pouvez télécharger cette version plus récente et l'installer.

Dernière version disponible

Ceci est la dernière version disponible. Cliquez sur Suivant pour continuer.

Aucun nouveau téléchargement disponible

Résolution: Ce message peut s'afficher lorsque vous êtes en train de vérifier la disponibilité de mises à jour pendant une installation ou une modification. Il indique que vous êtes en train d'installer (ou avez installé) la dernière version disponible.

Problèmes de connexion avec Internet

Connexion Internet: Le Gestionnaire d'installation n'a pas pu se connecter au serveur SOLIDWORKS afin de déterminer quels produits vous pouvez installer. Vous pourrez néanmoins choisir les produits à installer, mais vous ne pourrez pas télécharger de fichiers d'installation. Vous devrez fournir les fichiers source sur un DVD ou les fichiers préalablement téléchargés.

Impossible de vérifier la disponibilité de nouvelles versions

Le Gestionnaire d'installation n'a pas pu vérifier la disponibilité de nouvelles versions car il n'a pas pu établir de connexion avec le serveur.

Résolution:
  • Vérifiez la connexion Internet.
  • Vous pouvez poursuivre l'installation, sous condition que vous installiez à partir d'un DVD ou d'un ensemble de fichiers téléchargés précédemment.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Options de l'Assistance pour le perçage/Toolbox

Si SOLIDWORKS Toolbox est installé, SOLIDWORKS comprend une bibliothèque de types de perçages standard et de composants.

Pour obtenir des informations sur la configuration, l'extension et l'utilisation de SOLIDWORKS Toolbox, cliquez sur Aide > Aide de Toolbox dans SOLIDWORKS.
Pour afficher cette aide, vous devrez peut-être démarrer le complément Toolbox à l'aide de la commande Outils > Compléments.

Avant d'utiliser le composant SOLIDWORKS Toolbox, assurez-vous qu'il est configuré en accord avec la politique de votre société ou de votre groupe. Dans de nombreux cas, un groupe configure et assure la maintenance d'un composant Toolbox central. Contactez l'administrateur SOLIDWORKS pour qu'il vous aide à spécifier Toolbox pendant l'installation de SOLIDWORKS.

Vous pouvez modifier la configuration sélectionnée de SOLIDWORKS Toolbox après l'installation. Dans SOLIDWORKS, cliquez sur Outils > Options. Dans l'onglet Options du système, cliquez sur Assistance pour le perçage/Toolbox.

Les sections suivantes décrivent toutes les options que vous pouvez rencontrer sur cet écran pour toutes les configurations. Les options Toolbox que vous voyez dépendent des configurations préexistantes de SOLIDWORKS et de Toolbox sur cet ordinateur, ainsi que des choix que vous avez opérés dans le Gestionnaire d'installation SOLIDWORKS.

Créer une nouvelle version de Toolbox nouvelle_version

Créer une nouvelle version de SOLIDWORKS Toolbox sur cet ordinateur.

Lorsque vous créez une nouvelle version, dans l'écran de Sélection des produits, développez SOLIDWORKS > SOLIDWORKS Toolbox, et sélectionnez les normes à appliquer pour Toolbox. Toutes les normes sont sélectionnées par défaut.

Les versions de Toolbox qui existent sur cet ordinateur ne sont pas modifiées.

Référencer ou mettre à niveau une installation de Toolbox existante

Utilisez une installation Toolbox existante Cliquez sur Parcourir pour spécifier l'emplacement du Toolbox que vous voulez utiliser avec cette installation.

  • Si le composant Toolbox est configuré pour une version majeure antérieure de SOLIDWORKS, il est mis à niveau vers cette version. Toute personnalisation apportée à ce Toolbox est conservée dans l'installation de Toolbox mise à niveau.
    Si le composant Toolbox est mis à niveau vers une nouvelle version majeure de SOLIDWORKS, il devient alors incompatible avec les ordinateurs exécutant des versions majeures antérieures de SOLIDWORKS.
  • Si le composant Toolbox est configuré pour cette version de SOLIDWORKS (ce qui peut être le cas si vous spécifiez une installation réseau partagée de Toolbox qui a déjà été mise à niveau), il n'est alors pas soumis à une mise à niveau.
  • Si vous mettez à niveau Toolbox dans un environnement SOLIDWORKS PDM, des procédures additionnelles sont requises. Pour plus de détails, voir Remarques sur la configuration de SOLIDWORKS Toolbox.

Cette option apparaît dans tous les scénarios d'installation, à l'exception de la création d'une image administrative.

Mettre à niveau la version Toolbox version-antérieure

Copiez une installation de Toolbox configurée pour une version majeure antérieure vers un nouvel emplacement et mettez cette copie à niveau vers cette version.

Cette option apparaît si une version majeure antérieure de SOLIDWORKS est installée sur cet ordinateur, mais que vous avez choisi de ne pas mettre à niveau cette installation vers cette version.
L'objet de cette option est de mettre à niveau Toolbox pour une version majeure antérieure de SOLIDWORKS installée, sans perturber les utilisateurs utilisant l'ancienne version de Toolbox.

Si vous mettez à niveau Toolbox dans un environnement SOLIDWORKS PDM, des procédures additionnelles sont requises. Pour plus de détails, voir Remarques sur la configuration de SOLIDWORKS Toolbox.

Mettre à niveau la version de Toolbox version_antérieure qui est installée

Mettez à niveau cette installation de Toolbox à une version plus récente.
Si le composant Toolbox est mis à niveau vers une nouvelle version majeure de SOLIDWORKS, il devient alors incompatible avec les ordinateurs exécutant des versions majeures antérieures de SOLIDWORKS.

Cette option s'affiche si vous mettez à niveau une version majeure antérieure de SOLIDWORKS vers cette version, et qu'une installation de Toolbox configurée pour cette version antérieure est rencontrée sur l'ordinateur.

Si vous mettez à niveau Toolbox dans un environnement SOLIDWORKS PDM, des procédures additionnelles sont requises. Pour plus de détails, voir Remarques sur la configuration de SOLIDWORKS Toolbox.

Utiliser la version Toolbox version_actuelle qui est installée

Le Gestionnaire d'installation SOLIDWORKS a détecté sur cet ordinateur une installation de Toolbox configurée pour cette version majeure de SOLIDWORKS.

Si vous sélectionnez cette option, SOLIDWORKS utilisera cette version de Toolbox. Aucune mise à niveau n'est effectuée.

Cette option apparaît si une version majeure antérieure de SOLIDWORKS est installée sur cet ordinateur, mais qu'un composant Toolbox est configuré pour cette version. Cela peut se produire si une installation partagée de Toolbox est créée sur un ordinateur qui exécute toujours une version plus ancienne de SOLIDWORKS.

Spécifiez l'emplacement de Toolbox pour l'ordinateur client.

Spécifiez un emplacement de réseau ou de répertoire comme emplacement Toolbox par défaut pour les installations client effectuées à partir d'une image administrative.
Si, lorsque l'installation du client se produit, cet emplacement contient une installation de Toolbox configurée pour une version majeure antérieure de SOLIDWORKS, le Gestionnaire d'installation SOLIDWORKS met ce composant Toolbox à niveau.

Cette option apparaît lorsque vous créez une nouvelle image administrative.

Mettre à niveau ou utiliser la version de Toolbox référencée dans l'image existante pour l'ordinateur client

Utilisez l'emplacement de Toolbox spécifié dans une image administrative que vous mettez à jour.
Si, lorsque l'installation du client se produit, cet emplacement contient une installation de Toolbox configurée pour une version majeure antérieure de SOLIDWORKS, le Gestionnaire d'installation SOLIDWORKS met ce composant Toolbox à niveau.

Sélectionner un autre emplacement Toolbox pour l'ordinateur client

Spécifiez pour Toolbox un autre emplacement que celui qui est spécifié dans une image administrative existante que vous mettez à jour.
Si, lorsque l'installation du client se produit, cet emplacement contient une installation de Toolbox configurée pour une version majeure antérieure de SOLIDWORKS, le Gestionnaire d'installation SOLIDWORKS met ce composant Toolbox à niveau.

Table des matières

  • Remarques sur la configuration de SOLIDWORKS Toolbox

    SOLIDWORKS Toolbox est une fonction puissante et complexe. Cette rubrique résume certains des concepts à prendre en compte lorsque vous configurez Toolbox à l'aide du Gestionnaire d'installation SOLIDWORKS.

  • Format UNC

    Le format UNC (Convention uniforme [ou universelle] d'affectation des noms) spécifie un format de syntaxe des noms de fichiers pour décrire un emplacement de fichiers partagés.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Remarques sur la configuration de SOLIDWORKS Toolbox


Remarques sur la configuration de SOLIDWORKS Toolbox

SOLIDWORKS Toolbox est une fonction puissante et complexe. Cette rubrique résume certains des concepts à prendre en compte lorsque vous configurez Toolbox à l'aide du Gestionnaire d'installation SOLIDWORKS.

Où trouver davantage d'informations à propos de SOLIDWORKS Toolbox

Pour plus d'informations sur la configuration, l'extension et l'utilisation de SOLIDWORKS Toolbox, cliquez sur ? > Aide de Toolbox dans SOLIDWORKS.
Pour afficher cette aide, vous devrez peut-être démarrer le complément Toolbox à l'aide de la commande Outils > Compléments.

Partager Toolbox

Lorsque vous installez Toolbox, vous pouvez placer les données Toolbox sur l'ordinateur local ou dans un emplacement réseau partagé. Il est recommandé de stocker les données Toolbox dans un emplacement réseau. En utilisant un emplacement commun, tous les utilisateurs de SOLIDWORKS partagent un ensemble d'informations parfaitement cohérent.

Si c'est votre première installation, parcourez jusqu'à l'emplacement partagé où vous souhaitez installer Toolbox.

Mise à niveau d'une version existante de Toolbox

Si Toolbox est mise à niveau vers une nouvelle version majeure de SOLIDWORKS, elle devient alors incompatible avec les ordinateurs exécutant des versions majeures antérieures de SOLIDWORKS.

Si d'autres ordinateurs en restent à cette version majeure antérieure et continuent à requérir que Toolbox soit configuré pour cette version, faites une copie de cette version de Toolbox et mettez-la à niveau. La nouvelle installation de SOLIDWORKS mettra à niveau la copie de Toolbox, tandis que les installations antérieures de SOLIDWORKS continueront d'utiliser l'ancienne version de Toolbox.

Configuration de l'accès à Toolbox

Après l'installation, lorsque vous accédez aux composants Toolbox, SOLIDWORKS vérifie leur configuration et émet des suggestions pour en améliorer l'accès et les performances.

Pour accéder à Toolbox quand il est partagé en réseau (utilisation recommandée), servez-vous d'un chemin UNC au serveur sur lequel la version partagée de Toolbox a été installée. Pour plus d'informations, voir Format UNC.

Un administrateur peut créer un mot de passe pour Toolbox et définir les permissions et préférences pour le groupe de travail. La restriction de l'accès à la configuration et aux préférences communes garantit la cohérence des données Toolbox.

Mise à niveau de Toolbox dans un environnement SOLIDWORKS PDM

Quand vous mettez à niveau le logiciel SOLIDWORKS, Toolbox est mis à niveau si des pièces ont été ajoutées. Si le dossier racine de Toolbox est dans un coffre-fort SOLIDWORKS PDM, vous devez préparer le dossier Toolbox avant de lancer la mise à niveau de SOLIDWORKS.

Sur le premier système sur lequel vous allez effectuer la mise à niveau, vous devez utiliser Obtenir la dernière version pour télécharger les fichiers Toolbox vers le cache local et extraire le fichier de base de données Toolbox. Sur les autres systèmes mis à jour, il suffit de télécharger les fichiers Toolbox.

Avant de mettre à niveau :
  • Assurez-vous qu'une sauvegarde complète de la base de données et des archives du coffre-fort a été effectuée.
  • Assurez-vous que des pièces Toolbox ne sont pas extraites ou en cours d'utilisation par tout assemblage actuellement extrait.

Pour mettre Toolbox à niveau:

  1. Dans l'Explorateur Windows, connectez-vous au coffre-fort en tant qu'utilisateur avec toutes les autorisations (extraction, archivage, ajout, suppression).
  2. Cliquez à l'aide du bouton droit de la souris sur le dossier Toolbox et cliquez sur Obtenir la dernière version pour copier tous les fichiers Toolbox et la base de données Toolbox dans votre cache local.
    Si votre serveur d'archives est distant, ceci peut prendre plusieurs minutes.
  3. Extrayez le fichier de base de données Toolbox, SWBrowser.mdb, de \nom_du_dossier_Toolbox\lang\votre_langue .
  4. Exécutez le Gestionnaire d'installation SOLIDWORKS pour effectuer la mise à niveau.
  5. Sur l'écran Résumé, assurez-vous que l'emplacement d'installation sous Options Toolbox est celui du coffre-fort.

    Si ce n'est pas le cas, cliquez sur Modifier, sélectionnez Référencer ou mettre à niveau une installation de Toolbox existante et naviguez jusqu'à l'emplacement de Toolbox dans le coffre-fort.

  6. Une fois la mise à niveau terminée, dans l'Explorateur de fichiers, archivez le dossier Toolbox pour ajouter les nouveaux fichiers ou ceux qui ont été mis à niveau dans le coffre-fort afin que d'autres utilisateurs puissent travailler avec Toolbox.
  7. Pour les mises à niveau vers SOLIDWORKS 2012 ou version ultérieure, accédez à votre dossier Toolbox dans le coffre-fort et assurez-vous que les éléments suivants sont présents :
    • \Nom_du_dossier_Toolbox\Updates
    • \Nom_du_dossier_Toolbox\ToolboxStandards.xml
    • \Nom_du_dossier_Toolbox\Browser\ToolboxFiles.index

      Si ce n'est pas le cas, contactez votre revendeur.

  8. Mettez à jour le reste des ordinateurs qui utilisent l'intégration de SOLIDWORKS PDM avec Toolbox :
    1. Dans l'Explorateur Windows, connectez-vous au coffre-fort en tant qu'utilisateur avec au moins les autorisations de lecture pour le dossier Toolbox.
    2. Cliquez à l'aide du bouton droit de la souris sur le dossier Toolbox et cliquez sur Obtenir la dernière version pour copier les fichiers Toolbox dans votre cache local.
    3. Exécutez le Gestionnaire d'installation SOLIDWORKS pour effectuer la mise à niveau.

      Le programme d'installation détecte que Toolbox a déjà été mis à niveau.

Pour plus de détails sur la configuration de Toolbox dans SOLIDWORKS PDM, voir Configuration de Toolbox dans l'aide de l'Outil d'administration SOLIDWORKS PDM .

Sujet parent Options de l'Assistance pour le perçage/Toolbox
Format UNC


Format UNC

Le format UNC (Convention uniforme [ou universelle] d'affectation des noms) spécifie un format de syntaxe des noms de fichiers pour décrire un emplacement de fichiers partagés.

\\serveur\<volume\<chemin

Par exemple:

\\Disk_Server\SOLIDWORKS\AdminImage

Sujet parent Options de l'Assistance pour le perçage/Toolbox
Remarques sur la configuration de SOLIDWORKS Toolbox


Désinstaller des produits

Lorsque vous sélectionnez Supprimer ou Désinstaller des programmes dans le Panneau de configuration, cet écran affiche les produits SOLIDWORKS (avec les numéros de version), qui peuvent être désinstallés par cette version du Gestionnaire d'installation SOLIDWORKS. Choisissez une désinstallation standard, personnalisée ou complète.

La désinstallation standard supprime les fichiers et dossiers du programme d'un produit SOLIDWORKS. Par défaut, tous les produits SOLIDWORKS de la version sélectionnée sont spécifiés pour une désinstallation standard.

Une désinstallation personnalisée supprime un ou plusieurs éléments parmi les suivants: Fichiers et dossiers du programme, clés de registre et dossiers de données, tels que SOLIDWORKS Toolbox et les fichiers et dossiers de l'emplacement de téléchargement d'origine.

Une désinstallation complète supprime les répertoires d'installation, les clés de registre et les dossiers de données.

Pour désinstaller un produit:
  1. Sur l'écran Désinstaller, assurez-vous que le produit est sélectionné.

    Si vous désinstallez tous les produits, le Gestionnaire d'installation SolidWorks est désinstallé aussi.

  2. Désélectionnez les produits que vous ne voulez pas supprimer.

    Si vous gardez un produit, le Gestionnaire d'installation SOLIDWORKS n'est pas supprimé.

  3. Choisissez une désinstallation complète ou personnalisée.
    1. Cliquez sur Modifier dans Options avancées.

      L'écran Options avancées apparaît. L'option Fichiers et dossiers programme est cochée.

    2. Sélectionnez une option ou plus pour une désinstallation personnalisée ou toutes les options pour une désinstallation complète.
    3. Cliquez sur Retour au résumé.
    4. Sur l'écran Résumé, développez Options avancées pour afficher la méthode de désinstallation et les entrées.
  4. Cliquez sur Supprimer des éléments.
Lorsque vous cliquez sur Supprimer des éléments, le Gestionnaire d'installation SOLIDWORKS commence à supprimer les produits immédiatement.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Mentions légales

© 1995-2019, Dassault Systèmes SolidWorks Corporation, une société de Dassault Systèmes SE, 175 Wyman Street, Waltham, Mass. 02451 USA. Tous droits réservés.

Les informations et le logiciel dont il est question dans ce document peuvent être modifiés sans avis préalable et ne constituent pas un engagement de la part de Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

Aucun matériel ne peut être reproduit ou transmis, quels que soient la manière, les moyens utilisés, électroniques ou manuels, ou le but, sans l’autorisation écrite formelle de DS SolidWorks.

Le logiciel constituant l'objet de ce document est fourni sous licence, et ne peut être utilisé et reproduit que conformément aux termes de la licence. Toutes les garanties données par DS SolidWorks concernant le logiciel et la documentation qui l’accompagne sont énoncées dans le Contrat de licence, et aucun des termes explicites ou implicites de ce document ne peut être considéré comme une modification ou un amendement desdites garanties.

Mentions de brevets

Le logiciel de CAO mécanique 3D et/ou Simulation SOLIDWORKS® est protégé par les brevets américains 6 611 725 ; 6 844 877 ; 6 898 560 ; 6 906 712 ; 7 079 990 ; 7 477 262 ; 7 558 705 ; 7 571 079 ; 7 590 497 ; 7 643 027 ; 7 672 822 ; 7 688 318 ; 7 694 238 ; 7 853 940 ; 8 305 376 ; 8 581 902 ; 8 817 028 ; 8 910 078 ; 9 129 083 ; 9 153 072 ; 9 262 863 ; 9 465 894 ; 9 646 412 ; 9 870 436 ; 10 055 083 ; 10 073 600 ; 10 235 493 et autres brevets étrangers (par exemple, EP 1 116 190 B1 et JP 3 517 643).

Le logiciel eDrawings® est protégé par les brevets américains 7 184 044 ; 7 502 027 ; et le brevet canadien 2 318 706.

Brevets Etats-Unis et brevets étrangers en instance.

Marques commerciales et noms de produits pour les produits et services SOLIDWORKS

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, et le logo eDrawings logo sont des marques déposées et FeatureManager est une marque déposée codétenue par DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360 et TolAnalyst sont des marques de DS SolidWorks.

FeatureWorks est une marque déposée de HCL Technologies Ltd.

SOLIDWORKS 2020, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional, SOLIDWORKS Simulation Premium, SOLIDWORKS Flow Simulation, SOLIDWORKS CAM, SOLIDWORKS Manage, eDrawings Viewer, eDrawings Professional, SOLIDWORKS Sustainability, SOLIDWORKS Plastics, SOLIDWORKS Electrical Schematic Standard, SOLIDWORKS Electrical Schematic Professional, SOLIDWORKS Electrical 3D, SOLIDWORKS Electrical Professional, CircuitWorks, SOLIDWORKS Composer, SOLIDWORKS Inspection, SOLIDWORKS MBD, SOLIDWORKS PCB powered by Altium, SOLIDWORKS PCB Connector powered by Altium et SOLIDWORKS Visualize sont des noms de produit de DS SolidWorks.

Les autres noms de marques ou noms de produits sont les marques ou les marques déposées de leurs titulaires respectifs.

LOGICIEL INFORMATIQUE COMMERCIAL - BREVET

Le Logiciel est un "article commercial" tel que ce terme est défini à l'article 48 C.F.R. 2.101 (octobre 1995). Il consiste en un "logiciel informatique commercial" ("commercial computer software") et une "documentation du logiciel informatique commercial" ("commercial software documentation") au sens où ces deux expressions sont utilisées à l'Article 48 C.F.R. 12.212 (septembre 1995) et est concédé au gouvernement des Etats-Unis (a) pour acquisition par ou pour le compte d'organismes civils, conformément aux stipulations de l'Article 48 C.F.R. 12.212; ou (b) pour acquisition par ou pour le compte du Département américain de la Défense, conformément aux stipulations des Articles 48 C.F.R. 227.7202-1 (juin 1995) et 227.7202-4 (juin 1995)

Si vous recevez une demande d'un organisme du Gouvernement des Etats-Unis pour fournir le Logiciel avec des droits allant au-delà de ceux énoncés ci-dessus, vous vous engagez à notifier DS SolidWorks de l'étendue de la demande et DS SolidWorks disposera de cinq (5) jours ouvrables pour accepter ou rejeter une telle demande, à sa seule discrétion. Contractant/Fabricant: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright pour les produits SOLIDWORKS Standard, Premium, Professional et Education

Portions de ce logiciel © 1986-2018 Siemens Product Lifecycle Management Software Inc. Tous droits réservés.

Ce travail contient les logiciel suivants qui sont la propriété de Siemens Industry Software Limited :

D-Cubed® 2D DCM © 2019. Siemens Industry Software Limited. Tous droits réservés.

D-Cubed® 3D DCM © 2019. Siemens Industry Software Limited. Tous droits réservés.

D-Cubed® PGM © 2019. Siemens Industry Software Limited. Tous droits réservés.

D-Cubed® CDM © 2019. Siemens Industry Software Limited. Tous droits réservés.

D-Cubed® AEM © 2019. Siemens Industry Software Limited. Tous droits réservés.

Portions de ce logiciel © 1998-2019 HCL Technologies Ltd.

Des portions de ce logiciel incorporent PhysX™ par NVIDIA 2006-2010.

Portions de ce logiciel © 2001-2019 Luxology, LLC. Tous droits réservés, brevets en instance.

Portions de ce logiciel © 2007-2019 DriveWorks Ltd.

© 2012, Microsoft Corporation. Tous droits réservés.

Inclut la technologie de bibliothèque PDF Adobe®.

Copyright 1984-2016 Adobe Systems Inc. et ses concédants. Tous droits réservés. Protégé par les brevets américains 6 563 502 ; 6 639 593 ; 6 754 382 ; Brevets en instance.

Adobe, le logo Adobe, Acrobat, le logo Adobe PDF, Distiller et Reader sont des marques déposées ou des marques commerciales d'Adobe Systems Inc. aux Etats-Unis et dans d'autres pays.

Pour obtenir de plus amples informations sur le copyright DS SolidWorks, consultez Aide > A propos de SOLIDWORKS.

Copyright pour les produits SOLIDWORKS Simulation

Portions de ce logiciel © 2008 Solversoft Corporation.

PCGLSS © 1992-2017 Computational Applications and System Integration, Inc. Tous droits réservés.

Copyright pour le produit SOLIDWORKS PDM Professional

Outside In® Viewer Technology, © 1992-2012 Oracle

© 2012, Microsoft Corporation. Tous droits réservés.

Copyright pour les produits eDrawings

Portions de ce logiciel © 2000-2014 Tech Soft 3D.

Portions de ce logiciel © 1995-1998 Jean-Loup Gailly et Mark Adler.

Portions de ce logiciel © 1998-2001 3Dconnexion.

Portions de ce logiciel © 1998-2017 Open Design Alliance. Tous droits réservés.

Le logiciel eDrawings® pour Windows® est fondé en partie sur le travail d'Independent JPEG Group.

Portions d'eDrawings® pour iPad® copyright © 1996-1999 Silicon Graphics Systems, Inc.

Portions d'eDrawings® pour iPad® copyright © 2003 – 2005 Apple Computer Inc.

Copyright pour les produits SOLIDWORKS PCB

Portions de ce logiciel © 2017-2018 Altium Limited.

Copyright pour les produits SOLIDWORKS Visualize

Technologie NVIDIA GameWorks™ sous licence de NVIDIA Corporation. Copyright © 2002-2015 NVIDIA Corporation Tous droits réservés.


Editeur d'options du Gestionnaire d'images administratives

L'Editeur d'options du Gestionnaire d'images administratives de SOLIDWORKS a été amélioré.

  • Les administrateurs peuvent utiliser de nouvelles options de désinstallation complète ou partielle sur les ordinateurs clients Les options de désinstallation sont disponibles dans la section Options d'installation du client de l'Editeur d'options. Pour les afficher, cliquez sur Oui, désinstallation personnalisée, puis sélectionnez les éléments à supprimer.
  • Les administrateurs peuvent également présélectionner des normes SOLIDWORKS Toolbox dans une liste.


SOLIDWORKS PDM

SOLIDWORKS PDM est un produit de gestion de documents basé sur l'architecture client/serveur précédemment appelée SOLIDWORKS Enterprise PDM.

SOLIDWORKS PDM est disponible dans deux types :
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM utilise une base de données Microsoft SQL Server pour gérer les coffres-forts de fichiers.

Ce tableau répertorie les systèmes de base de données, les composants de serveur et les options de client disponibles pour chaque type de produit.
 | PDM Standard | PDM Professional
Conçu pour | Réseaux de bureau petits et moyens, avec généralement moins de 20 utilisateurs simultanés. | Grand réseaux de bureau, avec un grand nombre d'utilisateurs simultanés
Limites | Moins de 1 socket ou 4 cœurs, 1 Go de RAM et une base de données de 10 Go | Limites de SQL Standard : Moins de 4 sockets ou 16 cœurs, 128 Mo de RAM et une base de données de 524 Po
Système de gestion de base de données | Microsoft SQL Server Express 2014 Service Pack 3 ou versions ultérieures (inclus et installé avec SOLIDWORKS) | Microsoft SQL Server 2014 Service Pack 3 ou versions ultérieures (inclus séparément avec SOLIDWORKS) ou instances déjà installées de Microsoft SQL Server 2014 Service Pack 3 ou versions ultérieures.
Requiert SolidNetWork License Manager ? | Oui | Oui
Inclut un serveur d'archives et un serveur de base de données ? | Oui | Oui
Inclut le serveur Web SOLIDWORKS PDM, le serveur Web2 et le serveur Web API ? | Non | Oui
Types de clients | Natif | Natif, basé sur navigateur
Compléments client pour CAD Editor | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Microsoft Office Integration, Autodesk Inventor, AutoCAD
Compléments client pour Contributor | DraftSight | DraftSight, Intégration avec Microsoft Office
Compléments client pour Viewer |  | Intégration de Microsoft Office


Conseils pour l'utilisation de SOLIDWORKS avec Microsoft Windows 8

L'interface utilisateur de Windows 8 (et des version ultérieures) diffère de manière significative de celle des versions antérieures de Windows. Non seulement les techniques de navigation sont différentes, mais plusieurs méthodes ont été ajoutées pour accéder aux commandes clés.

Les rubriques suivantes fournissent des instructions sur l'accès à trois des fonctions essentielles avec Windows 8. Consultez ces rubriques lors de l'utilisation de Windows 8 pour installer SOLIDWORKS.
Ces étapes peuvent varier selon la configuration de votre système Windows. Consultez la documentation de Microsoft Windows pour des instructions et des options supplémentaires, surtout pour les systèmes postérieurs à Windows 8.
Installation sur des ordinateurs individuels


Lancer l'installation de SOLIDWORKS

Vous pouvez lancer l'installation de SOLIDWORKS de plusieurs manières : en chargeant un DVD dans l'ordinateur local, en accédant à un répertoire d'installation partagé, ou en téléchargeant depuis SOLIDWORKS.

Pour lancer l'installation de SOLIDWORKS, procédez comme suit :

  • Pour installer sur un ordinateur local à partir d'un disque, insérez le disque approprié dans le lecteur de l'ordinateur.
  • Pour installer à partir d'un répertoire de téléchargement, accédez à celui-ci et double-cliquez sur setup.exe.
  • Pour installer en téléchargeant depuis SOLIDWORKS :
    1. Naviguez jusqu'au site Web de SOLIDWORKS.
    2. Connectez-vous en tant que client sous contrat de maintenance avec votre adresse de messagerie et votre mot de passe ou votre numéro de série SOLIDWORKS.
    3. Sous Self Service (Libre-service), cliquez sur Download Software and Updates (Télécharger le logiciel et les mises à jour).
    4. Sous Download Software (Windows, Mac, Linux), sélectionnez la version et le Service Pack SOLIDWORKS à télécharger.