Installazione e Amministrazione di SOLIDWORKS

Questa guida descrive l'installazione, la gestione delle licenze, l'aggiornamento e l'amministrazione dei prodotti SOLIDWORKS per installazioni singole e multiple.

Installazioni individuali | Funzionamento delle installazioni multiple
Installazione Installazione su uno o alcuni computer. | Installazione Creazione di un'immagine amministrativa distribuita su un numero di computer client.
Licenza Attivazione del computer, licenza online, o licenza in rete. | Licenza Attivazione del computer, licenza online, o licenza in rete.
Aggiornamenti Migrazione di singoli computer a una nuova release. | Aggiornamenti Spostamento di più computer a una nuova release aggiornando l'immagine amministrativa utilizzata per l'installazione su tali computer.
Amministrazione Modifica, riparazione e rimozione delle installazioni tramite l'aggiornamento a nuove release. | Amministrazione Aggiornamento immagini amministrative e clienti, amministrazione licenze di rete.

Gestione installazioni di SOLIDWORKS consente di configurare le impostazioni dei componenti dei prodotti SOLIDWORKS, inclusi SOLIDWORKS, SOLIDWORKS Toolbox, PhotoView 360, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS PCB, SOLIDWORKS Visualize e SOLIDWORKS SolidNetWork License Manager.

SolidNetWork License Manager supporta più client di licenza mediante la distribuzione delle licenze ai client in rete. Ciò consente al numero di utenti di eccedere il numero di licenze grazie all'uso di licenze mobili.

SOLIDWORKS Admin Portal è un sistema di gestione dei servizi e delle risorse basato su cloud che consente di assegnare e gestire le licenze online. L'assegnazione delle licenze è necessaria solo per le licenze online. Per gli altri tipi di licenze, l'assegnazione delle licenze è facoltativa.

Indice

  • Installazione individuale o Immagine amministrativa

    I prodotti SOLIDWORKS devono essere installati singolarmente in ogni computer o è necessario creare un'immagine amministrativa e distribuire l'installazione a tutti i client con un singolo comando?

  • Controllo dei requisiti di sistema e software

    Prima dell'installazione, verificare che il sistema soddisfi i requisiti hardware, di sistema operativo e dei prodotti Microsoft. Si noti che le aggiunte, come SOLIDWORKS Electrical, SOLIDWORKS Visualize ed eDrawings presentano dei requisiti aggiuntivi specifici.

  • Download del supporto di installazione dal Portale clienti

    Tutti i supporti di installazione sono disponibili sul Portale clienti SOLIDWORKS.

  • Impostazione delle opzioni della Gestione installazioni

    Queste opzioni includono le impostazioni per la registrazione e la posizione dei file, la disattivazione dell'accesso a Internet e la lingua utilizzata per le schermate della Gestione installazioni.


Installazione individuale o Immagine amministrativa

I prodotti SOLIDWORKS devono essere installati singolarmente in ogni computer o è necessario creare un'immagine amministrativa e distribuire l'installazione a tutti i client con un singolo comando?

Se si effettua l'installazione solo su un computer o si gestiscono dozzine o centinaia di computer, la scelta è ovvia. Per le altre situazioni, considerare quanto segue.

Installazione individuale | Immagine amministrativa
Gli utenti possono amministrare SOLIDWORKS autonomamente. | L'amministratore di sistema può personalizzare installazioni multiple usando l'Editor opzioni, specificando le opzioni di installazione come la creazione di una nuova installazione o aggiornandone una esistente, eseguendo l'installazione come utente amministrativo, eseguendo comandi esterni prima o dopo l'installazione, raggruppamenti di prodotti diversi e così via.
I computer devono essere fisicamente accessibili alla persona che effettua l'installazione. | I computer client possono essere distanti ma devono essere accessibili dalla stessa rete.
Si possono installare versioni diverse, Service Pack o prodotti su computer diversi con impostazioni indipendenti. | Usando l'Editor opzioni, le immagini amministrative possono mantenere la coerenza nelle versioni, service pack, prodotti ed impostazioni per installazioni multiple.
I computer devono disporre dell'accesso alla rete o all'email. È necessaria una connessione di rete o email per attivare SOLIDWORKS ed eseguire il download dei file. L'accesso alla rete è anche richiesto per la raccolta delle licenze da un server di licenza di rete.

La connessione di rete locale è necessaria per distribuire l'applicazione; le unità dei supporti non sono necessarie sui computer client.

I client possono essere aggiornati automaticamente. Tutti i client implementati dalla stessa immagine amministrativa si trovano nello stesso service pack. Per mantenere versioni multiple, è possibile creare immagini amministrative multiple.

L'attivazione delle licenze può essere automatizzata.

Un'immagine amministrativa necessita di spazio addizionale su disco sul server; i client hanno bisogno dello stesso spazio per le installazioni individuali.

Argomento principale Installazione e Amministrazione di SOLIDWORKS
Controllo dei requisiti di sistema e software
Download del supporto di installazione dal Portale clienti
Impostazione delle opzioni della Gestione installazioni


Controllo dei requisiti di sistema e software

Prima dell'installazione, verificare che il sistema soddisfi i requisiti hardware, di sistema operativo e dei prodotti Microsoft. Si noti che le aggiunte, come SOLIDWORKS Electrical, SOLIDWORKS Visualize ed eDrawings presentano dei requisiti aggiuntivi specifici.

Per accedere ai requisiti di sistema correnti, visitare il sito http://solidworks.com/System_Requirements.

Argomento principale Installazione e Amministrazione di SOLIDWORKS
Installazione individuale o Immagine amministrativa
Download del supporto di installazione dal Portale clienti
Impostazione delle opzioni della Gestione installazioni


Download del supporto di installazione dal Portale clienti

Tutti i supporti di installazione sono disponibili sul Portale clienti SOLIDWORKS.

Se non è possibile accedere al Portale clienti, contattare il proprio rivenditore VAR per ricevere i DVD.

Per scaricare il supporto di installazione dal Portale clienti:

  1. Accedere al Portale clienti SOLIDWORKS come cliente dei servizi in abbonamento, utilizzando il proprio indirizzo e-mail e password o il proprio numero di serie di SOLIDWORKS.
  2. Nella sezione Download, fare clic su Download e aggiornamenti.
  3. Nella pagina Downloads (Download), in Select Version (Seleziona versione), selezionare l'anno della release da scaricare.
  4. Nella scheda SOLIDWORKS, sotto Product (Prodotto), selezionare il prodotto e il Service Pack per il sistema operativo in uso. Per una versione principale, è possibile scaricare:
    • Un file .ZIP che include il set di file completo.
    • Oppure, due file .ZIP: SOLIDWORKS Media (1 of 2) e SOLIDWORKS Media (2 of 2). Dividere il download in due file è comodo se si dispone di una connessione Internet lenta.
      Questa opzione non è disponibile per i Service Pack.
  5. Per la versione principale più recente, fare clic su SOLIDWORKS anno, ad esempio SOLIDWORKS Products 2020 0.0 per scaricare il software in un unico file .ZIP.
  6. Nella pagina SOLIDWORKS Download EULA, fare clic su Accept Agreement and Continue (Accetta Accordo e continua).
  7. Nella pagina successiva, fare clic su Download.

    Il file SolidWorksSetup.exe viene scaricato sul computer. Il file viene estratto in una cartella e viene avviata la Gestione installazioni.

È anche possibile scegliere manual download method (metodo di download manuale). Questa opzione consente di scaricare in modo selettivo il set di file di installazione completo. Se si sceglie questa opzione, seguire le istruzioni sulla pagina Web.
Argomento principale Installazione e Amministrazione di SOLIDWORKS
Installazione individuale o Immagine amministrativa
Controllo dei requisiti di sistema e software
Impostazione delle opzioni della Gestione installazioni


Impostazione delle opzioni della Gestione installazioni

Queste opzioni includono le impostazioni per la registrazione e la posizione dei file, la disattivazione dell'accesso a Internet e la lingua utilizzata per le schermate della Gestione installazioni.

Per impostare le opzioni della Gestione installazioni prima di installare il software:

  1. Se la Gestione installazioni SOLIDWORKS non è aperta, individuare il file SolidWorksSetup.exe nella directory in cui è stato scaricato il file ed estrarne il contenuto.
  2. Nella Gestione installazioni, fare clic con il pulsante destro del mouse sull'icona SOLIDWORKS sulla barra del titolo e selezionare:
    Opzione | Descrizione
    Livelli di accesso installazione Imposta il livello su Alto, Medio o Basso. Livelli più elevati raccolgono più dati per la risoluzione dei problemi, ma possono rallentare l'installazione. Per impostazione predefinita, è selezionato il livello Basso (più veloce), che fornisce le prestazioni migliori e una stabilità maggiore.

    Crea log dell'installatore Windows salva questi file log nella stessa cartella degli altri registri di installazione.

    Opzioni immagine amministrativa | Selezionare Usa nomi file brevi (formato 8.3) o Usa nomi cartelle e nomi file completi.
    Raccogli registri di installazione... | Specificare la directory in cui salvare i registri di installazione. La Gestione installazioni salva questi file in IM_Logs.zip.
    Disattiva l'accesso ad internet | Non è possibile disattivare l'accesso a Internet se si esegue l'installazione con una licenza online.
    Lingua | Imposta la lingua della Gestione installazioni. L'impostazione predefinita è Inglese.
  3. Fare clic su Chiudi.
Argomento principale Installazione e Amministrazione di SOLIDWORKS
Installazione individuale o Immagine amministrativa
Controllo dei requisiti di sistema e software
Download del supporto di installazione dal Portale clienti


Installazioni individuali

Indice

  • Installazione su singoli computer

    Per installare SOLIDWORKS in un singolo computer, sono disponibili vari metodi.

  • Amministrazione delle installazioni individuali

    Solitamente, l'amministrazione di singole installazioni implica la modifica, la riparazione, la rimozione e l'aggiornamento delle installazioni.


Installazione su singoli computer

Per installare SOLIDWORKS in un singolo computer, sono disponibili vari metodi.

Gestione installazioni SOLIDWORKS esegue l'installazione adattandola ai prodotti acquistati. Prima di iniziare l'installazione:

  • Tenere a disposizione il numero di serie di SOLIDWORKS.
  • Verificare che la connessione internet sia operativa. La connessione è richiesta per la verifica dei diritti.

Gestione installazioni SOLIDWORKS richiede vari componenti Microsoft, tra cui Microsoft Windows Installer, Microsoft Visual Studio Tools for Applications, Visual Basic e .NET Framework. Se non sono installate le versioni corrette di tutti componenti Microsoft richiesti, Gestione installazioni SOLIDWORKS li installa automaticamente prima di procedere con l'installazione dei prodotti SOLIDWORKS. Anche il servizio Bonjour per Windows un componente richiesto.

Metodo d'installazione Sintesi della procedura
Download dal Portale clienti SOLIDWORKS
  1. Accedere al Portale clienti SOLIDWORKS.
  2. Effettuare la connessione come utente del servizio di abbonamento, usando il proprio indirizzo di email e password o il proprio numero di serie SOLIDWORKS.
  3. In Self Service, fare clic su Download software e aggiornamenti.
  4. In Download software fare clic sulla versione di SOLIDWORKS da installare.
È necessaria una connessione a Internet e disporre di un abbonamento valido per l'accesso al Portale clienti.
Uso di una directory di download su un server Nella directory di download, fare doppio clic su setup.exe.

Tale directory deve essere accessibile dal computer in cui si installano i prodotti SOLIDWORKS e deve contenere tutti i file di installazione di SOLIDWORKS prima di avviare la procedura. Gestione installazioni SOLIDWORKS riesce anche a individuare i file mancanti se il computer dispone di accesso Internet e diritti di scrittura per la directory di download.

Uso dei supporti di installazione di SOLIDWORKS
  • Acquistare i DVD dal proprio rivenditore VAR e inserire i dischi nel lettore del proprio computer.
Aggiornamento di un'installazione di SOLIDWORKS esistente tramite Verifica aggiornamenti Selezionare una delle seguenti opzioni:
  • In SOLIDWORKS, fare clic su ? > Verifica aggiornamenti.
  • In Windows, fare clic su Start > Tutti i programmi > Gestione installazioni SOLIDWORKS > Verifica aggiornamenti.
È necessaria una connessione a Internet e privilegi di amministratore sul computer.

Nella Gestione installazioni SOLIDWORKS, è anche possibile selezionare l'opzione Scarica e condividi tutti i file, incluso il software necessario come prerequisito. Questa opzione è utile se si installa il software su alcuni computer e si desidera copiare il download utilizzando un'unità portatile o un'unità di rete. Inoltre, è utile per installare i Service Pack poiché la versione completa e il Service Pack sono contenuti in un'unica installazione.

Al termine dell'installazione, avviare l'applicazione SOLIDWORKS e attivare la licenza.

Per visualizzare un elenco di prodotti che sono installati sulla propria macchina, dal menu principale di SOLIDWORKS, fare clic su ? > I miei prodotti. I segni di spunta nella finestra di dialogo indicano i prodotti disponibili per l'utente o l'organizzazione a cui appartiene in base alla propria attivazione e alle licenze di rete. Inoltre è possibile approfondire la conoscenza dei prodotti SOLIDWORKS facendo clic sul collegamento nella parte superiore di ogni categoria di prodotti.

Per vedere quali licenze sono in uso, in Windows, fare clic su Start > SOLIDWORKS <versione> > Strumenti di SOLIDWORKS > SolidNetWork License Manager Client > scheda Uso della licenza.

Argomento principale Installazioni individuali
Amministrazione delle installazioni individuali
Suggerimenti per l'uso di SOLIDWORKS con Microsoft Windows 8


Amministrazione delle installazioni individuali

Solitamente, l'amministrazione di singole installazioni implica la modifica, la riparazione, la rimozione e l'aggiornamento delle installazioni.

Indice

  • Modifica di un'installazione

    È possibile modificare un'installazione per installare prodotti che non sono stati installati in precedenza o per rimuovere prodotti, purché l'installazione precedente sia stata eseguita con un gruppo completo di file di installazione. Questa opzione non è disponibile se l'installazione precedente è stata aggiornata con un Service Pack.

  • Riparazione di un'installazione

    In caso di problemi con un prodotto SOLIDWORKS installato, usare Gestione installazioni SOLIDWORKS per ripristinare l'installazione.

  • Ripristino di un'installazione individuale ad un Service Pack precedente

  • Rimozione di un'installazione

    Un'installazione può essere rimossa in un ambiente server/client o su un computer individuale.

  • Aggiornamento a una nuova release

    Esistono sono vari metodi per aggiornare una singola installazione a una nuova release di SOLIDWORKS.

  • Regole di coesistenza del prodotto

    Le seguenti regole di coesistenza del prodotto determinano il modo in cui i nuovi prodotti vengono installati e quelli esistenti aggiornati.

Argomento principale Installazioni individuali
Installazione su singoli computer


Modifica di un'installazione

È possibile modificare un'installazione per installare prodotti che non sono stati installati in precedenza o per rimuovere prodotti, purché l'installazione precedente sia stata eseguita con un gruppo completo di file di installazione. Questa opzione non è disponibile se l'installazione precedente è stata aggiornata con un Service Pack.

Se si installa SOLIDWORKS e in seguito si acquista un'aggiunta, è possibile modificare l'installazione per includere la nuova aggiunta. È necessario installare l'aggiunta in ogni singolo computer.

  1. Assicurarsi che non ci siano sessioni di SOLIDWORKS attive.
  2. In Windows 7 o versione successiva, fare clic su Start > Pannello di controllo >Programmi e funzionalità.
  3. Selezionare l'installazione di SOLIDWORKS da modificare e fare clic su Cambia.
  4. Nella schermata Benvenuti in Gestione installazioni SOLIDWORKS fare clic su Modificare l'installazione individuale (su questo computer)
  5. Nella schermata Numero seriale, verificare che siano indicati i numeri di seriali appropriati.
  6. Nella schermata Selezione del prodotto, selezionare i prodotti da installare o rimuovere.
    Quando si modifica un'installazione:
    • Nessun prodotto viene installato o rimosso di default, anche Se si specifica un nuovo numero seriale. Cambiare l'azione dell'installazione di ogni componente di prodotto o funzione.
    • Per visualizzare l'azione prevista di un componente specifico, fare clic sul nome del componente (ma non sulla sua casella di controllo). L'azione prevista appare nel campo delle informazioni sotto l'elenco dei prodotti.
    • Per cambiare l'azione di installazione per un componente del prodotto, fare clic sulla casella di controllo relativa al componente stesso. (Ad esempio, se si sta installando o rimuovendo componenti, selezionando la casella di controllo si specifica che il componente deve essere installato o rimosso e deselezionandola si specifica che il componente non deve essere installato o rimosso).
    • Quando si modifica l'azione di installazione specificata inizialmente per un componente, accanto a quest'ultimo viene visualizzato un asterisco (*).
    • Se accanto al componente viene visualizzata l'icona +, vuol dire che dispone di sottocomponenti da installare a scelta. Per visualizzare tali sottocomponenti, fare clic sull'icona +.
    • Quando si espande un componente per visualizzarne i sottocomponenti facoltativi, accanto al componente viene visualizzata l'icona -. Per comprimere l'elenco di sottocomponenti, fare clic sull'icona -.
  7. Nella schermata Sintesi, fare clic su Modifica ora.
  8. Nella schermata Installazione completata, fare clic su Fine.
Argomento principale Amministrazione delle installazioni individuali
Riparazione di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Rimozione di un'installazione
Aggiornamento a una nuova release
Regole di coesistenza del prodotto


Riparazione di un'installazione

In caso di problemi con un prodotto SOLIDWORKS installato, usare Gestione installazioni SOLIDWORKS per ripristinare l'installazione.

Tuttavia, è possibile ripristinare un'installazione solo se nel computer in uso sono disponibili tutti i file di origine dell'installazione precedente e tutti i Service Pack applicati, nella posizione in cui sono stati installati originariamente.

Un'installazione individuale può essere riparata. Non è possibile riparare un'immagine amministrativa; disinstallare e quindi installare nuovamente l'immagine amministrativa.
  1. In Windows 7 o versione successiva, fare clic su Start > Pannello di controllo > Programmi > Programmi e funzionalità.
  2. Selezionare la versione di SOLIDWORKS da ripristinare e fare clic su Cambia.
  3. Nella schermata Benvenuti alla Gestione installazioni SOLIDWORKS fare clic su Correggi l'installazione individuale (su questo computer).
  4. In Prodotti da riparare selezionare il prodotto desiderato.
  5. Deselezionare il resto dei prodotti.
  6. Fare clic su Ripara.
Argomento principale Amministrazione delle installazioni individuali
Argomento principale Errori di installazione / Installazione annullata
Modifica di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Rimozione di un'installazione
Aggiornamento a una nuova release
Regole di coesistenza del prodotto
Ripristino da un'installazione non riuscita o annullata
Come contattare il rivenditore SOLIDWORKS


Ripristino di un'installazione individuale ad un Service Pack precedente

Per ripristinare una singola installazione a un Service Pack precedente all'interno della release principale corrente, disinstallare il Service Pack attualmente installato sul computer e reinstallarne la versione precedente.
Argomento principale Amministrazione delle installazioni individuali
Modifica di un'installazione
Riparazione di un'installazione
Rimozione di un'installazione
Aggiornamento a una nuova release
Regole di coesistenza del prodotto


Rimozione di un'installazione

Un'installazione può essere rimossa in un ambiente server/client o su un computer individuale.

  1. Verificare che non siano presenti sessioni di SOLIDWORKS attive.
  2. Se si desidera trasferire la licenza di SOLIDWORKS su un altro computer, disattivare la licenza sul computer prima di rimuovere l'installazione di SOLIDWORKS dal computer in uso.
    Per ulteriori informazioni, vedere Trasferimento di una licenza.
  3. In Windows 7 o versione successiva, aprire il Pannello di controllo > Programmi e funzionalità.
  4. Selezionare il componente del prodotto da rimuovere.
    In alcuni casi, potrebbero essere disponibili più Service Pack di SOLIDWORKS per una stessa release principale. Per rimuovere una release principale di SOLIDWORKS, rimuovere tutti gli elementi dei Service Pack per tale release.
  5. Nello schermo Disinstallare:
    1. selezionare i prodotti da rimuovere. Di default, sono selezionati tutti i componenti di prodotto.
    2. Deselezionare i prodotti che non devono essere rimossi.
    3. Scegliere se effettuare una disinstallazione personalizzata o completa. Per impostazione predefinita, Gestione installazioni SOLIDWORKS esegue una disinstallazione standard, rimuovendo i file e le cartelle del programma.
      1. Fare clic su Cambia in Opzioni avanzate.

        Apparirà lo schermo Opzioni avanzate e l'opzione File e cartelle del programma sarà selezionata

      2. Selezionare una o più opzioni per effettuare una disinstallazione personalizzata o selezionare tutte le opzioni per effettuare una disinstallazione completa.
      3. Fare clic su Torna alla Sintesi.
      4. Nello schermo Sintesi, espandere Opzioni avanzate per visualizzare il metodo di disinstallazione e le voci.
    4. Fare clic su Rimuovi elementi.
Argomento principale Amministrazione delle installazioni individuali
Argomento principale Amministrazione delle installazioni multiple
Modifica di un'installazione
Riparazione di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Aggiornamento a una nuova release
Regole di coesistenza del prodotto
Aggiornamento di immagini amministrative a una nuova release
Amministrazione aggiornamento del prodotto con Service Pack
Trasferimento di una licenza


Aggiornamento a una nuova release

Esistono sono vari metodi per aggiornare una singola installazione a una nuova release di SOLIDWORKS.

Si può aggiornare ad una nuova release:
  • Mediante la ricezione di nuovi supporti di installazione
  • Alla notifica della disponibilità di aggiornamenti all'avvio di SOLIDWORKS
  • Controllando manualmente la disponibilità di aggiornamenti
  • Avviando una nuova variante di Gestione installazioni SOLIDWORKS

Quando si installa una nuova release maggiore, è possibile aggiornare una release maggiore già installata oppure installare parallelamente la nuova release. Se si installa una release Service Pack da una release precedente installata, tale release viene aggiornata automaticamente.

Argomento principale Amministrazione delle installazioni individuali
Modifica di un'installazione
Riparazione di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Rimozione di un'installazione
Regole di coesistenza del prodotto

Verifica manuale degli aggiornamenti

Se si dispone dei privilegi dell'amministratore sul computer, è possibile utilizzare uno dei metodi seguenti per verificare la disponibilità di aggiornamenti per una release di SOLIDWORKS attualmente installata.

  • In SOLIDWORKS, fare clic su ? > Verifica aggiornamenti.
  • In Microsoft Windows, selezionare Start > Tutti i programmi > Gestione installazioni SOLIDWORKS > Verifica aggiornamenti.

Accorgimenti per l'aggiornamento

I prodotti che possono avere installazioni multiple con versioni diverse non supportano sempre gli aggiornamenti maggiori, o la capacità di aggiornare tra le versioni maggiori in una sola operazione.

In questo caso Gestione installazioni SOLIDWORKS simula l'aggiornamento installando prima la versione nuova, quindi rimuovendo quella precedente. Al momento, gli aggiornamenti principali sono supportati dal prodotto SOLIDWORKS di base, ma non dagli altri prodotti.

Le conseguenze di questa modalità sono:
  • Quando si aggiorna il prodotto SOLIDWORKS di base a una versione principale:
    • le ubicazioni esistenti installate non cambiano.
    • L'aggiornamento può essere riportato indietro se avviene un errore o un annullamento durante l'aggiornamento.
  • Quando gli altri prodotti vengono aggiornati tra le versioni maggiori:
    • ogni prodotto viene prima installato come prodotto nuovo in un punto nuovo, quindi l'installazione originale sarà rimossa.
    • Una volta iniziato, l'aggiornamento non può essere riportato indietro se avviene un errore o un annullamento durante l'aggiornamento.


Regole di coesistenza del prodotto

Le seguenti regole di coesistenza del prodotto determinano il modo in cui i nuovi prodotti vengono installati e quelli esistenti aggiornati.

Regola | Esempi
Versioni multiple di release maggiori del prodotto principale SOLIDWORKS sono consentite, con l'eccezione dei prodotti indicati di seguito. | SOLIDWORKS 2019 SP3.0 e SOLIDWORKS 2020 SP0.0 possono coesistere sullo stesso computer.
Le Service Pack multiple dalla stessa versione principale non sono consentite. | SOLIDWORKS 2020 SP0.0 e 2020 SP1.0 non possono coesistere sullo stesso computer. Se si installa SOLIDWORKS 2020 SP1.0 su un computer su cui è già installato SOLIDWORKS 2020 SP0.0, la Gestione installazioni SOLIDWORKS sostituirà SP0.0 con SP1.0.
Solo una versione dei seguenti prodotti è consentita sul computer:
  • SolidNetWork License Manager
 Se SOLIDWORKS 2020 SP0.0 è installato, SolidNetWork License Manager viene aggiornato a 2020 SP0.0, anche se una release principale precedente di SOLIDWORKS rimane sul computer.
Solo una versione del seguente prodotto è consentita sul computer:
  • SOLIDWORKS Electrical
 Se si crea una nuova installazione di SOLIDWORKS Electrical 2020 SP1.0, Gestione installazioni SOLIDWORKS rimuove automaticamente le versioni precedenti di SOLIDWORKS Electrical dal computer. Eseguire il backup dell'ambiente SOLIDWORKS Electrical prima di effettuare l'aggiornamento.
Solo una versione dei seguenti prodotti è consentita sul computer:
  • Client PDM di SOLIDWORKS
  • SOLIDWORKS PDM Server

Se si installa SOLIDWORKS 2020 SP0.0 o SP1.0, è necessario eseguire anche l'aggiornamento a SOLIDWORKS 2020 PDM Server e PDM Client.

Se si installa SOLIDWORKS 2020 PDM Server, si consiglia di utilizzare il processo di installazione di PDM Server per installare SOLIDWORKS PDM Client. Non installare il client PDM SOLIDWORKS separatamente con il processo di installazione client.

SOLIDWORKS PDM client deve essere la stessa versione e service pack di SOLIDWORKS PDM server sullo stesso computer.

Vedere Installare un server PDM con argomento SLDIM per ulteriori informazioni.

Solo una versione di un prodotto compreso potrà essere installata per qualsiasi versione maggiore di SOLIDWORKS. Tuttavia, le versioni di prodotti da diverse versioni di SOLIDWORKS possono coesistere. | Se SOLIDWORKS 2020 SP0.0 viene aggiornato a 2020 SP1.0, SOLIDWORKS Composer 2020 SP0.0 viene aggiornato automaticamente a 2020 SP1.0. Tuttavia, SOLIDWORKS Composer 2019 SP4.0 può coesistere con SOLIDWORKS Composer 2020 SP0.0 o con SOLIDWORKS Composer 2020 SP1.0.
Argomento principale Amministrazione delle installazioni individuali
Modifica di un'installazione
Riparazione di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Rimozione di un'installazione
Aggiornamento a una nuova release


Installazioni multiple

Indice

  • Distribuzione su più client

    Il prodotto SOLIDWORKS può essere installato su più client creando un'immagine amministrativa e distribuendo l'installazione sui client.

  • Uso di immagini amministrative

    Un'immagine amministrativa consente di creare installazioni configurabili dei prodotti SOLIDWORKS da un singolo percorso di rete.

  • Distribuzione di un'immagine amministrativa ai client via email

    Una volta creata una directory condivisa per l'immagine amministrativa, è possibile notificare i client via email.

  • Distribuzione dalla riga di comando

    È possibile distribuire automaticamente un'immagine amministrativa usando un prompt dei comandi o file batch (installazione invisibile).

  • Amministrazione delle installazioni multiple

    Per installazioni multiple, le operazioni amministrative comprendono l'aggiornamento delle immagini amministrative alle nuove release, l'aggiornamento dei prodotti tramite Service Pack e la rimozione delle installazioni.


Distribuzione su più client

Il prodotto SOLIDWORKS può essere installato su più client creando un'immagine amministrativa e distribuendo l'installazione sui client.

Segue la procedura per la distribuzione su più client:
  1. Creare un'immagine amministrativa.
    • Creazione di un'immagine amministrativa dalla Gestione installazioni SOLIDWORKS
  2. Distribuire l'immagine amministrativa ai clienti.
    • Distribuzione di un'immagine amministrativa ai client via email
    • Installazione da un'immagine amministrativa mediante la riga di comando
  3. Implementare licenze.
    • Amministrazione di licenze individuali
    • Amministrazione delle licenze mediante SolidNetWork License Manager
Argomento principale Installazioni multiple
Uso di immagini amministrative
Distribuzione di un'immagine amministrativa ai client via email
Distribuzione dalla riga di comando
Amministrazione delle installazioni multiple
Suggerimenti per l'uso di SOLIDWORKS con Microsoft Windows 8


Uso di immagini amministrative

Un'immagine amministrativa consente di creare installazioni configurabili dei prodotti SOLIDWORKS da un singolo percorso di rete.

L'immagine amministrativa potrà essere installata da qualsiasi computer in rete, compreso il computer client.
  • L'immagine amministrativa deve essere in una cartella condivisa.
  • Se si includono tutti i prodotti, i requisiti di spazio disco dell'immagine amministrativa potrà essere 7GB o maggiore.
  • Se il nome di condivisione viene aggiornato con l'aggiornamento dell'immagine amministrativa, il client aggiornerà automaticamente all'avvio successivo dell'applicazione. Per i dettagli, vedere Aggiornamento dei client dalle immagini amministrative.
  • Quando si implementa un'immagine amministrativa, il suo percorso deve comportare meno di 58 caratteri.
  • Richiede ai client di possedere i privilegi amministrativi sui loro computer. Se non dispone di privilegi sufficienti, un client può eseguire un'installazione come un utente diverso. Questa opzione si rivela utile quando un singolo utente non dispone di permessi amministrativi locali sulla macchina (necessari per installare i prodotti SOLIDWORKS).

    Vedere Disposizione installazioni dall'editor delle opzioni. Illustra inoltre un metodo alternativo per installare le immagini quando un client non dispone di privilegi sufficienti.

  • Se è abilitata la funzionalità di registrazione di Windows o si utilizza la funzionalità di stato nell'Editor opzione immagine amministrativa, è necessario disporre delle autorizzazioni di lettura/scrittura per questa cartella: {Administrative image directory}\x64\Logs.

Una volta creata l'immagine amministrativa, è possibile utilizzare l'editor delle opzioni dell'immagine amministrativa per gestire le opzioni di installazione per gli utenti e i gruppi che eseguono l'installazione da tale immagine. Per i dettagli, vedere Editor opzioni immagine amministrativa.

Indice

  • Creazione di un'immagine amministrativa dalla Gestione installazioni SOLIDWORKS

    Se si installa SOLIDWORKS su multipli computer, sarà possibile creare un'immagine amministrativa e quindi implementare l'applicazione su altri computer.

Argomento principale Installazioni multiple
Distribuzione su più client
Distribuzione di un'immagine amministrativa ai client via email
Distribuzione dalla riga di comando
Amministrazione delle installazioni multiple
Aggiornamento dei client dalle immagini amministrative
Editor opzioni immagine amministrativa


Creazione di un'immagine amministrativa dalla Gestione installazioni SOLIDWORKS

Se si installa SOLIDWORKS su multipli computer, sarà possibile creare un'immagine amministrativa e quindi implementare l'applicazione su altri computer.

  1. Avviare Gestione installazioni SOLIDWORKS. Vedere Inizio dell'installazione di SOLIDWORKS.
  2. Nella schermata introduttiva, selezionare Immagine amministrativa:
    Verranno visualizzate le opzioni di creazione dell'immagine amministrativa:
    Opzione | Descrizione
    Creare una nuova immagine usando le impostazioni di default. | Creare l'immagine usando le impostazioni di configurazione di default (ovvero, non basate sulle impostazioni attualmente stabilite per un'immagine amministrativa esistente presso il sito).
    Creare una nuova immagine usando le impostazioni e i file da un'immagine esistente. | Creare l'immagine usando le impostazioni di configurazione specificate da un'immagine amministrativa esistente presso il sito. Fare clic su Sfoglia per specificare la directory di installazione dell'immagine amministrativa esistente.
  3. Seguire le istruzioni su schermo.

Indice

  • Editor opzioni immagine amministrativa

    L'Editor opzioni immagine amministrativa consente di personalizzare le impostazioni di parametro d'installazione in un'immagine amministrativa per singoli computer e per gruppi di computer.

Argomento principale Uso di immagini amministrative
Inizio dell'installazione di SOLIDWORKS


Editor opzioni immagine amministrativa

L'Editor opzioni immagine amministrativa consente di personalizzare le impostazioni di parametro d'installazione in un'immagine amministrativa per singoli computer e per gruppi di computer.

Dopo avere creato un'immagine amministrativa, Gestione installazioni chiede di avviare l'editor opzioni. L'editor opzioni può essere avviato anche facendo doppio clic su sldAdmintOptionEditor.exe nella cartella delle immagini amministrative.

Per specificare diverse configurazioni di installazione per gruppi di macchine o singole macchine, nell'Editor opzioni, selezionare le macchine specificando uno dei seguenti elementi:
  • nome macchina
  • indirizzo IP
  • intervallo indirizzi IP
Quindi, specificare le opzioni di installazione per queste macchine.
Tutte le finestre di dialogo, che chiedono un percorso file o cartella, includono un'opzione che consente di assegnare una cartella selezionata a una variabile di ambiente. Ad esempio, se si seleziona C:\Program Files\SOLIDWORKS Corp, il percorso del file è mappato a %ProgramFiles%\SOLIDWORKS Corp. Le variabili più comuni sono %ProgramFiles% e %SystemDrive%. Inoltre, non è possibile convertire tutti i percorsi in variabili di ambiente. Ad esempio, non è possibile mappare Z:\SOLIDWORKS Data a una variabile di ambiente.

Indice

  • Aggiunta ed eliminazione di gruppi e macchine

    L'Editor opzioni dell'immagine amministrativa consente di specificare configurazioni di installazione diverse per gruppi di macchine e per macchine individuali.

  • Visualizzazione e modifica delle impostazioni

    L'editor delle opzioni immagini amministrative di SOLIDWORKS consente di visualizzare e modificare le impostazioni delle opzioni per i gruppi e la macchine specificate per l'immagine.

  • Strumento Amministratore impostazioni

  • Disposizione installazioni dall'editor delle opzioni

    È possibile distribuire le installazioni direttamente dall'Editor delle opzioni usando sia un metodo manuale che push.

  • Uscita dall'Editor opzioni

    È possibile fare clic su OK o su Chiudi per uscire dall'Editor opzioni.

  • Creazione di un collegamento sul desktop per l'Editor opzioni

    È possibile create un collegamento sul desktop per l'Editor opzioni di una particolare immagine amministrativa all'interno dell'applicazione.

Argomento principale Creazione di un'immagine amministrativa dalla Gestione installazioni SOLIDWORKS


Aggiunta ed eliminazione di gruppi e macchine

L'Editor opzioni dell'immagine amministrativa consente di specificare configurazioni di installazione diverse per gruppi di macchine e per macchine individuali.

Ad esempio, si può decidere di configurare diversi sistemi per l'uso di un sottoinsieme particolare dei componenti di prodotto disponibili nell'immagine mentre un altro gruppo di sistema potrebbe utilizzare un sottoinsieme diverso dei componenti. Anche utilizzando la stessa immagine amministrativa, le impostazioni del gruppo Editor opzioni consentono di installare diversi sottoinsiemi di prodotto su diversi gruppi di computer.

Per aggiungere un gruppo:
  1. Fare clic con il pulsante destro del mouse su Impostazioni globali e scegliere Aggiungi gruppo.
  2. Immettere il nome del gruppo.

Per aggiungere i sistemi:
  1. Fare clic con il pulsante destro del mouse su un gruppo esistente o su Impostazioni globali e scegliere Aggiungi macchina.
    Facendo clic con il pulsante destro del mouse su un gruppo esistente, i computer verranno aggiunti al gruppo. Altrimenti, saranno aggiunte al primo livello.
  2. Effettuare una delle seguenti operazioni:
    • Selezionare Per nome macchina e immettere uno o più nomi di macchina. Macchine multiple possono essere separate da un'interruzione di riga, spazio, tab, virgola, punto, due punti o punto e virgola. Un elenco di nomi di macchine può essere copiato ed incollato da un file esterno. I nomi della macchina non possono includere qualificatori di dominio. Per esempio, pluto.solidworks.com non è valido.
    • Selezionare Per indirizzo IP e immettere l'indirizzo IP di una macchina.
    • Selezionare Per intervallo indirizzi IP e immettere l'indirizzo IP iniziale e l'indirizzo IP finale del range.
    • Fare clic su Aggiungi altre macchine per selezionare le macchine dalla rete.

Per spostare un computer esistente ad un gruppo:

trascinare la macchina in un gruppo.

Per spostare un computer da un gruppo:

trascinare la macchina su Impostazioni globali o su un gruppo diverso.

Per eliminare un gruppo o computer:

Fare clic con il pulsante destro del mouse sul gruppo o sulla macchina e scegliere Elimina gruppo o Elimina macchina.

Eliminando un gruppo, tutte le macchine all'interno di quel gruppo saranno eliminate.

Per eliminare tutti i gruppi e computer:

Fare clic con il pulsante destro del mouse su Impostazioni globali e scegliere Elimina tutto.

Argomento principale Editor opzioni immagine amministrativa
Visualizzazione e modifica delle impostazioni
Strumento Amministratore impostazioni
Disposizione installazioni dall'editor delle opzioni
Uscita dall'Editor opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni


Visualizzazione e modifica delle impostazioni

L'editor delle opzioni immagini amministrative di SOLIDWORKS consente di visualizzare e modificare le impostazioni delle opzioni per i gruppi e la macchine specificate per l'immagine.

  • Quando si avvia l'Editor delle opzioni per la prima volta, le impostazioni delle opzioni sono visualizzate in modalità sola lettura. L'icona Modifica non è ombreggiata.

    Se si fa clic su Impostazioni globali, su un gruppo o un computer è possibile visualizzare un riepilogo delle impostazioni delle opzioni per l'elemento specifico:

    Ambito | Impostazioni delle opzioni visualizzate
    Impostazioni globali | Tutte le impostazioni delle opzioni specificate per l'immagine amministrativa
    Raggruppare | Modifiche delle impostazioni di gruppo rispetto alle Impostazioni globali
    Macchina | Modifiche delle impostazioni della macchina rispetto al gruppo
  • Per apportare modifiche alle impostazioni delle opzioni, fare clic sull'icona Modifica. L'icona diventa ombreggiata e viene visualizzato un elenco più dettagliato relativo alle impostazioni delle opzioni.

    Se si fa clic su Impostazioni globali, su un gruppo o un computer è possibile modificare le impostazioni delle opzioni per l'elemento specifico. Quando si sceglie un'impostazione delle opzioni diversa dalle impostazioni globali o di gruppo ereditate, l'impostazione viene evidenziata.

    Se si fa di nuovo clic sull'icona Modifica, la visualizzazione torna in modalità sola lettura.

    Quando si apportano modifiche, l'Editor delle opzioni chiede all'utente se desidera salvare o eliminare i dati all'uscita.

Indice

  • Specificazione delle impostazioni per gruppi e sistemi

    Le impostazioni possono essere specificate per tutti i sistemi (Impostazioni globali), per gruppi di sistemi e per singoli computer.

  • Impostazioni opzione immagine amministrativa

    L'Editor delle opzioni consente di specificare le impostazioni delle opzioni per i singoli clienti o gruppi, compresi i numeri seriali, le opzioni di installazione client, i componenti software da installare e la posizione di Toolbox.

  • Eredità di impostazioni globali e di gruppo

    Gli elementi dipendenti da altri ereditano le Impostazioni globali o di gruppo dei loro padri.

  • Personalizzazione delle impostazioni per ciascun computer

    È inoltre possibile modificare le impostazioni applicate a computer specifici facendo clic con il pulsante destro del mouse sul nome del computer.

Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Strumento Amministratore impostazioni
Disposizione installazioni dall'editor delle opzioni
Uscita dall'Editor opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni


Specificazione delle impostazioni per gruppi e sistemi

Le impostazioni possono essere specificate per tutti i sistemi (Impostazioni globali), per gruppi di sistemi e per singoli computer.

  1. Nell'Editor delle opzioni fare clic sull'oggetto da modificare (Impostazioni Globali, gruppo o macchina).
  2. A destra fare clic sull'icona Modifica.
    L'icona Modifica diventa ombreggiata e viene visualizzato un elenco più dettagliato relativo alle impostazioni delle opzioni.
  3. Per apportare le modifiche, fare clic sulle impostazioni a destra corrispondenti all'elemento selezionato a sinistra.
    Vengono evidenziate le modifiche delle impostazioni delle opzioni che sovrascrivono le Impostazioni globali o di gruppo.
  4. Fare clic su OK o su Chiudi per salvare le modifiche.
    Opzione | Descrizione
    OK | L'Editor delle opzioni salva le modifiche e viene chiuso.
    Chiudi | L'Editor delle opzioni chiede se si desidera salvare le modifiche e viene chiuso.
Argomento principale Visualizzazione e modifica delle impostazioni
Impostazioni opzione immagine amministrativa
Eredità di impostazioni globali e di gruppo
Personalizzazione delle impostazioni per ciascun computer


Impostazioni opzione immagine amministrativa

L'Editor delle opzioni consente di specificare le impostazioni delle opzioni per i singoli clienti o gruppi, compresi i numeri seriali, le opzioni di installazione client, i componenti software da installare e la posizione di Toolbox.

Numeri di serie

Immettere i numeri seriali per installare i prodotti sulle macchine client.
Visto che esistono diverse modalità per l'acquisto dei prodotti SOLIDWORKS, alcuni numeri seriali potranno coprire due o più prodotti. Per esempio, un numero seriale per SOLIDWORKS può permettere di installare SOLIDWORKS Simulation senza immettere un numero seriale separato per SOLIDWORKS Simulation. Inoltre, alcuni prodotti non necessitano di un numero seriale. In caso di domande relative ai numeri seriali, contattare il proprio VAR.
Se si gestiscono le licenze usando le licenze SolidNetWork:
  • nel primo campo del numero seriale, immettere il numero di serie SolidNetWork.
  • Nel campo SNL Server port@server, immettere il nome e la porta di SolidNetWork License Manager nel formato nnnnn@servername. Separare voci multiple usando i punti e virgole.

Per i dettagli sulle licenze SolidNetWork, vedere Installazione e configurazione delle licenze SolidNetWork.

Opzioni di installazione client

Come effettuare le installazioni client delle versioni maggiori? È possibile specificare il modo in cui le installazioni client gestiranno un'installazione della versione principale precedente esistente:
  • Aggiornare la versione maggiore esistente (se esistente).

    Specificare questa opzione per sostituire l'installazione di versione maggiore precedente con l'installazione della nuova versione

  • Creare una nuova versione maggiore.

    Specificare questa opzione per conservare la versione precedente e creare una nuova installazione della nuova versione. Per specificare il percorso di installazione della nuova versione, fare clic su Sfoglia.
Disinstallare la versione precedente più recente prima di installare una versione nuova? Specificare se disinstallare l'installazione della versione maggiore esistente:
  • No, non effettuare la disinstallazione.

    Specificare questa opzione per conservare l'installazione della versione precedente.

  • Sì, effettuare una disinstallazione personalizzata.

    Selezionare questa opzione per rimuovere i seguenti elementi: File e cartelle dati creato tramite un'installazione precedente.

Come applicare le impostazioni di SOLIDWORKS? È possibile specificare un file delle impostazioni all'avvio del software. Le installazioni client fanno riferimento a un file delle impostazioni. Memorizzare il file delle impostazioni (*.sldsettings) in un percorso UNC condiviso visibile a tutte le installazioni. Specificare un percorso del file *.sldsettings prima di installare SOLIDWORKS. Le installazioni client rilevano il percorso del file *.sldsettings durante l'installazione.
Proteggere il file *.sldsettings impostando le autorizzazioni file di Windows in modo da consentire l'accesso in scrittura solo agli utenti designati.

Per creare o modificare un file *.sldsettings, fare clic su Avvia Amministratore impostazioni. Lo strumento Amministratore impostazioni di SOLIDWORKS consente di definire quali opzioni di sistema di SOLIDWORKS applicare ed eventualmente bloccare per gli utenti finali. È inoltre possibile definire come e quando applicare le impostazioni alle singole installazioni e modificare il file *.sldsettings in qualsiasi momento eseguendo lo strumento Amministratore impostazioni e sovrascrivendo il file esistente.

È possibile utilizzare un file *.sldsettings differente per macchine o gruppi differenti.

Il percorso del file *.sldsettings è definito al momento dell'installazione. Una volta implementato, non rinominare o spostare il file *.sldsettings.

È necessario disporre di un'installazione SOLIDWORKS 2020 [versione principale corrente] esistente per eseguire lo strumento Amministratore impostazioni.
Come attivare le installazioni client? L'utente può specificare se completare automaticamente l'attivazione del prodotto dopo l'esecuzione dell'installazione o richiedere che l'utente effettui l'attivazione del prodotto manualmente dopo l'installazione.
  • Attivare automaticamente al completamento di ogni installazione client.

    Selezionando l'impostazione di questa opzione si specifica che l'attivazione del prodotto viene eseguita automaticamente usando un file di Attivazione del prodotto SOLIDWORKS.

  • Non attivare automaticamente.

    Selezionare l'impostazione di questa opzione specifica che non ci sarà nessuna attivazione automatizzata del prodotto. L'utente client effettua l'attivazione del prodotto dopo l'installazione.

Opzioni amministrative

Creare un log diagnostico durante ogni installazione. | Un'installazione client può creare un log diagnostico per la risoluzione dei problemi di installazione. Generando questo log l'esecuzione dell'installazione client rallenterà. Il file di registro è memorizzato in Administrative image directory}\x64\Logs\<machine_name>\Status.xml.
Eseguire l'installazione come altro utente.

L'installazione client potrà essere eseguita come utente diverso. Questa opzione può essere utile quando singoli utenti non dispongono di permessi amministrativi locali sulle loro macchine (necessari per installare i prodotti SOLIDWORKS).

Se i client non sono dotati di privilegi amministrativi, si può ricorrere a un metodo alternativo per le operazioni di implementazione e installazione. Vedere Disposizione installazioni dall'editor delle opzioni.
Eseguire un programma prima o dopo l'installazione | È possibile specificare l'esecuzione di un programma personalizzato prima o dopo l'installazione client.
Specificare se il client deve partecipare al Programma SOLIDWORKS Customer Experience. | Si può specificare che le macchine client partecipano nel programma SOLIDWORKS Customer Experience. Le informazioni di prestazione vengono inviate alla SOLIDWORKS Corporation per migliorare il prodotto. Il processo è trasparente e confidenziale. Per i dettagli, vedere il sito Web del Programma di miglioramento dell'esperienza clienti.

Limiti delle opzioni di Esegui un programma prima dell'installazione ed Esegui un programma dopo l'installazione

Queste opzioni consentono di eseguire altri programmi o script di installazione sulle macchine client prima o dopo la distribuzione di SOLIDWORKS, ad esempio uno script che installa Microsoft Office.

Se si esegue la distribuzione automatica su macchine client con Windows 10, esiste un limite relativo all'utilizzo di queste opzioni. Si verifica un errore se si utilizza una delle opzioni per distribuire un programma di installazione o uno script che visualizza un'interfaccia utente, ad esempio uno script che visualizza finestre di dialogo. Quando la distribuzione automatica di SOLIDWORKS è in esecuzione, non è in grado di installare SOLIDWORKS sulla macchine di destinazione. Questo limite non si verifica nelle macchine client con Windows 7.

Per utilizzare le opzioni Esegui un programma prima dell'installazione ed Esegui un programma dopo l'installazione, selezionare solo programmi che possono essere installati in modalità invisibile.

Software da installare

Si può specificare quali componenti di prodotto SOLIDWORKS installare.
  • La selezione della casella di controllo accanto al componente del prodotto specifica che il componente verrà installato durante l'installazione sul client.
  • Deselezionando la casella, il componente non verrà installato.
  • Se un componente dispone di sottocomponenti da installare in modo opzionale, accanto al componente viene visualizzata l'icona +. Per visualizzare i sottocomponenti disponibili per un componente, fare clic sull'icona +.
  • Quando si espande un componente per visualizzare i sottocomponenti opzionali, accanto al componente viene visualizzata l'icona -. Per comprimere l'elenco dei sottocomponenti, fare clic sull'icona -.
La specifica Lingue limita le lingue installate solo per il prodotto SOLIDWORKS. Le installazioni di altri prodotti non saranno condizionate da questa specifica. Ad esempio, eDrawings® installa tutte le lingue.

Opzioni Toolbox

Specificare quali standard supportare e l'ubicazione di default di Toolbox per le installazioni client.

E' frequente avere utenti multipli che accedono ad un Toolbox condiviso, tipicamente attraverso un punto in rete (per esempio, un percorso UNC, una cartella condivisa o una specificazione di unità in rete comune).

Se la posizione contiene una versione principale precedente di Toolbox, l'installazione client aggiornerà Toolbox alla nuova versione principale. I file non saranno più compatibili con le versioni principali precedenti di SOLIDWORKS.
Se alcuni client continuano a utilizzare una versione precedente di SOLIDWORKS, è necessario specificare un percorso di rete Toolbox differente per i client che vengono aggiornati alla versione più recente.

Per i dettagli relativi all'amministrazione di Toolbox, vedere le informazioni su Toolboxnella Guida di SOLIDWORKS.

Installazione del software Toolbox senza installare i dati Toolbox

Se l'ambiente dispone di PDM o posizione di Creazione guidata fori/Toolbox condivisa, è possibile impostare le installazioni client in modo che non installino o aggiornino i dati Toolbox in quella posizione.

Eseguire questa operazione se:
  • Prima di installare il software SOLIDWORKS non è stata ancora impostata la vista locale di SOLIDWORKS PDM.
  • I file nella posizione sono in uso e potrebbero impedire il completamento delle installazioni SOLIDWORKS.
  • La posizione non è disponibile e potrebbe impedire il completamento delle installazioni SOLIDWORKS.

Quando si impostano le installazioni client in modo che non installino i dati Toolbox, il software SOLIDWORKS e le impostazioni fanno riferimento alla posizione di Creazione guidata fori/Toolbox, ma è necessario installare i dati in una posizione centrale in un secondo momento.

Per installare il software SOLIDWORKS senza includere i dati di Creazione guidata fori/Toolbox:
  • Quando viene richiesto se si desidera che questo client installi/aggiorni i file Toolbox, selezionare No, installare il software Toolbox senza includere i file di dati.

Almeno una persona, in genere l'amministratore CAD, deve installare o aggiornare i dati di Creazione guidata fori/Toolbox nella posizione centrale, altrimenti il software non funzionerà correttamente. Chiunque all'interno dell'organizzazione può gestire questa attività con un'unica installazione manuale del software SOLIDWORKS. Se si gestisce Toolbox all'interno di SOLIDWORKS PDM, seguire i passaggi descritti nella sezione Toolbox della Guida dell'amministratore di SOLIDWORKS PDM per installare o aggiornare i dati Toolbox.

Opzioni del client SOLIDWORKS PDM

È possibile selezionare le seguenti opzioni per la distribuzione di client e aggiunte di SOLIDWORKS PDM:

  • Tipo di prodotto PDM
  • Tipo di client PDM
  • Funzioni

Vedere la sezione su SOLIDWORKS PDM per ulteriori informazioni su questi client e aggiunte.

Opzioni Electrical

È possibile specificare i parametri seguenti per i componenti amministrativi di SOLIDWORKS Electrical:
  • Percorso dati
  • Nome del computer server collaborativo e numero di porta
  • Nome del computer server SQL Server e password

Vedere la sezione su SOLIDWORKS Electrical per ulteriori informazioni su questi componenti.

Argomento principale Visualizzazione e modifica delle impostazioni
Specificazione delle impostazioni per gruppi e sistemi
Eredità di impostazioni globali e di gruppo
Personalizzazione delle impostazioni per ciascun computer
Installazione e configurazione delle licenze SolidNetWork
Disposizione installazioni dall'editor delle opzioni
SOLIDWORKS Electrical


Eredità di impostazioni globali e di gruppo

Gli elementi dipendenti da altri ereditano le Impostazioni globali o di gruppo dei loro padri.

Ad esempio:
  • Le impostazioni definite per Impostazioni globali derivano da tutti i gruppi e sistemi.
  • Le impostazioni definite per un gruppo derivano da tutti computer all'interno di quel gruppo.

Le impostazioni possono cambiare per un sistema o gruppo per sovrascrivere le impostazioni di default o quelle derivate. Quando si cambiano le impostazioni di default o il loro valore derivato, tale opzione viene evidenziata.

Per ripristinare le impostazioni ai valori originali, fare clic con il pulsante destro del mouse sul gruppo o sul sistema quindi fare clic su Inverti alle impostazioni globali (per un gruppo o sistema non membro del gruppo) o Inverti alle impostazioni di gruppo (per un sistema membro di gruppo).
Argomento principale Visualizzazione e modifica delle impostazioni
Specificazione delle impostazioni per gruppi e sistemi
Impostazioni opzione immagine amministrativa
Personalizzazione delle impostazioni per ciascun computer


Personalizzazione delle impostazioni per ciascun computer

È inoltre possibile modificare le impostazioni applicate a computer specifici facendo clic con il pulsante destro del mouse sul nome del computer.

Dal menu di scelta rapida, è possibile effettuare le seguenti attività per ogni computer:
  • Elimina computer dall'editor
  • Torna alle impostazioni globali
  • Aggiungi o modifica note
  • Modifica opzioni

Modifica opzioni consente di modificare tutte le opzioni per il computer, come le opzioni di installazione client e le opzioni amministrative.

Argomento principale Visualizzazione e modifica delle impostazioni
Specificazione delle impostazioni per gruppi e sistemi
Impostazioni opzione immagine amministrativa
Eredità di impostazioni globali e di gruppo


Strumento Amministratore impostazioni

È possibile utilizzare lo strumento Amministratore impostazioni per impostare le opzioni sistema applicate durante la distribuzione o l'aggiornamento del software SOLIDWORKS, nonché per impedire agli utenti di modificare tali opzioni. Questo strumento sostituisce le impostazioni guidate di copiatura per la distribuzione delle impostazioni, sebbene il wizard sia sempre disponibile per copiare le impostazioni.

L'uso dello strumento Amministratore impostazioni prevede tre passaggi:
  1. Creare un'immagine amministrativa per accedere allo strumento.
  2. Utilizzare l'Amministratore impostazioni per generare un file *.sldSettings contenente le opzioni SOLIDWORKS selezionate.
  3. Includere il file *.sldSettings nelle installazioni SOLIDWORKS.

Indice

  • Accesso allo strumento Amministratore impostazioni

    Per accedere allo Strumento Amministratore impostazioni, occorre innanzitutto creare un'immagine amministrativa.

  • Utilizzo dello strumento Amministratore impostazioni

  • Applicazione e blocco delle opzioni

  • Opzioni di impostazione di finitura

  • Inclusione di un file .sldSettings nelle installazioni di SOLIDWORKS

Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Visualizzazione e modifica delle impostazioni
Disposizione installazioni dall'editor delle opzioni
Uscita dall'Editor opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni


Accesso allo strumento Amministratore impostazioni

Per accedere allo Strumento Amministratore impostazioni, occorre innanzitutto creare un'immagine amministrativa.

È possibile avviare lo strumento Amministratore impostazioni da un'immagine amministrativa.

Per accedere allo strumento Amministratore impostazioni:

  1. Lanciare sldAdminOptionEditor.exe nella cartella dell'immagine amministrativa.
  2. Nell'Editor opzione immagine amministrativa, fare clic su Modifica impostazioni.
  3. Nella sezione Opzioni di installazione client, effettuare le seguenti operazioni:
    1. Fare clic su Usare un file di impostazione esportato dallo strumento Amministratore impostazioni SOLIDWORKS.
    2. Fare clic su Avvia Amministratore impostazioni.
Argomento principale Strumento Amministratore impostazioni


Utilizzo dello strumento Amministratore impostazioni

Per utilizzare lo Strumento Amministratore impostazioni:

  1. Nella scheda Benvenuto, selezionare una delle seguenti opzioni:
    • Serie di opzioni di default per iniziare da questa release di SOLIDWORKS.
    • Importa opzioni di SOLIDWORKS 2020 da questo computer.
    • Accedi a un file sldreg esistente.
    • Accedi a un file sldSettings esistente.
    Il file *.sldreg è generato dalle Impostazioni guidate di copiatura, il file *.sldSettings è generato dallo strumento Amministratore impostazioni.
  2. Fare clic su Avanti.
Argomento principale Strumento Amministratore impostazioni


Applicazione e blocco delle opzioni

Nella scheda Opzioni di sistema, due colonne di caselle di spunta consentono di selezionare quali di queste opzioni applicare e quali invece bloccare tra quelle applicate, in modo da impedire agli utenti di modificarle.

Quando gli utenti accedono alla finestra di dialogo Opzioni di sistema nel software SOLIDWORKS, le opzioni bloccate sono visualizzate come non disponibili, con un'icona a forma di lucchetto [image]. Tuttavia, è possibile creare una password che consenta agli utenti di sbloccare le opzioni. Quando gli utenti passano con il mouse su un'opzione bloccata, viene visualizzata una descrizione del comando contenente il nome e l'indirizzo e-mail da contattare per richiedere la password.

Per applicare e bloccare le opzioni:

  1. Nella scheda Opzioni di sistema, effettuare le seguenti operazioni:
    1. Per applicare un'opzione di sistema, selezionare l'opzione e selezionare la casella corrispondente nella colonna Applica.
    2. Per bloccare un'opzione di sistema, selezionare l'opzione e selezionare la casella corrispondente in entrambe le colonne Applica e Blocco.
      Quando gli utenti accedono alla scheda Opzioni di sistema, queste opzioni sono visualizzate con un lucchetto [image].
  2. A seconda dell'opzione, può essere necessario specificare parametri aggiuntivi.
  3. È inoltre possibile impedire agli utenti di sopprimere i messaggi, applicando controlli per Messaggi/Errori/Avvertenze.
    1. Fare clic su Messaggi/Errori/Avvertenze.
    2. Selezionare Applica e, facoltativamente, selezionare Blocca per i messaggi che si desidera gestire.
    3. Impostare Mostra o Non mostrare per il messaggio.

      Se si seleziona Mostra, il messaggio viene rimosso dall'elenco dei messaggi soppressi dell'utente e viene mostrato all'utente al momento opportuno. Se si seleziona Non mostrare, il messaggio viene aggiunto automaticamente all'elenco dei messaggi soppressi dell'utente e non viene visualizzato quando l'utente sta lavorando su un modello.

      La tabella seguente descrive il comportamento nel software:
      Applica | Blocca | Mostra | Non mostrare | Comportamento
      X | X | Forza la visualizzazione del messaggio.
      X | X | Elimina il messaggio e lo aggiunge all'elenco dei messaggi soppressi.
      X | X | X | Forza la visualizzazione del messaggio e disattiva l'opzione Non visualizzare nuovamente nella finestra del messaggio.
      X | X | X | Elimina il messaggio e impedisce all'utente di attivarlo in Strumenti > Opzioni > Messaggi/Errori/Avvertenze.
  4. Nella scheda Opzioni di sistema, fare clic su Avanti.
Argomento principale Strumento Amministratore impostazioni


Opzioni di impostazione di finitura

Procedere nel seguente modo:

  1. Nella scheda Fine, selezionare quando applicare le opzioni di sistema:
    • la prima volta che un utente avvia il software.
    • ogni volta che un utente avvia il software.
    • e se applicare contemporaneamente le personalizzazioni.
  2. Si può scegliere di applicare le opzioni bloccate quando gli utenti sono fuori rete e consentire all'API di scavalcare il blocco delle opzioni.
  3. Per le opzioni di sistema bloccate, è necessario fornire il proprio nome e indirizzo e-mail. Il software SOLIDWORKS mostra queste informazioni in una descrizione dei comandi quando gli utenti passano con il mouse su un'opzione bloccata.
  4. Inoltre, è possibile consentire agli utenti di bypassare il blocco delle opzioni. A tale scopo, è necessario specificare una Password che può essere fornita agli utenti.
  5. Fare clic su Salva per generare un file .sldSettings per la distribuzione.
Argomento principale Strumento Amministratore impostazioni


Inclusione di un file .sldSettings nelle installazioni di SOLIDWORKS

Per includere un file *.sldSettings nell'installazione:

  1. Fare doppio clic su sldAdminOptionEditor.exe nella cartella dell'immagine amministrativa.
  2. Nell'Editor opzione immagine amministrativa, fare clic su Modifica impostazioni.
  3. Nella sezione Opzioni di installazione client, effettuare le seguenti operazioni:
    1. Fare clic su Usare un file di impostazione esportato dallo strumento Amministratore impostazioni SOLIDWORKS.
    2. Fare clic su Modifica percorso e individuare il file *.sldSettings.
    È possibile creare e applicare file *.sldSettings differenti per gruppi o macchine differenti.
  4. Distribuire e installare il software SOLIDWORKS.

Dopo la distribuzione, è possibile ripetere il punto 2 in qualsiasi momento per modificare un file *.sldSettings esistente. All'avvio successivo, il software SOLIDWORKS legge il file *.sldSettings modificato.

Argomento principale Strumento Amministratore impostazioni


Disposizione installazioni dall'editor delle opzioni

È possibile distribuire le installazioni direttamente dall'Editor delle opzioni usando sia un metodo manuale che push.

  • Usare la pagina Distribuzione manuale dell'Editor opzioni per inviare via email le istruzioni agli utenti su come avviare l'installazione. Usare questo metodo se gli utenti non sono dotati dei privilegi amministrativi necessari per i rispettivi client.
  • Usare la pagina Distribuzione automatica dell'Editor opzioni per effettuare automaticamente il push delle installazioni ai computer di destinazione. È possibile effettuare anche disinstallazioni personalizzate. Usare questo metodo se gli utenti non hanno i privilegi amministrativi richiesti per installare software sui propri sistemi.

Per usare uno di questi metodi, modificare la directory di installazione dell'immagine amministrativa in una directory condivisa di Windows, affinché sia accessibile da un percorso di rete (ad esempio \\computer\directory_condivisa, oppure copiare l'intera immagine in una directory locale di ciascun computer, come C:\SOLIDWORKS Admin\SOLIDWORKS 2020 SP0).

Indice

  • Utilizzo di un'unità associata per distribuire un'immagine amministrativa

    Un percorso UNC (\\nome_sistema\nome_condiviso ) è il metodo consigliato per specificare una posizione di rete come directory di installazione di un'immagine amministrativa. Tuttavia, è possibile utilizzare un'unità associata come posizione per il file StartSWInstall.hta dell'immagine amministrativa (es. U:\StartSWInstall.hta), a patto che tutti gli utenti che eseguono l'installazione abbiano associato la stessa lettera di unità alla directory condivisa dell'immagine amministrativa.

  • Utilizzo di StartSWInstall.exe per distribuire un'immagine amministrativa

  • Distribuzione manuale

    Usare questo metodo se gli utenti hanno i privilegi amministrativi richiesti per installare software sui propri sistemi.

  • Prerequisiti per la distribuzione automatica

    Le operazioni di installazione vengono eseguite automaticamente nei computer di destinazione e completate dall'Utilità di pianificazione Microsoft in ogni sistema, senza richiedere alcun intervento da parte dell'utente. Usare questo metodo se gli utenti non hanno i privilegi amministrativi richiesti per installare software sui propri sistemi.

  • Distribuzione automatica

  • Test di una configurazione per una distribuzione push

    La scheda Distribuisci automaticamente nell'Editor opzione immagine amministrativa contiene una funzione di test.

Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Visualizzazione e modifica delle impostazioni
Strumento Amministratore impostazioni
Uscita dall'Editor opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni


Utilizzo di un'unità associata per distribuire un'immagine amministrativa

Un percorso UNC (\\nome_sistema\nome_condiviso ) è il metodo consigliato per specificare una posizione di rete come directory di installazione di un'immagine amministrativa. Tuttavia, è possibile utilizzare un'unità associata come posizione per il file StartSWInstall.hta dell'immagine amministrativa (es. U:\StartSWInstall.hta), a patto che tutti gli utenti che eseguono l'installazione abbiano associato la stessa lettera di unità alla directory condivisa dell'immagine amministrativa.

Ad esempio, se si è associata l'unità U: alla directory condivisa dell'immagine amministrativa, l'e-mail di notifica istruirà gli utenti a fare clic sul link file://U:\StartSWIOnstall.hta. I destinatari dell'e-mail possono eseguire l'installazione solo se hanno associato l'unità U: alla posizione UNC dell'immagine amministrativa (\\nome_sistema\nome_condiviso ).

Argomento principale Disposizione installazioni dall'editor delle opzioni


Utilizzo di StartSWInstall.exe per distribuire un'immagine amministrativa

È possibile installare o disinstallare un'immagine amministrativa nei client eseguendo il comando admin_image_install_dir\ StartSWInstall.exe. Questo metodo consente di installare SOLIDWORKS utilizzando le opzioni, i computer e i gruppi definiti nell'editor delle opzioni dell'immagine amministrativa.

È possibile aggiungere le seguenti opzioni al comando StartSWInstall.exe:
/install | Installa l'immagine amministrativa sui computer client.
/uninstall Disinstalla il software dai computer client, con due opzioni facoltative:

/removedata

Disponibile solo per la disinstallazione. Rimuove i file di dati e le cartelle di SOLIDWORKS durante la disinstallazione.

/removeregistry

Disponibile solo per la disinstallazione. Rimuove le voci di registro di SOLIDWORKS durante la disinstallazione.
/showui | Visualizza una finestra di avanzamento per Gestione installazioni SOLIDWORKS. In caso contrario, l'applicazione Gestione installazioni SOLIDWORKS non è visibile all'utente.
/now | Avvia immediatamente l'installazione o la disinstallazione. La finestra di dialogo di avviso 5 minuti non viene visualizzata.

È preferibile utilizzare StartSWInstall.exe anziché StartSWInstall.hta nei casi in cui si desidera che l'installazione proceda senza alcuna interazione da parte dell'utente, ma non si desidera utilizzare la distribuzione automatica dall'Editor opzione immagine amministrativa.

Argomento principale Disposizione installazioni dall'editor delle opzioni


Distribuzione manuale

Usare questo metodo se gli utenti hanno i privilegi amministrativi richiesti per installare software sui propri sistemi.

Per distribuire le installazioni manualmente via email:

  1. Nell’Editor opzioni fare clic su Distribuzione.
    Verrà visualizzata la disponibilità di installazione e lo stato per ogni macchina.
  2. Fare clic su Invia email.
  3. Specificare il percorso di rete alla directory d'installazione dell'immagine amministrativa.
    In genere, il percorso della directory di installazione dell'immagine amministrativa viene inizialmente visualizzato come percorso di un file di Windows (ad esempio, C:\SOLIDWORKS Admin\SOLIDWORKS 2020 SP0). La finestra di dialogo indica Questo percorso non è un percorso di rete.
    1. Fare clic su Fare clic su Sfoglia per specificare il percorso di rete di questa directory d'installazione dell'immagine amministrativa.
    2. Navigare al computer dove è installata l'immagine amministrativa e selezionare la directory Windows condivisa specificata per la directory d'installazione dell'immagine amministrativa.
      Non accedere nella directory condivisa dell'immagine amministrativa (ad esempio, nelle sottodirectory 64 bit)).
    3. Fare clic su OK.
      La finestra di dialogo indica Questo percorso è un percorso di rete.
    Viene generata un'email per fornire al proprietario del computer le istruzioni su come eseguire l'installazione dall'immagine amministrativa usando il percorso di rete per il file StartSWInstall.hta nell'immagine amministrativa.
  4. Inviare l'email agli utenti responsabili dell'installazione di SOLIDWORKS.

Gli utenti possono fare doppio clic sul collegamento al percorso di rete per StartSWInstall.hta nell'email per installare SOLIDWORKS dall'immagine amministrativa.

Nell'Editor delle opzioni, viene visualizzato lo Stato di installazione:
In attesa | L'utente non ha ancora eseguito l'installazione su questo computer.
Riuscita | L'utente ha completato con successo l'installazione su questo computer.
Non riuscita | L'utente ha eseguito l'installazione su questo computer, ma non è riuscita.

Altri messaggi di stato che potrebbero essere visualizzati sono: Installato con successo, Disinstallato con successo, Installazione, Disinstallazione, Riavvio necessario, Installazione non riuscita, e Disinstallazione non riuscita.

Argomento principale Disposizione installazioni dall'editor delle opzioni


Prerequisiti per la distribuzione automatica

Le operazioni di installazione vengono eseguite automaticamente nei computer di destinazione e completate dall'Utilità di pianificazione Microsoft in ogni sistema, senza richiedere alcun intervento da parte dell'utente. Usare questo metodo se gli utenti non hanno i privilegi amministrativi richiesti per installare software sui propri sistemi.

Con un'installazione push, l'Utilità di pianificazione avvia l'esecuzione di Gestione installazioni SOLIDWORKS in base alle credenziali specificate dall'amministratore. L'utilità di pianificazione viene eseguita con l'account LocalSystem del computer. Questo account è rappresentato in rete come entità di protezione del computer. L'entità di sicurezza del computer deve disporre di accesso in lettura alla cartella condivisa in cui si trova l'immagine amministrativa.

In Active Directory, quando si aggiunge un computer a un gruppo di una cartella condivisa, selezionare Tipi di oggetto e verificare che sia selezionato Computer.

Inoltre, il computer che fornisce l'immagine amministrativa e i computer client di destinazione devono appartenere allo stesso dominio di Active Directory.

Argomento principale Disposizione installazioni dall'editor delle opzioni


Distribuzione automatica

Per distribuire automaticamente effettuando il push delle installazioni ai sistemi dell'utente:

  1. Nell'Editor delle opzioni, fare clic sulla scheda Distribuzione automatica.
    Verrà visualizzata la disponibilità di installazione e lo stato per ogni macchina.
  2. Nella colonna Distribuzione, selezionare i computer client di destinazione e i gruppi nella colonna Distribuzione.
    Selezionare uno o più computer o gruppi nella colonna Distribuzione prima di iniziare il processo di distribuzione.
  3. In Orario installazione, selezionare Ora per distribuire subito o Dopo per pianificare data e orario specifici per la distribuzione.
  4. In Opzioni client, selezionare le opzioni seguenti:
    • Installa o aggiorna SOLIDWORKS 2020
    • Disinstalla SOLIDWORKS 2020
      Se si sceglie di disinstallare, è possibile specificare se disinstallare le voci di registro, i file di dati e le cartelle insieme ai programmi e alle cartelle.
  5. Selezionare Riavvia automaticamente il computer se si desidera che una o più macchine di destinazione si riavvii, in caso di necessità, durante o dopo la distribuzione.
  6. Inserire le Credenziali client di una o più macchine di destinazione.
  7. Fare clic su Distribuzione per iniziare il processo di distribuzione.
Nell'Editor delle opzioni viene visualizzato lo Stato di installazione:
In attesa | L'installazione non è ancora stata eseguita su questo computer.
Riuscita | L'installazione è stata completata con successo su questo computer.
Non riuscita | L'installazione su questo computer non è riuscita.

Altri messaggi di stato che potrebbero essere visualizzati sono: Installato con successo, Disinstallato con successo, Pianificazione, Connessione, Installazione, Disinstallazione, Riavvio necessario, Installazione pianificata, Disinstallazione pianificata, Installazione non riuscita, Disinstallazione non riuscita, Connessione non riuscita e Pianificazione non riuscita.

Argomento principale Disposizione installazioni dall'editor delle opzioni


Test di una configurazione per una distribuzione push

La scheda Distribuisci automaticamente nell'Editor opzione immagine amministrativa contiene una funzione di test.

È possibile eseguire un'installazione simulata che esercita i sistemi utilizzati per la distribuzione, ad esempio:
  • Connessione al computer di destinazione.
  • Creazione di un'attività di installazione su quel computer.
  • Completamento dell'attività di installazione su quel computer.
  • Aggiornamento di stato e log sull'immagine amministrativa.
  • Rilevamento di un programma da eseguire prima o dopo l'installazione.

Il test verifica i percorsi dei file, convalida le autorizzazioni e segnala che l'installazione è stata completata correttamente. Non installa alcun software né modifica il registro nel sistema di destinazione. Se uno dei sistemi non funziona su uno dei computer di destinazione, il test indica quale sistema non ha funzionato.

Le descrizioni dei comandi forniscono ulteriori informazioni sugli errori. È possibile esportare i risultati in un foglio di calcolo .xml (o .csv), utile per esaminare più errori o condividere i risultati con altro personale di supporto.

Per testare una configurazione per una distribuzione push:

  1. Utilizzando la Gestione installazioni, creare un'Immagine amministrativa.
  2. Avviare l'Editor delle opzioni immagine amministrativa.

    È possibile avviare l'opzione dopo che la Gestione installazioni ha completato la creazione dell'immagine amministrativa oppure fare doppio clic su sldAdminOptionEditor.exe nella cartella dell'immagine amministrativa.

  3. Nella scheda Configurazione, aggiungere uno o più computer.
  4. Fare clic su Distribuisci automaticamente:
    1. Fornire il nome utente e la password di un amministratore del dominio.
    2. Selezionare uno o più computer da testare.
    3. Fare clic su Test.
  5. Quando compare il test di configurazione, fare clic su Esegui test.
  6. Attendere alcuni minuti per il completamento del test o fare clic su Annulla test in qualsiasi momento.
  7. Esaminare e correggere eventuali problemi di configurazione.
Argomento principale Disposizione installazioni dall'editor delle opzioni


Uscita dall'Editor opzioni

È possibile fare clic su OK o su Chiudi per uscire dall'Editor opzioni.

Fare clic su OK, Chiudi o utilizzare il pulsante Chiudi delle applicazioni Windows per applicare le modifiche e chiudere l'Editor opzioni.
  • Fare clic su OK per applicare le modifiche alle impostazioni e chiudere l'Editor opzioni.
  • Fare clic su OK per uscire dall'Editor opzioni.

    Se vi sono modifiche non applicate, un messaggio invita a salvarle prima di uscire.

  • Fare clic sul pulsante Chiudi delle applicazioni Windows (X). Se vi sono modifiche non applicate, un messaggio invita a salvarle prima di uscire.
Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Visualizzazione e modifica delle impostazioni
Strumento Amministratore impostazioni
Disposizione installazioni dall'editor delle opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni


Creazione di un collegamento sul desktop per l'Editor opzioni

È possibile create un collegamento sul desktop per l'Editor opzioni di una particolare immagine amministrativa all'interno dell'applicazione.

  1. Avviare l'Editor opzioni.
    Ad esempio, in Esplora risorse, aprire la directory di installazione dell'immagine amministrativa e fare doppio clic su sldAdminOptionEditor.exe.
  2. Fare clic su Creare collegamento sul desktop per questo editor delle opzioni.
    Sul desktop di Windows appare un collegamento all'Editor opzioni dell'immagine amministrativa.
Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Visualizzazione e modifica delle impostazioni
Strumento Amministratore impostazioni
Disposizione installazioni dall'editor delle opzioni
Uscita dall'Editor opzioni


Distribuzione di un'immagine amministrativa ai client via email

Una volta creata una directory condivisa per l'immagine amministrativa, è possibile notificare i client via email.

Configurare la directory dell'immagine amministrativa da condividere su una macchina accessibile agli altri computer (es. con un percorso UNC).

È possibile inviare una mail con il collegamento al percorso_installazione_immagine_amministrativa\StartSWInstall.hta a tutti i client. I client potranno quindi selezionare questo collegamento e fare clic su Installa ora i prodotti SOLIDWORKS per avviare l'installazione dall'immagine amministrativa.

Se si aggiorna un'immagine amministrativa ad una nuova versione di SOLIDWORKS, si potrà configurare la posizione dell'immagine amministrativa e condividere le proprietà in modo che i client installati precedentemente usando quella immagine si aggiorneranno automaticamente. Per i dettagli, vedere Aggiornamento dei client dalle immagini amministrative.
Argomento principale Installazioni multiple
Distribuzione su più client
Uso di immagini amministrative
Distribuzione dalla riga di comando
Amministrazione delle installazioni multiple
Aggiornamento dei client dalle immagini amministrative


Distribuzione dalla riga di comando

È possibile distribuire automaticamente un'immagine amministrativa usando un prompt dei comandi o file batch (installazione invisibile).

Per distribuire un'immagine amministrativa mediante la riga di comando per i client SOLIDWORKS PDM, vedere la Guida di installazione di SOLIDWORKS PDM.

Indice

  • Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa

    Dopo aver creato l'immagine amministrativa e prima di aver notificato i client, è necessario installare i componenti Microsoft Windows che non possono essere installati da immagini amministrative, utilizzando la riga di comando o Microsoft Active Directory.

  • Installazione da un'immagine amministrativa mediante la riga di comando

    È possibile distribuire le installazioni da un'immagine amministrativa utilizzando la riga di comando.

  • Proprietà della riga di comando

    Le proprietà della riga di comando descritte di seguito comprendono proprietà di funzione, proprietà globali, proprietà specifiche di prodotto e convenzioni internazionali di Windows.

  • Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory

    La distribuzione tramite Microsoft Active Directory è supportata per la distribuzione del prodotto principale SOLIDWORKS ai client.

  • Installazione dei prerequisiti di Windows con Microsoft Active Directory

    Attenersi alla seguente procedura per preparare un'immagine amministrativa esistente che dovrà installare SOLIDWORKS sui computer client mediante Microsoft Windows Active Directory.

Argomento principale Installazioni multiple
Distribuzione su più client
Uso di immagini amministrative
Distribuzione di un'immagine amministrativa ai client via email
Amministrazione delle installazioni multiple


Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa

Dopo aver creato l'immagine amministrativa e prima di aver notificato i client, è necessario installare i componenti Microsoft Windows che non possono essere installati da immagini amministrative, utilizzando la riga di comando o Microsoft Active Directory.

L'installazione manuale di questi componenti di Windows è necessaria solo se si effettua l'installazione da un'immagine amministrativa dalla riga di comando o con Microsoft Active Directory. Se si usa Gestione installazioni SOLIDWORKS per creare ed installare l'immagine amministrativa, questi componenti di Windows vengono installati automaticamente.
Di seguito è fornito il riepilogo dei file necessari a SOLIDWORKS nei componenti Windows:
Windows Performance Toolkit: |
Pacchetti ridistribuibili di Visual C++ 2008, 2010, 2012, 2013 e 2015 | Contiene i componenti runtime per Microsoft Visual C++. Le versioni 2008, 2010, 2012, 2013 e 2015 devono essere installate.
Visual Basic for Applications 7.1 | Fornisce il supporto per le macro di Visual Basic.
Strumenti Visual Studio per Applicazioni 2005 | Contiene un gruppo di strumenti che supportano le applicazioni Visual Studio 2005. Per quanto riguarda SOLIDWORKS 2013, l'installazione di Microsoft Visual Studio Tools for Applications (VSTA) è facoltativa. VSTA 2005 dipende dall'installazione di Microsoft .NET Framework 3.5 sul PC. Per Windows 7 e successivi, .NET Framework è una funzione del sistema operativo. Se è necessario installarlo, .NET Framework 3.5 è disponibile sui supporti Windows e su Internet. Se non è possibile reperire i supporti Windows, non si dispone di una connessione Internet o non si dispone dell'autorizzazione a installare Microsoft .NET Framework 3.5 sul computer, contattare l'amministratore per ottenere assistenza.
Strumenti Visual Studio per Applicazioni 2015 | Optional. Contiene un gruppo di strumenti che supportano le applicazioni Visual Studio 2015.
Visual Studio Remote Debugger | Fornisce un ambiente di debug per i sistemi operativi a 64 bit.
.NET Framework 4.6.2 | Contiene il runtime di lingua comune e i componenti .NET Framework necessari per eseguire le applicazioni .NET Framework 4.6.2.
Servizio Bonjour per Windows | Fornisce la capacità di rilevare servizi in una LAN (local area network).
Il pacchetto ridistribuibile di Visual C++ e .NET Framework 4.6.2 sono necessari per tutti i prodotti SOLIDWORKS, non solo per il prodotto principale SOLIDWORKS.

Questi componenti devono essere compresi nelle sottodirectory della directory con l'immagine amministrativa.

La tabella seguente indica i file necessari per ogni sistema operativo supportato.
Sistema operativo: Windows Server 2016 a 64 bit e Windows Server 2019 a 64 bit
Sistema operativo: Windows Server 2012 R2 a 64 bit
L'installazione su Windows Server 2012 R2, 2016 e 2019 è supportata per SOLIDWORKS PDM Server e SOLIDWORKS SolidNetWork License Manager.
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2012 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2013 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2015 Redistributable Package: | vc_redist_x86.exe vc_redist_x64.exe Entrambi devono essere installati.
Strumenti Visual Studio per Applicazioni 2005: (opzionale) | vsta_aide.msi
Se VSTA 2005 è installato, è necessario .NET 3.5 Framework (dotnetfx35.exe). Per Windows 7, .NET Framework 3.5 è una funzione del sistema operativo.
Strumenti Visual Studio per Applicazioni 2015 (opzionale): | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Più un pacchetto lingua opzionale.
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Servizio Bonjour per Windows: | bonjour64.msi
L'installazione su Windows Server 2012 R2 è supportata per SOLIDWORKS PDM Server e SOLIDWORKS SolidNetWork License Manager.
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2012 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2013 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2015 Redistributable Package: | vc_redist_x86.exe vc_redist_x64.exe Entrambi devono essere installati.
Strumenti Visual Studio per Applicazioni 2005: (opzionale) | vsta_aide.msi
Se VSTA 2005 è installato, è necessario .NET 3.5 Framework (dotnetfx35.exe). Per Windows 7, .NET Framework 3.5 è una funzione del sistema operativo.
Strumenti Visual Studio per Applicazioni 2015 (opzionale): | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Più un pacchetto lingua opzionale.
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Servizio Bonjour per Windows: | bonjour64.msi
Sistema operativo: Windows 7 64-bit
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2012 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2013 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2015 Redistributable Package: | vc_redist_x86.exe vc_redist_x64.exe Entrambi devono essere installati.
Strumenti Visual Studio per applicazioni: (opzionale) | vsta_aide.msi
Se VSTA 2005 è installato, è necessario .NET 3.5 Framework (dotnetfx35.exe). Per Windows 7, .NET Framework 3.5 è una funzione del sistema operativo.
Strumenti Visual Studio per Applicazioni 2015: (opzionale | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Più un pacchetto lingua opzionale.
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Servizio Bonjour per Windows: | bonjour64.msi
Sistema operativo: Windows 10 a 64 bit
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2012 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2013 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Entrambi devono essere installati.
Visual C++ 2015 Redistributable Package: | vc_redist_x86.exe vc_redist_x64.exe Entrambi devono essere installati.
Strumenti Visual Studio per Applicazioni 2005: (opzionale) | vsta_aide.msi
Se VSTA 2005 è installato, è necessario .NET 3.5 Framework (dotnetfx35.exe). Per Windows 7, .NET Framework 3.5 è una funzione del sistema operativo.
Strumenti Visual Studio per Applicazioni 2015: (opzionale) | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Più un pacchetto lingua opzionale.
.NET Framework 4.6.2: | .NET 4.6.2 fa parte del sistema operativo, che soddisfa questo requisito.
Servizio Bonjour per Windows: | bonjour64.msi

Indice

  • Installazione dei prerequisiti di Windows dalla riga di comando su sistemi operativi a 64 bit

    Attenersi alla seguente procedura per installare i prerequisiti di Windows per l'installazione dell'immagine amministrativa utilizzando la riga di comando su versioni a 64 bit di Windows.

Argomento principale Distribuzione dalla riga di comando
Installazione da un'immagine amministrativa mediante la riga di comando
Proprietà della riga di comando
Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory
Installazione dei prerequisiti di Windows con Microsoft Active Directory


Installazione dei prerequisiti di Windows dalla riga di comando su sistemi operativi a 64 bit

Attenersi alla seguente procedura per installare i prerequisiti di Windows per l'installazione dell'immagine amministrativa utilizzando la riga di comando su versioni a 64 bit di Windows.

Per installare più componenti in una sola operazione, creare un file batch con i comandi forniti nelle seguenti procedure e usarlo per installare i componenti sui computer client.

  1. assicurarsi che il computer di destinazione abbia almeno 620 MB di spazio su disco e una directory TEMP valida.
  2. Installare il pacchetto ridistribuibile RELEASE di Visual C++.
    Installare il pacchetto per RELEASE = 2008, 2010, 2012, 2013 e 2015.
    directory_immagine_amministrativa\Microsoft_C++_RELEASE_Redistributable_(x64)\vcredist_x64.exe /Q

    directory_immagine_amministrativa\Microsoft_C++_RELEASE_Redistributable\vcredist_x86.exe /Q

    Devono essere installate sia la versione a 32-bit sia quella a 64 bit di questo pacchetto.

    Ad esempio, per installare il pacchetto ridistribuibile di Visual C++ 2008, utilizzare:

    • directory_immagine_amministrativa\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q
    • directory_immagine_amministrativa\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q
  3. Installare Microsoft .NET Framework 4.6.2:
    directory_immagine_amministrativa\.Net_Framework_4.6.2\NDP462-KB3151800-x86-x64-AllOS-ENU.exe
  4. Installare gli strumenti Visual Studio per applicazioni 2015:
    directory_immagine_amministrativa\Microsoft_VSTA\vsta_setup.exe
  5. Installare Visual Studio Remote Debugger:
    directory_immagine_amministrativa\VSRemoteDebugger\install.exe /Q
  6. Installare Visual Basic 7.1:
    \Microsoft_VBA\vba71.msi\Microsoft_VBA\vba71.msi e directory_immagine_amministrativa\Microsoft_VBA\vba71_1033.msi sono richiesti per tutte le lingue.
    Solo la versione a 64 bit di questo pacchetto deve essere installata.

    Inoltre, installare il language pack seguente per la lingua desiderata:

    vba71_1028.msi | Cinese
    vba71_1031.msi | Tedesco
    vba71_1036.msi | Francese
    vba71_1040.msi | Italiano
    vba71_1041.msi | Giapponese
    vba71_1042.msi | Coreano
    vba71_1046.msi | Portoghese brasiliano
    vba71_2052.msi | Cinese semplificato
    vba71_3082.msi | Spagnolo
    Le lingue inglese, ceca, polacca, russa e turca non necessitano di language pack aggiuntivi.
    A partire da SOLIDWORKS 2013 Service Pack 2.0, è necessario installare un ulteriore prerequisito: Msiexec.exe /p vba71-kb27832-x64.msp
  7. Installare il servizio Bonjour per Windows:
    directory_immagine_amministrativa\Bonjour\Bonjour64.msi
Argomento principale Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa


Installazione da un'immagine amministrativa mediante la riga di comando

È possibile distribuire le installazioni da un'immagine amministrativa utilizzando la riga di comando.

Per un'installazione invisibile:

  1. Aprire una finestra Prompt dei comandi (in Windows, fare clic su Start > Esegui).
  2. Digitare il comando msiexec.exe con /i e /qb ed impostare le proprietà per qualsiasi opzione non compresa nei valori di default indicati di seguito.

    msiexec /i "64-bit_admin_image_path\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

Le proprietà della riga di comando del singolo componente di installazione includono:
  • Proprietà di funzione della riga di comando
  • Proprietà globali della riga di comando
  • eDrawings Proprietà della riga di comando
  • Proprietà della riga di comando per SOLIDWORKS Flow Simulation

Usare gli esempi seguenti come modelli per un'installazione invisibile.

Client SOLIDWORKS

  • Ambiente SOLIDWORKS (inglese)
  • Aggiunta Toolbox
  • Partecipazione nel programma feedback
  • Lingua francese

SOLIDWORKS:

msiexec /i "64-bit_admin_image_path\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\cartella_utente" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks, SolidWorksToolbox /qb

Il componente di installazione di lingua francese SOLIDWORKS deve essere installato separatamente:

msiexec /i "64-bit_admin_image_path\SOLIDWORKS French\french.msi" /qb

Quando si specificano i comandi di installazione del componente di lingua di SOLIDWORKS, non specificare argomenti di riga dei comandi.

Client di eDrawings

  • Prestazione log
  • Tutte le funzioni

msiexec /i "admin_image_path\eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\your_folder" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb

SOLIDWORKS Electrical

A causa della complessità tecnica insita nell'installare SOLIDWORKS Electrical con Microsoft SQL Server, gli esempi della riga di comando per SOLIDWORKS Electrical sono esclusi dalla documentazione.

SOLIDWORKS PCB

msiexec /i “admin_image_path\SOLIDWORKS PCB.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS PCB” /qb

SOLIDWORKS Visualize e Visualize Boost

Per SOLIDWORKS Visualize:

msiexec. /i “admin_image_path\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

Per SOLIDWORKS Visualize Boost:

msiexec /i “admin_image_path\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

Argomento principale Distribuzione dalla riga di comando
Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa
Proprietà della riga di comando
Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory
Installazione dei prerequisiti di Windows con Microsoft Active Directory


Proprietà della riga di comando

Le proprietà della riga di comando descritte di seguito comprendono proprietà di funzione, proprietà globali, proprietà specifiche di prodotto e convenzioni internazionali di Windows.

Indice

  • Proprietà di funzione della riga di comando

    L?installazione di SOLIDWORKS supporta queste proprietà ADDLOCAL per la distribuzione dalla riga di comando.

  • Proprietà globali della riga di comando

    Ogni proprietà viene definita per le installazioni amministrative o individuali, salvo indicazione diversa. I numeri di seriali possono essere comunicati sia a un'installazione tramite immagine amministrativa sia a un'installazione individuale che utilizza le proprietà globali.

  • eDrawings Proprietà della riga di comando

    Queste proprietà della riga di comando sono specifiche a eDrawings ®.

  • Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player

    Queste proprietà della riga di comando sono specifiche di SOLIDWORKS Composer e SOLIDWORKS Composer Player.

  • Proprietà della riga di comando per SOLIDWORKS Flow Simulation

    Queste proprietà della riga di comando sono specifiche a SOLIDWORKS Flow Simulation.

  • Proprietà riga di comando di SOLIDWORKS Inspection

    Queste proprietà della riga di comando sono specifiche a SOLIDWORKS Inspection.

  • Proprietà della riga di comando di SOLIDWORKS Visualize

    Queste proprietà della riga di comando sono specifiche per SOLIDWORKS Visualize.

  • Posizioni dei file MSI per immagini amministrative

    Per creare immagini amministrative dalla riga di comando, i file .msi dei componenti del prodotto vengono memorizzati nelle seguenti posizioni sui supporti SOLIDWORKS.

Argomento principale Distribuzione dalla riga di comando
Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa
Installazione da un'immagine amministrativa mediante la riga di comando
Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory
Installazione dei prerequisiti di Windows con Microsoft Active Directory


Proprietà di funzione della riga di comando

L?installazione di SOLIDWORKS supporta queste proprietà ADDLOCAL per la distribuzione dalla riga di comando.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • VSTA
Quando si specificano le proprietà per l'installazione da riga di comando:
  • SOLIDWORKS non supporta l'installazione del prodotto usando l'opzione ADDSOURCE.
  • le proprietà sono sensibili al contesto, non possono contenere spazi o trattini e devono essere separate da virgole.

    SOLIDWORKS deve essere specificato con le maiuscole e le minuscole corrette nelle proprietà ADDLOCAL affinché l'applicazione venga installata correttamente.

Argomento principale Proprietà della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà globali della riga di comando

Ogni proprietà viene definita per le installazioni amministrative o individuali, salvo indicazione diversa. I numeri di seriali possono essere comunicati sia a un'installazione tramite immagine amministrativa sia a un'installazione individuale che utilizza le proprietà globali.

Proprietà | Descrizione
ENABLEPERFORMANCE Specifica se l'applicazione deve inviare automaticamente i dati relativi alla prestazione a SOLIDWORKS Corporation.

1

Inviare i dati relativi alle prestazioni.

0

Non inviare i dati relativi alle prestazioni.
INSTALLDIR Cartella di installazione per SOLIDWORKS.

Solo installazioni individuali.
MBDSERIALNUMBER | Numero di serie del prodotto SOLIDWORKS Model Based Definition.
MOTIONSERIALNUMBER | Numero di serie del prodotto SOLIDWORKS Motion.
OFFICEOPTION Specificare il pacchetto del prodotto da installare:
0 | Client SOLIDWORKS
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
REINSTALL Specificare ALL per aggiornare tutte le caratteristiche attualmente installate.
Specificare questa proprietà solo se si esegue l'aggiornamento a una versione del Service Pack che rientra in una release principale esistente (ad esempio, se si esegue l'aggiornamento da un'installazione SOLIDWORKS 2020 SP01 esistente a SOLIDWORKS 2020 SP02).
REINSTALLMODE Opzioni di reinstallazione di Microsoft Installer.

Ad esempio, se si esegue l'aggiornamento di un'installazione da una versione del Service Pack a un'altra che rientra nella stessa versione maggiore, specificare REINSTALLMODE = vomus.

Per ulteriori informazioni sulle impostazioni di REINSTALLMODE, vedere la documentazione di Windows Installer all'indirizzo www.microsoft.com.

Specificare questa proprietà solo se si esegue l'aggiornamento a una versione del Service Pack che rientra in una release principale esistente (ad esempio, se si esegue l'aggiornamento da un'installazione SOLIDWORKS 2020 SP01 esistente a SOLIDWORKS 2020 SP02). Non specificare questa proprietà la prima volta che si installa una nuova versione maggiore di SOLIDWORKS.
SERVERLIST Elenco server di SolidNetWork.
L'elenco server di SolidNetWork è un elenco delimitato di stringhe, ognuna delle quali fa riferimento a un numero di porta su un server con il seguente formato:
  • Terna (delimitata da virgole) =xxxxx@nome_server1,yyyyy@nome_server2,zzzzz@nome_server3
  • Non terna (delimitata da punto e virgola) = xxxxx@nome_server1;yyyyy@nome_server2;zzzzz@nome_server3
X e Y sono singole cifre. Non inserire un delimitatore dopo l'ultimo server nell'elenco.

Solo installazioni individuali.
SIMULATIONSERIALNUMBER | Numero di serie del prodotto SOLIDWORKS Simulation.
SOLIDWORKSSERIALNUMBER | Numero di serie del prodotto SOLIDWORKS, aggiunte comprese.
SWMIGRATE Versione di SOLIDWORKS da aggiornare così come apparirebbe nell'elenco nella finestra di dialogo Scelta di installazione SOLIDWORKS. Ad esempio:

SWMIGRATE="SOLIDWORKS 2020 x64 Edition SP01"

Specificare questa proprietà solo se si installa una nuova versione maggiore e ne è già installata una maggiore precedente. Non specificare questa proprietà se si esegue l'aggiornamento da una versione del Service Pack a un'altra che rientra nella stessa versione maggiore.
TOOLBOXFOLDER Cartella di installazione per i file di SOLIDWORKS Toolbox.

Solo installazioni individuali.

Ad esempio: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

Se l'ambiente dispone di una posizione PDM o di Creazione guidata fori/Toolbox condivisa, è possibile impostare un'installazione client in modo tale da non installare o aggiornare i dati Toolbox in quella posizione tramite la proprietà NOTTOOLBOXSETUP. Specificare:

0 | Installa i file Toolbox.
1 | Non installare i file Toolbox.
TRANSFORMS Contiene elementi specifici per la lingua nel formato:
TRANSFORMS numero.mst
  • Cinese (1028)
  • Cinese semplificato (2052)
  • Ceco (1029)
  • Inglese (1033)
  • Francese (1036)
  • Tedesco (1031)
  • Italiano (1040)
  • Giapponese (1041)
  • Coreano (1042)
  • Polacco (1045)
  • Portoghese brasiliano (1046)
  • Russo (1049)
  • Spagnolo (1034)
  • Turco (1055)
UPGRADESWINSTALL
Specificare se aggiornare una versione esistente di SOLIDWORKS alla versione corrente.
0 | Nuova installazione, non aggiornare.
1 | Aggiorna

Solo installazioni individuali.

Specificare questa proprietà solo se si installa una nuova versione maggiore e ne è già installata una maggiore precedente. Non specificare questa proprietà se si esegue l'aggiornamento da una versione del Service Pack a un'altra che rientra nella stessa versione maggiore.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


eDrawings Proprietà della riga di comando

Queste proprietà della riga di comando sono specifiche a eDrawings ®.

Proprietà | Descrizione
ADDLOCAL Specifica quale porzione dell'applicazione eDrawings installare.
Tutto è l'opzione raccomandata.
Sintassi linea comandi | Funzione
Tutto | Installa tutte le funzioni. L'applicazione eDrawings ricerca applicazioni publisher di SOLIDWORKS e AutoCAD per validare l'installazione.
CALS | Visualizza i file CAL nell'eDrawings Viewer
Inventor | Creazione dei file eDrawings dall'applicazione Autodesk Inventor.
eDrawingsViewer | Visualizza eDrawings e altri file.
ProE | Visualizza i file ProE nell'eDrawings Viewer
DXFDWGTranslator | Visualizza i file DXF/DWG in eDrawings Viewer.
Shortcuts | Installa i collegamenti sul desktop.
XML3D | Visualizza i file 3DXML nell'eDrawings Viewer.
INSTALLDIR | Specifica la cartella di installazione per eDrawings
LOGPERFORMANCE Specifica se l'applicazione deve inviare automaticamente via email i dati relativi alla prestazione alla SOLIDWORKS Corporation.
1 | Invia dati prestazionali
0 | Altrimenti
SNLSERVER Immettere porta@nome_server del server di licenza SolidNetWork. Utilizzare il punto e virgola per separare più combinazioni porta@nome_server .

Il nome server e la porta per SNLSERVER sono necessari solo per la configurazione del server SNL di SOLIDWORKS. list_of_port@server_strings è un elenco di stringhe delimitato dal punto e virgola, ognuno dei quali fa riferimento ad un numero di porta su un server con il formato:

xxxxx@nome_server1; yyyyy@nome_server2;

dove x e y sono singole cifre. Dopo l’ultimo server nell’elenco, non aggiungere un punto e virgola.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player

Queste proprietà della riga di comando sono specifiche di SOLIDWORKS Composer e SOLIDWORKS Composer Player.

Per SOLIDWORKS Composer:

Proprietà | Descrizione
ACTIVSERIALNUMBER | Numero di serie di SOLIDWORKS Composer.
ACTIVSERIALNUMBERPLAYERPRO | Optional. Numero di serie di SOLIDWORKS Composer Player Pro.
ADDLOCAL Se si installa l'applicazione completa, non è necessario specificare gli elementi riportati di seguito.
Necessario:
  • Licenza
  • Eula
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
Opzionale:
  • Sync3Dvia
INSTALLDIR | Specifica la cartella di installazione per il software SOLIDWORKS Composer.

Per SOLIDWORKS Composer Player:

Proprietà | Descrizione
ACTIVSERIALNUMBERPLAYERPRO | Optional. Numero di serie di SOLIDWORKS Composer Player Pro.
INSTALLDIR | Specifica la cartella di installazione per il software SOLIDWORKS Composer Player.
Su macchine che non hanno SOLIDWORKS installato, è necessario utilizzare SOLIDWORKS Translator per importare i file in SOLIDWORKS Composer. Per distribuire SOLIDWORKS Translator, è necessario utilizzare il SOLIDWORKS Installation Manager; non è possibile utilizzare la riga di comando.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà della riga di comando per SOLIDWORKS Flow Simulation

Queste proprietà della riga di comando sono specifiche a SOLIDWORKS Flow Simulation.

Proprietà | Descrizione
ACTIVSERIALNUMBER Numero di serie di SOLIDWORKS Flow Simulation standalone.

(Installazioni individuali e installazioni client da un'immagine amministrativa)
CWUPGRADEINSTALL Aggiorna una versione esistente di un particolare software SOLIDWORKS Flow Simulation.
1 | Aggiorna
2 | Nuova installazione; installazione in una nuova directory

(Installazioni individuali e installazioni client da un'immagine amministrativa)
INSTALLDIR Specifica l'installazione per una particolare applicazione SOLIDWORKS Flow Simulation.

(Solo installazioni individuali)
SERVERLIST | Elenco di stringhe delimitate da punti e virgole, ognuno dei quali fa riferimento ad un numero di porta su un server con il formato: xxxxx@nome_server1; yyyyy@nome_server2;& dove x e y sono cifre singole. Dopo l’ultimo server nell’elenco, non aggiungere un punto e virgola.
SOLIDWORKSPATH Specifica la cartella dove è installato il software SOLIDWORKS.

(Installazioni individuali e installazioni client da un'immagine amministrativa)
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà riga di comando di SOLIDWORKS Inspection

Queste proprietà della riga di comando sono specifiche a SOLIDWORKS Inspection.

Propriet | Descrizione
ACTIVSERIALNUMBER | Numero seriale di SOLIDWORKS Inspection. (Installazioni individuali e installazioni client da un'immagine amministrativa)
INSTALLDIR | Specifica l'installazione del software di applicazione di SOLIDWORKS Inspection. (Solo installazioni individuali)
SERVERLIST | Elenco di stringhe delimitate da punti e virgole, ognuno dei quali fa riferimento ad un numero di porta su un server con il formato: xxxxx@nome_server1; yyyyy@nome_server2;& dove x e y sono cifre singole. Dopo l’ultimo server nell’elenco, non aggiungere un punto e virgola.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà della riga di comando di SOLIDWORKS Visualize

Queste proprietà della riga di comando sono specifiche per SOLIDWORKS Visualize.

Proprietà | Descrizione
ACTIVSERIALNUMBER | Numero di serie di SOLIDWORKS Visualize. (Installazioni individuali e installazioni client da un'immagine amministrativa)
INSTALLDIR | Specifica l'installazione del software di applicazione SOLIDWORKS Visualize. (Solo installazioni individuali)
SERVERLIST | Elenco di stringhe delimitate da punti e virgole, ognuno dei quali fa riferimento ad un numero di porta su un server con il formato: xxxxx@nome_server1; yyyyy@nome_server2;& dove x e y sono cifre singole. Dopo l’ultimo server nell’elenco, non aggiungere un punto e virgola.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Posizioni dei file MSI per immagini amministrative


Posizioni dei file MSI per immagini amministrative

Per creare immagini amministrative dalla riga di comando, i file .msi dei componenti del prodotto vengono memorizzati nelle seguenti posizioni sui supporti SOLIDWORKS.

SOLIDWORKS (prodotto principale, in inglese)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (componenti non in lingua inglese)

Cinese tradizionale | swwi\lang\chinese\chinese.msi
Cinese semplificato | swwi\lang\chinese-simplified\chinese-simplified.msi
NewFeature1 | swwi\lang\czech\czech.msi
NewFeature1 | swwi\lang\french\french.msi
NewFeature1 | swwi\lang\german\german.msi
NewFeature1 | swwi\lang\italian\italian.msi
NewFeature1 | swwi\lang\japanese\japanese.msi
NewFeature1 | swwi\lang\korean\korean.msi
NewFeature1 | swwi\lang\polish\polish.msi
Portoghese brasiliano | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
NewFeature1 | swwi\lang\russian\russian.msi
NewFeature1 | swwi\lang\spanish\spanish.msi
NewFeature1 | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

eDrawings Shaders

eDrawingsShaders\eDrawings.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

PhotoView 360 Network Render

pvnetworkrender\pvnetrender.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

Attivazione guidata SOLIDWORKS

swactwizard\Activation Wizard.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Composer

composer\SOLIDWORKS Composer.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS PCB

PCB\SOLIDWORKS PCB.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional fornisce un'API, ma è disponibile solo per il Client e non è disponibile in un file .msi. Per ulteriori informazioni, vedere la Guida API nella directory install\API del client di SOLIDWORKS PDM.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize


Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory

La distribuzione tramite Microsoft Active Directory è supportata per la distribuzione del prodotto principale SOLIDWORKS ai client.

Microsoft Active Directory è un servizio di directory per la gestione dei client e dei server negli ambienti in rete. Semplifica la gestione, la migrazione e l'utilizzo.

Per informazioni su come installare SOLIDWORKS mediante Microsoft Active Directory, contattare il proprio rivenditore.

Argomento principale Distribuzione dalla riga di comando
Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa
Installazione da un'immagine amministrativa mediante la riga di comando
Proprietà della riga di comando
Installazione dei prerequisiti di Windows con Microsoft Active Directory


Installazione dei prerequisiti di Windows con Microsoft Active Directory

Attenersi alla seguente procedura per preparare un'immagine amministrativa esistente che dovrà installare SOLIDWORKS sui computer client mediante Microsoft Windows Active Directory.

  1. Estrarre tutti i file di installazione del pacchetto ridistribuibile di Visual C++ e installarli.
    1. Visual C++ 2008
      1. administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x: {Target Directory}
      2. administrative_image_directory\Microsoft_C++_2008_Redistributable_(64)\vcredist_x64.exe /x: {Target Directory}
      3. Creare un criterio per installare i moduli ridistribuibili di Microsoft C++ 2008.
    2. Visual C++ 2010
      1. administrative_image_directory\Microsoft_C++_2010_Redistributable\vcredist_x86.exe /x:{Target Directory}
      2. administrative_image_directory\Microsoft_C++_2010_Redistributable\vcredist_x64.exe /x:{Target Directory}
      3. Creare un criterio per installare i moduli ridistribuibili di Microsoft C++ 2010.
    3. Visual C++ 2012
      1. Installare admistrative_image_directory\Microsoft_C++_2012_Redistributable\vcredist_x86.exe su un computer di prova.
      2. Copiare queste cartelle in un percorso di rete (directory di destinazione):
        1. C:\ProgramData\PackageCache\{BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030
        2. C:\ProgramData\PackageCache\{B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030
    4. Visual C++ 2013
      1. administrative_image_directory\Microsoft_C++_2013_Redistributable\vcredist_x86.exe /x: {Target Directory}
      2. administrative_image_directory\Microsoft_C++_2013_Redistributable_(64)\vcredist_x64.exe /x: {Target Directory}
      3. Creare un criterio per installare i moduli ridistribuibili di Microsoft C++ 2013.
    5. Visual C++ 2015
      1. administrative_image_directory\Microsoft_C++_2015_Redistributable\vcredist_x86.exe /x: {Target Directory}
      2. administrative_image_directory\Microsoft_C++_2015_Redistributable_(64)\vcredist_x64.exe /x: {Target Directory}
      3. Creare un criterio per installare i moduli ridistribuibili di Microsoft C++ 2015.

      1. Creare un criterio per installare i seguenti file:
        Il percorso del file non può contenere spazi.

        Directory di destinazione\ {BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030\packages\

        vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi

        Directory di destinazione\ {B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030\packages\

        vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi

      2. Installare administrative_image_directory\Microsoft_ C++_2012_Redistributable_(64)\vcredist_x64.exe su un computer di prova.
      3. Copiare queste cartelle in un percorso di rete (directory di destinazione):
        1. C:\ProgramData\PackageCache\{CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030
        2. C:\ProgramData\PackageCache\{37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030
      4. Creare un criterio per installare i seguenti file:
        Il percorso del file non può contenere spazi.

        Directory di destinazione\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Directory di destinazione\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Directory di destinazione\ {37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030\packages\

        vcRuntimeAdditionalamd64\vc_runtimeAdditionalx64.msi

  2. Installare Microsoft .NET Framework 4.6.2.
    SOLIDWORKS consiglia di installare .NET Framework 4.6.2 mediante Windows Updates Services (WSUS) o servizio simile.
  3. Installare Visual Studio Remote Debugger (versioni a 64 bit solo quando .NET Framework 3.5 è installato sul computer), creando la seguente policy:
    {directory_Microsoft_remote_debugger}\rdbgexp.MSI
    Non è necessario un file di trasformazione per questa installazione.
  4. Eseguire le attività seguenti:
    1. Aggiornare Visual Basic 7.1 per le applicazioni con il service pack vba71-kb2783832-x64.
    2. Dopo aver creato l'immagine amministrativa, eseguire questo comando:
      Msiexec /a {SOLIDWORKS Administrative image}/Microsoft_vba/vba71.msi /p {SOLIDWORKS Administrative image}/Microsoft_vba_ kb2783832/vba71-kb2783832-x64.msp
    3. Installare Visual Basic 7.1, creando il seguente criterio:
      {directoryVBA}\vba71.MSI
      Non è necessario un file di trasformazione per questa installazione.
  5. Installare pacchetto linguistico di Visual Basic 7.1, creando il seguente criterio:
    {directoryVBA}\vba71_nnnn.MSI
    Dove nnnn definisce la lingua richiesta:
    • 1028 = cinese
    • 1031 = tedesco
    • 1033 = inglese
    • 1036 = francese
    • 1040 = italiano
    • 1041 = giapponese
    • 1042 = coreano
    • 1046 = portoghese
    • 2052 = cinese (Cina)
    • 3082 = spagnolo
  6. Installare il servizio Bonjour creando il seguente criterio:
    {directoryBonjour}\Bonjour.MSI
    Non è necessario un file di trasformazione per questa installazione.
Argomento principale Distribuzione dalla riga di comando
Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa
Installazione da un'immagine amministrativa mediante la riga di comando
Proprietà della riga di comando
Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory


Amministrazione delle installazioni multiple

Per installazioni multiple, le operazioni amministrative comprendono l'aggiornamento delle immagini amministrative alle nuove release, l'aggiornamento dei prodotti tramite Service Pack e la rimozione delle installazioni.

Indice

  • Aggiornamento di immagini amministrative a una nuova release

    Per aggiornare i client che hanno installato da un'immagine amministrativa, aggiornare prima l'immagine amministrativa e quindi configurare i client perché facciano riferimento alla nuova copia dell'immagine.

  • Amministrazione aggiornamento del prodotto con Service Pack

    Gli aggiornamenti di prodotto con Service Pack possono contenere correzioni per la maggiore affidabilità del sistema, per la compatibilità del programma, per un livello di protezione migliore ecc.

  • Rimozione di un'installazione

    Un'installazione può essere rimossa in un ambiente server/client o su un computer individuale.

Argomento principale Installazioni multiple
Distribuzione su più client
Uso di immagini amministrative
Distribuzione di un'immagine amministrativa ai client via email
Distribuzione dalla riga di comando


Aggiornamento di immagini amministrative a una nuova release

Per aggiornare i client che hanno installato da un'immagine amministrativa, aggiornare prima l'immagine amministrativa e quindi configurare i client perché facciano riferimento alla nuova copia dell'immagine.

Eseguire la Gestione installazioni di SOLIDWORKS da Internet in modo che i file corretti siano referenziati. La Gestione installazioni di SOLIDWORKS si occuperà di questo, ma l'utente può eseguire l'aggiornamento direttamente dal sito Web dei download di SOLIDWORKS (http://www.solidworks.com/sw/support/downloads.htm).

Una volta aggiornata l'immagine amministrativa (che crea una nuova copia dell'immagine), i client possono essere aggiornati in modo da creare riferimenti alla nuova copia dell'immagine amministrativa.

Se i client fanno riferimento alla versione precedente dell'immagine amministrativa usando un'unità mappata o una directory condivisa, ridefinire quell'unità mappata o directory condivisa usando la posizione della copia aggiornata dell'immagine amministrativa.

Indice

  • Download dei file di installazione aggiornati per le immagini amministrative

    La Gestione installazioni di SOLIDWORKS è in grado di rilevare quando sono necessari file di installazione aggiornati per un'immagine amministrativa.

  • Aggiornamento di un'immagine amministrativa

    Per aggiornare un'immagine amministrativa, la Gestione installazioni SOLIDWORKS crea una nuova directory immagine. Si indica quindi ai client di utilizzare la nuova directory dell'immagine amministrativa per aggiornare alla nuova versione del prodotto.

  • Aggiornamento dei client dalle immagini amministrative

    La Gestione installazioni SOLIDWORKS può aggiornare automaticamente i computer client installati da un'immagine amministrativa.

Argomento principale Amministrazione delle installazioni multiple
Amministrazione aggiornamento del prodotto con Service Pack
Rimozione di un'installazione


Download dei file di installazione aggiornati per le immagini amministrative

La Gestione installazioni di SOLIDWORKS è in grado di rilevare quando sono necessari file di installazione aggiornati per un'immagine amministrativa.

  1. Avviare la Gestione installazioni di SOLIDWORKS inserendo il dvd.
  2. Nella schermata Benvenuto, fare clic su Immagine amministrativa.
  3. Nella schermata Numero seriale, immettere il numero seriale di SOLIDWORKS.
    La Gestione installazioni verifica il sito Web di SOLIDWORKS per i prodotti con licenza e i Service Pack disponibili.
  4. Se appare la schermata Versione più recente disponibile , selezionare Sì, scarica e installa la versione più recente: versione.
    Gestione installazioni di SOLIDWORKS avvia una nuova sessione per installare la versione più recente.
  5. In caso di problemi con la cartella di download, potrebbero apparire le Opzioni di download, nel qual caso accettare la directory di default per i nuovi file di installazione o immettere un nuovo nome di directory.
    Se appare un messaggio che la directory non esiste, fare clic su Sì per crearla.
  6. Nella schermata Download completato, fare clic su Chiudi per chiudere l'installatore corrente ed avviarlo per la nuova versione.
Argomento principale Aggiornamento di immagini amministrative a una nuova release
Aggiornamento di un'immagine amministrativa
Aggiornamento dei client dalle immagini amministrative


Aggiornamento di un'immagine amministrativa

Per aggiornare un'immagine amministrativa, la Gestione installazioni SOLIDWORKS crea una nuova directory immagine. Si indica quindi ai client di utilizzare la nuova directory dell'immagine amministrativa per aggiornare alla nuova versione del prodotto.

Questa procedura presume che si siano scaricati i file di installazione aggiornati per l'immagine amministrativa. Per i dettagli, vedere Download dei file di installazione aggiornati per le immagini amministrative.

  1. Avviare Gestione installazioni SOLIDWORKS. Per i dettagli, vedere Inizio dell'installazione di SOLIDWORKS.
  2. Nella schermata introduttiva, selezionare Immagine amministrativa.
    Verranno visualizzate le opzioni di creazione dell'immagine amministrativa:
    Opzione | Descrizione
    Creare una nuova immagine usando le impostazioni di default. | Creare l'immagine usando le impostazioni di configurazione di default (ovvero, non basate sulle impostazioni attualmente stabilite per un'immagine amministrativa esistente presso il sito).
    Creare una nuova immagine usando le impostazioni e i file da un'immagine esistente. | Creare l'immagine usando le impostazioni di configurazione specificate da un'immagine amministrativa esistente presso il sito. Fare clic su Sfoglia per specificare la directory di installazione dell'immagine amministrativa esistente.
  3. Nella schermata Numero seriale, controllare il numero seriale.
  4. Nella schermata Sintesi (Pronto a creare immagine), verificare che le opzioni dell'immagine amministrativa siano corrette.
    Per i dettagli sulle varie opzioni di un'immagine amministrativa e per l'installazione, fare clic su CAMBIA per aprire la pagina delle opzioni, quindi fare clic su ?.
  5. Per creare una nuova versione dell'immagine amministrativa, fare clic su Crea ora.

È ora possibile aggiornare i client a questa nuova versione dell'immagine amministrativa. Per i dettagli, vedere Aggiornamento dei client dalle immagini amministrative.

Argomento principale Aggiornamento di immagini amministrative a una nuova release
Download dei file di installazione aggiornati per le immagini amministrative
Aggiornamento dei client dalle immagini amministrative
Inizio dell'installazione di SOLIDWORKS


Aggiornamento dei client dalle immagini amministrative

La Gestione installazioni SOLIDWORKS può aggiornare automaticamente i computer client installati da un'immagine amministrativa.

Tipicamente, le immagini amministrative sono organizzate in cartelle su un server. Per supportare l'aggiornamento automatico dei clienti, l'immagine amministrativa di SolidWorks dovrà trovarsi in una cartella condivisa.

Dopo l'aggiornamento dell'immagine amministrativa, l'installazione originale sarà in una cartella e l'installazione aggiornata sarà in un'altra. Per usare l'installazione aggiornata, rimuovere prima di tutto l'opzione di condivisione dalla cartella dell'immagine amministrativa originale ed aggiungere l'opzione di condivisione alla cartella dell'immagine amministrativa aggiornata.

Quando SOLIDWORKS inizia su una macchina client installata da un'immagine amministrativa originale, visualizza la nuova versione e aggiorna il client.
Inoltre, quando SOLIDWORKS lancia un aggiornamento, gli altri prodotti installati da un'immagine amministrativa vengono automaticamente aggiornati.
Argomento principale Aggiornamento di immagini amministrative a una nuova release
Download dei file di installazione aggiornati per le immagini amministrative
Aggiornamento di un'immagine amministrativa

Rimozione dell'opzione Condivisione dalla cartella dell'immagine amministrativa originale

Quando si aggiorna un'immagine amministrativa con accesso da una cartella condivisa, è necessario rimuovere la condivisione dalla cartella originale.

  1. navigare alla cartella dove i file dell'immagine amministrativa originale sono ubicati.
  2. Fare clic con il pulsante destro del mouse sulla cartella e selezionare Proprietà.
  3. Nella scheda Condivisione, selezionare Non condividere questa cartella e fare clic su OK.

Aggiungere l'opzione di condivisione alla cartella dell'immagine amministrativa aggiornata, come descritto in Aggiunta dell'opzione Condivisione a una cartella dell'immagine amministrativa aggiornata.

Aggiunta dell'opzione Condivisione a una cartella dell'immagine amministrativa aggiornata

Una volta creata la cartella aggiornata dell'immagine amministrativa e dopo aver disattivato la condivisione per la cartella originale, è necessario aggiungere l'opzione Condivisione alla nuova cartella per riattivare l'immagine amministrativa.

  1. navigare alla cartella dove i file dell'immagine amministrativa aggiornata sono ubicati.
  2. Fare clic con il pulsante destro del mouse sulla cartella e selezionare Proprietà.
  3. Nella scheda Condivisione, specificare le proprietà di condivisione appropriate per la propria azienda o gruppo e modificare il nome di condivisione con il nome usato per la cartella delle immagini amministrative.
I computer con installazione dalla posizione condivisa dell'immagine amministrativa originale si aggiorneranno automaticamente alla nuova versione all'avvio di SOLIDWORKS.


Amministrazione aggiornamento del prodotto con Service Pack

Gli aggiornamenti di prodotto con Service Pack possono contenere correzioni per la maggiore affidabilità del sistema, per la compatibilità del programma, per un livello di protezione migliore ecc.

L'utente può acquisire gli aggiornamenti del prodotto in due modi:
  • Utilizzando Gestione installazioni SOLIDWORKS per verificare la disponibilità, scaricare e installare gli aggiornamenti.

    Gestione installazioni SOLIDWORKS può essere avviata manualmente o pianificata per controllare periodicamente gli aggiornamenti.

  • Scaricando i Service Pack manualmente dal sito Web del supporto SOLIDWORKS.

    I service pack vengono applicati come patch ad una versione esistente del software. Ad esempio, SOLIDWORKS 2020 SP1.0 è un Service Pack per SOLIDWORKS 2020 SP0.0. Questi Service Pack possono essere installati tramite la Gestione installazioni di SOLIDWORKS 2020; non è possibile installarli utilizzando la Gestione installazioni SOLIDWORKS in SOLIDWORKS 2019.

    Per le istruzioni o per scaricare ed installare i Service Pack, vedere la documentazione sull'installazione per la versione di SOLIDWORKS in via di aggiornamento.

Indice

  • Annullamento dei Service Pack in un'immagine amministrativa

    Si può riportare un'immagine amministrativa ad un Service Pack precedente. Se il software SOLIDWORKS viene installato dai CD, sarà necessario il CD originale per ripristinare un Service Pack. Sarà necessario avere una copia dell'immagine amministrativa precedente.

  • Applicazione dei Service Pack ai client distribuiti con Microsoft Active Directory

    Se SOLIDWORKS è stato installato con Microsoft Active Directory, sarà possibile utilizzare tale funzionalità per applicare i Service Pack ai client.

Argomento principale Amministrazione delle installazioni multiple
Aggiornamento di immagini amministrative a una nuova release
Rimozione di un'installazione


Annullamento dei Service Pack in un'immagine amministrativa

Si può riportare un'immagine amministrativa ad un Service Pack precedente. Se il software SOLIDWORKS viene installato dai CD, sarà necessario il CD originale per ripristinare un Service Pack. Sarà necessario avere una copia dell'immagine amministrativa precedente.

Le immagini amministrative che sono state aggiornate non possono essere riportate ad un Service Pack precedente. Le immagini amministrative create con qualsiasi metodo diverso dalla Gestione installazioni SOLIDWORKS non potranno essere riportate ad una versione precedente. I client installati da queste immagini amministrative devono essere disinstallati e quindi reinstallati con un'immagine amministrativa creata dalla versione precedente.
  1. Cancellare la cartella che contiene l'immagine amministrativa corrente. A tale fine, aprire la finestra Prompt dei comandi e digitare:
    rmdir /s/q percorso_immagine_amministrativa_corrente
  2. Spostare la copia di backup dell'immagine amministrativa nella posizione in cui è stata eliminata l'immagine amministrativa corrente. A tale fine, aprire la finestra Prompt dei comandi e digitare:
    move percorso_backup_immagine_amministrativa percorso_immagine_amministrativa_corrente
    Dopo avere ripristinato la versione precedente di un'immagine amministrativa, i computer client saranno riportati la versione precedente all'esecuzione successiva del software SOLIDWORKS.
Argomento principale Amministrazione aggiornamento del prodotto con Service Pack
Applicazione dei Service Pack ai client distribuiti con Microsoft Active Directory


Applicazione dei Service Pack ai client distribuiti con Microsoft Active Directory

Se SOLIDWORKS è stato installato con Microsoft Active Directory, sarà possibile utilizzare tale funzionalità per applicare i Service Pack ai client.

  1. Copiare l'immagine amministrativa su una nuova cartella usando la seguente riga di comando:
    xcopy percorso_a_immagine_amministrativa_corrente percorso_a_immagine_amministrativa_di_backup /s/i/v
  2. Aggiornare l'immagine amministrativa utilizzando Gestione installazioni SOLIDWORKS.
  3. Creare un nuovo file di trasformazione per specificare un'installazione di aggiornamento per il software SOLIDWORKS:
    1. Aprire la finestra Prompt dei comandi.
    2. Nella cartella che contiene l'immagine amministrativa, trascinare SWCreateMST.exe nella finestra del Prompt dei comandi.
      Il formato del comando è:

      percorso_immagine_amministrativa\SWCreateMST.exe percorso_a_file_MSI_di_una_immagine_amministrativa elenco_delle_proprietà

      La riga dei comandi deve comprendere tutti i parametri usati per creare il file di trasformazione originale, oltre alle proprietà UPGRADESWINSTALL e SWMIGRATE.

      Per esempio, se il comando originale era:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\cartella_utente" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@server_utente

      il comando di aggiornamento deve essere:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\cartella_utente" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@server_utente UPGRADESWINSTALL=1 SWMIGRATE="SOLIDWORKS versione service_pack"

      Il file di trasformazione SOLIDWORKS.mst viene creato nella cartella che contiene l'immagine amministrativa.

  4. In Active Directory, modificare il criterio Applicazioni pubblicate del gruppo o dei gruppi per distribuire il software SOLIDWORKS.
  5. Nella finestra di dialogo Criteri di gruppo, espandere Configurazione del computer e impostazioni software.
  6. Fare clic con il pulsante destro del mouse su Installazione del software e selezionare Nuovo > Pacchetto.
  7. Identificare l'immagine amministrativa e fare clic su Apri.
  8. Nella finestra di dialogo Deploy Software, selezionare Advanced published or assigned, quindi fare clic su OK.
  9. Nella finestra di dialogo Proprietà SOLIDWORKS, nella scheda Modifiche:
    1. Fare clic su Aggiungi.
    2. Navigare al file .mst.
    3. Fare clic su Apri.
  10. Fare clic su OK.
Argomento principale Amministrazione aggiornamento del prodotto con Service Pack
Annullamento dei Service Pack in un'immagine amministrativa


SOLIDWORKS PDM e SOLIDWORKS Manage

SOLIDWORKS PDM è un prodotto per la gestione dei documenti basato sull'architettura client/server precedentemente conosciuta come SOLIDWORKS Enterprise PDM. SOLIDWORKS PDM è disponibile in due tipi:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM utilizza un database Microsoft SQL Server per gestire i vault.

Questa tabella elenca i sistemi database, componenti server e le opzioni client disponibili per ogni tipo di prodotto.
 | PDM Standard | PDM Professional
Progettato per | Reti aziendali di piccole e medie dimensioni, generalmente con meno di 20 utenti simultanei. | Reti aziendali di grandi dimensioni, numerosi utenti simultanei
Limiti | Dimensioni inferiori a 1 socket o 4 core, 1 GB di RAM e 10 GB di database | Limiti SQL Standard: Dimensioni inferiori a 4 socket o 16 core, 128 GB di RAM e 524 PB di database
Sistema di gestione database | Microsoft SQL Server Express 2014 (incluso e installato con SOLIDWORKS) | Microsoft SQL Server 2014 (incluso separatamente con SOLIDWORKS) o istanze precedentemente installate di Microsoft SQL Server 2014, 2012 o 2008 R2
Richiede SolidNetWork License Manager? | Sì | Sì
Include il server archivio e il server database? | Sì | Sì
Include SOLIDWORKS PDM Web Server e Web2 Server? | No | Sì
Tipi di client | Nativo | Nativo, basato su browser
Aggiunte del client per CAD Editors | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Integrazione Microsoft Office, Autodesk Inventor, AutoCAD
Aggiunte del client per Contributors | DraftSight | DraftSight, Microsoft Office Integration
Aggiunte del client per Viewers |  | Integrazione con Microsoft Office

SOLIDWORKS Manage Professional offre strumenti avanzati di gestione dati per SOLIDWORKS PDM Professional. Offre funzionalità per un controllo della versione avanzato e per la gestione dei progetti, dei processi e degli elementi. Dashboard e rapporti interattivi aiutano a tenere traccia degli elementi, delle attività e dei progressi ottenuti durante il completamento dei progetti.

SOLIDWORKS Manage Professional ha un'architettura simile a quella di SOLIDWORKS PDM Professional. Utilizza un'architettura client-server, con un database Microsoft SQL Server, per gestire gli elementi e i dati del progetto. Vi sono tre servizi per database, server file e funzioni server Web, che supportano sia thick client che client browser Web. I tre servizi possono essere ospitati sullo stesso server o su server separati. Gli utenti che dispongono di licenze SOLIDWORKS Manage Professional Editor possono utilizzare il componente aggiuntivo SOLIDWORKS Manage, per accedere ai dati di gestione direttamente da SOLIDWORKS.

È possibile utilizzare Gestione installazioni SOLIDWORKS per installare il server e il client di SOLIDWORKS Manage Professional.

Per istruzioni sull'installazione di SOLIDWORKS Manage Professional, consultare la Guida di installazione di SOLIDWORKS PDM/SOLIDWORKS Manage.

Indice

  • Elenco di componenti server PDM

  • Differenze tra i client PDM

    Prima di installare il software client, è necessario determinare i client necessari a seconda dell'ambiente PDM in uso.

  • Prima di installare il server PDM

    Tenere a mente questi requisiti prima di installare i componenti server PDM:

  • Installare un server PDM con SLDIM

    Quando si installa il server PDM per PDM standard, è possibile installare il server di archivio, il server del database e il client PDM CAD Editor sulla stessa macchina. Non è necessario eseguire l'installazione del client separatamente.

  • L'installazione di PDM Client con SLDIM


Elenco di componenti server PDM

In questa tabella vengono riepilogati i componenti di SOLIDWORKS PDM Server.

Server | Funzione | Installazione
Microsoft SQL Server Express per PDM Standard | Gestisce i dati nei vault di dati SOLIDWORKS PDM. | Può essere installato con PDM Standard o utilizzare una versione precedentemente concessa in licenza e installata.
Microsoft SQL Server per PDM Professional | Gestisce i dati nei vault di dati SOLIDWORKS PDM. | Fornito separatamente con PDM Professional. Si può anche usare una versione precedentemente concessa in licenza e installata.
SolidNetWork License Manager | Gestisce licenze SOLIDWORKS PDM. | Deve essere installato prima che possano essere creati nuovi vault. Può essere installato con i componenti server di SOLIDWORKS PDM quando si utilizza SLDIM.
Server di archivio | Gestisce trasferimenti di file tra i client e l'archivio dei vault e gestisce gli utenti e le relative credenziali. | Necessario. Deve essere installato con PDM Standard o Professional.
Server database | Esamina i database PDM per verificare la presenza di aggiornamenti, gestisce le regole di importazione ed esportazione dati, gestisce il sistema di messaggi e le pianificazioni replica e cold storage. | Necessario. Deve essere installato con PDM Standard o Professional.
Web Server e Web2 Server | Fornisce l'accesso ai vault su Internet da client basati su browser. | Optional. Può essere installato solo con PDM Professional.
Server API Web | Gli utenti EXALEAD OnePart possono utilizzare un server API Web per indicizzare e recuperare i dati SOLIDWORKS PDM. | Optional. Può essere installato solo con PDM Professional.

I server di archiviazione vengono eseguiti come servizi nell'account di sistema dei computer in cui sono installati. Un server archivio può ospitare più vault sullo stesso computer.

In un'installazione standalone, il server archivio, il server database, il server di licenza e il server API WEB, nonché il database SQL Express o SQL Server, possono essere installati sullo stesso computer.

In un ambiente distribuito, i componenti del server possono trovarsi su computer diversi. È inoltre possibile configurare più server archivio in computer diversi per ospitare copie replicate dello stesso archivio del vault. Vedere la Guida di replicazione per SOLIDWORKS PDM Professional.

Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


Differenze tra i client PDM

Prima di installare il software client, è necessario determinare i client necessari a seconda dell'ambiente PDM in uso.

In questa tabella vengono riepilogati i client per SOLIDWORKS PDM Standard:
Tipo di client standard | Descrizione
CAD Editor | Supporta l'uso di file SOLIDWORKS, DWG/DXF, Microsoft Word e Microsoft Excel. Tutti i formati di file gestiti dal plug-in di Office si comportano nello stesso modo in SOLIDWORKS PDM Standard, ad eccezione di Preview.
Contribuente | Supporta l'uso di file SOLIDWORKS, DWG/DXF, Microsoft Word e Microsoft Excel.
Visualizzatore | Consente l'accesso di sola lettura ai vault del file. L'utente può transitare i file attraverso un flusso di lavoro, ma l'utente non può aggiungere o modificare (check-in, check-out, aggiornamento valori) i file.
In questa tabella vengono riepilogati i client per SOLIDWORKS PDM Professional:
Tipo di client Professional | Descrizione
CAD Editor e Web | Supporta tutti i tipi di file, permettendo la gestione avanzata e la visualizzazione dei formati CAD, come SOLIDWORKS. Attraverso aggiunte CAD gli utenti possono accedere a SOLIDWORKS PDM Professional dall’interno dell’applicazione CAD. Gli utenti remoti possono eseguire ricerche nei vault ed eseguire funzioni di base su Internet utilizzando i client Web e Web2.
Contributor e Web | Supporta l’uso di tutti i tipi di file, inclusi i formati CAD. Su questo tipo di client non sono supportate le aggiunte CAD. Gli utenti remoti possono eseguire ricerche nei vault ed eseguire funzioni di base su Internet utilizzando i client Web e Web2.
Visualizzatore | Consente l'accesso di sola lettura ai vault del file. L'utente può transitare i file attraverso un flusso di lavoro, ma l'utente non può aggiungere o modificare (check-in, check-out, aggiornamento valori) i file o utilizzare le aggiunte CAD.
Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


Prima di installare il server PDM

Tenere a mente questi requisiti prima di installare i componenti server PDM:

  • Ottenere diritti amministrativi completi per i computer in cui si intende installare server e client.
  • Verificare che il server database abbia accesso al server archivio tramite la porta TCP 3030 e a SQL Server tramite la porta TCP 1433.
  • Se si intende utilizzare un database SQL Server Express o SQL Server esistente, ottenere il nome del database SQL Server e l'ID e la password dell'account di un amministratore o un proprietario di database SQL Server con accesso in lettura/scrittura al database. Non è possibile utilizzare l'utente tew.
  • Se un client PDM è già installato sul sistema, disinstallarlo. Se si desidera che il server PDM e il client PDM siano sullo stesso sistema, è possibile installarli entrambi dalla pagina Prodotti del server in Gestione installazioni di SOLIDWORKS.
Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


Installare un server PDM con SLDIM

Quando si installa il server PDM per PDM standard, è possibile installare il server di archivio, il server del database e il client PDM CAD Editor sulla stessa macchina. Non è necessario eseguire l'installazione del client separatamente.

Quando si installa il server PDM per PDM Professional, è possibile includere questi componenti e anche il server Web, server Web2 e server API Web.

Per installare un server PDM e i suoi componenti:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina Benvenuto, selezionare Prodotti del server e verificare quanto segue:
    • Installare i componenti di SOLIDWORKS PDM Server su questo computer.
    • Installare SolidNetWork License Manager su questo computer.

      Se SolidNetWork License Manager viene installato, questa opzione non viene visualizzata.

  3. Se viene visualizzata la pagina Opzioni SolidNetWork License Manager, immettere un numero seriale e specificare una posizione per la directory, quindi fare clic su Avanti.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi, per SOLIDWORKS PDM Server, fare clic su Cambia.
  6. Nella pagina Opzioni del server SOLIDWORKS PDM:
    1. Per selezionare prodotto server, fare clic su SOLIDWORKS PDM Standard o Professional.
    2. Per Ubicazione installazione, fare clic su Sfoglia per specificare un percorso del file.
    3. In Selezionare funzioni:
      1. Fare clic su Server di archivio, Server database e Client per installare Questi componenti sulla stessa macchina. Se si è in un ambiente distribuito, è possibile installare il server di archivio e il server database eseguendo il gestore installazioni su un'altra macchina.
        Se un client PDM è già installato sulla macchina, è necessario annullare l'installazione e disinstallare il client. È quindi possibile eseguire SLDIM per installare il server PDM insieme al client.
      2. Se si sta installando PDM Professional, è anche possibile fare clic su server Web server Web2 e Server API Web.
        Se si sta installando il server API Web, è possibile specificare un valore per il Numero di porta HTTP compreso tra 0 e 65535. Il valore predefinito è 65453.
    4. In SQL Server, è possibile installare una nuova istanza degli strumenti del database forniti con PDM Server (SQL Server Express per PDM Standard), oppure è possibile specificare nome del database, nome utente e password di un'istanza esistente.
      L'edizione completa di SQL server viene fornita separatamente con PDM Professional.
    5. Fare clic su Torna alla Sintesi.
  7. Nella pagina Sintesi accettare i termini del contratto di licenza SOLIDWORKS e fare clic su Installa ora.

    Quando Gestione installazioni di SOLIDWORKS completa l'installazione, lo strumento Configurazione del server archivio viene avviato. Seguire le indicazioni nella procedura guidata per configurare il server archivio.

Per installare, configurare e risolvere i problemi relativi al server di archivio, al server del database, ai server Web e Web2 e ai database SQL Server, consultare gli argomenti pertinenti nella Guida di installazione di SOLIDWORKS PDM 2020.

Indice

  • Modifica di un'installazione di SOLIDWORKS PDM Server

Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


Modifica di un'installazione di SOLIDWORKS PDM Server

Per modificare un'installazione di SOLIDWORKS PDM Server e dei relativi componenti, utilizzare Programmi e funzionalità dal Pannello di controllo di Windows. Non è possibile modificare l'installazione tramite Gestione installazioni di SOLIDWORKS (SLDIM), anche se è stato utilizzato per installare SOLIDWORKS PDM Server.

Argomento principale Installare un server PDM con SLDIM


L'installazione di PDM Client con SLDIM

La versione principale del client SOLIDWORKS PDM deve corrispondere alla versione principale del server SOLIDWORKS PDM. Quando si installa o si aggiorna il SOLIDWORKS PDM Client, accertarsi che le versioni corrispondano.

Per installare un PDM Client:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina di benvenuto selezionare Individuale.
  3. Nella pagina Numero seriale fare clic su Avanti.
    I client SOLIDWORKS PDM non richiedono un numero di serie separato.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi, in Prodotti, fare clic su Cambia.
  6. Nella pagina Selezione prodotto fare clic su Selezionare pacchetti o prodotti diversi.
  7. Nella finestra di dialogo Selezionare il pacchetto da visualizzare selezionare un'edizione di SOLIDWORKS. Quindi fare clic su OK.
  8. Nella pagina Selezione prodotto selezionare SOLIDWORKS PDM Client. Quindi selezionare eDrawings per attivare la funzionalità di anteprima PDM. Se si utilizza una versione di SOLIDWORKS PDM Professional, è inoltre possibile selezionare Item Explorer.
  9. Nella pagina Sintesi espandere Opzioni SOLIDWORKS PDM e fare clic su Cambia.
  10. Nella pagina Opzioni del client SOLIDWORKS PDM selezionare quanto segue e fare clic su Torna alla sintesi:
    • Tipo di prodotto PDM
    • Tipo di client PDM
    • Aggiunte
  11. Nella pagina Sintesi accettare i termini del contratto di licenza SOLIDWORKS e fare clic su Installa ora.
Gli amministratori possono inoltre utilizzare l'Editor opzione immagine amministrativa per creare e distribuire immagini di client PDM. Per i dettagli, vedere Uso di immagini amministrative nella Guida di amministrazione e d'installazione di SOLIDWORKS.
Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


SOLIDWORKS Electrical

SOLIDWORKS Electrical semplifica la progettazione dei sistemi elettrici grazie a strumenti di progettazione intelligenti, a un database di parti completo e all'integrazione in tempo reale tra gli schemi elettrici 2D e i modelli 3D.

I componenti principali di SOLIDWORKS Electrical sono:
  • Schemi di SOLIDWORKS Electrical - Strumenti per la creazione dinamica degli schemi elettrici 2D.
  • SOLIDWORKS Electrical 3D - Strumenti per l'integrazione degli schemi elettrici 2D con i modelli 3D, al fine di consentire la modellazione dei sistemi elettrici 3D, compresi cavi e fili.
  • Dati: un database di parti, simboli, librerie e cataloghi che possono essere condivisi dagli utenti.
  • Server collaborativo: un'utility per gestire l'apertura e l'aggiornamento dei disegni elettrici.
  • Un'istanza del database Microsoft SQL Server.

SOLIDWORKS Electrical richiede un database Microsoft SQL Server. È possibile utilizzare un database esistente o una nuova variante come parte dell'installazione.

È possibile installare tutti i componenti di SOLIDWORKS Electrical nello stesso computer. Questa installazione è considerata in genere come installazione standalone. Tutti i dati del programma, come i disegni e i rapporti dei progetti, vengono memorizzati in un unico sistema. Per l'installazione di SOLIDWORKS Electrical sono necessari diritti amministrativi completi per il sistema.

È possibile installare i componenti di SOLIDWORKS Electrical anche come applicazione client/server. Questo tipo di installazione è necessario quando i dati devono essere memorizzati in un server di rete o quando è disponibile un database SQL Server esistente in un server di rete che memorizza tutti i database SOLIDWORKS Electrical. In questi casi, sono richiesti diritti amministrativi completi per i sistemi server e client. Inoltre, i sistemi client devono disporre dell'accesso di rete al server e dei privilegi di lettura/scrittura per la creazione di progetti, librerie e simboli.

Su un machina è possibile installare una sola versione di SOLIDWORKS Electrical. Se si sta creando una nuova installazione di SOLIDWORKS, e si seleziona SOLIDWORKS Electrical tra i prodotti da installare, la precedente versione di SOLIDWORKS Electrical verrà rimossa.

Eseguire sempre il backup dell'ambiente esistente di SOLIDWORKS Electrical prima di installare la nuova versione. Dall'interno degli schemi di SOLIDWORKS Electrical selezionare File Archivia ambiente oppure, in SOLIDWORKS Electrical 3D, selezionare SOLIDWORKS Electrical > Strumenti > Archivia ambiente.

Indice

  • Gestione dei dati in SOLIDWORKS Electrical

  • Requisiti per l'installazione di SOLIDWORKS Electrical


Gestione dei dati in SOLIDWORKS Electrical

Molti programmi utilizzano un solo database che contiene tutti i dati del programma. Questo non avviene con SOLIDWORKS Electrical. A ogni progetto in SOLIDWORKS Electrical è assegnato un numero di ID univoco e a ogni progetto è correlato un database che può essere identificato in base a tale ID univoco. Ad esempio, se nel Project Manager di SOLIDWORKS Electrical si trova un progetto con ID 112, il database associato è denominato "tew_project_data_112".

La disponibilità di un database univoco per ogni progetto consente di ridurre in modo significativo i tempi di elaborazione. Inoltre, in caso di errore critico del database, viene interessato dall'errore un solo progetto, garantendo l'integrità della maggior parte delle informazioni del programma.

Tuttavia, alcune aziende prevedono policy che limitano la creazione di nuovi database. Per eseguire SOLIDWORKS Electrical, non deve essere presente nessuna restrizione alla creazione di nuovi database da parte degli utenti. Per assicurarsi che le impostazioni di configurazione non impediscano agli utenti di creare nuovi database, rivolgersi all'amministratore del database o di sistema.
Argomento principale SOLIDWORKS Electrical
Requisiti per l'installazione di SOLIDWORKS Electrical


Requisiti per l'installazione di SOLIDWORKS Electrical

Per accedere ai requisiti di sistema correnti, visitare il sito http://solidworks.com/System_Requirements.

Indice

  • Modalità individuale o server

    È possibile installare SOLIDWORKS Electrical in modalità individuale o server.

  • Impostazione dell'ubicazione dei dati

  • Configurazione del Server collaborativo

  • Configurazione di Microsoft SQL Server

Argomento principale SOLIDWORKS Electrical
Gestione dei dati in SOLIDWORKS Electrical


Modalità individuale o server

È possibile installare SOLIDWORKS Electrical in modalità individuale o server.

È importante notare che SOLIDWORKS Electrical deve connettersi a una variante nuova o esistente di SQL Server.

In modalità individuale, è possibile installare i seguenti componenti:
  • Schemi di SOLIDWORKS Electrical
  • SOLIDWORKS Electrical 3D
  • Server collaborativo
  • Dati
  • Una nuova istanza del database SQL Server
In modalità server, è possibile installare i seguenti componenti:
  • Una nuova istanza del database SQL Server
  • Server collaborativo
  • Dati

È possibile combinare i componenti delle modalità individuale e server per creare un ambiente client/server. Ad esempio, è possibile installare i componenti Schemi di SOLIDWORKS Electrical e SOLIDWORKS Electrical 3D nei sistemi client e installare tutti i componenti server in un sistema server.

Argomento principale Requisiti per l'installazione di SOLIDWORKS Electrical
Impostazione dell'ubicazione dei dati
Configurazione del Server collaborativo
Configurazione di Microsoft SQL Server


Impostazione dell'ubicazione dei dati

Per l'ubicazione dei dati, selezionare una directory in cui memorizzare i dati del programma, come parti, modelli e simboli 2D e 3D. Questa ubicazione deve essere una directory dedicata. Non può essere una directory principale o la stessa directory utilizzata per memorizzare i dati di SOLIDWORKS.

La directory di predefinita è C:\ProgramData\SOLIDWORKS Electrical. Alla stessa directory viene aggiunta una cartella denominata Update per memorizzare tutti i dati del programma disponibili.

Al primo avvio di SOLIDWORKS Electrical, viene visualizzata la procedura guidata aggiornamento dati. In questa procedura guidata, è possibile selezionare i dati da aggiungere all'applicazione e al database SQL Server.
Argomento principale Requisiti per l'installazione di SOLIDWORKS Electrical
Modalità individuale o server
Configurazione del Server collaborativo
Configurazione di Microsoft SQL Server


Configurazione del Server collaborativo

Per eseguire SOLIDWORKS Electrical, è necessario installare il Server collaborativo nello stesso sistema che ospita il database di Microsoft SQL Server.

È necessario che il Server collaborativo venga sempre eseguito e che abbia una comunicazione bidirezionale costante e ininterrotta con i client tramite firewall e programmi antivirus.

Per installare il Server collaborativo in modalità individuale o server, è necessario specificare i seguenti parametri:
  • Nome del computer, ad esempio LOCALHOST
  • Indirizzo IP del computer, ad esempio 127.0.0.1
  • Numero di porta, ad esempio 26666

Per consentire una comunicazione bidirezionale ininterrotta, assicurarsi che il numero di porta 26666 sia disponibile sul sistema in cui il Server collaborativo è installato. Se la porta 26666 non è accessibile, contattare l'amministratore del sistema per trovare un'altra porta accessibile a SOLIDWORKS Electrical.

Argomento principale Requisiti per l'installazione di SOLIDWORKS Electrical
Modalità individuale o server
Impostazione dell'ubicazione dei dati
Configurazione di Microsoft SQL Server


Configurazione di Microsoft SQL Server

È necessario verificare che per qualsiasi tipo di installazione di SOLIDWORKS Electrical sia disponibile una variante del database SQL Server. È possibile utilizzare un database SQL Server esistente se è già installato nel sistema o installare una nuova variante come parte dell'installazione di SOLIDWORKS Electrical.

Quando si installa una nuova variante di SQL Server, l'installazione di SOLIDWORKS fornisce una versione gratuita di Microsoft SQL Server Express. Questa versione è limitata a 1 CPU, 1 GB di memoria e 10 GB di dati. I limiti di memoria e CPU sono sufficienti per supportare 5 utenti simultanei.

Se si installa SQL Server Express Edition, assicurarsi che il software e l'hardware del server soddisfino i requisiti elencati all'indirizzo http://solidworks.com/System_Requirements.

Tuttavia, se allo stesso server sono connessi 6 o più utenti simultanei, è consigliabile acquistare e installare una versione completa di SQL Server e utilizzare il flusso di lavoro descritto per l'installazione di SOLIDWORKS Electrical con una variante già esistente di SQL Server.

Per informazioni su SQL Server Express Edition, consultare la documentazione di Microsoft SQL Server.

Argomento principale Requisiti per l'installazione di SOLIDWORKS Electrical
Modalità individuale o server
Impostazione dell'ubicazione dei dati
Configurazione del Server collaborativo

Nuove istanze di SQL Server

Se si installa una nuova istanza di SQL Server, è necessario disporre di diritti amministrativi completi per il server e qualsiasi sistema client. È inoltre necessario assicurarsi che i client dispongano di privilegi di lettura/scrittura per il database in modo che sia possibile creare e modificare progetti, librerie, simboli e altri dati di progetto.

Quando si installa una nuova istanza di SQL Server, selezionare un nome diverso dal nome di default.

Istanze esistenti di SQL Server

Per installare nuovi database di SOLIDWORKS Electrical o connettersi a un'installazione di SOLIDWORKS Electrical su una variante già esistente di SQL Server, è necessario disporre di un account dell'utente con diritti amministrativi completi per il database di SQL Server.

Per garantire il corretto funzionamento di SOLIDWORKS Electrical, è necessario abilitare SQL Server per l'autenticazione in modalità mista. L'autenticazione in modalità mista consente l'uso delle credenziali Windows o SQL Server.

Per connettersi a un database SQL Server esistente, è possibile utilizzare l'autenticazione di Windows o SQL Server. Inserire un nome utente e una password per un account di accesso Windows o SQL Server con diritti amministrativi completi per SQL Server.

Per connettersi a SQL Server, non è possibile utilizzare l'utente 'TEW'. Per informazioni su come ottenere un account di accesso con le credenziali corrette per SQL Server, contattare l'amministratore di SQL Server o l'amministratore di sistema.

Post-installazione di SQL Server

Dopo l'installazione di SOLIDWORKS Electrical, la variante di SQL Server crea i seguenti database in SOLIDWORKS Electrical:
  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION
  • TEW_SQLEXPRESS


SOLIDWORKS PCB

SOLIDWORKS® PCB (in precedenza PCBWorks) è uno strumento per la progettazione di schede a circuito stampato (PCB) integrato nel software di progettazione 3D SOLIDWORKS. Viene installato dalla Gestione installazioni di SOLIDWORKS come parte dell'installazione Individuale.

Un elettrotecnico che utilizza SOLIDWORKS PCB è in grado di apportare modifiche a una scheda a circuito stampato e inserire tali modifiche in un archivio condiviso. Un ingegnere meccanico che utilizza il software SOLIDWORKS può estrarre dall'archivio la scheda a circuito stampato modificata, analizzare le modifiche, apportare ulteriori modifiche e salvare nuovamente il progetto nell'archivio, rendendolo nuovamente accessibile all'elettrotecnico.

Per abilitare questa collaborazione, è necessario installare SOLIDWORKS PCB Services, che gestisce l'archivio su un server condiviso. Viene installato dalla Gestione installazioni di SOLIDWORKS come parte di un'installazione Server e non richiede una licenza separata. Comprende Microsoft Internet Information Services e un database che memorizza i dati utilizzati per sincronizzare il lavoro dei progettisti elettrici e meccanici.

In ambienti di rete, SOLIDWORKS PCB Services viene normalmente installato su un server condiviso che non esegue il software SOLIDWORKS. Può anche essere installato con altri componenti di SOLIDWORKS PCB su un unico computer. SOLIDWORKS PCB Services deve essere sempre in esecuzione e stabilire una comunicazione bidirezionale ininterrotta attraverso firewall e antivirus con i client che eseguono SOLIDWORKS PCB e il software SOLIDWORKS e con qualsiasi client che esegue Altium Designer e che deve essere integrato con il software SOLIDWORKS.
Si consiglia di installare SOLIDWORKS PCB Services prima di installare SOLIDWORKS PCB.

Inoltre, un altro componente denominato aggiunta di SOLIDWORKS PCB deve essere abilitato sui computer che eseguono il software SOLIDWORKS. È possibile abilitare l'aggiunta da Strumenti > Aggiunte.

Gli elettrotecnici che dispongono di Altium Designer con licenza, possono anche scambiare progetti con gli utenti del software di progettazione 3D SOLIDWORKS attraverso l'archivio. Per eseguire tale scambio, gli utenti devono installare SOLIDWORKS PCB Connector. Questo software viene installato dal client Altium Designer.

Indice

  • Prerequisiti

  • Installazione di PCB Services con SLDIM

  • Installazione di con SLDIM

  • Modifica dell'accesso amministratore predefinito

  • Installazione di SOLIDWORKS PCB Viewer

    È possibile scaricare e installare SOLIDWORKS PCB Viewer® utilizzando la Gestione installazioni e semplificando così l'installazione in contemporanea con SOLIDWORKS o altri prodotti SOLIDWORKS. Questo visualizzatore PCB gratuito è disponibile senza licenza.

  • Installazione di PCB Connector per Altium Designer

  • Post-installazione

  • Aggiornamento di PCB Services

  • Disinstallazione di PCB Services


Prerequisiti

Prima di eseguire l'installazione, è necessario disporre dei seguenti requisiti:
  • Numero seriale di SOLIDWORKS PCB.
  • Numero seriale di SOLIDWORKS PCB Connector per i client Altium Designer i client devono essere integrato con il software SOLIDWORKS.

Per accedere ai requisiti di sistema correnti, vedere http://solidworks.com/System_Requirements.

Argomento principale SOLIDWORKS PCB


Installazione di PCB Services con SLDIM

Per installare SOLIDWORKS PCB Services:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina di Benvenuto selezionare Prodotti del server.
  3. Quindi selezionare Installa i componenti di SOLIDWORKS PCB Services nel computer in uso e fare clic su Avanti.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi, accettare le impostazioni predefinite per SOLIDWORKS PCB Services, oppure fare clic su Modifica per specificare le impostazioni seguenti:
    • Ubicazione installazione
    • Cartella database
    • Cartella file di revisione
    • Numero porta

    PCB Services comprende Microsoft Internet Information Services e un database che memorizza i dati utilizzati per sincronizzare il lavoro dei progettisti elettrici e meccanici.

    Il numero di porta predefinito è 9780.

  6. Accettare i termini del Contratto di licenza SOLIDWORKS e fare clic su Installa ora.
Argomento principale SOLIDWORKS PCB


Installazione di con SLDIM

Per installare SOLIDWORKS PCB:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina di benvenuto selezionare Individuale.
  3. Procedere nel modo seguente:
    1. Espandere Progettazione di componenti elettrici.
    2. Selezionare SOLIDWORKS PCB e immettere il numero seriale.
    3. Fare clic su Avanti.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi accettare i termini del contratto di licenza SOLIDWORKS e fare clic su Installa ora.
Argomento principale SOLIDWORKS PCB


Modifica dell'accesso amministratore predefinito

SOLIDWORKS PCB Services fornisce un account amministratore predefinito con le seguenti credenziali:
  • Nome utente: admin
  • Password: admin
Per una maggiore sicurezza, si consiglia di modificare le credenziali di accesso per questo account.

Per modificare l'accesso amministratore predefinito:

  1. Aprire un browser Web e inserire nella barra degli indirizzi il nome della macchina e il numero di porta, nel seguente formato: http://server name:port number.

    Il numero di porta predefinito è 9780.

  2. Sulla pagina Accedi a SOLIDWORKS PCB Services, inserire il nome utente admin e la password admin, quindi fare clic su Accedi.
  3. Nel menu SOLIDWORKS PCB Services, fare clic su Utenti, quindi sulla scheda Utenti.
  4. Fare clic sul collegamento associato all'account amministratore, oppure fare clic sull'icona Modifica utente [image].
  5. Modificare le informazioni dell'utente, il nome utente e la password.
  6. Fare clic su Salva.
Argomento principale SOLIDWORKS PCB


Installazione di SOLIDWORKS PCB Viewer

È possibile scaricare e installare SOLIDWORKS PCB Viewer® utilizzando la Gestione installazioni e semplificando così l'installazione in contemporanea con SOLIDWORKS o altri prodotti SOLIDWORKS. Questo visualizzatore PCB gratuito è disponibile senza licenza.

È possibile utilizzare il visualizzatore per accedere, stampare ed eseguire ricerche in tutti i file di progettazione che il team ha creato in Altium Designer.

È anche possibile aggiungere SOLIDWORKS PCB Viewer alla distribuzione dell'immagine amministrativa.

Non è possibile installare SOLIDWORKS PCB Viewer sullo stesso computer di SOLIDWORKS PCB.
Argomento principale SOLIDWORKS PCB


Installazione di PCB Connector per Altium Designer

Altium Designer è uno strumento di progettazione di schede a circuito stampato (PCB). Gli utenti che dispongono di Altium Designer installato e con licenza possono integrarlo con il software SOLIDWORKS installando SOLIDWORKS PCB Connector.

Per installare SOLIDWORKS PCB Connector su una macchina che esegue Altium Designer:

  1. Accedere al proprio account Altium, se l'accesso non viene eseguito automaticamente.
  2. Avviare Altium Designer, aprire la scheda DXP e fare clic su Estensioni e aggiornamenti.
  3. Nella pagina Estensioni e aggiornamenti, fare clic sulla scheda Acquisti.
  4. Scorrere in basso fino alla sezione Estensioni software. Quindi su SOLIDWORKS PCB Connector, fare clic sulla freccia verso il basso nell'angolo in alto a destra del riquadro per scaricare e iniziare l'installazione.

  5. Nella finestra di dialogo Conferma, fare clic su Sì per continuare l'installazione.
    È necessario eseguire i punti 6 e 7 nell'ordine specificato per evitare problemi di attivazione e installazione.
  6. Nella pagina Registrazione PCB Connector, inserire il numero seriale di SOLIDWORKS PCB Connector e fare clic su Registra.
  7. Nella finestra di dialogo Conferma visualizzata dall'applicazione Altium Designer, fare clic su Sì per riavviare il sistema e terminare l'installazione, oppure fare clic su No per completare l'installazione in un secondo momento.

Per disattivare una licenza SOLIDWORKS PCB Connector, nel menu Guida, fare clic su Licenze SOLIDWORKS PCB Connector > Disattiva licenze.

Argomento principale SOLIDWORKS PCB


Post-installazione

Dopo l'installazione di SOLIDWORKS PCB e dei suoi componenti, è possibile aggiungere gli account utente a SOLIDWORKS PCB Services, in modo che gli utenti possano accedere alle schede dall'archivio.

Altre operazioni aggiuntive includono l'accesso all'archivio dell'aggiunta SOLIDWORKS PCB e la disinstallazione del software.

Indice

  • Aggiunta di un utente a PCB Services

  • Accesso a un archivio PCB

Argomento principale SOLIDWORKS PCB


Aggiunta di un utente a PCB Services

Per aggiungere un utente al sito Web di SOLIDWORKS PCB Services:

  1. Aprire un browser Web e inserire il nome del server e il numero di porta assegnato a SOLIDWORKS PCB Services nella barra degli indirizzi. Ad esempio, nel formato: http://server name:port number.
  2. Sulla pagina Accedi a SOLIDWORKS PCB Services, inserire il proprio nome utente e password come amministratore e fare clic su Accedi.
  3. Nel menu SOLIDWORKS PCB Services, fare clic su Utenti, quindi sulla scheda Utenti.
  4. Fare clic sul pulsante Aggiungi utente e inserire le informazioni seguenti:
    • Nome
    • Cognome
    • Nome utente
    • Immetti password
    • Indirizzo email
    • Numero di telefono

    Inoltre, è necessario selezionare un Ruolo utente e selezionare la casella Membro per associare l'utente a un gruppo.

  5. Fare clic su Salva.
È possibile modificare le informazioni dell'utente nella scheda Utente.
Argomento principale Post-installazione


Accesso a un archivio PCB

In SOLIDWORKS, quando si seleziona una nuova scheda o si estrae una scheda esistente dal Task Pane Aggiunta PCB, è necessario effettuare l'accesso a SOLIDWORKS PCB Services per accedere all'archivio.

Per accedere all'archivio di SOLIDWORKS PCB:

  1. Dal Task Pane SOLIDWORKS, fare clic sul pulsante Aggiunta SOLIDWORKS PCB [image].
  2. Fare clic su Nuovo assieme scheda o su Estrai scheda dal vault.
  3. Accesso a SOLIDWORKS PCB Services:
    1. Specificare il nome del server e il numero di porta assegnato a SOLIDWORKS PCB Services. Ad esempio, digitare nel formato seguente: http://server name:port number.
    2. Inserire Nome utente e Password e fare clic su OK.
Argomento principale Post-installazione


Aggiornamento di PCB Services

Quando si aggiorna SOLIDWORKS PCB Services alla versione 2020, la Gestione installazioni SOLIDWORKS aggiorna il database Firebird ed esegue automaticamente la migrazione dei dati. Prima dell'aggiornamento, è necessario eseguire il backup del database.

Per aggiornare SOLIDWORKS PCB Services:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina di Benvenuto selezionare Prodotti del server.
  3. Selezionare Aggiornare SOLIDWORKS PCB Services nel computer in uso e fare clic su Avanti.

    Compare il seguente messaggio: SOLIDWORKS PCB Services richiede l'aggiornamento del database Firebird. Se si prosegue, il software Firebird e il database verranno aggiornati.

  4. Fare clic su Avanti.
  5. Nella pagina Riepilogo, accettare le impostazioni predefinite oppure fare clic su Cambia per specificare altre impostazioni.
  6. Accettare i termini del Contratto di licenza SOLIDWORKS e fare clic su Installa ora.
Argomento principale SOLIDWORKS PCB


Disinstallazione di PCB Services

Per disinstallare SOLIDWORKS PCB Services:

  1. Fare clic su Start > Tutti i programmi > SOLIDWORKS versione > SOLIDWORKS PCB Services > Disinstalla SOLIDWORKS PCB Services.
  2. Quando viene chiesto se si desidera rimuovere SOLIDWORKS PCB Services e i suoi componenti, fare clic su Sì.
  3. Quando viene chiesto se si desidera eliminare tutti i dati d SOLIDWORKS PCB Services, fare clic su No.
    È necessario fare clic su No se si desidera evitare che tutti i dati e i file di revisione vengano eliminati in modo permanente.
Argomento principale SOLIDWORKS PCB


SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize (noto in precedenza come Bunkspeed) fornisce una suite di strumenti software standalone che abbinano capacità di rendering avanzate a funzioni e flussi di lavoro visivi orientati alla progettazione, in modo da poter creare immagini estremamente realistiche dei modelli CAD 3D.

I prodotti SOLIDWORKS Visualize sono disponibili in due pacchetti:
  • Standard
  • Professional

Per un elenco delle caratteristiche disponibili in ciascuna versione del software SOLIDWORKS Visualize, andare su solidworks.com e cercare la scheda dati SOLIDWORKS Visualize.

Una licenza gratuita di SOLIDWORKS Visualize Standard è inclusa con tutte le licenze SOLIDWORKS 2020 Professional e Premium con abbonamento attivo. Per attivare la licenza gratuita, è necessario un numero di serie supplementare, disponibile effettuando l'accesso al Portale clienti SOLIDWORKS e facendo clic su I miei prodotti. Non è più possibile utilizzare il proprio numero di serie di SOLIDWORKS Professional o Premium per attivare la licenza gratuita di SOLIDWORKS Visualize Standard.

SOLIDWORKS Visualize supporta inoltre i tipi di licenza SolidNetWork (SNL), ad esempio la licenza flessibile, e l'attivazione non in linea.

Tramite la Gestione installazioni di SOLIDWORKS (SLDIM), installare SOLIDWORKS Visualize come parte dell'installazione Individuale. Può essere installato come app standalone, il che rappresenta un vantaggio se si desidera usare computer separati per la modellazione e il rendering. Non consuma una licenza SOLIDWORKS.

SOLIDWORKS Visualize Boost è un servizio che consente di distribuire il rendering da un computer che esegue SOLIDWORKS Visualize Professional a uno o più computer in una rete. Durante l'esecuzione del rendering, è possibile eseguire altre operazioni sul computer e le immagini finali sottoposte a rendering sono disponibili più rapidamente. È possibile eseguire il rendering delle immagini su un solo computer o su un cluster di più computer che eseguono Visualize Boost.

Una licenza gratuita di SOLIDWORKS Visualize Boost è inclusa con tutte le licenze SOLIDWORKS Visualize Professional 2020 con abbonamento attivo.
Visualize Boost è un prodotto aggiuntivo esclusivo per Visualize Professional. Visualize Boost non funziona con Visualize Standard.

Si consiglia di installare Visualize Boost su un computer separato da quello che esegue SOLIDWORKS Visualize Professional. È inoltre possibile installare Visualize Boost come parte dell'installazione Individuale in SLDIM.

Indice

  • Prerequisiti e requisiti di sistema

  • Installazione di SOLIDWORKS Visualize con SLDIM

  • Installazione di Visualize Boost con SLDIM


Prerequisiti e requisiti di sistema

Prima di installare SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost, è necessario disporre dei seguenti prerequisiti per ogni computer:
  • Numero di serie di SOLIDWORKS Visualize
  • Numero di serie di SOLIDWORKS Visualize Boost
Ogni computer che esegue SOLIDWORKS o SOLIDWORKS Visualize Boost deve soddisfare i seguenti requisiti:
  • Windows® 7 o Windows® 10 (64 bit)
  • CPU Dual Core; Quad Core consigliata
  • 8 GB di RAM; 16 GB consigliati
  • 2GB di spazio libero su disco; 5 GB consigliati
  • 2 GB o più di RAM GPU; 4GB consigliati
  • Scheda grafica NVIDIA®: NVIDIA Quadro®/NVIDIA GeForce®/Tesla™ con chip almeno NVIDIA Kepler™; configurazione a doppia GPU con schede almeno NVIDIA Maxwell™ per una migliore esperienza
  • Versione 385.41 (o superiore) del driver NVIDIA consigliata
  • Supporto del driver NVIDIA per CUDA® 9.0 o versioni successive richiesto
  • Connessione HDR Light Studio: HDR Light Studio v5.3.3 o versioni successive, tranne v5.4
  • 4 GB di memoria video o più indispensabili per la funzione Denoiser
Se sono installate schede grafiche diverse da NVIDIA, SOLIDWORKS Visualize passerà alla CPU predefinita e non utilizzerà queste schede per l'accelerazione GPU. Inoltre, le schede NVIDIA basate su architettura Fermi™ non supportano più l'accelerazione GPU.
Argomento principale SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost


Installazione di SOLIDWORKS Visualize con SLDIM

Per installare SOLIDWORKS Visualize:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina di benvenuto selezionare Individuale.
  3. Procedere nel modo seguente:
    1. Nella pagina Numero seriale, espandere Visualizzazione.
    2. Selezionare SOLIDWORKS Visualize e immettere il numero seriale.
    3. Fare clic su Avanti.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi accettare i termini del contratto di licenza SOLIDWORKS e fare clic su Installa ora.

Per avviare l'applicazione, fare doppio clic sull'icona del collegamento SOLIDWORKS Visualize sul desktop oppure, dal menu Start di Windows, fare clic su Tutti i programmi > SOLIDWORKS versione > SOLIDWORKS Visualize versione.

Indice

  • Operazioni di postinstallazione

Argomento principale SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost


Operazioni di postinstallazione

Dopo l'installazione sarà opportuno eseguire alcune operazioni per configurare SOLIDWORKS Visualize.

Indice

  • Creazione della cartella Content

  • Selezione di una modalità di rendering

  • Accesso alla guida, ai tutorial, alle informazioni di sistema e alle licenze

Argomento principale Installazione di SOLIDWORKS Visualize con SLDIM


Creazione della cartella Content

Alla prima esecuzione del software, SOLIDWORKS Visualize richiede di specificare una posizione in cui creare una cartella Content.

La cartella Content contiene le seguenti sottocartelle in cui è possibile memorizzare le risorse per i progetti:
Sottocartelle | Elementi memorizzati
Videocamere | Videocamere predefinite e salvate
Ambienti | Immagini con elevato range dinamico (HDR)
Tavolozze | File tavolozza esportati
Immagini | Rendering e scatti
Aspetti | Materiali nella libreria di aspetti I contenuti si aggiornano all'aggiunta di un aspetto alla libreria.
Modelli | File modello Per impostazione predefinita, SOLIDWORKS Visualize effettua ricerche prima in questa cartella quando si usa File > Importazione per un modello.
Piastre | Immagini 2D standard per l'uso in piastre posteriori
Progetti | File di progetto nativi in formato SVP
Trame | Trame 2D per l'uso negli aspetti
Argomento principale Operazioni di postinstallazione


Selezione di una modalità di rendering

Sistemi diversi possono generare risultati diversi con ciascuna modalità di rendering. Provare ogni modalità di rendering prima di impostare quella più adatta alle proprie esigenze.

Per selezionare una modalità di rendering:

  1. Fare clic su Strumenti > Opzioni > Punto di vista 3D.
  2. In Dispositivo di rendering, deselezionare Automatico.
  3. Selezionare una modalità di rendering:
    • CPU, se la CPU è notevolmente più potente della scheda grafica.
    • GPU, se si dispone di una scheda video potente, ad esempio una scheda nVidia con tecnologia CUDA e oltre 1 GB di VRAM.
    • Ibrido, se si dispone di un sistema equilibrato con una buona scheda nVidia e una CPU equivalente.

Per ulteriori informazioni, vedere Per cominciare.

Argomento principale Operazioni di postinstallazione


Accesso alla guida, ai tutorial, alle informazioni di sistema e alle licenze

Il menu Guida fornisce la documentazione e le opzioni per aggiornare il software e risolvere i problemi relativi al sistema.

Guida di Visualize | Apre la Guida in linea SOLIDWORKS Visualize.
Tutorial di Visualize | Apre MySolidWorks e consente di accedere ai tutorial di SOLIDWORKS Visualize.
Note sulla versione | Visualizza le note di rilascio online per la versione corrente.
Novità | Visualizza le nuove funzionalità dei prodotti SOLIDWORKS.
Tasti di scelta rapida | Elenca i tasti di scelta rapida.
System Info | Effettua un controllo di sistema del software SOLIDWORKS Visualize con l'hardware del PC e consiglia aggiornamenti, laddove necessario.
Attiva licenza | (licenze bloccate con nodo) Utilizza la procedura guidata Attivazione prodotto SOLIDWORKS per attivare il prodotto.
Disattiva licenza | (licenze bloccate con nodo) Utilizza la procedura guidata Attivazione prodotto SOLIDWORKS per disattivare il prodotto.
SolidNetWork License Manager | Utilizza la procedura guidata Attivazione prodotto SOLIDWORKS per disattivare il prodotto.
A proposito di Visualize | Visualizza il numero di versione e informazioni sulla licenza della copia di SOLIDWORKS Visualize.
Argomento principale Operazioni di postinstallazione


Installazione di Visualize Boost con SLDIM

Installare Visualize Boost utilizzando la Gestione installazioni di SOLIDWORKS. Richiede un numero seriale separato.

Siccome lo scopo di Visualize Boost è scaricare l'elaborazione del rendering, è necessario installare Visualize Boost su computer diversi da quelli che eseguono SOLIDWORKS Visualize Professional. Le prestazioni di rendering possono essere ottimizzate mediante l'installazione di Visualize Boost su computer dotati di più core CPU e unità di elaborazione grafica (GPU).

Per installare SOLIDWORKS Visualize Boost:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina di benvenuto selezionare Individuale.
  3. Procedere nel modo seguente:
    1. Nella pagina Numero seriale, espandere Visualizzazione.
    2. Selezionare SOLIDWORKS Visualize Boost e immettere il numero seriale.
    3. Fare clic su Avanti.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi accettare i termini del contratto di licenza SOLIDWORKS e fare clic su Installa ora.

Fare doppio clic sull'icona del collegamento SOLIDWORKS Visualize Boost sul desktop per aprire l'interfaccia.

Indice

  • Attivazione della licenza Visualize Boost

    È necessario attivare e configurare SOLIDWORKS Visualize Boost tramite un'interfaccia Web prima di poter usare il prodotto per il rendering. Sono supportati i browser Chrome, Firefox o Internet Explorer.

  • Configurazione di Visualize Boost

Argomento principale SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost


Attivazione della licenza Visualize Boost

È necessario attivare e configurare SOLIDWORKS Visualize Boost tramite un'interfaccia Web prima di poter usare il prodotto per il rendering. Sono supportati i browser Chrome, Firefox o Internet Explorer.

Dopo averlo attivato e configurato, Visualize Boost si avvia automaticamente con il sistema e viene eseguito in background. Nessuna azione necessaria.

Per attivare la licenza SOLIDWORKS Visualize Boost:

  1. Effettuare una delle seguenti operazioni:
    1. Dal desktop, fare doppio clic sull'icona del collegamento Visualize Boost.
    2. Aprire un browser e immettere l'URL: http://localhost:8993/config.html.
  2. Inserire un indirizzo email e fare clic su Attiva licenza.
Argomento principale Installazione di Visualize Boost con SLDIM


Configurazione di Visualize Boost

Per la maggior parte delle reti, le impostazioni predefinite sono sufficienti per configurare un computer per Visualize Boost, ma se l'ambiente di rete richiede altre impostazioni, attenersi alla seguente procedura per la configurazione manuale di un computer.

Per configurare un computer in modo che faccia parte di un cluster di rendering in Visualize Boost:

  1. Effettuare una delle seguenti operazioni:
    1. Se il proprio sistema esegue SOLIDWORKS Visualize Boost, fare doppio clic sull'icona del collegamento Visualize Boost sul desktop, oppure aprire un browser e inserire l'URL: http://localhost:8993/config.html.
    2. Se si utilizza un altro sistema, aprire un browser e inserire l'URL: http://<IP Address>:8993/config.html o http://<DNS name>:8993/config.html.
  2. Selezionare la Lingua dall'elenco a discesa nell'angolo in alto a destra dello schermo.
  3. Fare clic sulla scheda Impostazione per configurare il nodo Visualize Boost.
  4. Nel campo Nome cluster, specificare il nome del computer, ad esempio Rendering superveloce, Cluster di presentazione o Computer del 4° piano.

    Il nome del cluster è visualizzato in SOLIDWORKS Visualize Professional come un profilo di cluster. Per eseguire il rendering di un'immagine, gli utenti che eseguono SOLIDWORKS Visualize Professional devono selezionare un profilo di cluster da un elenco di cluster Boost disponibili.

    Si consiglia di specificare il nome del cluster sul computer che esegue Visualize Boost, invece che localmente sul computer che esegue Visualize Professional, in modo che tutti gli utenti di Visualize abbiano accesso agli stessi nomi di cluster nel proprio elenco di Profili Visualize Boost.
  5. Immettere la Porta di accesso client cluster.
    Questa è la porta utilizzata dai computer che eseguono SOLIDWORKS Visualize per connettersi al cluster Boost. La porta di accesso client cluster predefinita è 8998.
  6. Nell'area Modalità di collegamento alla rete, selezionare un'opzione in base al proprio ambiente di rete:
    • Selezionare Nessun collegamento alla rete per evitare che questo computer appartenga ad altri cluster. Questa modalità è utile per la risoluzione di problemi legati a Visualize Boost.
    • Selezionare Modalità UDP multicast se la rete supporta UDP multicast. Visualize Boost cerca la rete e forma un cluster di tutti i computer che utilizzano la modalità UDP multicast sulla stessa porta. Questa modalità è consigliata, se supportata dalla rete.
    • Selezionare Modalità TCP con discovery (predefinita) se non è possibile utilizzare la modalità UDP multicast. Visualize Boost cerca la rete e forma un cluster di tutti i computer che utilizzano la modalità TCP con discovery sulla stessa porta.
    • Selezionare Modalità TCP se si ha la necessità di creare un elenco esplicito dei computer nel cluster, poiché le altre modalità non sono in grado di trovare i computer da includere. Questa modalità richiede un lavoro di configurazione supplementare e non è consigliata se sono disponibili le modalità UDP multicast o TCP con discovery.
  7. Se si seleziona la Modalità UDP multicast o la Modalità TCP con discovery, immettere l'Indirizzo discovery cluster.
    Questa impostazione deve comprendere un indirizzo IP e un numero di porta superiore a 1024. La porta predefinita varia tra le diverse modalità di collegamento alla rete:
    • 8994 per UDP multicast
    • 8995 per TCP con discovery
    • 8996 per TCP

    Queste porte vengono utilizzate dai computer che eseguono Visualize Boost per connettersi tra loro. Tutti i computer configurati con lo stesso Indirizzo discovery cluster e che sono sulla stessa rete locale formano un cluster.

  8. Se si seleziona Modalità TCP:
    • Immettere una Porta di accesso cluster. Questa è la porta utilizzata dai nodi Visualize Boost nel cluster per comunicare tra loro. La porta predefinita per la modalità TCP è 8996.
    • Se il computer è destinato a essere il «nodo head» del cluster (computer che coordina il lavoro del cluster), utilizzare il campo Elenco indirizzi cluster per elencare gli indirizzi IP degli altri nodi nel cluster. Ogni indirizzo IP (ad esempio 192.168.0.100:8996) deve includere la Porta di accesso cluster configurata per tutti i nodi nel cluster. Lasciare il campo vuoto se il computer non è destinato a essere il nodo head del cluster.
  9. Fare clic su Salva configurazione. Visualize Boost salva la nuova configurazione, quindi arresta e riavvia il servizio.
  10. Fare clic sulla scheda Stato. Se lo stato è Pronto, sullo schermo sono visualizzati i computer collegati nel cluster e le Sessioni (lavori) assegnate al cluster.
Argomento principale Installazione di Visualize Boost con SLDIM


SOLIDWORKS Admin Portal e licenze online

SOLIDWORKS Admin Portal è un sistema di gestione dei servizi e delle risorse basato su cloud che consente di assegnare e gestire le licenze online.

Admin Portal semplifica il monitoraggio delle licenze online SOLIDWORKS, l'invito di membri in un account, l'assegnazione di prodotti e servizi ai membri e la creazione di nuovi amministratori. Inoltre, è possibile rimuovere gli utenti dalle licenze, anche in caso di utenti remoti.

Le licenze online offrono all'utente di SOLIDWORKS la flessibilità di utilizzare un'unica licenza SOLIDWORKS su tutti i propri dispositivi, in qualsiasi posizione, senza dover attivare e disattivare manualmente le licenze su ogni computer. È necessario disporre di una connessione a Internet per effettuare l'accesso e utilizzare le licenze online, ma dopo l'accesso è possibile selezionare la modalità non in linea e lavorare mentre il dispositivo non è connesso a una rete.

Indice

  • Accesso ad Admin Portal

    Per accedere ad Admin Portal, è necessario disporre di un ID SOLIDWORKS e di un account e Guest, Standard o Professional di MySolidWorks.

  • Attività dell'amministratore

    In genere, gli amministratori sono responsabili della gestione degli account utente e delle licenze online.

  • Utilizzo dei prodotti SOLIDWORKS con le licenze online

  • Accesso al pannello di amministrazione CAD

    Se si dispone di un contratto di abbonamento SOLIDWORKS, è possibile accedere al pannello di amministrazione CAD di SOLIDWORKS da Admin Portal, senza effettuare di nuovo l'accesso.


Accesso ad Admin Portal

Per accedere ad Admin Portal, è necessario disporre di un ID SOLIDWORKS e di un account e Guest, Standard o Professional di MySolidWorks.

Tuttavia, qualsiasi cliente commerciale con un ID SOLIDWORKS valido, indipendentemente dallo stato di abbonamento, può collegarsi a MySolidWorks.com e accedere ad Admin Portal, se idoneo.

Per accedere ad Admin Portal:

  1. Effettuare l'accesso su MySolidWorks.com.
  2. Sotto il nome del profilo, espandere l'elenco e fare clic su Admin Portal.
Argomento principale SOLIDWORKS Admin Portal e licenze online
Attività dell'amministratore
Utilizzo dei prodotti SOLIDWORKS con le licenze online
Accesso al pannello di amministrazione CAD


Attività dell'amministratore

In genere, gli amministratori sono responsabili della gestione degli account utente e delle licenze online.

Per impostazione predefinita, il software SOLIDWORKS è impostato per utilizzare l'attivazione del computer. La procedura di base per l'attivazione delle licenze online tramite Admin Portal è la seguente:
  1. Se il software SOLIDWORKS è già stato installato su un computer, disattivare manualmente la licenza.
  2. Impostare il tipo di attivazione del prodotto dall'attivazione del computer alle licenze online.
  3. Quindi, assegnare i prodotti e i servizi ai membri (utenti).

Indice

  • Creazione del primo account amministratore

    Se l'utente è la prima persona ad accedere a un account su Admin Portal, può promuovere se stesso a primo amministratore, a condizione che:

  • Gestione di prodotti e servizi

  • Gestione di membri e licenze

  • Impostazione dei prodotti per utilizzare le licenze online

    Per impostazione predefinita, il software SOLIDWORKS è impostato per utilizzare l'attivazione del computer. Se il software SOLIDWORKS è stato installato su un computer, è necessario disattivare manualmente la licenza e modificare quindi il tipo di attivazione per utilizzare le licenze online.

  • Promozione di un utente ad amministratore

    Se un account ha degli amministratori, Admin Portal visualizza le informazioni di contatto degli amministratori. È possibile contattarli e richiedere di diventare un amministratore dell'account.

  • Registrare I miei prodotti sul Portale clienti SOLIDWORKS

    Dopo aver nominato un amministratore per la propria azienda, nessun utente può registrare un prodotto da tale azienda nel Portale clienti SOLIDWORKS.

Argomento principale SOLIDWORKS Admin Portal e licenze online
Accesso ad Admin Portal
Utilizzo dei prodotti SOLIDWORKS con le licenze online
Accesso al pannello di amministrazione CAD


Creazione del primo account amministratore

Se l'utente è la prima persona ad accedere a un account su Admin Portal, può promuovere se stesso a primo amministratore, a condizione che:

  • L'account sia l'account principale dell'utente.
  • L'account disponga di risorse.
  • L'utente disponga di un prodotto registrato per l'account.

Se l'utente non è associato all'account o se l'account non dispone di risorse, contattare il Centro clienti SOLIDWORKS.

Per nominare se stessi come primo amministratore di un account:

  1. Accedere a MySolidWorks.com e, sotto il nome del profilo, espandere l'elenco e selezionare Admin Portal.

    La pagina di benvenuto informa che al momento non vi è alcun amministratore.

  2. Leggere e accettare i termini, le condizioni e la responsabilità di gestione per l'assegnazione delle licenze dei prodotti SOLIDWORKS.
  3. Fare clic su Promuovimi ad amministratore.
Argomento principale Attività dell'amministratore
Gestione di prodotti e servizi
Gestione di membri e licenze
Impostazione dei prodotti per utilizzare le licenze online
Promozione di un utente ad amministratore
Registrare I miei prodotti sul Portale clienti SOLIDWORKS


Gestione di prodotti e servizi

Admin Portal include una scheda Prodotti e una scheda Servizi. Utilizzare la scheda Prodotti per assegnare e attivare i prodotti. Utilizzare la scheda Servizi per assegnare ai membri servizi come corsi di eLearning e MySolidWorks Pro.

A differenza dei prodotti, non è possibile trasferire i servizi. Una volta assegnato un servizio a un membro, non è possibile rimuovere il servizio da tale membro.

La gestione dei Prodotti è facoltativa per i prodotti di attivazione della macchina, inclusi i prodotti di licenza di rete.

È possibile nominare i membri e assegnare loro i prodotti affinché ottengano i vantaggi seguenti:
  • I membri possono utilizzare le funzioni di accesso nella Gestione installazioni per installare i numeri seriali a loro assegnati.
  • L'assegnazione di prodotti con sottoscrizione ai membri garantisce loro l'accesso al contenuto online relativo.

Tuttavia, non è necessario nominare i membri e assegnare loro i prodotti per i prodotti di attivazione della macchina. L'accesso ai prodotti di attivazione della macchina è controllato da un server di licenza o eventi di attivazione, indipendentemente dall'assegnazione nell'Admin Portal. Nelle organizzazioni più grandi, è improbabile gestire tutti i membri e i relativi prodotti.

La gestione dei Prodotti è necessaria per le licenze online. Allo stesso modo, i Servizi devono essere assegnati ai membri denominati.

Argomento principale Attività dell'amministratore
Creazione del primo account amministratore
Gestione di membri e licenze
Impostazione dei prodotti per utilizzare le licenze online
Promozione di un utente ad amministratore
Registrare I miei prodotti sul Portale clienti SOLIDWORKS


Gestione di membri e licenze

Indice

  • Invito di nuovi membri in un account

    Gli amministratori possono invitare nuovi membri a far parte di un account.

  • Rimozione di membri dagli account

    Prima di rimuovere un membro, gli amministratori devono rimuovere tutti i prodotti assegnati all'account del membro.

  • Assegnazione di prodotti ai membri

    Gli amministratori possono assegnare un membro a un solo prodotto per tipo di prodotto. Ad esempio, a un membro possono essere assegnati un solo prodotto CAD e un solo prodotto Simulation.

  • Assegnazione dei membri ai prodotti

  • Assegnazione di servizi ai membri

  • Rimozione delle licenze dai membri

    È possibile rimuovere i prodotti da un membro.

  • Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati

    Admin Portal fornisce diversi modi per trovare un utente e per monitorare i diritti utente e i prodotti assegnati.

  • Ricerca di prodotti e controllo degli utenti assegnati

    Admin Portal fornisce diversi modi per trovare i prodotti e per monitorare a quali utenti sono assegnati i prodotti.

  • Rimozione di prodotti dai membri esterni

    I membri esterni sono persone al di fuori dell'organizzazione ma che hanno registrato uno dei prodotti dell'organizzazione. L'Admin Portal consente di identificarli e rimuoverli dal prodotto.

  • Utilizzo del menu dell'ingranaggio per le interrogazioni

    Il menu ingranaggio contiene i comandi per creare e rifinire le ricerche.

Argomento principale Attività dell'amministratore
Creazione del primo account amministratore
Gestione di prodotti e servizi
Impostazione dei prodotti per utilizzare le licenze online
Promozione di un utente ad amministratore
Registrare I miei prodotti sul Portale clienti SOLIDWORKS


Invito di nuovi membri in un account

Gli amministratori possono invitare nuovi membri a far parte di un account.

Per invitare nuovi membri:

  1. Fare clic sulla scheda Membri.
  2. Fare clic su Invita membro.
  3. Inserire gli Indirizzi e-mail dei membri da invitare.
    È possibile invitare più utenti inviando un'unica e-mail, inserendo i relativi indirizzi e-mail separati da un punto e virgola (;) nel campo degli indirizzi.
  4. Selezionare Membro o Amministratore come livello dei Diritti utente.
  5. Modificare il testo dell'invito, se necessario, e fare clic su Invia inviti.
Argomento principale Gestione di membri e licenze
Rimozione di membri dagli account
Assegnazione di prodotti ai membri
Assegnazione dei membri ai prodotti
Assegnazione di servizi ai membri
Rimozione delle licenze dai membri
Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati
Ricerca di prodotti e controllo degli utenti assegnati
Rimozione di prodotti dai membri esterni
Utilizzo del menu dell'ingranaggio per le interrogazioni


Rimozione di membri dagli account

Prima di rimuovere un membro, gli amministratori devono rimuovere tutti i prodotti assegnati all'account del membro.

Per rimuovere un membro da un account:

  1. Fare clic sulla scheda Membri.
  2. Selezionare un nome facendo clic su una riga dell'elenco Membri.

    Utilizzare i comandi di navigazione in basso per spostarsi avanti o indietro nell'elenco. È anche possibile utilizzare il riquadro Trova membri per cercare un membro.

  3. Nella pagina Dettagli membro, rimuovere tutti i prodotti dall'elenco Prodotti assegnati facendo clic su Rimuovi prodotto.
  4. In Dettagli membro, fare clic su Rimuovi membro e su OK per confermare.
Argomento principale Gestione di membri e licenze
Invito di nuovi membri in un account
Assegnazione di prodotti ai membri
Assegnazione dei membri ai prodotti
Assegnazione di servizi ai membri
Rimozione delle licenze dai membri
Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati
Ricerca di prodotti e controllo degli utenti assegnati
Rimozione di prodotti dai membri esterni
Utilizzo del menu dell'ingranaggio per le interrogazioni


Assegnazione di prodotti ai membri

Gli amministratori possono assegnare un membro a un solo prodotto per tipo di prodotto. Ad esempio, a un membro possono essere assegnati un solo prodotto CAD e un solo prodotto Simulation.

Non è possibile assegnare prodotti ai membri in attesa.

Per assegnare un prodotto a un membro:

  1. Fare clic sulla scheda Membri.
  2. Selezionare un nome facendo clic su una riga dell'elenco Membri.

    Utilizzare i comandi di navigazione in fondo all'elenco per spostarsi avanti o indietro nell'elenco. È anche possibile utilizzare il riquadro Trova membri per cercare un membro.

    La pagina Dettagli membro elenca i Prodotti assegnati e i Prodotti disponibili che non sono assegnati.

  3. Evidenziare un prodotto in Prodotti disponibili.

    È possibile assegnare a un membro solo un prodotto alla volta. La prima voce dell'elenco è selezionata per impostazione predefinita. Se il prodotto che si desidera assegnare non è il primo dell'elenco, deselezionare questa voce e selezionare la voce corretta.

    È possibile filtrare in base a diversi fattori per mostrare solo i prodotti:
    • Con un abbonamento valido o scaduto
    • Assegnati o non assegnati
    • Attivati o non attivati per le licenze online
    • Appartenenti a uno o più tipi di prodotto
    È anche possibile filtrare in base a un nome del prodotto o numero seriale.

    Se si seleziona il nome di prodotto, si apre la pagina Dettagli prodotto. Nel browser, premere Indietro per tornare alla pagina Dettagli membro.

  4. Fare clic su Assegna prodotto.

    Admin Portal aggiunge il prodotto all'elenco Prodotti assegnati del membro.

    È anche possibile assegnare i membri ai prodotti dalla pagina Dettagli prodotto.
Argomento principale Gestione di membri e licenze
Invito di nuovi membri in un account
Rimozione di membri dagli account
Assegnazione dei membri ai prodotti
Assegnazione di servizi ai membri
Rimozione delle licenze dai membri
Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati
Ricerca di prodotti e controllo degli utenti assegnati
Rimozione di prodotti dai membri esterni
Utilizzo del menu dell'ingranaggio per le interrogazioni


Assegnazione dei membri ai prodotti

Per assegnare un membro a un prodotto:

  1. Fare clic sulla scheda Prodotti.

    La pagina Dettagli prodotto elenca i membri disponibili che non sono assegnati al prodotto.

  2. Evidenziare un prodotto in Prodotti disponibili.
  3. Per trovare un membro, è possibile filtrare i membri disponibili in base a nome, cognome, e-mail e tipo di prodotto.
  4. Fare clic su Assegna membro.

È anche possibile assegnare i prodotti ai membri dalla sezione Prodotti assegnati della scheda Membri.

Argomento principale Gestione di membri e licenze
Invito di nuovi membri in un account
Rimozione di membri dagli account
Assegnazione di prodotti ai membri
Assegnazione di servizi ai membri
Rimozione delle licenze dai membri
Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati
Ricerca di prodotti e controllo degli utenti assegnati
Rimozione di prodotti dai membri esterni
Utilizzo del menu dell'ingranaggio per le interrogazioni


Assegnazione di servizi ai membri

Gli amministratori possono assegnare i servizi ai membri. Esempi di servizi sono MySolidWorks Professional e i corsi di eLearning. A differenza dei prodotti, non è possibile trasferire i servizi. Dopo avere assegnato un servizio a un membro, non è possibile rimuovere il servizio da tale membro.

Per assegnare i servizi ai membri:

  1. Fare clic sulla scheda Membri.
  2. Cercare un membro nel riquadro Trova membri, oppure fare clic su un nome utente nell'elenco.
  3. Nella pagina del Membro, sotto Dettagli membro, fare clic su Servizi.

    La scheda Servizi elenca i servizi assegnati al membro e i Servizi disponibili che non sono assegnati.

  4. Evidenziare un servizio in Servizi disponibili.

    È possibile assegnare ai membri solo un servizio alla volta. La prima voce dell'elenco è selezionata per impostazione predefinita. Se il servizio che si desidera assegnare non è il primo dell'elenco, deselezionare questa voce e selezionare la voce corretta.

    È possibile filtrare in base a diversi fattori per mostrare solo i servizi:
    • Con un abbonamento valido o scaduto.
    • Assegnati o non assegnati.
    È anche possibile filtrare in base a un nome del servizio o numero seriale.

    Se si seleziona il nome del servizio, si apre la pagina Dettagli servizio. Nel browser, fare clic su Indietro per tornare alla pagina Dettagli membro.

  5. Fare clic su Assegna servizio.

Admin Portal aggiunge il prodotto all'elenco Servizi del membro.

Argomento principale Gestione di membri e licenze
Invito di nuovi membri in un account
Rimozione di membri dagli account
Assegnazione di prodotti ai membri
Assegnazione dei membri ai prodotti
Rimozione delle licenze dai membri
Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati
Ricerca di prodotti e controllo degli utenti assegnati
Rimozione di prodotti dai membri esterni
Utilizzo del menu dell'ingranaggio per le interrogazioni


Rimozione delle licenze dai membri

È possibile rimuovere i prodotti da un membro.

Per rimuovere un prodotto da un membro:

  1. Fare clic sulla scheda Membri.
  2. Cercare un membro nel riquadro Trova membri, oppure fare clic sul nome nell'elenco.

    Nella pagina del membro, Prodotti assegnati elenca tutti i prodotti associati al membro e Prodotti disponibili elenca i prodotti non assegnati.

  3. Selezionare il prodotto in Prodotti assegnati e fare clic su Rimuovi prodotto.
  4. Fare clic su OK per confermare.

    Admin Portal aggiunge il prodotto all'elenco Prodotti disponibili del membro.

Se un membro utilizza i prodotti in modalità offline, non è possibile recuperare e riassegnare la licenza finché il membro non disattiva la Modalità offline o non scade il periodo di 30 giorni per la modalità offline.
Argomento principale Gestione di membri e licenze
Invito di nuovi membri in un account
Rimozione di membri dagli account
Assegnazione di prodotti ai membri
Assegnazione dei membri ai prodotti
Assegnazione di servizi ai membri
Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati
Ricerca di prodotti e controllo degli utenti assegnati
Rimozione di prodotti dai membri esterni
Utilizzo del menu dell'ingranaggio per le interrogazioni


Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati

Admin Portal fornisce diversi modi per trovare un utente e per monitorare i diritti utente e i prodotti assegnati.

Per eseguire la ricerca di un membro e per controllare i diritti utente e i prodotti assegnati:

  1. Fare clic sulla scheda Membri.
  2. Nel riquadro Trova membri, è possibile filtrare in base ai diritti utente e ai prodotti assegnati:
    • Selezionare Amministratore, Membro o In attesa per restringere la ricerca agli utenti con tale stato.
    • Selezionare uno o più tipi di prodotto per limitare la ricerca agli utenti a cui sono assegnati i prodotti selezionati.
  3. Per controllare i diritti e i prodotti assegnati a uno specifico utente, selezionare un nome in Membri.

    È possibile visualizzare il livello dei diritti per un utente specifico in Dettagli membro. La stessa pagina elenca i prodotti assegnati associati all'utente e i prodotti disponibili che possono essere assegnati.

Argomento principale Gestione di membri e licenze
Invito di nuovi membri in un account
Rimozione di membri dagli account
Assegnazione di prodotti ai membri
Assegnazione dei membri ai prodotti
Assegnazione di servizi ai membri
Rimozione delle licenze dai membri
Ricerca di prodotti e controllo degli utenti assegnati
Rimozione di prodotti dai membri esterni
Utilizzo del menu dell'ingranaggio per le interrogazioni


Ricerca di prodotti e controllo degli utenti assegnati

Admin Portal fornisce diversi modi per trovare i prodotti e per monitorare a quali utenti sono assegnati i prodotti.

Per cercare un prodotto:

  1. Fare clic sulla scheda Prodotti.
  2. Nel riquadro Trova prodotti, immettere il nome del prodotto.
  3. È possibile filtrare in base a diversi fattori per mostrare solo i prodotti:
    • Con un abbonamento valido o scaduto
    • Assegnati o non assegnati
    • Attivati o non attivati per le licenze online
    • Appartenenti a uno o più tipi di prodotto
    È anche possibile filtrare in base a un numero di serie.
  4. Fare clic su Cerca.
  5. Per controllare gli utenti assegnati a un prodotto, selezionare un nome di prodotto in Prodotti.
    La pagina Dettagli prodotto elenca tutti i membri ai quali è assegnato il prodotto.
Argomento principale Gestione di membri e licenze
Invito di nuovi membri in un account
Rimozione di membri dagli account
Assegnazione di prodotti ai membri
Assegnazione dei membri ai prodotti
Assegnazione di servizi ai membri
Rimozione delle licenze dai membri
Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati
Rimozione di prodotti dai membri esterni
Utilizzo del menu dell'ingranaggio per le interrogazioni


Rimozione di prodotti dai membri esterni

I membri esterni sono persone al di fuori dell'organizzazione ma che hanno registrato uno dei prodotti dell'organizzazione. L'Admin Portal consente di identificarli e rimuoverli dal prodotto.

Per rimuovere i prodotti dai membri esterni:

  1. Fare clic sulla scheda Prodotti.
  2. Nel pannello Trova prodotti, inserire il nome del prodotto o i criteri di ricerca.
  3. Fare clic su Cerca.
  4. Selezionare il nome del prodotto.
    La pagina Dettagli prodotto elenca tutti i membri ai quali è assegnato il prodotto.
  5. Nell'elenco di Membri esterni assegnati, selezionare il membro esterno e fare clic su Rimuovi membro.
Argomento principale Gestione di membri e licenze
Invito di nuovi membri in un account
Rimozione di membri dagli account
Assegnazione di prodotti ai membri
Assegnazione dei membri ai prodotti
Assegnazione di servizi ai membri
Rimozione delle licenze dai membri
Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati
Ricerca di prodotti e controllo degli utenti assegnati
Utilizzo del menu dell'ingranaggio per le interrogazioni


Utilizzo del menu dell'ingranaggio per le interrogazioni

Il menu ingranaggio contiene i comandi per creare e rifinire le ricerche.

Comando | Tasti di scelta rapida | Descrizione
Nuova interrogazione | Alt + Q | Crea un'interrogazione inserendo del testo in uno o più campi della pagina Membri (ad es. Nome, Cognome, Diritti utente, E-mail e Prodotti assegnati) e della pagina Prodotti (ad es. Nome del prodotto, Tipo di prodotto, Numero di serie, Attivato, Assegnato e Scadenza).
Esegui interrogazione | Alt + Invio | Esegue l'interrogazione.
Restringi interrogazione | Alt + G | Modifica e aggiunge il testo nei campi dell'interrogazione.
Colonne visualizzate | Ctrl + Maiusc + K | Seleziona le colonne da visualizzare nelle pagine Membri e Prodotti.
Esporta |  | Esporta i risultati dell'interrogazione. È possibile esportare tutte le righe o solo la riga corrente nella colonna ed esportare tutte le colonne o solo le colonne visibili. I risultati possono essere esportati come file di testo delimitato da tabulatori, file di testo separato da virgole, file HTML o file di testo con delimitatore specificato dall'utente.
Ordinamento avanzato |  | Ordina i risultati dell'interrogazione in base a massimo tre colonne.
Argomento principale Gestione di membri e licenze
Invito di nuovi membri in un account
Rimozione di membri dagli account
Assegnazione di prodotti ai membri
Assegnazione dei membri ai prodotti
Assegnazione di servizi ai membri
Rimozione delle licenze dai membri
Ricerca dei membri e controllo dei diritti utente e dei prodotti assegnati
Ricerca di prodotti e controllo degli utenti assegnati
Rimozione di prodotti dai membri esterni


Impostazione dei prodotti per utilizzare le licenze online

Per impostazione predefinita, il software SOLIDWORKS è impostato per utilizzare l'attivazione del computer. Se il software SOLIDWORKS è stato installato su un computer, è necessario disattivare manualmente la licenza e modificare quindi il tipo di attivazione per utilizzare le licenze online.

Argomento principale Attività dell'amministratore
Creazione del primo account amministratore
Gestione di prodotti e servizi
Gestione di membri e licenze
Promozione di un utente ad amministratore
Registrare I miei prodotti sul Portale clienti SOLIDWORKS

Disattivazione delle licenze installate in SOLIDWORKS

Prima di utilizzare una licenza online, è necessario verificare che lo stesso prodotto non sia installato sul computer. Se è installato, è necessario disattivare la licenza del prodotto installato prima di configurare le licenze online tramite Admin Portal.

Per disattivare una licenza:

  • Nel software SOLIDWORKS, fare clic su Guida > Licenze > Disattiva e seguire le istruzioni.
È possibile avere sia licenze online sia licenze SolidNetWork sullo stesso computer. Ad esempio, lo stesso computer può eseguire SOLIDWORKS Premium 2020 con una licenza online e SOLIDWORKS Simulation Premium 2020 con una licenza SolidNetWork.

Modifica del tipo di attivazione alle licenze online

Prima di poter utilizzare le licenze online con un prodotto, è necessario modificare il tipo di attivazione dall'attivazione del computer alle licenze online.

È possibile modificare il tipo di attivazione di una licenza prima o dopo l'assegnazione a un membro. Non è possibile modificare il tipo di attivazione di una licenza se questa è attivata o se il prodotto è assegnato a più di un membro. Se una licenza è attivata attraverso l'attivazione del computer, non può essere disattivata da remoto; un utente sul computer deve disattivare la licenza.

Per modificare il tipo di attivazione alle licenze online:

  1. Se il prodotto è assegnato a un membro:
    1. Fare clic sulla scheda Membri e selezionare un membro nell'elenco.
    2. In Prodotti assegnati, fare clic sul prodotto che si desidera modificare.
    3. In Dettagli prodotto, sotto Tipo di attivazione, fare clic su Cambia in licenza online.
    4. Fare clic su OK per confermare, oppure su Annulla.
  2. Se il prodotto non è assegnato a un membro:
    1. Fare clic sulla scheda Prodotti e selezionare un prodotto nell'elenco.

      È possibile utilizzare il riquadro Trova prodotti per cercare il prodotto.

  3. In Dettagli prodotto, sotto Tipo di attivazione, fare clic su Cambia in licenza online.
  4. Fare clic su OK per confermare, oppure su Annulla.
  5. Assegnare un prodotto a un membro.
Quando si assegna una licenza online, il prodotto può essere utilizzato solo da quel membro. Tuttavia, l'assegnazione di un prodotto con attivazione dal computer a un membro viene effettuata esclusivamente a scopo di tracciamento. Qualsiasi persona che utilizzi il computer designato può utilizzare il prodotto. In questa situazione, potrebbe essere necessario controllare che la persona che utilizza il computer sia il membro che si presuppone abbia tale licenza.


Promozione di un utente ad amministratore

Se un account ha degli amministratori, Admin Portal visualizza le informazioni di contatto degli amministratori. È possibile contattarli e richiedere di diventare un amministratore dell'account.

Se si è un amministratore, è possibile promuovere ad amministratori altri utenti dell'account.

Per promuovere un utente ad amministratore:

  1. Fare clic sulla scheda Membri.
  2. Selezionare un utente dall'elenco dei nomi.

    Se non si riesce a trovare un utente, è possibile interrogare Admin Portal inserendo i criteri di ricerca nel riquadro Trova membri.

  3. Nel pannello Dettagli membro, sotto Diritti utente, fare clic su Cambia in amministratore.
  4. Quindi, fare clic su OK per confermare, oppure su Annulla.
  5. Viene visualizzata un'e-mail che invita l'utente a diventare un amministratore. Fare clic su Invia.

Diritti utente viene visualizzato come In sospeso quando viene inviato l'invito. Dopo l'accettazione, Diritti utente cambia in Amministratore.

È possibile abbassare di livello un amministratore a semplice utente, selezionando Cambia in membro.
Argomento principale Attività dell'amministratore
Creazione del primo account amministratore
Gestione di prodotti e servizi
Gestione di membri e licenze
Impostazione dei prodotti per utilizzare le licenze online
Registrare I miei prodotti sul Portale clienti SOLIDWORKS


Registrare I miei prodotti sul Portale clienti SOLIDWORKS

Dopo aver nominato un amministratore per la propria azienda, nessun utente può registrare un prodotto da tale azienda nel Portale clienti SOLIDWORKS.

All'utente viene negata la registrazione e viene inviata un'e-mail all'amministratore nominato dall'azienda con le informazioni di contatto del richiedente e il numero di serie richiesto. Come amministratore, è possibile decidere se assegnare o non assegnare i prodotti al richiedente per suo conto.
L'assegnazione di un prodotto raggiunge lo stesso stato della registrazione di un prodotto.

Se il richiedente è già un membro dell'account, è possibile assegnare il prodotto richiesto o un prodotto equivalente per suo conto.

Se il richiedente non è già un membro dell'account, l'amministratore può invitare il richiedente come membro e completare l'assegnazione dopo avere fatto ciò.

Argomento principale Attività dell'amministratore
Creazione del primo account amministratore
Gestione di prodotti e servizi
Gestione di membri e licenze
Impostazione dei prodotti per utilizzare le licenze online
Promozione di un utente ad amministratore


Utilizzo dei prodotti SOLIDWORKS con le licenze online

Le licenze online di SOLIDWORKS offrono all'utente la flessibilità di utilizzare un'unica licenza su tutti i propri dispositivi, in qualsiasi posizione, senza dover attivare e disattivare manualmente le licenze su ogni computer.

Ad esempio, è possibile lavorare su un computer in ufficio durante il giorno, quindi tornare a casa e accedere allo stesso prodotto dal proprio computer di casa. Non è necessario disporre di una seconda licenza per il prodotto. Non è necessario disattivare manualmente una licenza sul computer dell'ufficio e riattivarla successivamente sul computer di casa.

È necessario disporre di una connessione a Internet per effettuare l'accesso e utilizzare le licenze online. Dopo l'accesso, è possibile selezionare la modalità non in linea e lavorare mentre il computer non è connesso a una rete.

Inoltre, è possibile eseguire la sincronizzazione delle opzioni SOLIDWORKS su più computer e accedere ai siti Web di SOLIDWORKS (come MySolidWorks.com e il Portale clienti SOLIDWORKS) senza effettuare di nuovo l'accesso.

Indice

  • Accesso a un prodotto SOLIDWORKS con una licenza online

    Dopo aver installato un prodotto SOLIDWORKS con una licenza online, è possibile effettuare l'accesso su qualsiasi computer. Non è necessario installare nuovamente il prodotto per utilizzarlo su un altro computer.

  • Utilizzo di un prodotto SOLIDWORKS in modalità non in linea

    Quando si utilizza un prodotto SOLIDWORKS con una licenza online, è possibile specificare la modalità non in linea quando non si dispone di una connessione a Internet.

  • Cambio di computer quando si utilizzano le licenze online

    Le licenze online offrono la flessibilità di utilizzare una sola licenza su tutti i computer dell'utente. Tuttavia, la licenza può essere utilizzata su un solo computer alla volta.

  • Sincronizzazione delle impostazioni e opzioni su più macchine

    Se si utilizza il software SOLIDWORKS su più macchine, è possibile aggiornare le impostazioni su una macchina e sincronizzarle su tutte le altre macchine che eseguono SOLIDWORKS 2018 e versioni successive.

  • Comunicazione di utilizzo delle licenze online per il prodotto SOLIDWORKS

Argomento principale SOLIDWORKS Admin Portal e licenze online
Accesso ad Admin Portal
Attività dell'amministratore
Accesso al pannello di amministrazione CAD


Accesso a un prodotto SOLIDWORKS con una licenza online

Dopo aver installato un prodotto SOLIDWORKS con una licenza online, è possibile effettuare l'accesso su qualsiasi computer. Non è necessario installare nuovamente il prodotto per utilizzarlo su un altro computer.

Per accedere a un prodotto SOLIDWORKS con una licenza online:

  1. Fare clic su SOLIDWORKS [image] sul desktop.
  2. Immettere il proprio ID SOLIDWORKS e la password, quindi fare clic su Login.
    L'ID SOLIDWORKS può essere l'indirizzo e-mail.

Il prodotto SOLIDWORKS si avvia se si immettono un ID SOLIDWORKS e una password validi e se si è in possesso di una licenza per il prodotto assegnata dal proprio amministratore SOLIDWORKS.

È possibile chiudere e riavviare il prodotto SOLIDWORKS sullo stesso COMPUTER senza dover immettere nuovamente le credenziali, fino a quando non si effettua la disconnessione.

Argomento principale Utilizzo dei prodotti SOLIDWORKS con le licenze online
Utilizzo di un prodotto SOLIDWORKS in modalità non in linea
Cambio di computer quando si utilizzano le licenze online
Sincronizzazione delle impostazioni e opzioni su più macchine
Comunicazione di utilizzo delle licenze online per il prodotto SOLIDWORKS


Utilizzo di un prodotto SOLIDWORKS in modalità non in linea

Quando si utilizza un prodotto SOLIDWORKS con una licenza online, è possibile specificare la modalità non in linea quando non si dispone di una connessione a Internet.

Per lavorare in modalità non in linea:

  • Nella barra del titolo di SOLIDWORKS, fare clic con il pulsante destro del mouse su Login [image] e selezionare Ottieni licenza offline.

È possibile utilizzare il prodotto SOLIDWORKS per un periodo di 30 giorni senza connettersi nuovamente al sito Web di SOLIDWORKS. Dopo 30 giorni, è necessario fare nuovamente clic su Ottieni licenza offline per continuare a lavorare in modalità non in linea.

Quando si utilizza una licenza online in modalità non in linea su un computer, non è possibile utilizzare tale licenza su altri computer.
Argomento principale Utilizzo dei prodotti SOLIDWORKS con le licenze online
Accesso a un prodotto SOLIDWORKS con una licenza online
Cambio di computer quando si utilizzano le licenze online
Sincronizzazione delle impostazioni e opzioni su più macchine
Comunicazione di utilizzo delle licenze online per il prodotto SOLIDWORKS


Cambio di computer quando si utilizzano le licenze online

Le licenze online offrono la flessibilità di utilizzare una sola licenza su tutti i computer dell'utente. Tuttavia, la licenza può essere utilizzata su un solo computer alla volta.

L'utente esegue il software SOLIDWORKS sul proprio computer principale e non effettua la disconnessione. Quando l'utente tenta di accedere a un secondo computer (ad esempio, un computer a casa), il software consente di trasferire la licenza dal computer principale.

Per avviare il software SOLIDWORKS su un secondo computer:

  1. Quando l'utente accede al secondo computer, il software SOLIDWORKS informa che un prodotto con licenza online è in uso su un altro computer. Fare clic su Sì per continuare.

    Il prodotto SOLIDWORKS viene eseguito sul secondo computer.

  2. Quando l'utente torna al proprio computer principale, viene richiesto di salvare il lavoro svolto prima di chiudere il software SOLIDWORKS. Fare clic su OK per salvare le modifiche apportate al modello.
Argomento principale Utilizzo dei prodotti SOLIDWORKS con le licenze online
Accesso a un prodotto SOLIDWORKS con una licenza online
Utilizzo di un prodotto SOLIDWORKS in modalità non in linea
Sincronizzazione delle impostazioni e opzioni su più macchine
Comunicazione di utilizzo delle licenze online per il prodotto SOLIDWORKS


Sincronizzazione delle impostazioni e opzioni su più macchine

Se si utilizza il software SOLIDWORKS su più macchine, è possibile aggiornare le impostazioni su una macchina e sincronizzarle su tutte le altre macchine che eseguono SOLIDWORKS 2018 e versioni successive.

La sincronizzazione delle impostazioni è un servizio e potrebbe essere bloccata da alcune configurazioni di rete. Per accedere al servizio di storage nel cloud, assicurarsi che il firewall o i server proxy consentano la comunicazione con *.solidworks.com.

Per sincronizzare impostazioni e opzioni su più macchine:

  1. Accedere al software SOLIDWORKS.
  2. In Strumenti > Opzioni, fare clic su Sincronizza impostazioni.
  3. Scegliere il metodo manuale o automatico:
    • Sincronizza ora.

      Carica impostazioni. Invia le impostazioni dalla macchina corrente al servizio di storage su cloud. È possibile aggiornare in qualsiasi momento le impostazioni nel cloud caricandole di nuovo.

      Scarica impostazioni. Scarica e applica le impostazioni dal servizio di storage su cloud alla macchina corrente.

    • Sincronizzazione automatica.

      Sincronizza automaticamente le macchine correnti con il servizio di storage su cloud. Le impostazioni e le personalizzazioni selezionate sono caricate automaticamente nei servizi di storage su cloud a mano a mano che vengono aggiornate, quindi vengono scaricate e applicate all'avvio o all'accesso.

    Le impostazioni di sincronizzazione possono variare su macchine diverse. Ad esempio, è possibile specificare una macchina che sincronizzi automaticamente le opzioni di sistema e la posizione dei file ma non le personalizzazioni. Su un'altra macchina, è possibile specificare che è necessario scaricare e caricare manualmente tutti i tipi di impostazioni.

    La sincronizzazione non consente di sovrascrivere le impostazioni dell'amministratore applicate o bloccate.
  4. Fare clic su OK.
Argomento principale Utilizzo dei prodotti SOLIDWORKS con le licenze online
Accesso a un prodotto SOLIDWORKS con una licenza online
Utilizzo di un prodotto SOLIDWORKS in modalità non in linea
Cambio di computer quando si utilizzano le licenze online
Comunicazione di utilizzo delle licenze online per il prodotto SOLIDWORKS


Comunicazione di utilizzo delle licenze online per il prodotto SOLIDWORKS

Esistono due modi per notificare il prodotto SOLIDWORKS che si desidera far passare a una licenza online:
  • Quando si accede a un prodotto SOLIDWORKS, un messaggio informa l'utente che il numero di serie inserito è stato reimpostato per la licenza online. Riavviare il prodotto ed effettuare l'accesso.
  • L'amministratore può indicare al prodotto di utilizzare le licenze online invece di un numero di serie tramite l'Editor opzione immagine amministrativa. Ogni prodotto installato in questo modo richiede l'accesso per eseguire il software.
Argomento principale Utilizzo dei prodotti SOLIDWORKS con le licenze online
Accesso a un prodotto SOLIDWORKS con una licenza online
Utilizzo di un prodotto SOLIDWORKS in modalità non in linea
Cambio di computer quando si utilizzano le licenze online
Sincronizzazione delle impostazioni e opzioni su più macchine


Accesso al pannello di amministrazione CAD

Se si dispone di un contratto di abbonamento SOLIDWORKS, è possibile accedere al pannello di amministrazione CAD di SOLIDWORKS da Admin Portal, senza effettuare di nuovo l'accesso.

Nel pannello di amministrazione CAD, è possibile eseguire operazioni quali monitoraggio delle prestazioni, monitoraggio delle statistiche della sessione e visualizzazione dei dettagli dei computer della rete che eseguono il software SOLIDWORKS.

Per ulteriori informazioni, vedere la Guida in linea del pannello di amministrazione CAD.

Argomento principale SOLIDWORKS Admin Portal e licenze online
Accesso ad Admin Portal
Attività dell'amministratore
Utilizzo dei prodotti SOLIDWORKS con le licenze online


Amministrazione delle licenze

Dopo l'installazione, è possibile attivare le licenze SOLIDWORKS sia singolarmente su ogni computer (attivazione computer), installando e attivando licenze di rete mobili su un server (licenze SolidNetWork) o effettuando l'accesso alle applicazioni SOLIDWORKS (licenze online).

Di solito, le installazioni su computer individuali usano l'attivazione della licenza; tuttavia, è possibile installare il software individualmente e poi controllare le licenze con SolidNetWork License Manager. Inoltre, sebbene i siti di grandi dimensioni di solito usano licenze in rete mobili, è possibile implementare le installazioni da un'immagine amministrativa e successivamente attivare i numeri seriali dai computer individuali.

Indice

  • Amministrazione di licenze individuali

    È possibile impostare una licenza individuale per utilizzare l'attivazione del computer o la licenza online. In questa sezione viene illustrata l'attivazione computer. Per ulteriori informazioni sulle licenze online, vedere la sezione relativa ad Admin Portal.

  • Amministrazione delle licenze mediante SolidNetWork License Manager

    SolidNetWork License Manager supporta più client di licenza mediante la distribuzione delle licenze ai client in rete. Ciò consente al numero di utenti di eccedere il numero di licenze grazie all'uso di licenze mobili.


Amministrazione di licenze individuali

È possibile impostare una licenza individuale per utilizzare l'attivazione del computer o la licenza online. In questa sezione viene illustrata l'attivazione computer. Per ulteriori informazioni sulle licenze online, vedere la sezione relativa ad Admin Portal.

Solitamente, l'amministrazione di licenze individuali implica l'attivazione e la disattivazione delle licenze direttamente dal software SOLIDWORKS.

L'attivazione è un processo di registrazione e immatricolazione per le licenze standalone di SOLIDWORKS (non SolidNetWork License). Se la licenza del prodotto non è stata attivata, SOLIDWORKS tenta di attivarla al primo avvio.

È possibile disattivare le licenze individuali facendo clic su ? > Licenze > Disattiva nel software SOLIDWORKS.

Argomento principale Amministrazione delle licenze
Amministrazione delle licenze mediante SolidNetWork License Manager

Attivazione di una licenza

Per eseguire i prodotti SOLIDWORKS in un determinato computer, è prima necessario attivare la licenza per tale computer.

L'attivazione richiede l'accesso ad Internet o all'e-mail. Dopo l'attivazione, non sarà più necessario essere online per usare i prodotti. Senza accesso email sul computer dove viene utilizzato questo prodotto, sarà possibile salvare il file di attivazione ed inviarlo da un altro computer.

Questo procedimento svolge le seguenti operazioni:
  • Attiva tutte le licenze del sofware per qualsiasi prodotto SOLIDWORKS.
  • Consente di trasferire i diritti di licenza da un computer all'altro.
  • Può essere effettuata immediatamente (consigliato) o entro trenta giorni dall'installazione.
  • Elimina il bisogno dei dispositivi di sicurezza. Tuttavia, se si eseguono le versioni precedenti dei prodotti SOLIDWORKS che non utilizzano l'attivazione, è necessario mantenere il dispositivo di sicurezza.

Gli amministratori di sistema che devono gestire più numeri di serie possono utilizzare l'editor delle opzioni dell'immagine amministrativa. Per i dettagli, vedere Editor opzioni immagine amministrativa.

Per attivare una licenza:

  1. Avviare il software SOLIDWORKS.
  2. Avviare l'attivazione del prodotto SOLIDWORKS tramite uno dei metodi seguenti:
    • Se la licenza non è ancora stata attivata nel computer in uso, all'avvio del software SOLIDWORKS si apre automaticamente la finestra Attivazione del prodotto SOLIDWORKS.
    • Se la finestra Attivazione del prodotto SOLIDWORKS non si apre automaticamente, avviare l'attivazione selezionando ? > Licenze > Attiva.
  3. Fare clic sul Prodotto desiderato per attivare la licenza specifica.
  4. Selezionare l'attivazione automatica via Internet o l'attivazione manuale via email.
  5. Fornire le informazioni di contatto email.
  6. Fare clic su Avanti.
    • Internet: L'attivazione è automatica.
    • Email: Fare clic su Salva per creare un file di richiesta, quindi inviarlo tramite e-mail a activation@solidworks.com. Quando si riceve l'e-mail con il file di risposta, estrarre il file e fare clic su Apri per caricarlo.
      Se richiesto, è possibile uscire e ripetere la procedura di attivazione per aprire il file della risposta.
  7. Fare clic su Fine.
Editor opzioni immagine amministrativa

Trasferimento di una licenza

Per trasferire una licenza a un computer nuovo o aggiornato, disattivarla prima sul server chiavi di licenza di Dassault Systèmes SolidWorks Corporation, quindi riattivarla sull'altro computer.

Nel caso in cui non sia possibile disattivare la licenza di Dassault Systèmes SolidWorks Corporation (ad esempio, a causa di un errore del disco rigido), la riattivazione avverrà comunque nella maggior parte dei casi. In caso contrario, contattare il proprio rivenditore autorizzato per assistenza.

Per trasferire nuovamente una licenza al server:

  1. Nel software SOLIDWORKS, fare clic su Guida > Licenze > Disattiva e seguire le istruzioni.
  2. Per riattivare la licenza, passare al computer nuovo o aggiornato e attivare la licenza procedendo come per l'attivazione iniziale. Per i dettagli, vedere Attivazione di una licenza.


Amministrazione delle licenze mediante SolidNetWork License Manager

SolidNetWork License Manager supporta più client di licenza mediante la distribuzione delle licenze ai client in rete. Ciò consente al numero di utenti di eccedere il numero di licenze grazie all'uso di licenze mobili.

Questa immagine raffigura una tipica installazione di licenze SolidNetWork:

Questa immagine illustra:
  • Il software SolidNetWork License Manager viene installato e attivato solamente sul computer del gestore di licenze.
  • I computer client di licenza non possiedono altro software specifico SolidNetWork.

    Se si specifica un numero seriale di licenza SolidNetWork all'installazione, la Gestione installazioni di SOLIDWORKS identifica tale computer come un client di licenza SolidNetWork. La Gestione installazioni SOLIDWORKS invita a specificare il nome del computer del Gestore di licenze SolidNetWork e il numero di porta per connettere il client al gestore di licenze.

  • Il gestore di licenze e tutti i client di licenza devono avere connettività TCP/IP.

Indice

  • Attivazione di una licenza SolidNetWork

    Prima che gli utenti possano eseguire prodotti SOLIDWORKS sui loro computer, è necessario attivare una licenza SolidNetWork sul computer di SolidNetWork License Manager.

  • Trasferimento di una licenza SolidNetWork

    Per trasferire una licenza SolidNetWork a un computer nuovo o aggiornato, disattivare prima la licenza sul server chiavi di licenza di Dassault Systèmes SOLIDWORKS Corporation, quindi riattivarla sull'altro computer.

  • Installazione e configurazione delle licenze SolidNetWork

    La configurazione delle licenze SolidNetWork implica l'installazione di SolidNetWork License Manager sul computer destinato a gestore di licenze e quindi l'installazione di SOLIDWORKS sui computer client mediante il numero seriale della licenza SolidNetWork.

  • Amministrazione delle licenze SolidNetWork

    Le operazioni comprendono avvio, aggiornamento e disinstallazione del gestore di licenze, nonché presa in prestito e restituzione delle licenze.

Argomento principale Amministrazione delle licenze
Amministrazione di licenze individuali


Attivazione di una licenza SolidNetWork

Prima che gli utenti possano eseguire prodotti SOLIDWORKS sui loro computer, è necessario attivare una licenza SolidNetWork sul computer di SolidNetWork License Manager.

L'attivazione richiede l'accesso ad Internet o all'email. Dopo l'attivazione, non sarà più necessario essere online per usare i prodotti. Senza accesso email sul computer dove viene utilizzato questo prodotto, sarà possibile salvare il file di attivazione ed inviarlo da un altro computer.

Questo procedimento svolge le seguenti operazioni:
  • Attivare SOLIDWORKS SolidNetWork License Manager con le licenze SolidNetWork valide per più prodotti SOLIDWORKS.
  • Consente di trasferire i diritti di licenza SolidNetWork da un computer di SolidNetWork License Manager a un altro.
  • Consente di installare e attivare i diritti di licenza SolidNetWork su un computer di SolidNetWork License Manager.
  • Da eseguire prima di utilizzare le licenze SolidNetWork.
  • Elimina il bisogno dei dispositivi di sicurezza. Se si attiva una licenza SolidNetWork per questa versione di SOLIDWORKS, le vengono attivate le licenze SolidNetWork per le versioni precedenti di SOLIDWORKS. (Non è più necessario conservare il dispositivo di sicurezza.)

Per attivare una licenza SolidNetWork:

  1. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Se non è stata ancora attivata la licenza SolidNetWork, un messaggio chiede se lo si desidera fare ora. Fare clic su Sì per attivare.
  3. In Come eseguire l'attivazione?, selezionare Automaticamente su internet (consigliato).
  4. In Informazioni contatto, specificare un indirizzo e-mail.
La finestra di dialogo Attivazione/Riattivazione riuscita mostra i prodotti attivati.
Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Installazione e configurazione delle licenze SolidNetWork
Amministrazione delle licenze SolidNetWork


Trasferimento di una licenza SolidNetWork

Per trasferire una licenza SolidNetWork a un computer nuovo o aggiornato, disattivare prima la licenza sul server chiavi di licenza di Dassault Systèmes SOLIDWORKS Corporation, quindi riattivarla sull'altro computer.

Nel caso in cui non sia stato possibile disattivare la licenza di Dassault Systèmes SOLIDWORKS Corporation (ad esempio, a causa di un errore del disco), la riattivazione avverrà comunque nella maggior parte dei casi. In caso contrario, contattare il proprio rivenditore autorizzato per assistenza.

Per ritrasferire una licenza SolidNetWork al server:

  1. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
  2. In Informazioni sulla licenza, fare clic su Modifica. Si avvia la procedura guidata Attivazione del prodotto SOLIDWORKS.
  3. In Cosa vuoi fare?, selezionare Disattivare una licenza software e fare clic su Avanti.
  4. In Come si desidera effettuare la disattivazione?, selezionare Automaticamente su Internet (consigliato).
  5. In Informazioni contatto, specificare un indirizzo e-mail.
  6. Fare clic su Avanti. La disattivazione della licenza del prodotto viene completata.
Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Attivazione di una licenza SolidNetWork
Installazione e configurazione delle licenze SolidNetWork
Amministrazione delle licenze SolidNetWork


Installazione e configurazione delle licenze SolidNetWork

La configurazione delle licenze SolidNetWork implica l'installazione di SolidNetWork License Manager sul computer destinato a gestore di licenze e quindi l'installazione di SOLIDWORKS sui computer client mediante il numero seriale della licenza SolidNetWork.

Indice

  • Installazione e attivazione di un gestore di licenze

    SolidNetWork License Manager supporta molteplici client di licenza. Distribuisce le licenze ai client in rete.

  • Installazione di un client di licenza

    Quando si installa SOLIDWORKS su un computer client di licenza SolidNetWork, il numero seriale identifica tale computer come client di licenza SolidNetWork.

  • Installare i SolidNetWork License Manager prima dei client di licenza

    Si consiglia di installare e configurare SolidNetWork License Manager su almeno un computer prima di installare uno dei computer client di licenza SolidNetWork.

  • Gestione dell'accesso alle versioni di SOLIDWORKS

    Gli amministratori possono impedire agli utenti di utilizzare versioni specifiche di SOLIDWORKS in un ambiente SolidNetWork. Questa funzionalità consente di gestire le versioni di SOLIDWORKS utilizzate da persone, progetti e business unit diversi.

  • Installazione del Gestore di licenze a terna

    La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Se il computer che gestisce il file della licenza non è disponibile, uno degli altri due potrà farlo.

  • Uso di licenze SolidNetWork con i firewall

    Se il computer utilizza un firewall, è necessario configurare le porte per il supporto delle licenze SolidNetWork.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Attivazione di una licenza SolidNetWork
Trasferimento di una licenza SolidNetWork
Amministrazione delle licenze SolidNetWork


Installazione e attivazione di un gestore di licenze

SolidNetWork License Manager supporta molteplici client di licenza. Distribuisce le licenze ai client in rete.

Se si intende aggiornare da una versione precedente di SolidNetWork License Manager che usava i dongle per l'hardware per l'attivazione delle licenze, rimuovere il dongle prima di installare la nuova versione di SolidNetWork License Manager.

  1. Avviare Gestione installazioni di SOLIDWORKS (come descritto sotto Inizio dell'installazione di SOLIDWORKS).
    1. Come tipo di installazione, selezionare:
      • Prodotti del server
      • Installare SolidNetWork License Manager (licenze distribuite) sul computer.
    2. Nella pagina Opzioni SolidNetWork License Manager, specificare il numero di serie della licenza di SolidNetWork e il percorso di installazione di SolidNetWork License Manager.
    3. Nella pagina Riepilogo, fare clic su Installa ora per completare il processo di installazione di Gestione installazioni SOLIDWORKS.
  2. Per attivare le licenze SolidNetWork:
    1. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Quando un messaggio invita ad attivare, fare clic su Sì.
    3. Nella schermata Informazioni sul server di licenza SolidNetWork:
      • Se la propria azienda usa un firewall, selezionare Un firewall è in uso su questo server.

        Per ulteriori informazioni, vedere Uso di licenze SolidNetWork con i firewall.

      • Lasciare il valore predefinito per Numero porta (e per Numero porta daemon fornitore se è attivo un firewall) o digitare i numeri di porta utilizzati dall'azienda.
        Il numero della porta è un numero TCP/IP nel range 1024 - 60000 che non può essere usato da altri processi. In genere, il numero di default 25734 è adatto e con tutta probabilità sarà diverso da quello di un a qualsiasi altro processo di server FLEXnet attualmente in esecuzione sul computer di gestione delle licenze.
    4. Nella schermata Attivare il prodotto SOLIDWORKS:
      • Selezionare la procedura via internet o email.
      • Fornire le informazioni di contatto e-mail.
      • Fare clic su Avanti per continuare.
        • Internet: L'attivazione è automatica.
        • Email: Premere Salva per creare un file di richiesta, quindi inviarlo ad activation@solidworks.com. Quando si riceve una mail con il file di risposta, estrarre il file e fare clic su Apri per caricarlo.
          Se necessario, è possibile uscire e ripetere la procedura di attivazione per aprire il file della risposta.
  3. Fare clic su Fine.
Argomento principale Installazione e configurazione delle licenze SolidNetWork
Installazione di un client di licenza
Installare i SolidNetWork License Manager prima dei client di licenza
Gestione dell'accesso alle versioni di SOLIDWORKS
Installazione del Gestore di licenze a terna
Uso di licenze SolidNetWork con i firewall
Inizio dell'installazione di SOLIDWORKS


Installazione di un client di licenza

Quando si installa SOLIDWORKS su un computer client di licenza SolidNetWork, il numero seriale identifica tale computer come client di licenza SolidNetWork.

  1. Avviare Gestione installazioni di SOLIDWORKS (come descritto sotto Inizio dell'installazione di SOLIDWORKS).
  2. Nella schermata di benvenuto, fare clic su Individuale (su questo computer) se questa è la prima installazione di SOLIDWORKS su questo computer per questa release principale.
    Se si aggiorna da una release esistente e si cambia da una licenza individuale alla licenza SolidNetWork, fare clic su Modificare l'installazione individuale (su questo computer). Per dettagli, vedere Aggiornamento da licenze individuali a licenze SolidNetWork.
  3. Quando viene richiesto il numero seriale, immettere il numero seriale della licenza SolidNetWork.
  4. Nella finestra di dialogo Aggiungi server, digitare l'indirizzo di SolidNetWork License Manager nel formato:

    porta@Nome computer

    Il numero della porta deve essere identico a quello utilizzato per il computer del gestore di licenze. Il valore predefinito è 25734 (come descritto in Installazione e attivazione di un gestore di licenze).

    La Gestione installazioni SOLIDWORKS tenterà di confermare che questo SolidNetWork License Manager è accessibile. Se non si è ancora installato un gestore di licenze, questa autenticazione non andrà a buon fine ma si potrà comunque procedere con l'installazione del client di licenza.
  5. Completare l'installazione di SOLIDWORKS attenendosi alle istruzioni della Gestione installazioni.
Argomento principale Installazione e configurazione delle licenze SolidNetWork
Installazione e attivazione di un gestore di licenze
Installare i SolidNetWork License Manager prima dei client di licenza
Gestione dell'accesso alle versioni di SOLIDWORKS
Installazione del Gestore di licenze a terna
Uso di licenze SolidNetWork con i firewall
Inizio dell'installazione di SOLIDWORKS
Aggiornamento da licenze individuali a licenze SolidNetWork


Installare i SolidNetWork License Manager prima dei client di licenza

Si consiglia di installare e configurare SolidNetWork License Manager su almeno un computer prima di installare uno dei computer client di licenza SolidNetWork.

Quando si installa mediante un numero seriale della licenza SolidNetWork, la Gestione installazioni SOLIDWORKS invita a immettere il nome e il numero di porta del computer del SolidNetWork License Manager e quindi tenta di autenticare tali informazioni.

Se non si è installato SolidNetWork License Manager sul computer specificato, l'autenticazione non riuscirà. In questo caso, tuttavia, una mancata autenticazione non indica se le informazioni fornite sul gestore di licenze siano corrette. Se il gestore di licenze è installato, la mancata autenticazione indica che sono state fornite informazioni inesatte sul gestore di licenze.

Argomento principale Installazione e configurazione delle licenze SolidNetWork
Installazione e attivazione di un gestore di licenze
Installazione di un client di licenza
Gestione dell'accesso alle versioni di SOLIDWORKS
Installazione del Gestore di licenze a terna
Uso di licenze SolidNetWork con i firewall


Gestione dell'accesso alle versioni di SOLIDWORKS

Gli amministratori possono impedire agli utenti di utilizzare versioni specifiche di SOLIDWORKS in un ambiente SolidNetWork. Questa funzionalità consente di gestire le versioni di SOLIDWORKS utilizzate da persone, progetti e business unit diversi.

Per gestire l'accesso a SOLIDWORKS utilizzando un file di opzioni FLEXnet:

  1. Nella directory di installazione di SolidNetwork License Manager, creare un file di testo:
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. Per gestire l'accesso a una specifica versione di SOLIDWORKS nel file di licenza, aggiungere la seguente sintassi accanto a SOLIDWORKS:
    :SWVERSION=xx dove xx è la versione del prodotto SOLIDWORKS che si desidera gestire
  3. Per gestire più versioni di SOLIDWORKS, aggiungere una riga per ogni versione che si desidera gestire.

    Non sono supportate tutte le opzioni FLEXnet. Le opzioni supportate per i filtri di versione sono:

    INCLUDE | Per consentire all'utente o al gruppo solo la capacità di avviare la versione specifica. A tutti gli altri utenti non sarà consentito di avviare la versione.
    INCLUDE_BORROW | Per consentire all'utente o al gruppo solo la capacità di prendere in prestito la versione specifica. A tutti gli altri utenti non sarà consentito di prendere in prestito la versione.
    EXCLUDE | Per impedire all'utente o al gruppo elencato di avviare la versione specifica di SOLIDWORKS. EXCLUDE ha priorità su INCLUDE.
    EXCLUDE_BORROW | Per impedire all'utente o al gruppo elencato di prendere in prestito la versione specifica di SOLIDWORKS. EXCLUDE ha priorità su INCLUDE.
    Esempi:
    1 | SWVERSION=27.0 si riferisce a SOLIDWORKS 2020
    SWVERSION=26.0 si riferisce a SOLIDWORKS 2019
    2 | INCLUDE solidworks:SWVERSION=27.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=27.0 USER jane
    Queste righe nel file delle opzioni consentono solo a jane di eseguire SOLIDWORKS 2020. Tutti gli altri utenti non possono eseguire o prendere in prestito SOLIDWORKS 2020, ma possono eseguire e prendere in prestito altre versioni di SOLIDWORKS. Inoltre, jane può eseguire e prendere in prestito anche altre versioni di SOLIDWORKS.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=27.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=26.0 GROUP chicago
    EXCLUDE solidworks USER don
    Queste righe definiscono un GRUPPO di utenti denominato chicago, che non possono accedere a SOLIDWORKS 2020 e SOLIDWORKS 2019, ma possono eseguire qualsiasi altra versione di SOLIDWORKS. L'utente don non può eseguire alcuna versione di SOLIDWORKS.
    4 | EXCLUDE swinspection_std:SWVERSION=27.0 HOST machine1
    Questa riga vieta a chiunque si trovi sulla macchina1 di lanciare SOLIDWORKS Inspection 2020.

    Per ulteriori informazioni su FLEXnet, vedere la Guida amministrativa di FLEXnet Publisher nella directory di installazione di SolidNetWork License Manager (\Docs\flexuser\licensingenduserguide.pdf).

Argomento principale Installazione e configurazione delle licenze SolidNetWork
Installazione e attivazione di un gestore di licenze
Installazione di un client di licenza
Installare i SolidNetWork License Manager prima dei client di licenza
Installazione del Gestore di licenze a terna
Uso di licenze SolidNetWork con i firewall


Installazione del Gestore di licenze a terna

La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Se il computer che gestisce il file della licenza non è disponibile, uno degli altri due potrà farlo.

Requisiti per l'uso di gestori di licenze a terna:
  • Installare i gestori di licenze a terna su computer stabili non programmati per spegnimenti frequenti.
  • I tre computer dei gestori di licenze devono essere sulla stessa sottorete. Non configurare mai i gestori di licenze a terna con comunicazioni lente o con connessione remota.
  • L'amministratore di sistema deve intervenire immediatamente qualora un computer del gestore di licenze si porti fuori linea per riavviarlo non appena possibile.
    Se sono in esecuzione solo due computer del gestore di licenze, la situazione è peggiore rispetto al caso in cui è in esecuzione un solo computer del gestore di licenza perché le probabilità di guasto raddoppiano.

Indice

  • Installazione del gestore di licenze a terna iniziale

    Questa procedura dimostra come installare SolidNetWork License Manager sul primo computer della terna.

  • Installazione del gestore di licenze a terna su altri computer

    Seguire queste istruzioni per installare il software SolidNetWork License Manager sul secondo e terzo computer della terna. La procedura è pressoché identica a quella per installare il software sul computer iniziale, ad eccezione dei passi 2(f) e 2(i).

Argomento principale Installazione e configurazione delle licenze SolidNetWork
Installazione e attivazione di un gestore di licenze
Installazione di un client di licenza
Installare i SolidNetWork License Manager prima dei client di licenza
Gestione dell'accesso alle versioni di SOLIDWORKS
Uso di licenze SolidNetWork con i firewall


Installazione del gestore di licenze a terna iniziale

Questa procedura dimostra come installare SolidNetWork License Manager sul primo computer della terna.

  1. Sul primo computer del gestore di licenze a terna, installare SolidNetWork License Manager mediante la Gestione installazioni SOLIDWORKS:
    1. Avviare Gestione installazioni di SOLIDWORKS (come descritto sotto Inizio dell'installazione di SOLIDWORKS).
    2. Come tipo di installazione, selezionare:
      • Prodotti del server
      • Installare SolidNetWork License Manager (licenze distribuite) sul computer.
    3. Nella pagina Opzioni SolidNetWork License Manager, specificare il numero di serie della licenza di SolidNetWork e il percorso di installazione di SolidNetWork License Manager.
    4. Nella pagina Riepilogo, fare clic su Installa ora per completare il processo di installazione di Gestione installazioni SOLIDWORKS.
  2. Utilizzando SolidNetWork License Manager, configurare il computer iniziale del gestore di licenze a terna:
    1. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Fare clic su No.
      Si apre la scheda Amministrazione del server del SOLIDWORKS SolidNetWork License Manager.
    3. In Opzioni avanzate, fare clic su Opzioni.
      Viene visualizzata la finestra di dialogo Opzioni avanzate.
    4. In Modalità di licenza del server SolidNetWork, fare clic su Usa un file di licenza e fare clic su OK.
      La finestra di dialogo Opzioni avanzate si chiude.
    5. In Informazioni sulla licenza, fare clic su Modifica.
      Compare la Creazione guidata del file di licenza SolidNetWork.
    6. In Tipo di server, selezionare Terna e fare clic su Avanti.
    7. Nel riquadro Informazioni sul server, verificare che il nome del computer e il numero di porta del computer iniziale del gestore di licenze a terna siano corretti e fare clic su Avanti.

      Verificare che l'indirizzo NIC (Network Interface Card) corrisponda alle informazioni contenute nel file di licenza ricevuto da SOLIDWORKS e che il numero di porta del computer del gestore di licenze a terna sia corretto. L'indirizzo NIC è denominato anche indirizzo MAC (Media Access Control). Fare quindi clic su Avanti.

      Per individuare l'indirizzo NIC, aprire una finestra del Prompt dei comandi e digitare:

      ipconfig /all

      Inoltre, se sul computer è attivo un firewall, potrebbe essere necessario selezionare altre opzioni in questa schermata. Per informazioni, vedere Uso di licenze SolidNetWork con i firewall.

    8. Nella schermata Informazioni sul server del Partner a terna, immettere il nome del computer e l'ID dell'host degli altri due computer di gestione licenza della terna.
      Ciò assicura che qualora un gestore di licenze non sia accessibile, i computer client potranno ottenere una licenza da uno degli altri due server.
    9. Nella schermata Licenze, fare clic su Leggi per identificare e aprire il file di licenza SolidNetWork.
      Le licenze appariranno in Creazione guidata del file di licenza SolidNetWork. Per questo computer, utilizzare il file di licenza ricevuto dal VAR o dal Centro clienti.
    10. Fare clic su Fine.
    11. Fare clic su OK per chiudere la procedura guidata File di licenza SolidNetWork e quindi su Fine per uscire da SolidNetWork License Manager.
Argomento principale Installazione del Gestore di licenze a terna
Installazione del gestore di licenze a terna su altri computer
Inizio dell'installazione di SOLIDWORKS
Uso di licenze SolidNetWork con i firewall


Installazione del gestore di licenze a terna su altri computer

Seguire queste istruzioni per installare il software SolidNetWork License Manager sul secondo e terzo computer della terna. La procedura è pressoché identica a quella per installare il software sul computer iniziale, ad eccezione dei passi 2(f) e 2(i).

Il presupposto di partenza è che si sia già installato almeno un gestore di licenze a terna su un altro computer.

  1. Sul computer del gestore di licenze a terna, installare SolidNetWork License Manager mediante la Gestione installazioni SOLIDWORKS:
    1. Avviare Gestione installazioni SOLIDWORKS (come descritto in Inizio dell'installazione di SOLIDWORKS).
    2. Come tipo di installazione, selezionare:
      • Prodotti del server
      • Installare SolidNetWork License Manager (licenze distribuite) sul computer.
    3. Nella pagina Opzioni SolidNetWork License Manager, specificare il numero di serie della licenza di SolidNetWork e il percorso di installazione di SolidNetWork License Manager.
    4. Nella pagina Riepilogo, fare clic su Installa ora per completare il processo di installazione di Gestione installazioni SOLIDWORKS.
  2. Utilizzando SolidNetWork License Manager, configurare il computer del gestore di licenze a terna:
    1. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
      Dato che si tratta della prima volta che SolidNetWork License Manager viene eseguito su questo computer, un messaggio chiede se si desidera attivare ora.
    2. Fare clic su No.
      Si apre la scheda Amministrazione del server del SOLIDWORKS SolidNetWork License Manager.
    3. In Opzioni avanzate, fare clic su Opzioni.
      Viene visualizzata la finestra di dialogo Opzioni avanzate.
    4. In Modalità di licenza del server SolidNetWork, fare clic su Usa un file di licenza e fare clic su OK.
      La finestra di dialogo Opzioni avanzate si chiude.
    5. In Informazioni sulla licenza, fare clic su Modifica.
      Compare la Creazione guidata del file di licenza SolidNetWork.
    6. In Tipo di server, selezionare Terna e Sincronizzazione delle informazioni su server/licenza, quindi fare clic su Avanti.
    7. Nel riquadro Informazioni sul server, verificare che il nome del computer e il numero di porta del computer del gestore di licenze a terna siano corretti e fare clic su Avanti.

      Verificare che l'indirizzo NIC (Network Interface Card) corrisponda alle informazioni contenute nel file di licenza ricevuto da SOLIDWORKS e che il numero di porta del computer del gestore di licenze a terna sia corretto. L'indirizzo NIC è denominato anche indirizzo MAC (Media Access Control). Fare quindi clic su Avanti.

      Per individuare l'indirizzo NIC, aprire una finestra del Prompt dei comandi e digitare:

      ipconfig /all

      Inoltre, se sul computer è attivo un firewall, potrebbe essere necessario selezionare altre opzioni in questa schermata. Per ulteriori informazioni, vedere Uso di licenze SolidNetWork con i firewall.

    8. Nella schermata Informazioni sul server del Partner a terna, specificare il nome del computer e l'ID host.
      Ciò assicura che qualora un gestore di licenze non sia accessibile, i computer client potranno ottenere una licenza da uno degli altri due server.
    9. Nella schermata Licenze, fare clic su Leggi per identificare e aprire il file di licenza SolidNetWork.
      Le licenze appariranno in Creazione guidata del file di licenza SolidNetWork.
    Il file di licenza viene generato dal primo computer del gestore di licenze a terna configurato. Generalmente, il file delle licenze è ubicato in \licenses\sw_d.lic. Ad esempio: C:\Program Files\SOLIDWORKS Corp\SolidNetWork License Manager\licenses\sw_d.lic .
    1. Fare clic su Fine.
      Compare un'avvertenza della Creazione guidata del file di licenza SolidNetWork.
    2. Fare clic su OK per chiudere la procedura guidata File di licenza SolidNetWork e quindi su Fine per uscire da SolidNetWork License Manager.

Ripetere la procedura per il terzo computer del gestore di licenze a terna.

Argomento principale Installazione del Gestore di licenze a terna
Installazione del gestore di licenze a terna iniziale


Uso di licenze SolidNetWork con i firewall

Se il computer utilizza un firewall, è necessario configurare le porte per il supporto delle licenze SolidNetWork.

Nel software del firewall, aggiungere due porte di licenza SolidNetWork (es. SNL-in-port e SNL-out-port) all'elenco di eccezioni del firewall. Per i dettagli sulla configurazione di queste porte, consultare l'amministratore del sistema.

Se si utilizza Windows Firewall su un sistema operativo Windows supportato, è necessario modificare le porte sul computer del gestore di licenze SolidNetWork e modificare il file di licenza SolidNetWork per distribuire le licenze ai computer client.

Indice

  • Modifica delle porte computer del gestore di licenze per Windows Firewall

    Se si utilizza Windows Firewall, è necessario modificare le impostazioni della porta firewall sul computer del SolidNetWork License Manager.

  • Modifica delle impostazioni di SolidNetWork License Manager per Windows Firewall

    Se si utilizza Windows Firewall, è necessario modificare il file di licenza SolidNetWork in modo che utilizzi le porte del firewall per distribuire le licenze ai computer client.

Argomento principale Installazione e configurazione delle licenze SolidNetWork
Installazione e attivazione di un gestore di licenze
Installazione di un client di licenza
Installare i SolidNetWork License Manager prima dei client di licenza
Gestione dell'accesso alle versioni di SOLIDWORKS
Installazione del Gestore di licenze a terna


Modifica delle porte computer del gestore di licenze per Windows Firewall

Se si utilizza Windows Firewall, è necessario modificare le impostazioni della porta firewall sul computer del SolidNetWork License Manager.

  1. In Windows, aprire il Pannello di controllo e fare doppio clic su Centro di sicurezza.
  2. Fare clic su Windows Firewall.
  3. Nella scheda Eccezioni fare clic su Aggiungi porta.
  4. Digitare un Nome (es. SNL-in-port) e un Numero porta (es. 25734) e fare clic su OK.
  5. Per la seconda porta, fare clic su Aggiungi porta nella scheda Eccezioni, specificare il nome e il numero dell'altra porta (es. SNL-out-port e 25735) e fare clic su OK. Annotare il numero di porta, perché servirà in futuro per la modifica del file di licenza SolidNetWork.
  6. Chiudere il Centro di sicurezza Windows e il Pannello di controllo.
Argomento principale Uso di licenze SolidNetWork con i firewall
Modifica delle impostazioni di SolidNetWork License Manager per Windows Firewall


Modifica delle impostazioni di SolidNetWork License Manager per Windows Firewall

Se si utilizza Windows Firewall, è necessario modificare il file di licenza SolidNetWork in modo che utilizzi le porte del firewall per distribuire le licenze ai computer client.

  1. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Nella scheda Amministrazione del server, in Server di licenza, fare clic su Ferma. (Fare clic su Sì quando un messaggio invita a confermare e su OK per arrestare il server di licenza.)
  3. In Informazioni sulla licenza, fare clic su Modifica.
  4. In Tipo di server, selezionare la disposizione dei server in rete (Singolo o Terna) e fare clic su Avanti.
  5. In Informazioni server:
    1. Selezionare Un firewall è in uso su questo server.
    2. Numero porta e Numero porta Daemon venditore dovrebbero contenere i numeri di porta specificati per Windows Firewall (per i dettagli, vedere Modifica delle porte computer del gestore di licenze per Windows Firewall).
    3. Selezionare File opzioni e fare clic su Sfoglia per individuare il file. Fare clic su Modifica per modificare uno qualsiasi dei suoi parametri.
      Il file di opzioni consente all'amministratore di licenze di controllare i vari parametri di funzionamento di programma di gestione delle licenze FLEXnet.

      La posizione consigliata per il file di opzioni è nella directory di installazione di SolidNetwork License Manager (SolidNetwork_License_Manager_install_dir\Licenses \sw_d.opt). Questo file deve trovarsi nella stessa directory del file sw_d.lic.

      Per ulteriori informazioni sul file di opzioni, consultare la Guida amministrativa di FLEXnet Publisher nella cartella di installazione di SolidNetwork License Manager (\Docs\flexuser\licensingenduserguide.pdf).

    4. Fare clic su Avanti, quindi su Fine.
  6. Nella scheda Amministrazione del server, in Server di licenza, fare clic su Avvia.
  7. Fare clic su OK per chiudere SolidNetWork License Manager.
Argomento principale Uso di licenze SolidNetWork con i firewall
Modifica delle porte computer del gestore di licenze per Windows Firewall


Amministrazione delle licenze SolidNetWork

Le operazioni comprendono avvio, aggiornamento e disinstallazione del gestore di licenze, nonché presa in prestito e restituzione delle licenze.

Prima di avviare o aggiornare il gestore di licenze, è necessario restituire le licenze prese in prestito.

Indice

  • Avvio di SolidNetWork License Manager

    È possibile avviare SolidNetWork License Manager dal menu Start di Windows.

  • Aggiornamento di SolidNetWork License Manager

    Per le release maggiori di SOLIDWORKS, l'aggiornamento del gestore di licenze implica la disinstallazione del gestore precedente, l'installazione di quello nuovo e la riattivazione della licenza SolidNetWork.

  • Eliminazione dei file di licenza SolidNetWork

    Cancellare i file di licenza SolidNetWork precedenti e scaduti prima di aggiornare a quelli nuovi.

  • Presa in prestito e restituzione di licenze SolidNetWork

    Una licenza SolidNetWork può essere presa in prestito per usare il software da una postazione remota. Dato che una licenza presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

  • Monitoraggio del tempo di inattività di una licenza

    SOLIDWORKS può registrare il tempo di inattività con il SolidNetWork License Manager, in modo tale che le licenze non utilizzate per un certo periodo di tempo vengano restituite al gruppo delle licenze disponibili.

  • Installazione di licenze temporanee

    La licenza temporanea "ANY" può essere utilizzata provvisoriamente quando la licenza SolidNetWork originale non è disponibile.

  • Aggiornamento da licenze individuali a licenze SolidNetWork

    È possibile aggiornare un computer dalla modalità di licenza SOLIDWORKS individuale alle licenze SolidNetWork specificando il numero seriale della licenza SolidNetWork nella Gestione installazioni SOLIDWORKS.

  • Uso delle licenze SolidNetWork con prodotti aggiuntivi

    È anche possibile usare SolidNetWork License Manager per distribuire le licenze per i prodotti aggiuntivi principali di SOLIDWORKS.

  • Selezione di una licenza di SOLIDWORKS Simulation con una licenza SolidNetWork

    Gli utenti SolidNetWork License possono controllare quali licenze di SOLIDWORKS® Simulation utilizzare nel proprio gruppo di licenze quando aggiungono SOLIDWORKS Simulation. Inoltre, possono aggiornare la licenza di SOLIDWORKS Simulation senza scaricare l'aggiunta nel caso in cui sia necessario un tipo di licenza superiore per studi più avanzati.

  • Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa

    È possibile configurare un computer su una rete in modo che funga da gestore di licenze per distribuire le licenze SolidNetWork e da posizione per l'immagine amministrativa, dalla quale gli utenti possano installare il software SOLIDWORKS.

  • Gestione delle licenze con FLEXnet Publisher

    Le licenze SolidNetWork si basano sulla gestione delle licenze con FLEXnet Publisher®.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Attivazione di una licenza SolidNetWork
Trasferimento di una licenza SolidNetWork
Installazione e configurazione delle licenze SolidNetWork


Avvio di SolidNetWork License Manager

È possibile avviare SolidNetWork License Manager dal menu Start di Windows.

In Windows, eseguire il comando: Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager.
Argomento principale Amministrazione delle licenze SolidNetWork


Aggiornamento di SolidNetWork License Manager

Per le release maggiori di SOLIDWORKS, l'aggiornamento del gestore di licenze implica la disinstallazione del gestore precedente, l'installazione di quello nuovo e la riattivazione della licenza SolidNetWork.

Il gestore di licenze di una release più recente può distribuire licenze ai computer client che non aggiornano ma restano alla release precedente.

  1. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Nella scheda Uso della licenza, verificare che nessun client in rete abbia in esecuzione SOLIDWORKS.
  3. Disinstallare la vecchia gestione licenze. Per i dettagli, vedere Disinstallazione di SolidNetWork License Manager.
  4. Installare il nuovo gestore di licenze e riattivare la licenza SolidNetWork sul computer del gestore di licenze. Per i dettagli, vedere Installazione e attivazione di un gestore di licenze.

Se si aggiorna SOLIDWORKS SolidNetWork License Manager su un computer che esegue anche l'applicazione SOLIDWORKS, aggiornare prima i SolidNetWork Licence Manager e i client e solo successivamente installare su tale computer eventuali Service Pack di SOLIDWORKS.

Se si aggiorna il gestore di licenze su un computer che ospita immagini amministrative, aggiornare il gestore di licenze prima delle immagini amministrative. Per i dettagli, vedere Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa.

Indice

  • Disinstallazione di SolidNetWork License Manager

    Quando si aggiorna SolidNetWork License Manager, è necessario disinstallare il gestore di licenze vecchio prima di installare quello nuovo.

Argomento principale Amministrazione delle licenze SolidNetWork


Disinstallazione di SolidNetWork License Manager

Quando si aggiorna SolidNetWork License Manager, è necessario disinstallare il gestore di licenze vecchio prima di installare quello nuovo.

  1. Avviare SolidNetwork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Verificare che nessun client in rete abbia in esecuzione SOLIDWORKS.
    La scheda Uso della licenza mostra i client con SOLIDWORKS in esecuzione.
  3. Se si intende trasferire la licenza SolidNetWork su un altro computer, disattivarla da questo computer prima di rimuovere SolidNetWork License Manager.
    Per informazioni sul trasferimento di licenze SolidNetWork, vedere Trasferimento di una licenza SolidNetWork.
  4. Nella scheda Amministrazione del server, in Server di licenza, fare clic su Ferma.
  5. Fare clic su OK per uscire dal gestore di licenze.
  6. In Windows, selezionare Pannello di controllo > Installazione applicazioni.
  7. Selezionare SOLIDWORKS SolidNetWork License Manager, fare clic su Rimuovi e confermare l'eliminazione.
  8. In Esplora risorse, eliminare la cartella SOLIDWORKS SolidNetWork License Manager.
    Di solito questa cartella si trova in Program Files nella directory di installazione di SOLIDWORKS.

È ora possibile procedere ad installare una nuova versione del gestore di licenze. Per i dettagli, vedere Installazione e attivazione di un gestore di licenze.

Se il computer di SolidNetwork License Manager ha un dongle hardware allegato, rimuovere il dongle prima di installare la nuova versione di SolidNetWork License Manager.
Argomento principale Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Installazione e attivazione di un gestore di licenze


Eliminazione dei file di licenza SolidNetWork

Cancellare i file di licenza SolidNetWork precedenti e scaduti prima di aggiornare a quelli nuovi.

  1. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Nella scheda Amministrazione del server, in File di licenza, fare clic su Modifica, quindi su Avanti fino a raggiungere la schermata Licenze.
  3. Nella schermata Licenze, selezionare il file di licenza SolidNetWork vecchio o scaduto, quindi fare clic su Rimuovi.
  4. Fare clic su Fine, quindi su OK.
Argomento principale Amministrazione delle licenze SolidNetWork


Presa in prestito e restituzione di licenze SolidNetWork

Una licenza SolidNetWork può essere presa in prestito per usare il software da una postazione remota. Dato che una licenza presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

Le licenze in prestito sono valide solo per l'utente e la macchina su cui sono state prese in prestito e non possono essere trasferite.

La licenza viene prestata per un periodo di tempo specificato, fino a 30 giorni, (o come definito dall'amministratore del sistema) e la licenza viene rimossa dal gruppo di licenze disponibili.

Le operazioni di presa in prestito e restituzione di una licenza non funzionano se la licenza SOLIDWORKS è in uso.

L'amministratore del sistema può personalizzare il prestito per:
  • definire gli utenti o i gruppi che possono prendere in prestito le licenze:
  • Impostare il numero di licenze che non possono essere prese in prestito

Per ulteriori informazioni, vedere directory_installazione_Gestore_licenze_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

Indice

  • Presa in prestito di licenze SolidNetWork

  • Restituzione di una licenza SolidNetWork presa in prestito

    Dato che una licenza SolidNetWork presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

Argomento principale Amministrazione delle licenze SolidNetWork


Presa in prestito di licenze SolidNetWork

È possibile avviare SolidNetWork License Manager dal menu Start di Windows. È necessario essere connessi a SolidNetWork License Manager per ottenere in prestito la licenza.

Questi passaggi possono variare a seconda della configurazione del sistema. Per ulteriori istruzioni e opzioni, consultare la documentazione di Microsoft Windows.
  1. Avviare SolidNetWork License Manager sul computer client (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Nella scheda Prestito della licenza:
    1. In Prestito fino al selezionare una data.
    2. Selezionare i prodotti da prendere in prestito quindi, fare clic su Prendere in prestito e su Sì per confermare.
    3. Fare clic su Aggiorna. La colonna Data di scadenza indica la data di riconsegna delle licenze.
  3. Fare clic su OK.
Argomento principale Presa in prestito e restituzione di licenze SolidNetWork
Restituzione di una licenza SolidNetWork presa in prestito


Restituzione di una licenza SolidNetWork presa in prestito

Dato che una licenza SolidNetWork presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

  1. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Nella scheda Prestito della licenza:
    1. Selezionare i prodotti da riconsegnare, fare clic su Ritorno e su Sì per confermare.
    2. Fare clic su Aggiorna. La colonna Data di scadenza si svuota, ad indicare che le licenze sono state riconsegnate.
  3. Fare clic su OK.
Non è necessario restituire le licenze dopo la data di scadenza. La licenza viene restituita al gruppo sul gestore di licenze SolidNetWork a mezzanotte della data di scadenza e le applicazioni sul sistema remoto non funzioneranno più.
Argomento principale Presa in prestito e restituzione di licenze SolidNetWork
Presa in prestito di licenze SolidNetWork


Monitoraggio del tempo di inattività di una licenza

SOLIDWORKS può registrare il tempo di inattività con il SolidNetWork License Manager, in modo tale che le licenze non utilizzate per un certo periodo di tempo vengano restituite al gruppo delle licenze disponibili.

  1. Nella directory di installazione di SolidNetwork License Manager, creare un file di testo:
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. Aggiungere la seguente linea al file:
    TIMEOUTALL secondi

    dove secondi è un numero maggiore o uguale a 900 (15 minuti), il tempo minimo consentito.

Argomento principale Amministrazione delle licenze SolidNetWork


Installazione di licenze temporanee

La licenza temporanea "ANY" può essere utilizzata provvisoriamente quando la licenza SolidNetWork originale non è disponibile.

Installando il file di licenza "ANY", si accetta di implementare il file di licenza tradizionale al momento della ricezione di una licenza SolidNetWork da Dassault Systèmes SOLIDWORKS Corporation. La conformità con le limitazioni della licenza è necessaria.

Per installare una licenza "ANY":

  1. Gli utenti di SolidNetWork esistenti devono disinstallare SolidNetWork License Manager ed eliminare la cartella di installazione. Per i dettagli, vedere Disinstallazione di SolidNetWork License Manager.
  2. Avviare Gestione installazioni SOLIDWORKS (come descritto in Inizio dell'installazione di SOLIDWORKS).
    1. Come tipo di installazione, selezionare:
      • Prodotti del server
      • Installare SolidNetWork License Manager (licenze distribuite) sul computer.
    2. Nella pagina Opzioni SolidNetWork License Manager, specificare il numero di serie della licenza di SolidNetWork e il percorso di installazione di SolidNetWork License Manager.
    3. Nella pagina Riepilogo, fare clic su Installa ora per completare il processo di installazione di Gestione installazioni SOLIDWORKS.
  3. Avviare SolidNetWork License Manager (Start > Programmi > versione SOLIDWORKS > SolidNetWork License Manager > SolidNetWork License Manager).
  4. Quando un messaggio invita ad attivare, fare clic su No.
    Si apre la scheda Amministrazione del server del SOLIDWORKS SolidNetWork License Manager.
  5. In Opzioni avanzate, fare clic su Opzioni.
    Viene visualizzata la finestra di dialogo Opzioni avanzate.
  6. In Modalità di licenza del server SolidNetWork, fare clic su Usa un file di licenza e fare clic su OK.
    La finestra di dialogo Opzioni avanzate si chiude.
  7. In Informazioni sulla licenza, fare clic su Modifica.
    Compare la Creazione guidata del file di licenza SolidNetWork.
  8. In Tipo di server, selezionare Singolo e fare clic su Avanti.
  9. Se appare questo messaggio:
    Impossibile leggere il numero di ID del dispositivo di sicurezza. Fare clic su Annulla.
    Appare automaticamente l'ID "ANY".
    Se sul computer è attivo un firewall, potrebbe essere necessario selezionare altre opzioni in questa schermata. Per ulteriori informazioni, vedere Uso di licenze SolidNetWork con i firewall.
  10. Continuare con l'installazione.
Argomento principale Amministrazione delle licenze SolidNetWork


Aggiornamento da licenze individuali a licenze SolidNetWork

È possibile aggiornare un computer dalla modalità di licenza SOLIDWORKS individuale alle licenze SolidNetWork specificando il numero seriale della licenza SolidNetWork nella Gestione installazioni SOLIDWORKS.

Se un computer non ha SOLIDWORKS installato, è possibile specificare le licenze SolidNetWork inserendo il numero seriale SolidNetWork quando si esegue l'installazione con la Gestione installazioni SOLIDWORKS.

Se un computer ha già installato SOLIDWORKS e si passa da un tipo di licenza individuale alle licenze SolidNetWork, è possibile modificare l'installazione del computer client e specificare il numero di serie della licenza SolidNetWork al posto di quello della licenza individuale quando si esegue Gestione installazioni SOLIDWORKS. Per i dettagli, vedere Modifica di un'installazione.
Se si è installato SOLIDWORKS da un'immagine amministrativa, l'opzione di modifica non è disponibile. È necessario apportare delle modifiche all'immagine amministrativa mediante l'Editor opzione immagine amministrativa, disinstallare il client ed eseguire nuovamente l'installazione.
Argomento principale Amministrazione delle licenze SolidNetWork
Modifica di un'installazione


Uso delle licenze SolidNetWork con prodotti aggiuntivi

È anche possibile usare SolidNetWork License Manager per distribuire le licenze per i prodotti aggiuntivi principali di SOLIDWORKS.

  • Non è necessario un numero equo di licenze del software SOLIDWORKS e di licenze aggiuntive SOLIDWORKS.
  • Per prelevare una licenza di un prodotto aggiuntivo, l'utente deve prima prelevare una licenza del software SOLIDWORKS.
  • Per prendere in prestito la licenza di un prodotto aggiuntivo, è necessario prendere in prestito sia la licenza del software SOLIDWORKS che la licenza del prodotto SOLIDWORKS che comprende l'aggiunta. Una licenza SOLIDWORKS Standard sarà preso in prestito di default, ma per attivare un'aggiunta, sarà necessario prendere in prestito una licenza SOLIDWORKS Professional o SOLIDWORKS Premium.
  • Per rilasciare la licenza di un prodotto aggiuntivo:
    • In SOLIDWORKS, fare clic su Strumenti > Aggiunte e deselezionare l'aggiunta.
    • Uscire da SOLIDWORKS.
Argomento principale Amministrazione delle licenze SolidNetWork


Selezione di una licenza di SOLIDWORKS Simulation con una licenza SolidNetWork

Gli utenti SolidNetWork License possono controllare quali licenze di SOLIDWORKS® Simulation utilizzare nel proprio gruppo di licenze quando aggiungono SOLIDWORKS Simulation. Inoltre, possono aggiornare la licenza di SOLIDWORKS Simulation senza scaricare l'aggiunta nel caso in cui sia necessario un tipo di licenza superiore per studi più avanzati.

  1. Per utilizzare una licenza specifica di SOLIDWORKS Simulation:
    1. In SOLIDWORKS, fare clic su Strumenti > Aggiunte e nella finestra di dialogo Aggiunta, selezionare SOLIDWORKS Simulation.
    2. In SOLIDWORKS Simulation (CommandManager), fare clic sulla freccia Giù [image] per visualizzare un elenco di licenze sul server che possano supportare Simulation.

    3. Selezionare la licenza SOLIDWORKS Simulation appropriata.
  2. Per controllare o modificare la licenza corrente di SOLIDWORKS Simulation, fare clic sulla freccia Giù [image] in SOLIDWORKS Simulation (CommandManager).

    La licenza in uso visualizza un segno di spunta. Se sono disponibili tipi di licenza più avanzati è possibile eseguire l'aggiornamento.
    Non è possibile eseguire il downgrade di una licenza SOLIDWORKS Simulation. Disattivare l'aggiunta SOLIDWORKS Simulation e aggiungere nuovamente la licenza a un livello inferiore.
  3. Opzionale: Per disattivare l'aggiunta, fare clic su SOLIDWORKS Simulation (CommandManager) o deselezionarla da Strumenti > Aggiunte.
I seguenti casi utilizzano ancora l'ordine di licenza:
  • Quando viene avviata l'esecuzione di SOLIDWORKS Simulation.
  • Se SOLIDWORKS Simulation viene aggiunto in Strumenti > Aggiunte.
  • Se si fa clic su SOLIDWORKS Simulation senza specificare una licenza dall'elenco a discesa.
Argomento principale Amministrazione delle licenze SolidNetWork


Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa

È possibile configurare un computer su una rete in modo che funga da gestore di licenze per distribuire le licenze SolidNetWork e da posizione per l'immagine amministrativa, dalla quale gli utenti possano installare il software SOLIDWORKS.

I computer client possono ottenere le licenze dal gestore di licenze e quindi installare SOLIDWORKS dallo stesso computer.

Per realizzare questa configurazione, il gestore di licenze e l'immagine amministrativa devono essere installati sullo stesso computer. Installare il gestore di licenze per primo e successivamente creare e distribuire l'immagine amministrativa.
Per i dettagli, vedere:
  • Installazione e attivazione di un gestore di licenze
  • Distribuzione su più client
Argomento principale Amministrazione delle licenze SolidNetWork


Gestione delle licenze con FLEXnet Publisher

Le licenze SolidNetWork si basano sulla gestione delle licenze con FLEXnet Publisher®.

Per ulteriori informazioni sulla gestione delle licenze con FLEXnet Publisher, vedere la Guida amministrativa di FLEXnet Publisher nella directory di installazione di SolidNetwork License Manager (\Docs\flexuser\licensingenduserguide.pdf).

Per le informazioni più recenti sulla gestione delle licenze con FLEXnet Publisher, contattare Acresso® Software.

Argomento principale Amministrazione delle licenze SolidNetWork


Diagnostica

Consultare questi argomenti per risolvere i problemi di installazione.

Indice

  • Uso della licenza di rete

  • File di registro della Gestione installazioni SOLIDWORKS

    I file di registro della Gestione installazioni SOLIDWORKS sono disponibili per assistere nella risoluzione dei problemi di installazione.

  • Cartella di download di Gestione installazioni SOLIDWORKS

    Gestione installazioni SOLIDWORKS consente di scaricare i file di installazione necessari in una cartella specificata dall'utente. Questo argomento fornisce le risposte alle domande più frequentemente poste circa la cartella del download.

  • Diagnostica delle licenze SolidNetWork

    Se l'installazione del Gestore di licenze SolidNetWork non va a buon fine, controllare se esiste una soluzione tra queste spiegazioni.

  • Diagnostica aggiornamenti

    Se si riscontrano problemi durante l'aggiornamento a una nuova release di SOLIDWORKS, verificare se esiste una soluzione tra queste spiegazioni.

  • Convalidare scheda grafica quando si installa o si aggiorna

    Una volta terminata l'installazione o l'aggiornamento di SOLIDWORKS sulla macchina, si dovrebbe eseguire SOLIDWORKS Rx per assicurarsi che sulla macchina siano in esecuzione una scheda grafica e un driver della scheda grafica supportati.


Uso della licenza di rete

Questa finestra si apre quando il server non ha più licenze per un prodotto.

Fare clic sulla freccia nella casella Prodotto per visualizzare tutte le opzioni di prodotto. Le opzioni includono SOLIDWORKS e tutte le aggiunte disponibili per l'acquisto.

Numero totale di licenze è il numero totale di licenze acquistate.

Licenze gratuite è il numero di licenze non attualmente in uso.

La casella Licenze usate da offre informazioni su ogni persona che correntemente usa una licenza.

Argomento principale Diagnostica
File di registro della Gestione installazioni SOLIDWORKS
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Diagnostica aggiornamenti
Convalidare scheda grafica quando si installa o si aggiorna


File di registro della Gestione installazioni SOLIDWORKS

I file di registro della Gestione installazioni SOLIDWORKS sono disponibili per assistere nella risoluzione dei problemi di installazione.

Questi file log si trovano nella stessa posizione degli altri file log dell'applicazione di SOLIDWORKS.
  • Per Windows 7 o versione successiva:

    C:\Users\nome utente\AppData\Roaming\SOLIDWORKS\Installation Logs\versione installata

Per visualizzare la directory dei file di registro, potrebbe essere necessario configurare le opzioni della cartella Windows attivando Mostra file e cartelle nascosti.

Se i dati dell'applicazione sono su un'unità diversa da C:, regolare il percorso in maniera corrispondente.

Questa directory contiene il file SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.TXT, un registro generale delle operazioni svolte dalla Gestione installazioni SOLIDWORKS.

La sottodirectory Other Logs contiene registri di installazione con informazioni più dettagliate.

Argomento principale Diagnostica
Uso della licenza di rete
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Diagnostica aggiornamenti
Convalidare scheda grafica quando si installa o si aggiorna


Cartella di download di Gestione installazioni SOLIDWORKS

Gestione installazioni SOLIDWORKS consente di scaricare i file di installazione necessari in una cartella specificata dall'utente. Questo argomento fornisce le risposte alle domande più frequentemente poste circa la cartella del download.

Domanda Risposta
Come installare i file in questa cartella?

Eseguire setup.exe. Potrebbe essere necessario scaricare alcuni file se viene selezionata l'installazione di elementi non ancora scaricati.

Non eseguire l'installazione con msiexec (vedere sotto).
Posso installare i file MSI manualmente da questa cartella usando msiexec o altra applicazione?

No. Gestione installazioni non scarica alcuni dei file richiesti per l'esecuzione di msiexec.
Posso selezionare la stessa cartella del download per ogni versione che installo?

Le cartelle di download riportano il nome della versione. A partire da SOLIDWORKS 2010, Gestione installazioni SOLIDWORKS crea automaticamente nella cartella specificata una sottocartella specifica per la versione.

Ho scaricato alcuni prodotti manualmente dal sito web di Dassault Systèmes SOLIDWORKS Corporation. La Gestione installazioni può installare questi file?
A partire da SW2009, Gestione installazioni SOLIDWORKS è in grado di utilizzare i file scaricati manualmente. Tuttavia, è preferibile eseguire Gestione installazioni SOLIDWORKS scegliendo l'opzione per il download dei file. Gestione installazioni SOLIDWORKS mostra i file necessari in base al componente da installare, fornendo i collegamenti per scaricare i singoli file. Questa opzione può essere usata quando la pagina di download in essa contenuta non funziona (a causa di limitazioni sul download gestite da un server proxy).
Se Microsoft Internet Explorer invita a salvare o eseguire i file durante il download o l'installazione, scegliere sempre Salva.
Posso condividere i file che ho scaricato con altri utenti?

Sì. A tale fine, scaricare in una cartella condivisa in rete. Ogni client potrà quindi eseguire Gestione installazioni SOLIDWORKS dalla cartella condivisa.

Non è necessario scaricare altro a meno che non si scelgano alcuni elementi non selezionati durante il download iniziale oppure se il computer che utilizza questo download per l'installazione ha requisiti diversi da quello utilizzato per il download.

Nel caso si effettui il download per conto di un altro utente ma non l'installazione, selezionare l'opzione Solo download durante l'installazione. Questa opzione consentirà di selezionare i prodotti a prescindere da ciò che è installato sul proprio sistema. Tuttavia, questa opzione non può essere usata per scaricare le patch o per creare le immagini amministrative.
Come posso scoprire quando è disponibile una nuova versione di SOLIDWORKS?
L'utente sarà informato di ciò nei seguenti casi:
  • Se si esegue Verifica aggiornamenti ( Start > Tutti i programmi > Gestione installazioni SOLIDWORKS > Verifica aggiornamenti)
  • Se si è attivato SOLIDWORKS Background Downloader.
  • Se si seleziona una versione installata di SOLIDWORKS in Windows Installazione applicazioni e si fa clic su Cambia
  • Se viene eseguita una versione precedente di Gestione installazioni (sldIM.exe) da una cartella di download
In questi casi, è possibile selezionare di scaricare la versione più recente. Gestione installazioni SOLIDWORKS scarica ed esegue la propria versione più recente, ignorando qualsiasi altro file di installazione. Dopo l'esecuzione della versione più recente di Gestione installazioni SOLIDWORKS, selezionare un gruppo di azioni di installazione. Gestione installazioni SOLIDWORKS determina i file di installazione necessari (ma non scaricati in precedenza) e propone di scaricare tali file.
Gestione installazioni SOLIDWORKS non permette di selezionare un Service Pack diverso da installare.

Ogni versione di Gestione installazioni SOLIDWORKS è progettata per installare solo una versione specifica dei prodotti SOLIDWORKS. Per installare un Service Pack diverso, è necessario eseguire la versione corrispondente di Gestione installazioni SOLIDWORKS. Per trovare la versione più recente disponibile, vedere l'argomento precedente.
Perché Gestione installazioni SOLIDWORKS impedisce di scaricare file?

Se i limiti del server proxy impediscono il download dei file, Gestione installazioni SOLIDWORKS non può scaricare i file automaticamente.

Scaricare i file manualmente e installarli tramite Gestione installazioni SOLIDWORKS. In Gestione installazioni SOLIDWORKS selezionare l'opzione per scaricare i singoli file (ad esempio Esegui download manuale nella pagina Opzioni di download). In base alle selezioni del proprio prodotto e requisiti di sistema, apparirà una pagina web in una finestra separata che contiene i link per scaricare tutti i file necessari manualmente. Questi collegamenti sono identici a quelli forniti dal Portale clienti SOLIDWORKS, ma non è necessario cercare i file.
Non tutti i prodotti SOLIDWORKS installati sono aggiornati al Service Pack più recente. Perché Verifica aggiornamenti afferma che è installata la versione più recente?

Verifica aggiornamenti indica solo se è stata installata (o è in esecuzione) la versione più recente di Gestione installazioni SOLIDWORKS.

Per aggiornare tutti i prodotti alla versione più recente installata, in Installazione applicazioni selezionare la più recente versione di SOLIDWORKS installata e fare clic su Cambia.

Posso copiare un dvd su una cartella del download?

Sì, ma le installazioni possono non riuscire, a meno che non venga copiato l'intero contenuto di ogni DVD rilasciato per la piattaforma in uso. Gestione installazioni SOLIDWORKS cerca i file swdata*.id per determinare la versione. Se questi file non sono presenti, non riconoscerà alcuno dei file di installazione copiati e sarà necessario scaricarli.
Argomento principale Diagnostica
Uso della licenza di rete
File di registro della Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Diagnostica aggiornamenti
Convalidare scheda grafica quando si installa o si aggiorna
Suggerimenti per l'uso di SOLIDWORKS con Microsoft Windows 8


Diagnostica delle licenze SolidNetWork

Se l'installazione del Gestore di licenze SolidNetWork non va a buon fine, controllare se esiste una soluzione tra queste spiegazioni.

Argomento principale Diagnostica
Uso della licenza di rete
File di registro della Gestione installazioni SOLIDWORKS
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica aggiornamenti
Convalidare scheda grafica quando si installa o si aggiorna

Accesso ai file di registro della licenza SolidNetWork

Nel caso di errore relativo alla licenza, la soluzione spesso è indicata nel file directory_installazione_Gestore_SNL\lmgrd.log.

Impossibile ottenere una licenza per SOLIDWORKS. Impossibile connettere al server di licenza.

Solitamente, il problema è causato da impostazioni errate della porta.

  • Le impostazioni della porta tra il gestore di licenza SolidNetWork e il client di licenza potrebbero non corrispondere.
  • Altre impostazioni della porta per versioni multiple dei Gestori di licenze SolidNetWork potrebbero non essere state specificate.
  • Dato il nome del server, verificare che il computer client possa risolvere in modo corretto l'indirizzo e il percorso al server. Dato il nome del computer client, verificare che il server possa risolvere in modo corretto l'indirizzo e il percorso al client.
Per i dettagli sulle impostazioni della porta per i SolidNetWork License Manager e i client, vedere Uso di licenze SolidNetWork con i firewall.
Uso di licenze SolidNetWork con i firewall


Diagnostica aggiornamenti

Se si riscontrano problemi durante l'aggiornamento a una nuova release di SOLIDWORKS, verificare se esiste una soluzione tra queste spiegazioni.

Argomento principale Diagnostica
Uso della licenza di rete
File di registro della Gestione installazioni SOLIDWORKS
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Convalidare scheda grafica quando si installa o si aggiorna

Aggiornamento da un'origine spostata

Quando viene installato SOLIDWORKS, la Gestione installazioni di SOLIDWORKS ricorda l'ubicazione delle fonti d'installazione (media disco, immagine disco su una rete, etc.). Il sistema presuppone che le fonti siano disponibili nello stesso punto al momento dell'aggiornamento.

Se la fonte si sposta o viene cancellata, o se cambia il mezzo della fonte, la Gestione installazioni di SOLIDWORKS genererà un messaggio di errore. Tuttavia, si potrà continuare ad aggiornare navigando ad un'altra ubicazione mantenendo tutti gli stessi file e struttura di cartella.


Convalidare scheda grafica quando si installa o si aggiorna

Una volta terminata l'installazione o l'aggiornamento di SOLIDWORKS sulla macchina, si dovrebbe eseguire SOLIDWORKS Rx per assicurarsi che sulla macchina siano in esecuzione una scheda grafica e un driver della scheda grafica supportati.

Per autenticare una scheda grafica e il driver:

  1. Al termine dell'installazione tramite Gestione installazioni, verrà visualizza la pagina Fine. Sotto Verifica il sistema fare clic su Esegui diagnostica di sistema.

    SOLIDWORKS Rx avvia ed esegue la diagnostica.

  2. SOLIDWORKS Rx conferma se la scheda grafica e il driver sono supportati. Se la scheda grafica è supportata ma non il driver, appare un messaggio di stato che fornisce un link a un driver supportato.

Ogni decimo avvio di SOLIDWORKS, appare un messaggio Verifica il sistema e consiglia nuovamente di eseguire la diagnostica di sistema. Per sospendere queste notifiche, fare clic con il pulsante destro del mouse su SOLIDWORKS Resource Monitor [image] nell'area di notifica di Windows e fare clic su Elimina notifiche grafiche.

È possibile convalidare una scheda grafica e il driver in qualsiasi momento facendo clic con il pulsante destro del mouse su SOLIDWORKS Resource Monitor nell'area di notifica di Windows. Il menu di scelta rapida consente inoltre di:
  • Visualizza la guida di SOLIDWORKS Resource Monitor
  • Eseguire la diagnosi del sistema
  • Elimina notifiche abbonamento
  • Aggiorna driver di grafica
Argomento principale Diagnostica
Uso della licenza di rete
File di registro della Gestione installazioni SOLIDWORKS
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Diagnostica aggiornamenti


Guida dell'applicazione Gestione installazioni di SOLIDWORKS

La Gestione installazioni SOLIDWORKS è un'applicazione standalone che installa e aggiorna i prodotti SOLIDWORKS.

La Gestione installazioni SOLIDWORKS è lo strumento principale per scaricare, installare, modificare, aggiornare, riparare e rimuovere il software SOLIDWORKS.

La Gestione installazioni di SOLIDWORKS può essere eseguita:
  • Da un DVD di SOLIDWORKS o una cartella di origine condivisa o una di download (per l'installazione di una nuova versione)
  • Dal Pannello di controllo Installazione applicazioni (per modificare o rimuovere una versione esistente)
  • Mediante un controllo degli aggiornamenti automatico o manuale (per rilevare, scaricare, installare le nuove versioni)

Ogni versione di SOLIDWORKS ha una versione di Gestione installazioni di SOLIDWORKS specifica per quella versione di SOLIDWORKS.

Indice

  • SOLIDWORKS Background Downloader

    SOLIDWORKS Background Downloader esegue il download dei file automatizzato (ad esempio, quando si trova una nuova versione del Service Pack) usando processi in background, permettendo di proseguire con il lavoro durante il download. Al termine del download, l'utente può decidere se eseguire subito l'installazione, posticipare il download o eliminarlo.

  • Risultati di Verifica aggiornamenti

    Verifica aggiornamenti cerca le versioni successive di SOLIDWORKS.

  • Ubicazione immagine amministrativa

    Specificare la posizione di installazione dell'immagine amministrativa.

  • Opzioni di download

    Specificare i dettagli per completare il download, ad esempio la posizione dei file scaricati, come scaricare i file e se installare i file dopo il download.

  • Opzioni di download per i file di Gestione installazioni SOLIDWORKS

    Si è scelto di scaricare una versione successiva della Gestione installazioni di SOLIDWORKS. Usare questo schermo per specificare dove e come scaricare.

  • Download dei file di installazione del prodotto

    Specificare dove e come scaricare i file mancanti per il prodotto specificato.

  • Avanzamento del download

    La Gestione installazioni di SOLIDWORKS scarica, verifica ed estrae tutti i file in parallelo durante questo processo.

  • Risultati del download

    Indica se il download si è completato correttamente, se non è riuscito o se è stato annullato.

  • Errori di installazione / Installazione annullata

    L'installazione ha riscontrato un errore o è stata annullata.

  • Installazione completata

    La Gestione installazioni di SOLIDWORKS ha completato la procedura.

  • Ubicazione installazione

  • Opzioni di aggiornamento

    Una o più precedenti versioni maggiori di SOLIDWORKS sono installate su questo computer. È possibile creare una nuova installazione, che coesisterà con la versione precedente; in alternativa, è possibile eseguire un aggiornamento che rimuoverà la versione precedente.

  • Avanzamento dell'installazione

    Questo schermo mostra l'avanzamento dell'installazione.

  • Tipo di installazione

    È possibile specificare l'operazione di installazione che si desidera eseguire. Ad esempio, creazione di una nuova installazione, modifica o riparazione di un'installazione esistente, creazione di un'immagine amministrativa, installazione di prodotti del server amministrativo o download di file da condividere e installare su altri computer.

  • Installazione e gestione di computer multipli

    La Gestione installazioni di SOLIDWORKS fornisce i seguenti strumenti per installare e gestire multipli computer SOLIDWORKS.

  • Download manuale

    Si è scelto di scaricare i file manualmente (oppure si sono scaricati manualmente i file all'ultima esecuzione della Gestione installazioni di SOLIDWORKS).

  • Versione più recente disponibile

    La Gestione installazioni ha identificato una versione più recente dei prodotti SOLIDWORKS. Si può scegliere di installare la versione contenuta nel dvd d'installazione originale o nel download oppure scaricare ed installare la versione più recente.

  • Nessuna nuova versione disponibile

    Non ci sono versioni più recenti disponibili per il download. Procedere con l'installazione della versione specifica.

  • Processi rilevati

    La Gestione installazioni di SOLIDWORKS ha rilevato alcuni processi in corso su questo computer che possono impedire la riuscita dell'installazione.

  • Selezione prodotti

    È possibile specificare i componenti del prodotto da installare, modificare, scaricare o rimuovere.

  • Prodotti da scaricare

    Selezionare i prodotti SOLIDWORKS da scaricare in un punto specifico.

  • Prodotti da riparare

    Quando si seleziona Ripara questa installazione, questo schermo visualizzerà i prodotti SOLIDWORKS con i numeri di versione che potranno essere riparati da questa Gestione installazione di SOLIDWORKS.

  • Numeri di seriali

    I numeri seriali, trovati nella casella di distribuzione, associano il proprio computer con i prodotti SOLIDWORKS acquistati.

  • Installazione del server

    I prodotti server che l'utente tenta di installare sono elencati, con i risultati delle installazioni.

  • SolidNetWork License Manager

    Specificare le opzioni di installazione per il prodotto server di SolidNetWork License Manager.

  • Sintesi

    La Gestione installazioni di SOLIDWORKS ha tutte le informazioni necessarie per completare l'installazione.

  • Avvertimenti di controllo sistema

    La Verifica del sistema ha riportato problemi che possono avere conseguenze se si decide di continuare con l'installazione. Nella maggioranza dei casi, si potrà procedere senza problemi con la Gestione installazioni di SOLIDWORKS.

  • Creazione guidata fori/Opzioni Toolbox

    Se è installato SOLIDWORKS Toolbox, SOLIDWORKS include una libreria standard di tipi di foro e minuteria.

  • Disinstalla prodotti

    Quando si seleziona Rimuovi o Disinstalla programmi dal Pannello di controllo, questa schermata visualizzerà i prodotti SOLIDWORKS (con numeri di versione), che saranno disinstallati da questa versione di Gestione installazioni di SOLIDWORKS. Scegliere se effettuare una disinstallazione standard, personalizzata o completa.

Suggerimenti per l'uso di SOLIDWORKS con Microsoft Windows 8


SOLIDWORKS Background Downloader

SOLIDWORKS Background Downloader esegue il download dei file automatizzato (ad esempio, quando si trova una nuova versione del Service Pack) usando processi in background, permettendo di proseguire con il lavoro durante il download. Al termine del download, l'utente può decidere se eseguire subito l'installazione, posticipare il download o eliminarlo.

Background Downloader è attivato per impostazione predefinita quando si installa SOLIDWORKS.

Quando è in esecuzione la Gestione installazioni, per un'operazione di installazione o di download, Background Downloader viene messo in pausa. Per esempio, i download in corso verranno messi in pausa, non viene consentito l'avvio di alcun nuovo download e non verrà consentito di modificare le specifiche della cartella di download.

È possibile disattivare Background Downloader durante l'installazione. Nella pagina Riepilogo, in Opzioni di download, deselezionare l'opzione Usare il background downloader per i futuri Service Pack.

Quando è attivo, l'icona appare nella barra delle applicazioni di Windows:

Facendo clic su questa icona, è possibile eseguire le seguenti operazioni:
  • Assistenza con il Background Downloader
  • Download in pausa
  • Riprendi il download
  • Annulla download
  • Opzioni di installazione
  • Modifica posizione di download
  • Controlla gli aggiornamenti
  • Verifica automatica aggiornamenti
  • Download automatico aggiornamenti
  • Disattiva Background Downloader

Guida di Background Downloader

Aprire questo argomento relativo al Background Downloader nella Guida di installazione di SOLIDWORKS.

Pausa/Riprendi download

Se un download è in esecuzione in background, fare clic su Download in pausa per mettere in pausa il download. È possibile riprenderlo in seguito facendo clic su Riprendi il download.

Annulla download

Se il download è in esecuzione, arrestarlo ed eliminare tutti i file che Background Downloader ha già scaricato.
Non è possibile riprendere un download annullato.

Opzioni di installazione

Al termine del download, è possibile scegliere tra le opzioni seguenti:
  • Installa ora: installa i file scaricati.
  • Ricordami dopo: non installa i file scaricati, ma imposta un messaggio di promemoria per l'utente.
  • Elimina questo download: non installa i file scaricati e li elimina. (Questa funzione è utile se l'utente decide di non voler più installare i file scaricati).

Cambia posizione di download

Cambiare la posizione in cui sono memorizzati i file scaricati da Background Downloader.

Questa opzione non è disponibile mentre il download è in esecuzione o in pausa.

Verifica aggiornamenti

Eseguire la funzione Verifica aggiornamenti della Gestione installazioni di SOLIDWORKS.

Verifica automatica degli aggiornamenti

Eseguire periodicamente la Verifica aggiornamenti, informando l'utente quando sono disponibili aggiornamenti da scaricare.

Download automatico degli aggiornamenti

Eseguire periodicamente la Verifica aggiornamenti, scaricando gli aggiornamenti appena sono disponibili.

Disattivazione e riattivazione del Background Downloader di SOLIDWORKS

È possibile disattivare il Background Downloader facendo clic sull'icona e selezionando Disattiva Background Downloader.

Per riattivare il Background Downloader, fare clic su Start > Tutti i programmi > Gestione installazioni SOLIDWORKS > SOLIDWORKS Background Downloader.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Risultati di Verifica aggiornamenti

Verifica aggiornamenti cerca le versioni successive di SOLIDWORKS.

Se si hanno privilegi di amministratore sul computer, è possibile eseguire il comando Verifica aggiornamenti manualmente:
  • In Windows, fare clic su Start > Tutti i programmi > SOLIDWORKS Installation Manager > Verifica aggiornamenti
  • In SOLIDWORKS, fare clic su ? > Verifica aggiornamenti.
Verifica aggiornamenti non è disponibile su client installati da immagini amministrative.

Versione più recente disponibile

La Gestione installazioni di SOLIDWORKS ha identificato una versione più recente dei prodotti SOLIDWORKS. Si potrà aggiornare ad una versione più recente selezionando la Gestione installazioni di SOLIDWORKS per quella versione.

Questa versione più recente può scaricare i file di installazione in base ai prodotti specificati nell'installazione. Inoltre, sarà possibile condividere i file scaricati con altri utenti che installano usando la Gestione installazioni di SOLIDWORKS.

Questi download sono solo per uso con la Gestione installazioni di SOLIDWORKS.
Queste opzioni sono disponibili:
  • nel caso di multiple versioni disponibili, è possibile selezionare una versione dall'elenco.
  • Per informazioni dettagliate su questa versione, fare clic su Controlla cosa è compreso in questo aggiornamento.
Fare clic su Avanti per ottenere ed eseguire la versione selezionata della Gestione installazioni di SOLIDWORKS.

Nessun nuovo download disponibile/Impossibile verificare nuove versioni

La Gestione installazioni di SOLIDWORKS non ha trovato una versione più recente dei prodotti SOLIDWORKS, probabilmente perché si sta installando la versione più recente disponibile o perché non è collegata al sito SOLIDWORKS da verificare.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Ubicazione immagine amministrativa

Specificare la posizione di installazione dell'immagine amministrativa.

Quando si crea un'immagine amministrativa, valgono queste opzioni:
Nuova ubicazione immagine | La directory nella quale la Gestione installazioni SOLIDWORKS creerà la nuova immagine. | Questa posizione non può contenere un'immagine amministrativa esistente. L'immagine amministrativa deve trovarsi in una cartella condivisa perché sia possibile applicarla ai client.
Spazio stimato necessario per la creazione dell'immagine | Spazio aggiuntivo necessario per l'immagine amministrativa. | Verificare che il disco di installazione abbia una quantità di spazio disponibile sufficiente in base ai requisiti dell'immagine.
Crea immagine da | La directory dalla quale si installano i prodotti SOLIDWORKS. Questa opzione è disponibile solo se si è selezionata l'opzione Solo installazione. Per i dettagli, vedere Opzioni di download.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Opzioni di download

Specificare i dettagli per completare il download, ad esempio la posizione dei file scaricati, come scaricare i file e se installare i file dopo il download.

La Gestione installazioni di SOLIDWORKS supporta la distribuzione del software elettronico (ESD). Se non s'intende installare da un dvd SOLIDWORKS, si dovrà specificare la fonte dei prodotti SOLIDWORKS in via di installazione.

Per le risposte alle domande relative alla cartella del download, vedere Cartella di download di Gestione installazioni SOLIDWORKS.

Che cosa si intende fare?

Scegliere una delle seguenti opzioni:

Download e installa/Download e crea immagini

Al termine del download, Gestione installazioni SOLIDWORKS esegue un'installazione dei file scaricati.

Solo download. È possibile scaricare i file una sola volta e poi condividerli su più computer.

Gestione installazioni SOLIDWORKS non esegue un'installazione al termine del download.

Di solito, si specifica questa opzione se si scaricano i file per configurare una serie di file da condividere su più computer.

Se si sceglie questa opzione, un messaggio invita a selezionare uno tra due gruppi di file per il download:
  • File per QUESTO computer: il download conterrà solo i file mancanti nel gruppo dei file di installazione attualmente presente su questo computer.
    Il download dovrebbe avere dimensioni minori perché contiene:
    • Solo i file dei prodotti selezionati nella pagina Selezione prodotti
    • Solo i file di prerequisito necessari al computer e non ancora installati

    Tuttavia se per l'installazione si tenta di utilizzare questo gruppo di file scaricati su un altro computer, alcuni file potrebbero mancare perché i file di installazione per un computer non sono sempre identici a quelli per un altro computer. Si possono utilizzare i file scaricati per l'installazione su un altro computer ma mentre la procedura è in corso potrebbe essere necessario scaricare altri file per completare la serie di file di installazione su tale computer.

  • File da condividere con QUALSIASI computer: il download conterrà il gruppo completo dei file di installazione, da utilizzare per installare questa versione su qualsiasi computer.

    Questo download avrà grandi dimensioni perché contiene tutti i file da usare per installare questa versione di un prodotto su un computer qualsiasi.

    Se si specifica un gruppo limitato di prodotti da installare, questa opzione ignora tale specifica e scarica tutti i prodotti contenuti nella release.

    Il download conterrà tutti i file necessari per creare un'immagine amministrativa, non solo quelli per eseguire un'installazione individuale.

Installa solo/Crea solo immagine. Possiedo già tutti i file di installazione necessari.

Gestione installazioni SOLIDWORKS non scarica i file ma utilizza quelli presenti nella directory selezionata.

Fare clic su Sfoglia per selezionare una posizione diversa. Ad esempio, è possibile navigare al DVD di installazione o ad una cartella di download, a patto che tale posizione contenga tutti i file necessari.

Nel caso di messaggio di errore circa la cartella non completa mentre si presumevano tutti i file di installazione presenti in quel punto, i potenziali motivi sono:
  • è stato selezionato un componente per l'installazione non scaricato precedentemente o è stato selezionato di default.
  • I file sono stati scaricati su un altro computer con un gruppo diverso di requisiti di sistema.
  • L'utente ha effettuato un'installazione client e ora sta creando un'immagine amministrativa che richiede un gruppo di file più ampio.

È possibile navigare a una cartella contenente tutti i file (ad es. il DVD) oppure selezionare una delle opzioni di download.

Dove si desidera scaricare i file necessari?

La posizione della cartella di download.

In alcuni casi, questa opzione potrebbe essere visibile ma ombreggiata e quindi non selezionabile. Ad esempio, se è selezionato Solo installazione, Gestione installazioni SOLIDWORKS installerà tutti i file scaricati dalla directory specificata nell'opzione, e non utilizzerà una directory di download distinta.

Tutti i file devono essere scaricati nella stessa cartella del download, sia che siano stati scaricati o prelevati da una propria ubicazione.

Dimensione stimata del download

I tempi stimati del download e i requisiti di spazio su disco si basano sull'elenco completo dei componenti scelti, a prescindere che si tratti di un download nuovo o di uno esistente ripreso da una sessione precedente.

Ad esempio, se si riprende un download precedente la Gestione installazioni di SOLIDWORKS elaborerà solo quei file che non sono stati ancora scaricati. I tempi del download potranno essere minori di quelli calcolati.

Se un file è stato scaricato nel download precedente, la sua dimensione non è inclusa nella stima. La stima potrebbe dunque essere superiore alla dimensione effettiva del download.

Come si desidera effettuare il download?

e può essere eseguito in due modi:

Eseguire il download manuale

In alcuni casi, un server proxy potrebbe impedire i download automatici dalla Gestione installazioni di SOLIDWORKS.

Selezionando questa opzione, è possibile scaricare manualmente i file attraverso una pagina Web, quindi completare l'installazione con la Gestione installazioni di SOLIDWORKS. Questa pagina Web è personalizzata dalla Gestione installazioni di SOLIDWORKS al fine di scaricare solamente i file necessari per completare l'installazione.

Velocizza i download usando una maggiore banda di rete

Il downloader utilizza un algoritmo per incrementare la velocità del download aumentando la banda di rete usata durante il download.

In alcuni casi, ciò può disturbare la prestazione di rete. Nel caso di difficoltà durante il download, questa opzione potrà non essere supportata dal server proxy. Provare ad azzerare l'opzione e tentare nuovamente il download. Per i dettagli, contattare il proprio amministratore di rete.

Questa opzione vale solo per i download automatici e non ha conseguenze sui download manuali.

Uso di SOLIDWORKS Background Downloader

SOLIDWORKS Background Downloader può essere usato per completare questa operazione di download o per scaricare le future release dei Service Pack di SOLIDWORKS appena diventano disponibili.

Solidworks Background Downloader può identificare automaticamente e scaricare nuovi aggiornamenti service pack nel background, notificando quando il download è completato e i file sono pronti per l'installazione. Per i dettagli, vedere SOLIDWORKS Background Downloader.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Opzioni di download per i file di Gestione installazioni SOLIDWORKS

Si è scelto di scaricare una versione successiva della Gestione installazioni di SOLIDWORKS. Usare questo schermo per specificare dove e come scaricare.

Per le risposte alle domande relative alla cartella del download, vedere Cartella di download di Gestione installazioni SOLIDWORKS.

Questa schermata compare solo se si è verificato un problema con la cartella di download di default (es. se manca il diritto di scrittura o l'accesso di rete). Di solito, è sufficiente specificare una directory di download alternativa per continuare.

Directory del download

Navigare alla destinazione per i file della Gestione installazioni di SOLIDWORKS.

Sono visualizzate la dimensione del download e la quantità di spazio necessaria. La quantità di spazio necessario comprende lo spazio extra per estrarre certi download e sarà maggiore della dimensione del download attuale.

Usare l'accelerazione del download

Se si sceglie questa opzione, il download utilizzerà un algoritmo per incrementare la velocità del download.

L'accelerazione del download aumenta la larghezza di banda e potrà disturbare la prestazione di rete. Controllare con il proprio amministratore di rete prima di attivare l'accelerazione del download.

Se l'accelerazione del download non è supportata dal server proxy, questa opzione sarà automaticamente disattivata.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Download dei file di installazione del prodotto

Specificare dove e come scaricare i file mancanti per il prodotto specificato.

La Gestione installazioni di SOLIDWORKS scarica, verifica ed estrae tutti i file in parallelo durante il processo di download.

Uscendo da questa schermata verrà annullato il resto della sequenza di installazione.

Per le conseguenze dell'annullamento e le istruzioni su come completare le installazioni interrotte, vedere Errori di installazione.

Directory del download

Navigare alla destinazione per i file scaricati.

Sono indicati la dimensione del download e lo spazio necessario. La quantità di spazio necessario comprende lo spazio per estrarre certi download e sarà maggiore della dimensione del download attuale.

Per le risposte alle domande relative alla cartella del download, vedere Cartella di download di Gestione installazioni SOLIDWORKS.

Opzioni di download

Velocizza i download usando una maggiore banda di rete

Il downloader utilizza un algoritmo per incrementare la velocità del download aumentando la banda di rete usata durante il download.

In alcuni casi, ciò può disturbare la prestazione di rete. Nel caso di difficoltà durante il download, questa opzione potrà non essere supportata dal server proxy. Provare ad azzerare l'opzione e tentare nuovamente il download. Per i dettagli, contattare il proprio amministratore di rete.
L'accelerazione del download aumenta la larghezza di banda e potrà disturbare la prestazione di rete. Controllare con il proprio amministratore di rete prima di attivare l'accelerazione del download.

Se l'accelerazione del download non è supportata dal server proxy, questa opzione potrebbe essere disattivata automaticamente.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Errori di installazione / Installazione annullata
Cartella di download di Gestione installazioni SOLIDWORKS


Avanzamento del download

La Gestione installazioni di SOLIDWORKS scarica, verifica ed estrae tutti i file in parallelo durante questo processo.

Per annullare il download dopo l'avvio, fare clic su Annulla.

Se si annulla il download o se questo non riesce, uno schermo Download annullato o Problema di download indicherà quali download non sono stati completati e consentirà di riprendere la procedura o di chiudere l'applicazione.

Per le risposte alle domande relative alla cartella del download, vedere Cartella di download di Gestione installazioni SOLIDWORKS.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Risultati del download

Indica se il download si è completato correttamente, se non è riuscito o se è stato annullato.

Problema di download/Download annullato

Se appare il messaggio Problema di download, la Gestione installazioni di SOLIDWORKS ha riscontrato problemi che hanno impedito il buon esito del download.

Se appare il messaggio Download annullato, l'utente ha annullato il download prima che fosse completato.

Per continuare:

Riprova/Riprendi download automatici | Per riprendere un download automatico dal punto in cui è stato annullato, selezionare questa opzione e fare clic su Riprova download o Riprendi download.
Scarica i file singolarmente in un browser web | In alcuni casi, un server proxy potrebbe impedire i download automatici dalla Gestione installazioni di SOLIDWORKS. | Selezionando questa opzione, è possibile scaricare manualmente i file attraverso una pagina Web, quindi completare l'installazione con la Gestione installazioni di SOLIDWORKS. Questa pagina Web è personalizzata dalla Gestione installazioni di SOLIDWORKS al fine di scaricare solamente i file necessari per completare l'installazione.

Download completo

La schermata Download completato appare quando termina il download se si è specificata l'opzione Solo download.

Fare clic su Fine per chiudere la Gestione installazioni di SOLIDWORKS.

Non tentare di installare uno di questi prodotti manualmente. Utilizzare sempre la Gestione installazioni di SOLIDWORKS per installare i file scaricati.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Errori di installazione / Installazione annullata

L'installazione ha riscontrato un errore o è stata annullata.

Se si verifica un errore o un annullamento:
  • i prodotti installati prima dell'errore o annullamento rimarranno nel computer.
  • Il prodotto in via di installazione al momento dell'annullamento viene riportato allo stato precedente, in modo che non ci siano installazioni parziali.
  • I prodotti restanti non sono installati o sono stati disinstallati. L'elenco è fornito in Non ancora tentato.

    Per riprendere l'installazione o la disinstallazione di questi prodotti, fare clic sui link forniti.

La Gestione installazioni di SOLIDWORKS prima installa qualsiasi prerequisito non installato nel computer, come ad esempio .NET Framework.

Indice

  • Ripristino da un'installazione non riuscita o annullata

    Se si verifica un errore o un'interruzione durante l'installazione, è possibile recuperarla da quel punto rieseguendo l'installazione.

  • Riparazione di un'installazione

    In caso di problemi con un prodotto SOLIDWORKS installato, usare Gestione installazioni SOLIDWORKS per ripristinare l'installazione.

  • Come contattare il rivenditore SOLIDWORKS

    Se la modifica o riparazione dell'installazione non riesce, contattare il proprio rivenditore SOLIDWORKS con le informazioni raccolte da questo schermo. Potrebbe essere richiesto di fornire un file zip dei file log della Gestione installazioni di SOLIDWORKS.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Ripristino da un'installazione non riuscita o annullata

Se si verifica un errore o un'interruzione durante l'installazione, è possibile recuperarla da quel punto rieseguendo l'installazione.

  1. Registrare il messaggio di errore e il codice del prodotto per l'installazione non riuscita, come mostrato nella schermata Errori di installazione o Installazione annullata.
    Se il software richiede un file di origine e non si sta modificando un'installazione SOLIDWORKS esistente, l'installazione o il computer potrebbero essere danneggiati. Rivolgersi al proprio rivenditore SOLIDWORKS.
  2. Riavviare il proprio computer.
  3. Per verificare che nessun prodotto SOLIDWORKS sia in esecuzione, in Windows premere i tasti Ctr+Alt+Canc per aprire il Task Manager.
  4. Nella scheda Processi, se uno qualsiasi dei seguenti processi appare in Nome immagine, selezionarlo e fare clic su Fine processo.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Se l'applicazione è già installata e si tenta di modificare o rimuoverla, provare a riparare l'installazione. Per i dettagli, vedere Riparazione di un'installazione.
  6. In Windows 7 o versione successiva, fare clic su Start > Pannello di controllo > Programmi e funzionalità.
  7. Selezionare la versione di SOLIDWORKS che non è riuscita.
    Se non esiste una voce corrispondente alla versione di SOLIDWORKS in via di installazione, ripetere la procedura di installazione.
  8. Procedere in uno dei modi seguenti:
    • Per riprovare, fare clic su Cambia e selezionare tutti i prodotti la cui installazione non è riuscita o è stata ignorata.

    • Per ignorare le installazioni non riuscite, fare clic su Cambia e selezionare tutti i prodotti la cui installazione è stata ignorata. Deselezionare il prodotto con installazione non riuscita.

    • Per abbandonare l'installazione, fare clic su Rimuovi e selezionare qualsiasi prodotto già installato.
    Ciò non ripristinerà la versione precedente di qualsiasi prodotto in via di aggiornamento.
Argomento principale Errori di installazione / Installazione annullata
Riparazione di un'installazione
Come contattare il rivenditore SOLIDWORKS


Come contattare il rivenditore SOLIDWORKS

Se la modifica o riparazione dell'installazione non riesce, contattare il proprio rivenditore SOLIDWORKS con le informazioni raccolte da questo schermo. Potrebbe essere richiesto di fornire un file zip dei file log della Gestione installazioni di SOLIDWORKS.

  1. Identificare i file di registro:
    • Per Windows 7 o versione successiva:

      C:\Users\nome utente\AppData\Roaming\SOLIDWORKS\Installation Logs\versione installata\

    Se non si trova la cartella, potrebbe essere nascosta. In Esplora risorse, fare clic su Strumenti > Opzioni di cartella. Nella scheda Visualizza, in Impostazioni avanzate, selezionare Mostra file e cartelle nascosti per File e cartelle nascosti.
  2. Comprimere l'intero contenuto di questa cartella, comprese le sottocartelle.
Argomento principale Errori di installazione / Installazione annullata
Ripristino da un'installazione non riuscita o annullata
Riparazione di un'installazione


Installazione completata

La Gestione installazioni di SOLIDWORKS ha completato la procedura.

Potrebbero visualizzarsi una o più di queste opzioni.

Novità

Per le installazioni individuali, alla fine del processo di installazione, apparirà un documento che descriverà la nuova funzionalità in SOLIDWORKS e i relativi prodotti aggiuntivi.

Per le installazioni dall'immagine amministrativa, il documento apparirà sui computer client al completamento dell'installazione.

Sondaggio

Inviate le vostre opinioni relative al processo di installazione rispondendo ad un breve sondaggio.

Partecipa al programma di miglioramento dell'esperienza clienti di SOLIDWORKS

Le informazioni di prestazione vengono inviate alla SOLIDWORKS Corporation per migliorare il prodotto. Il processo è trasparente e confidenziale. Selezionare una delle seguenti opzioni:
  • Sì, voglio unirmi
  • No, grazie
  • Sollecitami nuovamente in futuro
Per ulteriori informazioni, consultare Sito web del Customer Experience Improvement Program.

La creazione dell'immagine amministrativa è completata

Ultimata la creazione dell'immagine amministrativa, è possibile fare clic su Personalizza immagine per eseguire l'Editor opzioni dell'immagine amministrativa.

Fare clic su Dimostra come installare questa immagine su un client per visualizzare le istruzioni sull'uso dell'Editor opzioni.

Per i dettagli sulla configurazione di un'immagine amministrativa con l'Editor delle opzioni, vedere Editor opzioni immagine amministrativa.

Fare clic su Personalizza immagine per avviare l'Editor opzioni dell'immagine amministrativa e personalizzare le impostazioni di questa immagine amministrativa.
È possibile avviare l'Editor opzioni successivamente facendo doppio clic su sldAdminOptionEditor.exe nella directory di installazione dell'immagine amministrativa.

Indice

  • Verifica degli aggiornamenti per SOLIDWORKS

    Se si dispone dei privilegi di amministratore, è possibile utilizzare Gestione installazioni di SOLIDWORKS per verificare manualmente la disponibilità di aggiornamenti o per configurare automaticamente il controllo degli aggiornamenti.

  • Programma di miglioramento dell'esperienza clienti SOLIDWORKS

    Quando si installa SOLIDWORKS, si può specificare che le informazioni sulle prestazioni vengano inviate a SOLIDWORKS Corporation per migliorare il prodotto.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Editor opzioni immagine amministrativa


Verifica degli aggiornamenti per SOLIDWORKS

Se si dispone dei privilegi di amministratore, è possibile utilizzare Gestione installazioni di SOLIDWORKS per verificare manualmente la disponibilità di aggiornamenti o per configurare automaticamente il controllo degli aggiornamenti.

  1. Avviare la Gestione installazioni di SOLIDWORKS effettuando una delle seguenti operazioni:

    • Nell'applicazione SOLIDWORKS, fare clic su ? > Verifica aggiornamenti.

    • In Windows, fare clic su Start > Programmi > Gestione installazioni di SOLIDWORKS > Verifica aggiornamenti.

    La Gestione installazioni di SOLIDWORKS indica se sono disponibili nuovi aggiornamenti.
  2. Se sono disponibili, scegliere se scaricarli ed installarli.
  3. Per abilitare il controllo periodico e automatico degli aggiornamenti, al termine della Gestione installazioni di SOLIDWORKS selezionare Verifica aggiornamenti ogni __ giorni e specificare la frequenza dei controlli.
Argomento principale Installazione completata
Programma di miglioramento dell'esperienza clienti SOLIDWORKS


Programma di miglioramento dell'esperienza clienti SOLIDWORKS

Quando si installa SOLIDWORKS, si può specificare che le informazioni sulle prestazioni vengano inviate a SOLIDWORKS Corporation per migliorare il prodotto.

SOLIDWORKS utilizza questi dati per determinare le abitudini relative all'uso del prodotto e alla qualità. Il nostro obiettivo è quello di fornire la massima qualità nel prodotto e i log della prestazione vengono appunto utilizzati in questo processo.

Il processo è trasparente. Tutte le informazioni contenute nei file di registro sono riservate. Non vengono utilizzate per altri scopi e l'utente non sarà contattato.

Per ulteriori informazioni, vedere il sito Web del Programma di miglioramento dell'esperienza clienti.

Argomento principale Installazione completata
Verifica degli aggiornamenti per SOLIDWORKS


Ubicazione installazione

Per tutte installazioni tranne la creazione di un'immagine amministrativa, valgono queste opzioni:
Installa i prodotti selezionati in | La directory nella quale si installa SOLIDWORKS. Quando si aggiorna o di modifica un'installazione, tutti i file devono essere installati nella posizione esistente di tale installazione. In questo caso, non è possibile cambiare al posizione dell'installazione esistente di SOLIDWORKS.
Spazio stimato necessario per l'installazione | Si tratta di spazio aggiuntivo necessario per i prodotti selezionati per l'installazione o la modifica. | Verificare che il disco di installazione abbia una quantità di spazio disponibile sufficiente in base ai requisiti di installazione.
Installa da | La directory dalla quale si installa SOLIDWORKS. Questa opzione è disponibile solo se si è selezionata l'opzione Solo installazione. Per i dettagli, vedere le Opzioni di download.
Rivolgersi all'amministratore del sistema prima di cambiare la posizione di installazione di SOLIDWORKS.

Ubicazioni immagine amministrativa

Quando si crea un'immagine amministrativa, valgono queste opzioni:
Nuova ubicazione immagine | La directory nella quale la Gestione installazioni SOLIDWORKS creerà la nuova immagine. | Questa posizione non può contenere un'immagine amministrativa esistente.
Spazio stimato necessario per la creazione dell'immagine | Spazio aggiuntivo necessario per l'immagine amministrativa. | Verificare che il disco di installazione abbia una quantità di spazio disponibile sufficiente in base ai requisiti dell'immagine.
Crea immagine da | La directory dalla quale si installano i prodotti SOLIDWORKS. Questa opzione è disponibile solo se si è selezionata l'opzione Solo installazione. Per i dettagli, vedere le Opzioni di download.
Ubicazione immagine esistente | Quando si aggiorna un'immagine amministrativa esistente, Gestione installazioni SOLIDWORKS crea una nuova immagine in base alle impostazioni dell'immagine esistente. Questa immagine esistente non viene modificata. Indica la posizione dell'immagine originale specificata nella schermata Benvenuti.

Evitare l'uso di percorsi di directory specifici per la versione

Se si specifica un numero di versione in una directory di installazione (ad es. C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2019\) e successivamente si aggiorna tale installazione a SOLIDWORKS 2020, si avrà una directory di installazione di SOLIDWORKS 2020 denominata SOLIDWORKS 2019.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Opzioni di download


Opzioni di aggiornamento

Una o più precedenti versioni maggiori di SOLIDWORKS sono installate su questo computer. È possibile creare una nuova installazione, che coesisterà con la versione precedente; in alternativa, è possibile eseguire un aggiornamento che rimuoverà la versione precedente.

Creazione di una nuova installazione di SOLIDWORKS versione.

Se si sceglie di creare una nuova installazione, è possibile selezionare il prodotto SOLIDWORKS da installare.

Per ciascuno dei prodotti selezionati, viene creata una nuova installazione di questa versione principale. Le precedenti versioni principali restano sul computer, a eccezione di SOLIDWORKS Electrical e SOLIDWORKS PDM Client.

Se si deseleziona un prodotto, la nuova versione non viene installata.

La creazione di una nuova versione può essere utile per accedere alla versione precedente di SOLIDWORKS dopo aver installato una versione più recente. Ad esempio, se si condividono i file con altri utenti che ancora utilizzano la versione precedente, utilizzare la versione più recente per evitare incompatibilità di file tra le versioni.

Aggiornamento di SOLIDWORKS versione_principale_precedente a SOLIDWORKS 2020 versione_principale_corrente.

Se si sceglie di eseguire l'aggiornamento, è possibile selezionare il prodotto SOLIDWORKS da aggiornare. Per ciascuno dei prodotti selezionati viene creata una nuova installazione e vengono rimosse le versioni precedenti.

Se si deseleziona un prodotto, la nuova versione non viene installata e la versione precedente rimane sul computer.

Note relative a SOLIDWORKS Electrical e SOLIDWORKS PDM Client

È possibile installare una sola versione di SOLIDWORKS Electrical su un computer. Se si sta creando una nuova installazione di SOLIDWORKS e si seleziona SOLIDWORKS Electrical tra i prodotti da installare, la versione precedente di SOLIDWORKS Electrical viene rimossa.

Eseguire il backup dell'ambiente SOLIDWORKS Electrical esistente prima di installare la nuova versione. In Schemi di SOLIDWORKS Electrical selezionare File Archivia ambiente, oppure in SOLIDWORKS Electrical 3D selezionare SOLIDWORKS Electrical > Strumenti > Archivia ambiente.

La versione principale del client SOLIDWORKS PDM deve corrispondere alla versione principale del server SOLIDWORKS PDM. Se non si intende aggiornare SOLIDWORKS PDM Server, deselezionare l'aggiornamento di SOLIDWORKS PDM.

Per rimuovere un componente di prodotto, in Windows, utilizzare Installazione applicazioni. Per i dettagli, vedere Rimozione di un'installazione.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Rimozione di un'installazione


Avanzamento dell'installazione

Questo schermo mostra l'avanzamento dell'installazione.

Per annullare l'installazione dopo l'avvio, fare clic su Annulla.

Per le conseguenze dell'annullamento e le istruzioni su come completare le installazioni interrotte, vedere Errori di installazione.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Tipo di installazione

È possibile specificare l'operazione di installazione che si desidera eseguire. Ad esempio, creazione di una nuova installazione, modifica o riparazione di un'installazione esistente, creazione di un'immagine amministrativa, installazione di prodotti del server amministrativo o download di file da condividere e installare su altri computer.

Se la versione più recente del software SOLIDWORKS è già installata sul computer, sono disponibili le opzioni per modificarla o ripararla.

Individuale

Installare i prodotti SOLIDWORKS su questo computer.

Questa opzione compare solo se la versione non è installata sul computer.

Modifica l'installazione individuale

Modificare l'installazione esistente di SOLIDWORKS su questo computer.

Questa opzione compare solo se la versione è installata sul computer.
Le modifiche comprendono:
  • Aggiunta o rimozione di componenti del prodotto SOLIDWORKS
  • Passaggio a un altro pacchetto SOLIDWORKS (ad esempio SOLIDWORKS Professional, SOLIDWORKS Premium e così via)
  • Modifica del numero seriale di SOLIDWORKS
    Se si è già specificato un numero seriale di SOLIDWORKS durante un'installazione precedente, la Gestione installazioni di SOLIDWORKS potrebbe non visualizzare di nuovo la richiesta. Per modificare il numero di serie, è necessario selezionare questa opzione.

Correggi l'installazione individuale

Ripristinare l'installazione esistente di SOLIDWORKS su questo computer.

Questa opzione compare solo se la versione è installata sul computer.
La riparazione verifica che tutti i file siano presenti e registrati e le risoluzioni siano definitive. I dati creati non sono impattati.
  • Per rimuovere un prodotto, assicurarsi che sia selezionato.
  • Deselezionare le caselle per i prodotti che non devono essere riparati.
Un'installazione individuale può essere riparata. Non è possibile riparare un'installazione con immagine amministrativa, ma è necessario reinstallarla.

Immagine amministrativa

Creare o aggiornare un'immagine amministrativa da distribuire su più computer.

Per i dettagli sull'installazione di SOLIDWORKS su più client con l'uso delle immagini amministrative, vedere Uso di immagini amministrative.

Quando si crea o aggiorna un'immagine amministrativa:
  • È possibile utilizzare le impostazioni di installazione di un'immagine esistente per configurare l'immagine nuova o aggiornata oppure utilizzare le impostazioni di installazione di default di SOLIDWORKS.
  • Se si aggiorna un'immagine esistente:
    • Gestione installazioni SOLIDWORKS crea una nuova copia dell'immagine, anche se si effettua un aggiornamento. L'immagine originale non viene modificata.
    • È possibile creare l'immagine aggiornata utilizzando i file dell'immagine esistente in fase di aggiornamento. Il download risultante è pertanto minore.
    Se non si specifica un'immagine per cui sia disponibile una release Service Pack per l'aggiornamento dell'immagine precedente, non è possibile utilizzare il download di dimensione più piccola.

Prodotti del server

I prodotti del server SOLIDWORKS comprendono SOLIDWORKS Electrical, SOLIDWORKS PDM e SolidNetWork License Manager.

Per SOLIDWORKS Electrical e SOLIDWORKS PDM, è possibile scegliere di installare gli strumenti client e server sullo stesso PC o su PC diversi.

Per i dettagli sull'installazione di questi server, vedere gli argomenti corrispondenti nella Guida in linea.

Scarica e condividi tutti i file

Scaricare i file di installazione per i prodotti SOLIDWORKS selezionati senza installare i prodotti.

Questa opzione non è disponibile se si utilizza un DVD per l'installazione.
Il contenuto dei file scaricati è identico ai file disponibili sui DVD di installazione di SOLIDWORKS. Selezionare questa opzione per scaricare il gruppo completo dei file d'installazione, a prescindere da quali file possano già essere installati sul computer. È quindi possibile copiare i file su un dispositivo portatile o in una directory di rete e utilizzarli per installare il software SOLIDWORKS su altri computer. È anche possibile utilizzare questo metodo per impostare un server dal quale gli utenti potranno eseguire le installazioni.
Questo metodo è diverso dalla creazione di un'immagine amministrativa.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Uso di immagini amministrative
SOLIDWORKS PDM
Amministrazione delle licenze mediante SolidNetWork License Manager
SOLIDWORKS Electrical


Installazione e gestione di computer multipli

La Gestione installazioni di SOLIDWORKS fornisce i seguenti strumenti per installare e gestire multipli computer SOLIDWORKS.

Immagini amministrative di SOLIDWORKS

Se si installa SOLIDWORKS su multipli computer, sarà possibile creare un'immagine amministrativa e quindi implementare l'applicazione su altri computer.

SOLIDWORKS PDM

SOLIDWORKS PDM è un prodotto per la gestione dei documenti basato sulla stessa architettura client/server di SOLIDWORKS Enterprise PDM. È disponibile in due versioni: Standard e Professional. SOLIDWORKS PDM utilizza un database Microsoft SQL Server per gestire i vault.

SolidNetWork License Manager

SolidNetWork License Manager consente al numero di utenti di eccedere il numero di licenze rendendo mobile l'uso delle licenze. Quando la licenza di un client non è in uso, è disponibile per un altro utente SOLIDWORKS.

È anche possibile usare SolidNetWork License Manager per distribuire le licenze per i prodotti aggiuntivi principali di SOLIDWORKS come ad esempio FeatureWorks.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Download manuale

Si è scelto di scaricare i file manualmente (oppure si sono scaricati manualmente i file all'ultima esecuzione della Gestione installazioni di SOLIDWORKS).

Fare clic sul link per aprire una pagina web generata automaticamente con un elenco completo dei file necessari per il download.

È necessario scaricarli nella cartella indicata nella pagina di riepilogo. L'installazione non può iniziare se non sono stati scaricati tutti i file nella cartella.

Una volta completati i download manuali, fare clic su Avanti per continuare.

Per scaricarli manualmente, è possibile modificare l'opzione tornano alla pagina di riepilogo e modificando le opzioni di download.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Versione più recente disponibile

La Gestione installazioni ha identificato una versione più recente dei prodotti SOLIDWORKS. Si può scegliere di installare la versione contenuta nel dvd d'installazione originale o nel download oppure scaricare ed installare la versione più recente.

Se si installa da un download

Scegliere una delle seguenti opzioni:
  • Continuare a installare versione.

    Selezionare questa opzione per continuare ad installare la versione contenuta nel download iniziale.

  • Scaricare e installare una nuova versione: versione.

    Selezionare questa opzione per scaricare e installare la nuova versione. Nel caso di versioni multiple disponibili, selezionare la versione da scaricare ed installare.

Se si installa da un DVD

In Utilizzare la versione più recente?, selezionare una delle risposte seguenti:
  • No, continuare a installare versione da questo DVD. L'aggiornamento può avvenire successivamente.

    Selezionare questa opzione per continuare l'installazione utilizzando la Gestione installazioni corrente.

    Al completamento dell'installazione, sarà possibile selezionare ed installare gli aggiornamenti usando la Gestione installazioni. Per controllare gli aggiornamenti, selezionare Start > Gestione installazioni di SOLIDWORKS > Verifica aggiornamenti.
    Il comando Verifica aggiornamenti è disponibile solo se si dispone di privilegi di amministratore per il computer.

    Il vantaggio è che questo genera un download più piccolo. Gli svantaggi sono rappresentati dal fatto che questa è una procedura a due fasi e i file scaricati sono specifici della versione (e non possono essere condivisi usando versioni diverse).

  • Sì, esegui l'installazione da questo DVD, quindi scarica e aggiorna a versione.

    Selezionare questa opzione per scaricare ed eseguire una versione più recente della Gestione installazioni per installare i prodotti SOLIDWORKS per quella versione.

    Se è disponibile un piccolo Service Pack per aggiornare la versione su DVD, la Gestione installazioni installa la versione originale dal DVD e poi applica l'aggiornamento del Service Pack. Il download risultante è pertanto minore.

    È possibile ottenere lo stesso risultato selezionando l'opzione per continuare l'installazione da DVD e applicare l'aggiornamento in un momento successivo.

    Il vantaggio è che questa opzione è una procedura unica.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Nessuna nuova versione disponibile

Non ci sono versioni più recenti disponibili per il download. Procedere con l'installazione della versione specifica.

Per procedere con l'installazione, fare clic su Avanti.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Processi rilevati

La Gestione installazioni di SOLIDWORKS ha rilevato alcuni processi in corso su questo computer che possono impedire la riuscita dell'installazione.

  • Per continuare l'installazione, adottare una delle seguenti metodologie:
    • Chiudere questi processi (es. l'uso del Task Manager in Microsoft Windows) e premere Riprova.
    • Fare clic su Ignora per procedere senza chiudere i processi.
  • Per interrompere l'installazione, premere Annulla.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Selezione prodotti

È possibile specificare i componenti del prodotto da installare, modificare, scaricare o rimuovere.

Nell'elenco prodotti:
  • L'elenco prodotti contiene tutti i prodotti disponibili nel pacchetto specificata sopra l'elenco stesso.
  • Per visualizzare l'azione prevista di un componente specifico, fare clic sul nome del componente (ma non sulla sua casella di controllo). L'azione prevista appare nel campo delle informazioni sotto l'elenco dei prodotti.
  • Per cambiare l'azione di installazione per un componente del prodotto, fare clic sulla casella di controllo relativa al componente stesso. (Ad esempio, se si sta installando o rimuovendo componenti, selezionando la casella di controllo si specifica che il componente deve essere installato o rimosso e deselezionandola si specifica che il componente non deve essere installato o rimosso).
  • Se si esegue Modifica installazione, appare un asterisco (*) a sinistra dei componenti dopo aver apportato modifiche alla selezione.
  • Se un componente dispone di sottocomponenti da installare in modo opzionale, accanto al componente viene visualizzata l'icona +. Per visualizzare i sottocomponenti disponibili per un componente, fare clic sull'icona +.
  • Quando si espande un componente per visualizzare i sottocomponenti opzionali, accanto al componente viene visualizzata l'icona -. Per comprimere l'elenco dei sottocomponenti, fare clic sull'icona -.

Se si applica un Service Pack, non è possibile selezionare le funzioni di SOLIDWORKS visualizzate sotto SOLIDWORKS (ad es. FeatureWorks). Ciò accade perché non è possibile aggiungere o rimuovere una funzione quando si effettua questo tipo di aggiornamento.

Le azioni effettuate da Gestione installazioni SOLIDWORKS sono controllate da una serie di regole di coesistenza del prodotto. Per dettagli, vedere Regole di coesistenza del prodotto.

SOLIDWORKS Installation Manager seleziona per impostazione predefinita questi componenti di prodotto:
  • Se si esegue un aggiornamento o si installa un Service Pack, Gestione installazioni SOLIDWORKS seleziona i prodotti attualmente installati.
  • In caso contrario, Gestione installazioni SOLIDWORKS seleziona tutti i prodotti che l'utente è autorizzato a utilizzare.
Per ridurre i tempi di installazione o download e i requisiti di spazio su disco, espandere i componenti del prodotto e deselezionare la casella di controllo dei componenti non desiderati.

Se Gestione Installazioni SOLIDWORKS non ha potuto verificare i prodotti che l'utente può utilizzare, è possibile fare clic su Seleziona pacchetti o prodotti diversi per cambiare il pacchetto di prodotti (ad esempio SOLIDWORKS Professional o SOLIDWORKS Premium) da installare o modificare. Gestione installazioni SOLIDWORKS elenca tutti i prodotti SOLIDWORKS presenti sui supporti di installazione e compatibili con il pacchetto selezionato. È possibile selezionare un prodotto qualsiasi tra quelli acquistati o in valutazione.

Ricerca SOLIDWORKS

La Ricerca SOLIDWORKS fornisce un mezzo di ricerca efficace dei documenti SOLIDWORKS e 3D ContentCentral. La ricerca visualizza un'anteprima e l'ubicazione del file e il nome.

Dopo l'installazione, Ricerca SOLIDWORKS indicizza i documenti SOLIDWORKS per rendere più rapide le ricerche. Di default, vengono indicizzati solo i file SOLIDWORKS.

L'installazione di Ricerca SOLIDWORKS installa automaticamente Windows Desktop Search se non è ancora installato nel computer.

Supporto internazionale

Espandere il prodotto SOLIDWORKS e il componente Lingue per visualizzare le lingue che è possibile installare.

La specifica Lingue limita le lingue installate solo per il prodotto SOLIDWORKS. Le installazioni di altri prodotti non saranno condizionate da questa specifica. Ad esempio, eDrawings® e SOLIDWORKS PDM installano tutte le lingue.

Spazio necessario

Gestione installazioni SOLIDWORKS indica la dimensione totale dell'installazione o quella totale del download nella parte inferiore della pagina.

  • Se è stata selezionata l'opzione Solo download, viene visualizzata la dimensione del download. La dimensione del download è l'ammontare totale di spazio su disco richiesto per tutti i file scaricati (non incluso lo spazio extra per estrarre i file dopo il completamento del download). Quest valore è un'approssimazione.
    Tutti i file necessari per l'installazione sono compresi nella dimensione del download totale. Se alcuni file sono già stati scaricati nella cartella di download corrente, non vengono scaricati di nuovo. Quindi, la dimensione effettiva del download potrà essere minore della dimensione del download totale o potrà non essere necessario scaricare alcun file.
  • Altrimenti, apparirà la dimensione dell'installazione. La dimensione dell'installazione è la modifica nell'uso di spazio su disco necessaria al completamento di questa installazione. A causa della compressione del file, queste cifre sono approssimative.

    Nel caso di aggiornamento o rimozione di un'installazione esistente, la dimensione dell'installazione potrà essere zero.

    Il valore indicato non comprende lo spazio necessario per scaricare o estrarre i file se necessari per l'installazione.

    Se i download sono necessari e l'utente sta scaricando nella stessa unità, i requisiti di spazio su disco effettivi potranno essere significativamente maggiori rispetto alla dimensione dell'installazione che appare.

    Per ridurre i tempi del download o di installazione per le modifiche future, non cancellare i file scaricati dopo l'installazione. Gli aggiornamenti e le patch successive richiedono generalmente l'accesso all'ultimo gruppo completo dei file d'installazione.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Regole di coesistenza del prodotto


Prodotti da scaricare

Selezionare i prodotti SOLIDWORKS da scaricare in un punto specifico.

I prodotti disponibili per il download sono determinati dal numero seriale fornito:

  • l'azione da effettuare per ciascun componente appare alla destra di ogni elemento.
  • Se accanto al componente viene visualizzata l'icona +, vuol dire che dispone di sottocomponenti da installare a scelta. Per visualizzare tali sottocomponenti, fare clic sull'icona +.
  • Quando si espande un componente per visualizzarne i sottocomponenti facoltativi, accanto al componente viene visualizzata l'icona -. Per comprimere l'elenco di sottocomponenti, fare clic sull'icona -.
  • Fare clic sulla casella a sinistra di ogni componente per scegliere come gestire la Gestione installazioni di SOLIDWORKS.
Gestione installazioni SOLIDWORKS scarica tutti i componenti del prodotto cui l'utente ha diritto, tranne se diversamente specificato. Per ridurre i tempi del download e i requisiti di spazio su disco, espandere i componenti del prodotto e deselezionare i componenti non necessari.

Se Gestione installazioni di SOLIDWORKS non ha potuto verificare i prodotti cui l'utente ha diritto, selezionare un pacchetto SOLIDWORKS da scaricare. Gestione installazioni di SOLIDWORKS elenca tutti i prodotti SOLIDWORKS compatibili con il pacchetto selezionato.

Se Gestione installazioni di SOLIDWORKS non ha potuto verificare i prodotti cui ha diritto l'utente, è possibile fare clic su Seleziona pacchetti o prodotti diversi per cambiare il pacchetto di prodotti (es. SOLIDWORKS Professional o SOLIDWORKS Premium) da installare o modificare. Gestione installazioni di SOLIDWORKS elenca tutti i prodotti SOLIDWORKS presenti sui supporti di installazione che sono compatibili con il pacchetto selezionato. È possibile selezionare un prodotto qualsiasi tra quelli acquistati o in valutazione.

Supporto internazionale

La specifica Lingue limita le lingue installate per il solo prodotto SOLIDWORKS. Le installazioni di altri prodotti non saranno condizionate da questa specifica. Ad esempio, eDrawings® e SOLIDWORKS Explorer installano tutte le lingue.

Spazio necessario

In base ai prodotti selezionati, lo spazio necessario per effettuare il download verrà visualizzato. La dimensione del download è l'ammontare totale di spazio su disco richiesto per tutti i file scaricati (non incluso lo spazio extra per estrarre i file dopo il completamento del download). Quest valore è un'approssimazione.

Per ridurre i tempi del download o di installazione per gli aggiornamenti futuri e le patch, non cancellare i file scaricati dopo l'installazione. Gli aggiornamenti e le patch successive richiedono generalmente l'accesso all'ultimo gruppo completo dei file d'installazione.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Prodotti da riparare

Quando si seleziona Ripara questa installazione, questo schermo visualizzerà i prodotti SOLIDWORKS con i numeri di versione che potranno essere riparati da questa Gestione installazione di SOLIDWORKS.

La riparazione verifica che tutti i file siano presenti e registrati e le risoluzioni siano definitive. I dati creati non sono impattati.
  • Per rimuovere un prodotto, assicurarsi che sia selezionato.
  • Deselezionare le caselle per i prodotti che non devono essere riparati.

Fare clic su Ripara per iniziare a riparare i prodotti selezionati.

Un'installazione individuale può essere riparata. Non è possibile riparare un'installazione con immagine amministrativa, ma è necessario reinstallarla.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Numeri di seriali

I numeri seriali, trovati nella casella di distribuzione, associano il proprio computer con i prodotti SOLIDWORKS acquistati.

Se sul computer sono già installati dei prodotti SOLIDWORKS, i relativi numeri di serie vengono visualizzati per impostazione predefinita:
  • Immettere il numero seriale di SOLIDWORKS se non è già visualizzato.
  • Se si dispone di numeri seriali per prodotti non inclusi nella licenza SOLIDWORKS, immetterli nei campi appropriati.
  • Se l'Amministratore SOLIDWORKS ha assegnato i prodotti all'utente nel SOLIDWORKS Admin Portal, utilizzare la funzione Accedi nella parte superiore della pagina per popolare automaticamente i numeri seriali assegnati.

Con una connessione Internet, i numeri seriali forniti determinano i prodotti ai quali ha diritto l'utente mentre si prosegue con l'installazione.

Visto che esistono diverse modalità per l'acquisto dei prodotti SOLIDWORKS, alcuni numeri seriali potranno coprire due o più prodotti. Per esempio, un numero seriale per SOLIDWORKS può permettere di installare SOLIDWORKS Simulation senza immettere un numero seriale separato per SOLIDWORKS Simulation. Inoltre, alcuni prodotti non necessitano di un numero seriale. In caso di domande relative ai numeri seriali, contattare il proprio VAR.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Installazione del server

I prodotti server che l'utente tenta di installare sono elencati, con i risultati delle installazioni.

Stato di installazione del server

Le installazioni di prodotti server sono eseguite da un'applicazione esterna. Se tale applicazione non è attualmente in primo piano, è necessario attivarla per completare l'installazione.

Fare clic su Annulla per interrompere le installazioni di prodotti server.

Installazione server completata

L'applicazione esterna si è conclusa.

Fare clic su Fine o su Avanti.
  • Se si installano altri prodotti amministrativi (es. un'immagine amministrativa SOLIDWORKS), l'installazione continua.
  • Se l'installazione di prodotti server è l'unica procedura di installazione che si desidera eseguire, a questo punto la Gestione installazioni di SOLIDWORKS si chiude.

Installazione server annullata o non riuscita

Se l'installazione di un prodotto server è stata annullata o non è riuscita dopo l'avvio, i server non installati saranno elencati.

Fare clic su Chiudi o su Avanti.
  • Se si sono specificate altre installazioni di prodotti amministrativi, la Gestione installazioni di SOLIDWORKS riprende.
  • Se l'installazione di prodotti server è l'unica procedura di installazione che si desidera eseguire, a questo punto la Gestione installazioni di SOLIDWORKS si chiude.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


SolidNetWork License Manager

Specificare le opzioni di installazione per il prodotto server di SolidNetWork License Manager.

Numeri seriali

Specificare i numeri di serie della licenza SolidNetWork. È possibile specificare più numeri di serie separandoli con virgole.
I numeri di serie di SolidNetWork sono diversi dai numeri di serie di SOLIDWORKS.

Ubicazione installazione

Specificare il percorso di installazione di SolidNetWork License Manager.

Se si sta aggiornando un SolidNetWork License Manager esistente, è necessario installarlo nel percorso di installazione esistente.

Per saperne di più...

Per i dettagli sull'installazione, la configurazione e l'utilizzo di SolidNetWork License Manager, vedere Amministrazione delle licenze mediante SolidNetWork License Manager.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Amministrazione delle licenze mediante SolidNetWork License Manager


Sintesi

La Gestione installazioni di SOLIDWORKS ha tutte le informazioni necessarie per completare l'installazione.

Per continuare: | Fare clic sul pulsante azione ora per avviare l'installazione (ad esempio Installa ora, Crea ora, Download ora, Modifica ora).
Per modificare le impostazioni di installazione: | Fare clic su CAMBIA [image] nella sezione che si desidera modificare (ad esempio Prodotti, Ubicazione installazione, Opzioni Toolbox).
Per annullare: | Fare clic su Annulla per uscire da Gestione installazioni di SOLIDWORKS senza modificare i componenti dell'installazione.
Per tornare a una pagina precedente: | Fare clic su Indietro per tornare a una pagina precedente in Gestione installazioni di SOLIDWORKS.
Per informazioni su uno specifico set di opzioni di installazione (ad esempio, Prodotti, Ubicazione installazione, Opzioni Toolbox e così via):
  1. Fare clic su CAMBIA [image] in corrispondenza della sezione per la quale si desidera ottenere maggiori informazioni.
  2. Nella pagina dei dettagli che viene visualizzata fare clic su ? per ottenere informazioni relative alle opzioni di installazione corrispondenti.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Avvertimenti di controllo sistema

La Verifica del sistema ha riportato problemi che possono avere conseguenze se si decide di continuare con l'installazione. Nella maggioranza dei casi, si potrà procedere senza problemi con la Gestione installazioni di SOLIDWORKS.

Gli avvertimenti possono verificarsi in qualsiasi fase tra quelle sotto elencate e forniscono suggerimenti per continuare.

Problemi di convalida del numero seriale

La Gestione installazioni non è stata in grado di verificare la disponibilità di nuove versioni perchè non è riuscita a convalidare il numero di serie. Se si è connessi ed è stato inserito un numero di serie valido, ciò potrebbe indicare un problema temporaneo sul server di SOLIDWORKS. Riprovare in un altro momento.

Convalida numero seriale: La Gestione installazioni di SolidWorks non ha potuto convalidare il numero seriale per stabilire quali prodotti possono essere installati. Si potrà comunque scegliere i prodotti da installare, ma non sarà possibile scaricare i file di installazione. È necessario procurarsi un gruppo completo dei file sorgente oppure il DVD di installazione.

Risoluzione:
  • Controllare la connessione Internet. Il controllo del numero seriale richiede una connessione Internet operativa.
  • Verificare che il numero seriale specificato sia valido per i prodotti che si desidera installare.
  • Per alcune installazioni è necessario essere in possesso di un abbonamento valido al momento del rilascio della versione. Per ulteriori dettagli, consultare il proprio rivenditore SOLIDWORKS.
  • Nella maggioranza dei casi, si potrà procedere all'installazione a patto che si utilizzi un DVD o un gruppo di file scaricati in precedenza.

Versione più recente disponibile

Versione più recente disponibile

Nuove versioni disponibili

È disponibile per il download una versione più recente di questo prodotto.

Risoluzione: Quando si esegue un'operazione Verifica aggiornamenti, l'installazione potrebbe richiedere di installare una versione successiva, disponibile tramite download da SOLIDWORKS. È possibile continuare questa operazione utilizzando la versione inizialmente specificata oppure si può effettuare il download di questa versione più recente e continuare l'operazione usando questa versione.

Versione più recente disponibile

Questa è la versione più recente disponibile. Fare clic su Avanti per continuare.

Nessun nuovo download disponibile

Risoluzione: Questo messaggio può comparire quando si verifica la disponibilità di aggiornamenti durante un'installazione o una modifica. Indica che si sta installando (o si è installata) la versione più recente disponibile.

Problemi di connessione Internet

Connessione internet: Il Manager installazioni non è stato in grado di connettersi al server di SOLIDWORKS per determinare i prodotti disponibili per l'installazione. Sarà comunque possibile scegliere i prodotti da installare, ma non è possibile effettuare il download di qualsiasi file di installazione. È necessario fornire i file di origine su DVD o un gruppo di file scaricati in precedenza.

Impossibile verificare nuove versioni

La Gestione installazioni di SolidWorks non ha potuto verificare la disponibilità di nuove versioni perché non è riuscita a connettersi al server.

Risoluzione:
  • Controllare la connessione Internet.
  • Si può procedere all'installazione a patto che si utilizzi un DVD o un gruppo di file scaricati in precedenza.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Creazione guidata fori/Opzioni Toolbox

Se è installato SOLIDWORKS Toolbox, SOLIDWORKS include una libreria standard di tipi di foro e minuteria.

Per informazioni dettagliate sulla configurazione, sull'estensione e sull'uso di SOLIDWORKS Toolbox, fare clic su ? > Guida di Toolbox in SOLIDWORKS.
Per aprire la guida, potrebbe essere necessario avviare l'aggiunta Toolbox da Strumenti > Aggiunte.

Prima di utilizzare SOLIDWORKS Toolbox, assicurarsi che sia configurato correttamente secondo le direttive aziendali o del proprio gruppo. In molti casi, un gruppo configura e gestisce una installazione centrale di Toolbox. Consultare l'amministratore di SOLIDWORKS per informazioni su come specificare l'installazione di Toolbox durante l'installazione di SOLIDWORKS.

È possibile modificare il SOLIDWORKS Toolbox selezionato dopo l'installazione. In SOLIDWORKS, fare clic su Strumenti > Opzioni. Nella scheda Opzioni del sistema, fare clic su Creazione guidata fori/Toolbox.

Le sezioni seguenti descrivono tutte le opzioni che possono presentarsi in questa schermata per tutte le configurazioni. Le opzioni effettive di Toolbox dipendono da configurazioni preesistenti di SOLIDWORKS e Toolbox su questo computer e sulle scelte della Gestione installazioni specificata fino a questo punto.

Creare una nuova versione di Toolbox

Creare una nuova versione di SOLIDWORKS Toolbox su questo computer.

Quando si crea una nuova versione, nella schermata Selezione prodotto espandere SOLIDWORKS > SOLIDWORKS Toolbox e selezionare gli standard da supportare per Toolbox. Tutti gli standard sono selezionati per impostazione predefinita.

Qualsiasi Toolbox esistente su questo computer non viene modificata.

Fare riferimento o aggiornare un Toolbox esistente

Usare un Toolbox esistente. Fare clic su Sfoglia per specificare la posizione del Toolbox da utilizzare per questa installazione.

  • Se Toolbox è configurato per una precedente release maggiore di SOLIDWORKS, viene aggiornato a questa versione. Qualsiasi elemento personalizzato di Toolbox viene mantenuto nella versione aggiornata.
    L'aggiornamento di Toolbox a una nuova versione di release maggiore di SOLIDWORKS rende Toolbox incompatibile con i computer che eseguono versioni di SOLIDWORKS di release maggiore precedenti.
  • Se Toolbox è configurato per questa versione di SOLIDWORKS (come se si specifica un Toolbox condiviso in rete già aggiornato), non viene aggiornato.
  • Se si aggiorna un Toolbox in un ambiente SOLIDWORKS PDM, è necessario eseguire alcune procedure aggiuntive. Per i dettagli, vedere note sulla configurazione di SOLIDWORKS Toolbox.

Questa opzione appare in tutte le situazioni di installazione, tranne durante la creazione di un'immagine amministrativa.

Aggiornare una versione precedente Toolbox

Copiare un Toolbox configurato per una release maggiore precedente in una nuova posizione e aggiornare tale copia a questa versione.

Questa opzione appare se su questo computer è installata una precedente versione di release maggiore di SOLIDWORKS, ma si è scelto di non aggiornare tale installazione a questa release.
Lo scopo di questa opzione è aggiornare un Toolbox di una precedente release maggiore di SOLIDWORKS installato senza conseguenze per gli utenti che usano ancora la versione precedente di Toolbox.

Se si aggiorna un Toolbox in un ambiente SOLIDWORKS PDM, è necessario eseguire alcune procedure aggiuntive. Per i dettagli, vedere note sulla configurazione di SOLIDWORKS Toolbox.

Aggiornare questa versione precedente di Toolbox installata

Aggiornare questo Toolbox alla versione più recente.
L'aggiornamento di Toolbox a una nuova versione di release maggiore di SOLIDWORKS rende Toolbox incompatibile con i computer che eseguono versioni di SOLIDWORKS di release maggiore precedenti.

Questa opzione appare se si aggiorna una precedente release maggiore di SOLIDWORKS a questa versione e un Toolbox configurato per tale release è già installato su questo computer.

Se si aggiorna un Toolbox in un ambiente SOLIDWORKS PDM, è necessario eseguire alcune procedure aggiuntive. Per i dettagli, vedere note sulla configurazione di SOLIDWORKS Toolbox.

Utilizzare la versione corrente di Toolbox installata

La Gestione installazioni SOLIDWORKS ha rilevato su questo computer un Toolbox configurato per questa versione di release maggiore di SOLIDWORKS.

Se si seleziona questa opzione, SOLIDWORKS userà questo Toolbox. Nessun aggiornamento.

Questa opzione appare se su questo computer è installata una precedente versione di release maggiore di SOLIDWORKS, ma è configurato un Toolbox per questa versione. Potrebbe accadere se viene creato un Toolbox condiviso su un computer che ancora segue una versione precedente di SOLIDWORKS.

Specificare la posizione di Toolbox per il computer client

Specificare una posizione di rete o una cartella come posizione predefinita di Toolbox quando i client installano da un'immagine amministrativa.
Se la posizione contiene un'istanza di Toolbox configurata per una precedente release principale di SOLIDWORKS al momento dell'installazione del client, Gestione installazioni SOLIDWORKS effettua l'aggiornamento di tale Toolbox.

Questa opzione appare quando si crea una nuova immagine amministrativa.

Aggiornare o utilizzare il Toolbox referenziato nell'immagine esistente per il computer client

Usare la posizione di Toolbox specificata in un'immagine amministrativa esistente in corso di aggiornamento.
Se la posizione contiene un'istanza di Toolbox configurata per una precedente release principale di SOLIDWORKS al momento dell'installazione del client, Gestione installazioni SOLIDWORKS effettua l'aggiornamento di tale Toolbox.

Selezionare una posizione diversa di Toolbox per il computer client

Specificare una posizione di Toolbox diversa da quella indicata nell'immagine amministrativa esistente in corso di aggiornamento.
Se la posizione contiene un'istanza di Toolbox configurata per una precedente release principale di SOLIDWORKS al momento dell'installazione del client, Gestione installazioni SOLIDWORKS effettua l'aggiornamento di tale Toolbox.

Indice

  • Note sulla configurazione di SOLIDWORKS Toolbox

    SOLIDWORKS Toolbox è uno strumento potente e complesso. Questo argomento riassume alcuni concetti fondamentali prima di configurare un Toolbox con la Gestione installazioni SOLIDWORKS.

  • Formato UNC

    Il formato UNC (convenzione di nomina universale) rappresenta un formato specifico per la sintassi dei nomi di file ed è utilizzato per descrivere una posizione condivisa.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Note sulla configurazione di SOLIDWORKS Toolbox


Note sulla configurazione di SOLIDWORKS Toolbox

SOLIDWORKS Toolbox è uno strumento potente e complesso. Questo argomento riassume alcuni concetti fondamentali prima di configurare un Toolbox con la Gestione installazioni SOLIDWORKS.

Ulteriori informazioni su SOLIDWORKS Toolbox

Per i dettagli sulla configurazione, l'estensione e l'utilizzo di SOLIDWORKS Toolbox, fare clic su ? > Guida di Toolbox in SOLIDWORKS.
Per aprire la Guida, potrebbe essere necessario avviare l'aggiunta Toolbox utilizzando il comando Strumenti > Aggiunte.

Uso di un Toolbox condiviso

Quando si installa Toolbox, è possibile salvare i dati di Toolbox sul proprio sistema o in una posizione in rete condivisa. Si consiglia di memorizzare i dati di Toolbox in una posizione di rete. Utilizzando una posizione condivisa, tutti gli utenti di SOLIDWORKS potranno accedere agli stessi fissaggi.

Se questa è la prima installazione, navigare alla nuova ubicazione condivisa dove installare Toolbox.

Aggiornamento di Toolbox esistente.

L'aggiornamento di Toolbox a una nuova versione di release maggiore di SOLIDWORKS rende Toolbox incompatibile con i computer che eseguono versioni di SOLIDWORKS di release maggiore precedenti.

Se altri computer vengono mantenuti ad una release maggiore precedente e continuano a necessitare di un Toolbox configurato per tale release, si consiglia di creare una copia di tale Toolbox e di aggiornarla. La nuova installazione SOLIDWORKS aggiornerà la copia di Toolbox e le precedenti installazioni SOLIDWORKS continueranno ad usare il vecchio Toolbox.

Configurazione accesso a Toolbox

Dopo l'installazione, quando si accede ai componenti Toolbox, SOLIDWORKS verificherà il modo in cui Toolbox è stato configurato e suggerisce come migliorare l'accesso e la prestazione.

Per accedere a Toolbox in rete condiviso (consigliato), usare un percorso UNC al server sul quale è installato il Toolbox condiviso. Per i dettagli, vedere Formato UNC.

Un amministratore può creare una password per l'accesso a Toolbox e definire i permessi e le preferenze per l'intero gruppo di lavoro. Limitare l'accesso alla configurazione e impostare preferenze comuni è un modo per assicurare che i dati di Toolbox utilizzati dall'intero gruppo di lavoro siano coerenti.

Aggiornamento di Toolbox in un ambiente SOLIDWORKS PDM

Quando si aggiorna il software SOLIDWORKS, Toolbox viene aggiornato se vi sono state aggiunte parti. Se la cartella di origine Toolbox è contenuta in un vault di SOLIDWORKS PDM, prima di iniziare l'aggiornamento di SOLIDWORKS, è necessario prepararla.

Sul primo sistema da aggiornare, eseguire il check out del database Toolbox e utilizzare Leggi l'ultima versione per scaricare i file Toolbox nella cache locale ed eseguire il check out del file di database di Toolbox. Sugli altri sistemi da aggiornare, l’unica operazione consiste nello scaricare i file Toolbox.

Prima di eseguire l'aggiornamento:
  • Assicurarsi che esista un backup completo recente del database del vault e dell'archivio.
  • Assicurarsi che non sia stato eseguito il check out delle parti Toolbox o che queste non siano utilizzate da assiemi di cui è stato eseguito il check out.

Per aggiornare Toolbox:

  1. In Esplora Risorse, accedere al vault come utente con permessi totali (check out, check in, aggiunta, eliminazione).
  2. Fare clic con il pulsante destro del mouse sulla cartella Toolbox e selezionare Prendi la versione più recente per copiare le parti Toolbox nella cache locale.
    Se il proprio server di archivio è remoto, l'operazione impiegherà alcuni minuti.
  3. Eseguire il check-out del database Toolbox, di nome SWBrowser.mdb da \Toolbox_folder_name\lang\your_lang .
  4. Eseguire la Gestione installazioni SOLIDWORKS per aggiornare.
  5. Nello schermo Sintesi, assicurarsi che l'ubicazione dell'installazione Opzioni Toolbox sia l'ubicazione nel vault.

    Nel caso contrario, fare clic su Cambia, selezionare Riferimento o upgrade di un Toolbox esistente e navigare all'ubicazione Toolbox nel vault.

  6. Al completamento dell'upgrade, in Esplora risorse, fare il check in della cartella Toolbox per aggiungere i file nuovi o aggiornati al vault in modo che gli utenti possano lavorare con Toolbox.
  7. Per gli aggiornamenti a SOLIDWORKS 2012 o versione successiva, accede alla propria cartella Toolbox nel vault e verificare che siano presenti:
    • \Toolbox_folder_name\Aggiornamenti
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      Se non sono presenti, contattare il proprio rivenditore VAR.

  8. Eseguire l'aggiornamento del resto dei computer che usano l'integrazione di SOLIDWORKS PDM con Toolbox:
    1. In Esplora Risorse, accedere al vault come utente con il permesso almeno di lettura alla cartella Toolbox.
    2. Fare clic con il pulsante destro del mouse sulla cartella Toolbox e selezionare Prendi la versione più recente per copiare le parti Toolbox nella cache locale.
    3. Eseguire la Gestione installazioni SOLIDWORKS per aggiornare.

      Il programma di installazione rileva che Toolbox è già aggiornato.

Per i dettagli sulla configurazione Toolbox in SOLIDWORKS PDM, vedere Configurazione di Toolboxnella Guida in linea dello strumento Amministrazione SOLIDWORKS PDM .

Argomento principale Creazione guidata fori/Opzioni Toolbox
Formato UNC


Formato UNC

Il formato UNC (convenzione di nomina universale) rappresenta un formato specifico per la sintassi dei nomi di file ed è utilizzato per descrivere una posizione condivisa.

\\server\volume\percorso

Ad esempio:

\\Disk_Server\SOLIDWORKS\AdminImage

Argomento principale Creazione guidata fori/Opzioni Toolbox
Note sulla configurazione di SOLIDWORKS Toolbox


Disinstalla prodotti

Quando si seleziona Rimuovi o Disinstalla programmi dal Pannello di controllo, questa schermata visualizzerà i prodotti SOLIDWORKS (con numeri di versione), che saranno disinstallati da questa versione di Gestione installazioni di SOLIDWORKS. Scegliere se effettuare una disinstallazione standard, personalizzata o completa.

La disinstallazione standard rimuove i file di programma e le cartelle di un prodotto SOLIDWORKS. Per impostazione predefinita, tutti i prodotti SOLIDWORKS per la release selezionata sono specificati per una disinstallazione standard.

Una disinstallazione personalizzata rimuove uno o più elementi: file e cartelle del programma, chiavi di registro e cartelle dati, come ad esempio SOLIDWORKS Toolbox e i file e cartelle dall'ubicazione di download originale.

Una completa disinstallazione rimuove le directory di installazione, le chiavi di registro e le cartelle dati.

Per disinstallare un prodotto:
  1. nello schermo Disinstalla, assicurarsi che il prodotto sia selezionato.

    Se si disinstallano tutti i prodotti, la Gestione installazioni sarà anch'essa disinstallata.

  2. Deselezionare i prodotti che non devono essere rimossi.

    Se si mantengono dei prodotti, la Gestione installazioni di SOLIDWORKS non sarà rimossa.

  3. Scegliere se effettuare una disinstallazione personalizzata o completa.
    1. Fare clic su Cambia in Opzioni avanzate.

      Si visualizza la finestra di dialogo Opzioni avanzate. L'opzione File e cartelle del programma è selezionata.

    2. Selezionare una o più opzioni per effettuare una disinstallazione personalizzata o selezionare tutte le opzioni per effettuare una disinstallazione completa.
    3. Fare clic su Torna alla Sintesi.
    4. Nello schermo Sintesi, espandere Opzioni avanzate per visualizzare il metodo di disinstallazione e le voci.
  4. Fare clic su Rimuovi elementi.
Quando si fa clic su Rimuovi elementi, la Gestione installazioni di SOLIDWORKS inizia subito a rimuovere i prodotti.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Note legali

© 1995-2019, Dassault Systèmes SolidWorks Corporation, un'azienda del gruppo Dassault Systèmes SE, 175 Wyman Street, Waltham, Mass. 02451 USA. Tutti i diritti riservati.

Le informazioni e il software ivi presentati sono soggetti a modifica senza preavviso e impegno da parte di Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

Nessun materiale può essere riprodotto o trasmesso sotto qualsiasi forma o attraverso qualsiasi mezzo, elettronico o meccanico, e per qualsiasi scopo senza il previo consenso scritto di DS SolidWorks.

Il software descritto in questo documento è fornito in base alla licenza e può essere usato o copiato solo in ottemperanza dei termini della stessa. Ogni garanzia fornita da DS SolidWorks relativamente al software e alla documentazione è stabilita nell'accordo di licenza e nessun'altra dichiarazione, esplicita o implicita in questo documento o nel suo contenuto dovrà essere considerata o ritenuta una correzione o revisione di tale garanzia.

Notifiche brevetti

I software CAD meccanico 3D e/o Simulation di SOLIDWORKS® sono protetti dai brevetti degli Stati Uniti 6.611.725; 6.844.877; 6.898.560; 6.906.712; 7.079.990; 7.477.262; 7.558.705; 7.571.079; 7.590.497; 7.643.027; 7.672.822; 7.688.318; 7.694.238; 7.853.940; 8.305.376; 8.581.902; 8.817.028; 8.910.078; 9.129.083; 9.153.072; 9.262.863; 9.465.894; 9.646.412; 9.870.436; 10.055.083; 10.073.600; 10.235.493 e da brevetti esteri (ad es. EP 1.116.190 B1 e JP 3.517.643).

Il software eDrawings® è protetto dal brevetto USA 7.184.044; dal brevetto USA 7.502.027; e dal brevetto canadese 2.318.706.

Altri brevetti USA e stranieri in corso di concessione.

Marchi commerciali e nomi di prodotto per i Prodotti e Servizi SOLIDWORKS

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings e il logo eDrawings sono marchi registrati e FeatureManager è un marchio registrato in comune proprietà di DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360 e TolAnalyst sono marchi commerciali di DS SolidWorks.

FeatureWorks è un marchio depositato della HCL Technologies Ltd.

SOLIDWORKS 2020, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional, SOLIDWORKS Simulation Premium, SOLIDWORKS Flow Simulation, SOLIDWORKS CAM, SOLIDWORKS Manage, eDrawings Viewer, eDrawings Professional, SOLIDWORKS Sustainability, SOLIDWORKS Plastics, SOLIDWORKS Electrical Schematic Standard, SOLIDWORKS Electrical Schematic Professional, SOLIDWORKS Electrical 3D, SOLIDWORKS Electrical Professional, CircuitWorks, SOLIDWORKS Composer, SOLIDWORKS Inspection, SOLIDWORKS MBD, SOLIDWORKS PCB powered by Altium, SOLIDWORKS PCB Connector powered by Altium, and SOLIDWORKS Visualize sono nomi di prodotti di DS SolidWorks.

Altre nomi di marca o di prodotto sono marchi commerciali o marchi depositati dei rispettivi titolari.

SOFTWARE PER COMPUTER COMMERCIALE – PROPRIETÀ

Il Software è un "elemento commerciale" così come da definizione dal documento 48 C.F.R. 2.101 (OCT 1995), composto da "software per computer commerciale" e "documentazione del software commerciale" come da definizione dal documento 48 C.F.R. 12.212 (SEPT 1995) e fornito al governo Statunitense (a) per acquisizione di o da parte di agenzie civili, compatibile con la direttiva stabilita nel documento 48 C.F.R. 12.212; o (b) per l'acquisizione di o da parte di unità del Dipartimento della Difesa, compatibile con le direttive stabilite nei documenti 48 C.F.R. 227.7202-1 (JUN 1995) e 227.7202-4 (JUN 1995)

In caso di richiesta da parte di una qualsiasi agenzia del governo Statunitense di fornire il Software con diritti che eccedono quelli stabiliti sopra, notificare la DS SolidWorks dell'ambito della richiesta e la DS SolidWorks, a sua discrezione, accetterà o meno tale richiesta entro cinque giorni lavorativi. Appaltatore/Produttore: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Note di diritti di autore per i prodotti SOLIDWORKS Standard, Premium, Professional ed Education

Parti di questo software © 1986-2018 Siemens Product Lifecycle Management Software Inc. Tutti i diritti riservati.

Questo lavoro contiene il seguente software di proprietà di Siemens Industry Software Limited:

D-Cubed® 2D DCM © 2019. Siemens Industry Software Limited. Tutti i diritti riservati.

D-Cubed® 3D DCM © 2019. Siemens Industry Software Limited. Tutti i diritti riservati.

D-Cubed® PGM © 2019. Siemens Industry Software Limited. Tutti i diritti riservati.

D-Cubed® CDM © 2019. Siemens Industry Software Limited. Tutti i diritti riservati.

D-Cubed® AEM © 2019. Siemens Industry Software Limited. Tutti i diritti riservati.

Parti di questo software © 1998-2019 HCL Technologies Ltd.

Porzioni di questo software incorporano PhysX™ by NVIDIA 2006-2010.

Parti di questo software © 2001-2019 Luxology, LLC. Tutti i diritti riservati, brevetti in attesa di deposito.

Parti di questo software © 2007-2019 DriveWorks Ltd.

© 2012, Microsoft Corporation. Tutti i diritti sono riservati.

Include la tecnologia Libreria Adobe® PDF.

Copyright 1984-2016 Adobe Systems Inc. e suoi concessori di licenza. Tutti i diritti sono riservati. Protetto dai brevetti USA 6.563.502; 6.639.593; 6.754.382; altri brevetti in corso di concessione.

Adobe, il logo Adobe, Acrobat, il logo Adobe PDF, Distiller e Reader sono marchi depositati o marchi commerciali di Adobe Systems Inc. negli Stati Uniti e in altri paesi.

Per ulteriori informazioni sul copyright DS SolidWorks, vedere ? > Informazioni su SOLIDWORKS.

Note diritti di autore per i prodotti SOLIDWORKS Simulation

Porzioni di questo software © 2008 Solversoft corporation.

PCGLSS © 1992-2017 Computational Applications and System Integration, Inc. Tutti i diritti riservati.

Note dei diritti di autore per il prodotto SOLIDWORKS PDM Professional

Outside In® Viewer Technology, © 1992-2012 Oracle

© 2012, Microsoft Corporation. Tutti i diritti riservati.

Note diritti di autore per i prodotti eDrawings

Porzioni di questo software © 2000-2014 Tech Soft 3D.

Porzioni di questo software © 1995-1998 Jean-Loup Gailly and Mark Adler.

Porzioni di questo software © 1998-2001 3Dconnexion.

Porzioni di questo software © 1998-2017 Open Design Alliance. Tutti i diritti sono riservati.

Il software eDrawings® per Windows® è in parte basato sul lavoro del gruppo Independent JPEG Group.

Porzioni di eDrawings® per iPad® copyright © 1996-1999 Silicon Graphics Systems, Inc.

Parti di eDrawings® per iPad® copyright © 2003-2005 Apple Computer Inc.

Note diritti di autore per i prodotti SOLIDWORKS PCB

Parti di questo software © 2017-2018 Altium Limited.

Note diritti di autore per i prodotti SOLIDWORKS Visualize

Tecnologia NVIDIA GameWorks™ fornita con licenza di NVIDIA Corporation. Copyright © 2002-2015 NVIDIA Corporation. Tutti i diritti riservati.


Editor opzioni immagine amministrativa

L'Editor delle opzioni immagini amministrative di SOLIDWORKS è stato migliorato.

  • Gli amministratori possono usare nuove opzioni di disinstallazione per effettuare una completa o personalizzata disinstallazione sui computer client. Le opzioni di disinstallazione sono disponibili nella sezione Opzioni installazione client dell'Editor delle opzioni. Per visualizzare le opzioni, fare clic su Sì, effettua una disinstallazione personalizzata e quindi scegliere gli elementi da rimuovere.
  • Gli amministratori possono inoltre preselezionare gli standard di SOLIDWORKS Toolbox da un elenco.


SOLIDWORKS PDM

SOLIDWORKS PDM è un prodotto per la gestione dei documenti basato sull'architettura client/server precedentemente conosciuta come SOLIDWORKS Enterprise PDM.

SOLIDWORKS PDM è disponibile in due tipi:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM utilizza un database Microsoft SQL Server per gestire i vault.

Questa tabella elenca i sistemi database, componenti server e le opzioni client disponibili per ogni tipo di prodotto.
 | PDM Standard | PDM Professional
Progettato per | Reti aziendali di piccole e medie dimensioni, generalmente con meno di 20 utenti simultanei. | Reti aziendali di grandi dimensioni, numerosi utenti simultanei
Limiti | Dimensioni inferiori a 1 socket o 4 core, 1 GB di RAM e 10 GB di database | Limiti SQL Standard: Dimensioni inferiori a 4 socket o 16 core, 128 GB di RAM e 524 PB di database
Sistema di gestione database | Microsoft SQL Server Express 2014 Service Pack 3 o successivi (incluso e installato con SOLIDWORKS) | Microsoft SQL Server 2014 Service Pack 3 o successivi (incluso separatamente con SOLIDWORKS) o istanze precedentemente installate di Microsoft SQL Server 2014 Service Pack 3 o successivi.
Richiede SolidNetWork License Manager? | Sì | Sì
Include il server archivio e il server database? | Sì | Sì
Include server Web SOLIDWORKS PDM, Web2 Server e server API Web? | No | Sì
Tipi di client | Nativo | Nativo, basato su browser
Aggiunte del client per CAD Editors | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Integrazione Microsoft Office, Autodesk Inventor, AutoCAD
Aggiunte del client per Contributors | DraftSight | DraftSight, Microsoft Office Integration
Aggiunte del client per Viewers |  | Integrazione con Microsoft Office


Suggerimenti per l'uso di SOLIDWORKS con Microsoft Windows 8

L'interfaccia utente di Windows 8 (e versioni successive) si differenzia in modo significativo rispetto alle versioni precedenti di Windows. Non solo le tecniche di esplorazione sono differenti, ma sono stati aggiunti diversi metodi per accedere ai comandi principali.

Gli argomenti elencati di seguito forniscono istruzioni per accedere a tre delle funzioni principali con Windows 8. Fare riferimento a questi argomenti quando si utilizza Windows 8 per installare SOLIDWORKS.
Questi passaggi possono variare a seconda della configurazione del sistema Windows. Per ulteriori istruzioni e opzioni, consultare la documentazione di Microsoft Windows, specialmente per i sistemi successivi a Windows 8.
Installazione su singoli computer


Inizio dell'installazione di SOLIDWORKS

È possibile iniziare l'installazione di SOLIDWORKS da un DVD sul computer locale, accedendo a una directory di installazione condivisa o scaricando i file da SOLIDWORKS.

Per iniziare l'installazione di SOLIDWORKS, adottare una delle seguenti metodologie:

  • per installare dal disco su un computer locale, inserire il disco appropriato nel drive apposito.
  • Per eseguire l'installazione da una directory di download, passare alla directory e fare doppio clic su setup.exe.
  • Per installare tramite download da SOLIDWORKS:
    1. Andare al sito Web di SOLIDWORKS.
    2. Effettuare la connessione come utente del servizio di abbonamento, usando il proprio indirizzo di email e password o il proprio numero di serie SOLIDWORKS.
    3. In Self Service, fare clic su Download software e aggiornamenti.
    4. In Download software (Windows, Mac, Linux), selezionare la versione di SOLIDWORKS e il Service Pack da scaricare.